source: projects/specs/trunk/f/freerdp/freerdp-vl.spec @ 6955

Revision 6955, 6.1 KB checked in by daisuke, 12 years ago (diff)

update to 1.0.1

Line 
1Name:           freerdp
2Version:        1.0.1
3Release:        1%{?_dist_release}
4Summary:        Remote Desktop Protocol client
5Summary(ja):    リモートデスクトッププロトコルクライアント
6
7Group:          Applications/Intenet
8License:        GPLv2+
9URL:            http://www.freerdp.com/
10
11Source0:        https://github.com/downloads/FreeRDP/FreeRDP/%{name}-%{version}.tar.gz
12# https://github.com/FreeRDP/FreeRDP/commit/165d39a290a109c0af16a1d223d1426cb524a844 backport
13
14Patch0:         fastpath_send_input_pdu-sec_bytes.patch
15Patch1:         c10866db66c0d462ea7c2c38bb01740bcfb4fcb4.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires:  cmake
19BuildRequires:  xmlto
20BuildRequires:  openssl-devel
21BuildRequires:  libX11-devel
22BuildRequires:  libXext-devel
23BuildRequires:  libXinerama-devel
24BuildRequires:  libXcursor-devel
25BuildRequires:  libXdamage-devel
26BuildRequires:  libXv-devel
27BuildRequires:  libxkbfile-devel
28BuildRequires:  pulseaudio-libs-devel
29BuildRequires:  cups-devel
30BuildRequires:  pcsc-lite-devel
31BuildRequires:  desktop-file-utils
32
33Provides:       xfreerdp = %{version}-%{release}
34Requires:       %{name}-libs = %{version}-%{release}, %{name}-plugins = %{version}-%{release}
35Requires:       %{name}-plugins = %{version}-%{release}
36
37%description
38The xfreerdp Remote Desktop Protocol (RDP) client from the FreeRDP
39project.
40
41xfreerdp can connect to RDP servers such as Microsoft Windows
42machines, xrdp and VirtualBox.
43
44
45%package        libs
46Summary:        Core libraries implementing the RDP protocol
47Summary(ja):    RDPプロトコル実装のコアライブラリ
48Group:          System Environment/Libraries
49%description    libs
50libfreerdp implements the core of the RDP protocol.
51
52libfreerdpchanman can be used to load plugins that can handle channels
53in the RDP protocol.
54
55libfreerdpkbd implements functionality for handling keyboards in X.
56
57
58%package        plugins
59Summary:        Plugins for handling the standard RDP channels
60Summary(ja):    標準RDPチャンネルを扱うためのプラグイン
61Group:          System Environment/Libraries
62Requires:       %{name}-libs = %{version}-%{release}
63%description    plugins
64A set of plugins to the channel manager implementing the standard virtual
65channels extending RDP core functionality.  For example, sounds, clipboard
66sync, disk/printer redirection, etc.
67
68
69%package        devel
70Summary:        Development files for %{name}
71Summary(ja):    %{name}の開発ファイル
72Group:          Development/Libraries
73Requires:       %{name}-libs = %{version}-%{release}
74Requires:       pkgconfig
75
76%description    devel
77The %{name}-devel package contains libraries and header files for
78developing applications that use %{name}-libs.
79
80
81%prep
82%setup -q
83%patch0 -p1
84%patch1 -p1
85
86cat << EOF > xfreerdp.desktop
87[Desktop Entry]
88Type=Application
89Name=X FreeRDP
90NoDisplay=true
91Comment=Connect to RDP server and display remote desktop
92Icon=%{name}
93Exec=/usr/bin/xfreerdp
94Terminal=false
95Categories=Network;RemoteAccess;
96EOF
97
98%build
99%cmake \
100        -DWITH_CUPS=ON \
101        -DWITH_PCSC=ON \
102        -DWITH_PULSEAUDIO=ON \
103        -DWITH_X11=ON \
104        -DWITH_XCURSOR=ON \
105        -DWITH_XEXT=ON \
106        -DWITH_XINERAMA=ON \
107        -DWITH_XKBFILE=ON \
108        -DWITH_XV=ON \
109        -DWITH_ALSA=OFF \
110        -DWITH_CUNIT=OFF \
111        -DWITH_DIRECTFB=OFF \
112        -DWITH_FFMPEG=OFF \
113        -DWITH_SSE2=OFF \
114        -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
115        .
116
117make %{?_smp_mflags}
118
119
120%install
121rm -rf $RPM_BUILD_ROOT
122
123make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
124
125# No need for keymap files when using xkbfile
126rm -rf $RPM_BUILD_ROOT/usr/share/freerdp
127
128desktop-file-install --dir=$RPM_BUILD_ROOT%{_datadir}/applications xfreerdp.desktop
129install -p -D resources/FreeRDP_Icon_256px.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
130
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135
136%post
137# This is no gtk application, but try to integrate nicely with GNOME if it is available
138gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
139
140
141%post libs -p /sbin/ldconfig
142
143
144%postun libs -p /sbin/ldconfig
145
146
147%files
148%defattr(-,root,root,-)
149%{_bindir}/xfreerdp
150%{_mandir}/man1/xfreerdp.*
151%{_datadir}/applications/xfreerdp.desktop
152%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
153
154%files libs
155%defattr(-,root,root,-)
156%doc LICENSE README ChangeLog
157%{_libdir}/lib%{name}-*.so.*
158%dir %{_libdir}/%{name}/
159
160%files plugins
161%defattr(-,root,root,-)
162%{_libdir}/%{name}/*
163
164%files devel
165%defattr(-,root,root,-)
166%{_includedir}/%{name}/
167%{_libdir}/lib%{name}-*.so
168%{_libdir}/pkgconfig/%{name}.pc
169
170
171%changelog
172* Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.6-1
173- update to 1.0.1
174- import patches from fedora package.
175- add BRs.
176
177* Fri May 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
178- initial build for Vine Linux
179
180* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.2-3
181- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
182
183* Fri Jan 28 2011 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-2
184- rebuild on rawhide because of broken dependencies
185
186* Tue Nov 16 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-1
187- freerdp-0.8.2
188
189* Mon Nov 08 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-2
190- make -devel require pkgconfig
191- first official Fedora package
192
193* Sun Nov 07 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-1
194- freerdp-0.8.1
195
196* Sat Sep 25 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-2
197- hack the generated libtool to not set rpath on x86_64
198- configure with alsa explicitly
199
200* Tue Aug 24 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-1
201- freerdp-0.7.4
202- cleanup of packaging structure
203
204* Wed Jul 28 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.3-1
205- 0.7.3
206- fix some minor pylint warnings
207
208* Fri Jul 23 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.2-2
209- 0.7.2
210- Address many comments from cwickert:
211- - cleanup of old formatting, alignment with spectemplate-lib.spec and
212    cwickert spec from #616193
213- - add alsa as build requirement
214- - remove superfluous configure options and disable static libs
215- - add missing rpm groups
216
217* Sun Jun 13 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.0-1
218- First official release, first review request
Note: See TracBrowser for help on using the repository browser.