source: projects/specs/trunk/f/freeciv/freeciv-vl.spec @ 2139

Revision 2139, 13.3 KB checked in by iwaim, 14 years ago (diff)

freeciv 2.2.3-1

Line 
1# include fallback defs for _ggz_config, _ggz_datadir macros
2# feel free to drop when ggz-client-lib including these is deployed everywhere
3%{!?_ggz_config:%define _ggz_config %{_bindir}/ggz-config}
4%{!?_ggz_datadir:%define _ggz_datadir %(%{_ggz_config} --datadir >& /dev/null ||:)}
5
6Name:           freeciv
7Version:        2.2.3
8Release:        1%{?_dist_release}
9Summary:        A multi-player strategy game
10
11Group:          Amusements/Games
12License:        GPLv2+
13URL:            http://freeciv.wikia.com/index.php/Freeciv
14Source0:        http://download.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
15Source1:        freeciv-ja_2.2.3-fixed.po
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18##Fix DSO patch
19Patch10:        freeciv-client-fix-DSO.patch
20
21BuildRequires:  gtk2-devel
22BuildRequires:  readline-devel
23BuildRequires:  zlib-devel
24BuildRequires:  SDL_mixer-devel
25BuildRequires:  esound-devel
26BuildRequires:  ncurses-devel
27BuildRequires:  ggz-client-libs-devel
28BuildRequires:  desktop-file-utils
29BuildRequires:  gettext
30
31Requires(post): ggz-client-libs
32Requires(preun): ggz-client-libs
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: iwaim
37
38%description
39Freeciv is a turn-based, multi-player, X based strategy game. Freeciv
40is generally comparable to, and has compatible rules with, the
41Civilization II(R) game by Microprose(R). In Freeciv, each player is
42the leader of a civilization, and is competing with the other players
43in order to become the leader of the greatest civilization.
44
45
46%prep
47%setup -q -n %{name}-%{version}
48%patch10 -p0
49%__rm -f po/ja.{po,gmo}
50%__cp -p %{SOURCE1} po/ja.po
51
52%build
53%configure --enable-client=gtk --disable-static
54make %{?_smp_mflags}
55
56%install
57rm -rf $RPM_BUILD_ROOT
58make install DESTDIR=$RPM_BUILD_ROOT
59%find_lang %{name}
60
61desktop-file-install --vendor vine --delete-original    \
62        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
63        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
64
65desktop-file-install --vendor vine --delete-original \
66        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
67        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}-server.desktop
68
69# Remove civmanual
70rm $RPM_BUILD_ROOT%{_bindir}/civmanual
71# ggz config
72# omit ggz.modules, to register at install, not build, time.
73if [ -e $RPM_BUILD_ROOT%{_sysconfdir}/ggz.modules ]; then
74rm $RPM_BUILD_ROOT%{_sysconfdir}/ggz.modules
75fi
76# include .dsc files
77install -p -D -m644 data/civclient.dsc $RPM_BUILD_ROOT%{_ggz_datadir}/civclient.dsc
78find $RPM_BUILD_ROOT -name '*.la' -delete
79find $RPM_BUILD_ROOT -name '*.a' -delete
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post
85%{_ggz_config} --install --force --modfile=%{_ggz_datadir}/civclient.dsc || :
86touch --no-create %{_datadir}/icons/hicolor
87if [ -x %{_bindir}/gtk-update-icon-cache ]; then
88  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
89fi
90
91%preun
92if [ $1 -eq 0 ]; then
93%{_ggz_config} --remove --modfile=%{_ggz_datadir}/civclient.dsc || :
94fi
95
96%postun
97touch --no-create %{_datadir}/icons/hicolor
98if [ -x %{_bindir}/gtk-update-icon-cache ]; then
99  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
100fi
101
102
103%files -f %{name}.lang
104%defattr(-,root,root)
105%doc COPYING NEWS doc/BUGS doc/HOWTOPLAY doc/README
106%doc doc/README.AI doc/README.agents doc/README.attributes doc/README.cma
107%doc doc/README.delta doc/README.effects doc/README.ftwl doc/HACKING
108%doc doc/README.scorelog doc/TODO
109%doc doc/README.graphics doc/README.sound
110%{_bindir}/freeciv-server
111%{_bindir}/freeciv-gtk2
112%{_datadir}/%{name}/
113%{_datadir}/applications/vine-*.desktop
114%{_datadir}/icons/hicolor/*/apps/*.png
115%{_datadir}/pixmaps/%{name}-client.png
116%{_mandir}/man6/freeciv*6*
117%{_ggz_datadir}/civclient.dsc
118
119
120%changelog
121* Fri Sep 17 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.3-1
122- new upstream release
123- update ja.po (Source1): fixed upstream ja.po
124
125* Wed Sep  1 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.2-1
126- build for Vine Linux: from Fedora 2.2.2-1
127 - change BuildRequires: ggz-gtk-client-devel to gz-client-libs-devel
128- add ja.po (Source1) from http://loda.jp/freeciv/?id=81
129
130* Mon Aug 02 2010 Thomas Janssen <thomasj@fedoraproject.org> 2.2.2-1
131- security fix https://www.redhat.com/security/data/cve/CVE-2010-2445.html
132- fixes #612296
133
134* Sun Jun 06 2010 Thomas Janssen <thomasj@fedoraproject.org> 2.2.0-2
135- security fix http://gna.org/bugs/?15624
136- #600742 #600743 #600744
137
138* Tue Mar 02 2010 Thomas Janssen <thomasj@fedoraproject.org> 2.2.0-1
139- New upstream source 2.2.0
140
141* Fri Jan 29 2010 Brian Pepple <bpepple@fedoraproject.org> - 2.1.11-1
142- Update to 2.1.11.
143
144* Fri Dec 11 2009 Brian Pepple <bpepple@fedoraproject.org> - 2.1.10-1
145- Update to 2.1.10.
146
147* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.9-2
148- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
149
150* Sun Apr  5 2009 Brian Pepple <bpepple@fedoraproject.org> - 2.1.9-1
151- Update to 2.1.9.
152
153* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 2.1.8-3
154- drop bind-devel BuildReq, it is not needed
155
156* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.8-2
157- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
158
159* Thu Dec  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.8-1
160- Update to 2.1.8.
161
162* Wed Nov 26 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.7-1
163- Update to 2.1.7.
164
165* Sat Nov 22 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.6-2
166- Simplify summary.
167
168* Sat Aug 23 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.6-1
169- Update to 2.1.6.
170
171* Thu Jun 19 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.5-1
172- Update to 2.1.5.
173
174* Tue Apr 29 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.4-1
175- Update to 2.1.4.
176
177* Sat Feb  9 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> 2.1.3-4
178- Fix up typo.
179
180* Fri Feb  8 2008 Rex Dieter <rdieter@fedoraproject.org> 2.1.3-3
181- fixup ggz integration (#431726)
182
183* Mon Feb  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.3-2
184- Add ggz gaming support.
185
186* Sat Jan 26 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.3-1
187- Update to 2.1.3.
188
189* Tue Dec 25 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.2-1
190- Update to 2.1.2.
191
192* Thu Nov 29 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.1-1
193- Update to 2.1.1.
194- Drop buffer overflow patch. fixed upstream.
195- Drop open file patch. fixed upstream.
196
197* Sat Nov 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.0-2
198- Add patch to fix buffer overflow. (#397531)
199
200* Sun Oct 28 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.0-1
201- Update to 2.1.0.
202- Update urls.
203- Update aifill & open patches.
204- Remove old freeciv pixmap.
205- Remove desktop patch.
206
207* Sun Sep 16 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-4
208- Add patch to fix open function build bug.
209
210* Tue Aug 21 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-3
211- Rebuild.
212
213* Thu Aug  2 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-2
214- Update license tag.
215
216* Tue Feb 13 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-1
217- Update to 2.0.9.
218- Drop button patch, fixed upstream.
219- Drop security patch, fixed upstream.
220- Drop X-Fedora category from desktop files.
221
222* Thu Sep  7 2006 Brian Pepple <bpepple@fedoraproject.org> - 2.0.8-7
223- Rebuild for FC6.
224
225* Wed Aug  2 2006 Brian Pepple <bpepple@fedoraproject.org> - 2.0.8-6
226- Update security patch.
227- Add patch to fix turn done buttons style.
228
229* Tue Aug  1 2006 Brian Pepple <bpepple@fedoraproject.org> - 2.0.8-5
230- Add patch to fix CVE-2006-3913 vulnerability. (#200545)
231- Replace desktop file category 'Strategy' with 'StrategyGame'. (#198086)
232
233* Mon Mar  6 2006 Brian Pepple <bdpepple@ameritech.net> - 2.0.8-2
234- Update to 2.0.8.
235
236* Thu Feb 16 2006 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-6
237- Remove unnecessary BR (alsa-lib-devel & SDL-devel).
238
239* Mon Feb 13 2006 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-5
240- rebuilt for new gcc4.1 snapshot and glibc changes
241
242* Sun Dec  4 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-4
243- Rebuild for new bind.
244
245* Sun Nov  6 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-3
246- Update to 2.0.7.
247- Modify desktop patch for upstream fixes.
248- Drop the %%config from .desktop files.
249
250* Mon Sep 26 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.6-3
251- Update to 2.0.6.
252
253* Fri Sep  2 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.5-3
254- Update to 2.0.5.
255- Enable debug info.
256
257* Tue Aug 16 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.4-4
258- Rebuild for cairo dep.
259
260* Thu Jul 28 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.4-2
261- Update to 2.0.4.
262- Use new stdsounds.
263
264* Fri Jul 15 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.3-2
265- Bump release.
266
267* Thu Jul 14 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.3-1
268- Update to 2.0.3.
269
270* Tue Jun 14 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.2-1
271- Update to 2.0.2.
272- Add dist tag.
273
274* Tue Apr 26 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.1-1.fc4
275- Update to 2.0.1.
276
277* Mon Apr 18 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.0-3.fc4
278- Re-add patch to set aifill to 5 on new servers to get some opponents.
279
280* Mon Apr 18 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.0-2.fc4
281- remove redundant --dir* options in %%configure & %%makeinstall.
282
283* Mon Apr 18 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.0-1.fc4
284- Update to 2.0.0.
285- Drop 1.14 patches.
286- Add new BR's for 2.0.0.
287
288* Sat Mar 26 2005 Brian Pepple <bdpepple@ameritech.net> - 1.14.2-7
289- Fixed typos.
290
291* Sat Mar 26 2005 Brian Pepple <bdpepple@ameritech.net> - 1.14.2-6
292- Added more macros.
293- Replaced BuildPrereq with BuildRequires.
294- Drop version of gtk2-devel, since FC3 & later meet minimum needed.
295
296* Wed Mar 23 2005 Brian Pepple <bdpepple@ameritech.net> - 1.14.2-5
297- Changed X-Red-Hat-Extra to X-Fedora.
298- Added URL.
299- Changed BuildRoot to preferred value.
300- Removed period from summary.
301
302* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> 1.14.2-4
303- Rebuilt for new readline.
304
305* Tue Oct 26 2004 Daniel Reed <djr@redhat.com> 1.14.2-3
306- [136921] Try a little harder to run as nobody
307
308* Mon Oct 25 2004 Daniel Reed <djr@redhat.com> 1.14.2-2
309- [136921] Provide the user with the opportunity to run FreeCiv as root if unable to su to nobody, and throw up an error message if everything fails
310
311* Mon Sep 13 2004 Karsten Hopp <karsten@redhat.de> 1.14.2-1
312- update to latest stable version
313
314* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
315- rebuilt
316
317* Mon Feb 23 2004 Karsten Hopp <karsten@redhat.de> 1.14.1-3
318- rebuild with new chown syntax
319
320* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
321- Use ':' instead of '.' as separator for chown.
322
323* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
324- rebuilt
325
326* Wed Dec 03 2003 Karsten Hopp <karsten@redhat.de> 1.14.1-1
327- update to bugfix release 1.14.1
328
329* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
330- rebuilt
331
332* Thu May 08 2003 Karsten Hopp <karsten@redhat.de> 1.14.0-1
333- update
334
335* Thu Feb 20 2003 Karsten Hopp <karsten@redhat.de> 1.13.0-6
336- remove last patch (obsolete)
337
338* Wed Feb 19 2003 Karsten Hopp <karsten@redhat.de>
339- fix message translation (#84599)
340
341* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
342- rebuilt
343
344* Thu Nov 07 2002 Karsten Hopp <karsten@redhat.de>
345- spelling fix (#75021)
346- set aifill to 5 on new servers to get some opponents (#72586)
347
348* Thu Aug 01 2002 Karsten Hopp <karsten@redhat.de>
349- desktop fixes (#69391)
350
351* Wed Jul 24 2002 Karsten Hopp <karsten@redhat.de>
352- 0.1.13
353- s/Games/Game in desktop-file-install
354- fix URL
355- add standard sounds
356
357* Wed Jul 17 2002 Karsten Hopp <karsten@redhat.de> 1.12.0-6
358- fix path to datafiles if FREECIV_PATH is not set (#67922)
359- fix desktop files (#67920)
360- use desktop-file-install
361
362* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
363- automated rebuild
364
365* Thu May 23 2002 Tim Powers <timp@redhat.com>
366- automated rebuild
367
368* Thu Jan 24 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.12.0-2
369- Rebuild in current environment
370
371* Thu Aug 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.12.0-1
372- 1.12.0 (non-beta)
373
374* Tue Jul 31 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.11.4-9
375- Rebuild - the fix for #49442 didn't seem to get in last time.
376
377* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.11.4-8
378- Fix up demographics (#50119)
379
380* Wed Jun 27 2001 Than Ngo <than@redhat.com>
381- support new gettext
382- add patch to build against new libtool
383
384* Tue Mar 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
385- use gtk-config instead of glib-config
386
387* Sun Feb 25 2001 Bernhard Rosenkraenzer <bero@redhat.com>
388- Fix up civclient-wrapper so it doesn't fail silently when started as
389  potentially harmful user (Bug #28928)
390
391* Tue Aug  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
392- Fix warning in civclient-wrapper (Bug 14860)
393
394* Fri Jul 21 2000 Trond Eivind Glomsrød <teg@redhat.com>
395- 1.11.4
396- move to /usr/bin and /usr/share/freeciv (no more /usr/games)
397
398* Wed Jul 12 2000 Trond Eivind Glomsrød <teg@redhat.com>
399- remove icon, glint is obsoleted
400- don't use find to build file lists, it claimed to own
401  lots of directories
402- use %%{_tmppath}
403
404* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
405- automatic rebuild
406
407* Mon Jul 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
408- 1.11.0 (Bug #13610)
409- Add .desktop files (Bug #13610)
410- Add BuildPrereq: lines
411- fix build
412
413* Thu Jun  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
414- move to dist
415- update
416- clean up the spec file
417- fix build with gcc 2.96
418- make the gtk client default; it's better than the Xaw one by now.
419
420* Thu Feb 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
421- 1.10.0
422
423* Fri Feb  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
424- 1.9.2
425- use the configure macro
426
427* Sun Nov  7 1999 Bernhard Rosenkraenzer <bero@redhat.com>
428- redo RPM for 1.9.0 (many changes to build/install procedure)
Note: See TracBrowser for help on using the repository browser.