source: projects/specs/trunk/f/foomatic/foomatic-vl.spec @ 8533

Revision 8533, 22.6 KB checked in by tomop, 10 years ago (diff)

foomatic-4.0.11-1

Line 
1%define dbver_rel 4.0
2%define dbver_snap 20140607
3%define enginever 4.0.11
4%define filtersver 4.0.17
5
6Summary: Foomatic printer database.
7Name:           foomatic
8Version:        %{enginever}
9Release:        1%{?_dist_release}
10License:        GPL
11Group: System Environment/Libraries
12
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: tomop, daisuke, machino
16
17Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
18Source1: http://www.linuxprinting.org/download/foomatic/foomatic-filters-%{filtersver}.tar.gz
19Source2: http://www.linuxprinting.org/download/foomatic/foomatic-db-%{dbver_rel}-%{dbver_snap}.tar.gz
20
21# Use libdir.
22Patch1: foomatic-filters-libdir.patch
23Patch2: foomatic-db-engine-libdir.patch
24
25# Handle non-UTF-8 encodings in imported PPD files.
26Patch15: foomatic-bad-utf8.patch
27
28Url:            http://www.linuxprinting.org
29Requires:       perl >= 5.12.3
30Requires:       %(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
31Requires:       hplip
32BuildRequires:  perl >= 5.12.3
33BuildRequires:  libxml2-devel
34BuildRequires:  ghostscript-devel
35BuildRequires:  autoconf, automake
36BuildRequires:  mpage
37BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
38Provides:       perl(Foomatic::GrovePath)
39# For 'rm' and '/sbin/service' in post
40Requires(pre):  coreutils initscripts
41Obsoletes: foomatic-db < 4.0.0
42Obsoletes: foomatic-ppd < 4.0.0
43Obsoletes: foomatic-ppd-gimp-print < 4.0.0
44Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0.0
45Obsoletes: foomatic-ppd-omni < 4.0.0
46
47# We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
48Conflicts: ghostscript < 7.05
49
50%description
51Foomatic is a comprehensive, spooler-independent database of printers,
52printer drivers, and driver descriptions. It contains utilities to
53generate driver description files and printer queues for CUPS, LPD,
54LPRng, and PDQ using the database. There is also the possibility to
55read the PJL options out of PJL-capable laser printers and take them
56into account at the driver description file generation.
57
58There are spooler-independent command line interfaces to manipulate
59queues (foomatic-configure) and to print files/manipulate jobs
60(foomatic printjob).
61
62The site http://www.linuxprinting.org/ is based on this database.
63
64%prep
65%setup -q  -c -a 1 -a 2
66
67#pushd foomatic-filters-%{filtersver}
68#%patch1 -p1 -b .libdir
69#popd
70
71pushd foomatic-db-engine-%{enginever}
72chmod a+x mkinstalldirs
73#%patch2 -p1 -b .libdir
74#%patch15 -p1
75popd
76
77pushd foomatic-db-%{dbver_snap}
78
79cd db/source
80
81# For gutenprint printers, use gutenprint-ijs-simplified.5.2.
82perl -pi -e 's,>gutenprint<,>gutenprint-ijs-simplified.5.2<,' printer/*.xml
83
84# Remove references to foo2zjs, foo2oak, foo2hp and foo2qpdl (bug #208851).
85# Also foo2lava, foo2kyo, foo2xqx (bug #438319).
86for x in zjs oak hp qpdl lava kyo xqx
87do
88  find printer -name '*.xml' |xargs grep -l "<driver>foo2${x}"|xargs rm -vf
89  rm -f driver/foo2${x}.xml opt/foo2${x}-*
90done
91# Same for m2300w/m2400w
92find printer -name '*.xml' |xargs grep -l '<driver>m2[34]00w<'|xargs rm -vf
93rm -f driver/m2300w.xml driver/m2400w.xml opt/m2300w-*
94# Same for all these.
95for x in drv_x125 ml85p pbm2lwxl pbmtozjs bjc800j
96do
97  find printer -name '*.xml' |xargs grep -l "<driver>${x}</driver>"|xargs rm -vf
98  rm -vf driver/${x}.xml opt/${x}-*
99done
100
101popd
102
103%build
104export LIB_CUPS=%{_libdir}/cups
105export CUPS_BACKENDS=%{_libdir}/cups/backend
106export CUPS_FILTERS=%{_libdir}/cups/filter
107export CUPS_PPDS=%{_datadir}/cups/model
108
109pushd foomatic-filters-%{filtersver}
110%configure
111make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
112        INSTALLDIRS=vendor
113popd
114
115pushd foomatic-db-engine-%{enginever}
116%configure --disable-xmltest
117make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
118        INSTALLDIRS=vendor defaults
119make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
120        INSTALLDIRS=vendor
121popd
122
123pushd foomatic-db-%{dbver_snap}
124%configure
125make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
126        INSTALLDIRS=vendor
127popd
128
129%install
130rm -rf %{buildroot}
131
132pushd foomatic-filters-%{filtersver}
133eval `perl '-V:installvendorlib' '-V:installvendorarch'`
134mkdir -p %{buildroot}/$installvendorlib
135
136
137echo %{buildroot}
138
139make    DESTDIR=%{buildroot} PREFIX=%{_prefix} \
140        INSTALLDIRS=vendor \
141        INSTALLVENDORLIB=$installvendorlib \
142        INSTALLVENDORARCH=$installvendorarch \
143        install-main install-cups
144popd
145
146pushd foomatic-db-engine-%{enginever}
147make    DESTDIR=%buildroot PREFIX=%{_prefix} \
148        INSTALLDIRS=vendor \
149        INSTALLVENDORLIB=$installvendorlib \
150        INSTALLVENDORARCH=$installvendorarch \
151        install
152popd
153
154pushd foomatic-db-%{dbver_snap}
155make    DESTDIR=%buildroot PREFIX=%{_prefix} \
156        INSTALLDIRS=vendor \
157        INSTALLVENDORLIB=$installvendorlib \
158        INSTALLVENDORARCH=$installvendorarch \
159        install
160popd
161
162# Remove ghostscript UPP drivers that are gone in 7.07
163rm -f %buildroot%{_datadir}/foomatic/db/source/driver/{bjc6000a1,PM760p,PM820p,s400a1,sharp,Stc670pl,Stc670p,Stc680p,Stc760p,Stc777p,Stp720p,Stp870p}.upp.xml
164
165# Remove drivers with no command line.
166pushd foomatic-db-engine-%{enginever}
167perl -Ilib ./foomatic-cleanupdrivers %buildroot%{_datadir}/foomatic
168popd
169
170# Update any old-style printer IDs still left around.
171echo '#!/usr/bin/perl -pi' > convert-printerids.pl
172sed -e 's|^\(.*\) \(.*\)$|s,printer/\1,printer/\2,g;|' \
173        %{buildroot}%{_datadir}/foomatic/db/oldprinterids \
174        >> convert-printerids.pl
175chmod a+x convert-printerids.pl
176./convert-printerids.pl %{buildroot}%{_datadir}/foomatic/db/source/{opt,driver}/*.xml
177find %{buildroot}%{_datadir}/foomatic/db/source/ -type f | xargs chmod 0644
178
179# Use relative, not absolute, symlink for CUPS filter.
180ln -sf ../../../bin/foomatic-rip %{buildroot}%{_libdir}/cups/filter/foomatic-rip
181
182mkdir %{buildroot}%{_datadir}/foomatic/db/source/PPD/Custom
183mkdir -p %{buildroot}%{_var}/cache/foomatic
184
185echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
186
187# Remove things we don't ship.
188rm -rf  %{buildroot}%{_libdir}/perl5/site_perl \
189        %{buildroot}%{_libdir}/ppr \
190        %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample
191find %{buildroot} -name .packlist -o -name '*.xml.*' | xargs rm -f
192
193
194%post
195/bin/rm -f /var/cache/foomatic/*
196
197# restart the print server if it is running now
198/sbin/service lpd condrestart >/dev/null 2>&1
199/sbin/service cups condrestart >/dev/null 2>&1
200
201exit 0
202
203%clean
204rm -fr %buildroot $RPM_BUILD_DIR/%{name}
205
206%files
207%defattr(-,root,root)
208%doc --parents */README */USAGE */ChangeLog
209%dir %{_sysconfdir}/foomatic
210%config(noreplace) %{_sysconfdir}/foomatic/filter.conf
211%config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
212%{_bindir}/*
213%{_sbindir}/*
214%{perl_vendorlib}/Foomatic
215%{_libdir}/cups/backend/*
216%{_libdir}/cups/driver/*
217%{_libdir}/cups/filter/*
218%{_datadir}/foomatic
219%{_datadir}/cups/model/foomatic-db-ppds
220%{_mandir}/*/*
221%{_var}/cache/foomatic
222
223%changelog
224* Sun Jun  8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.11-1
225- new upstream release.
226
227* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
228- new upstream release.
229
230* Mon Jun 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
231- added hplip and coreutils to "Requires:".
232- removed hpijs and fileutils from "Requires:".
233
234* Wed Apr 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
235- new upstream release.
236- dropped Source3 (no longer provided by upstream).
237- updated Patch2.
238
239* Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
240- rebuild with perl 5.12.3
241
242* Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
243- add Requires: hpijs
244
245* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
246- new upstream release
247
248* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
249- new upstream release.
250- applied some patches from Fedora development.
251- remove subpackages.
252
253* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
254- applied new versioning policy
255- used rpm macros: %%perl_sitelib %%perl_sitearch
256- added foomatic-db-engine-3.1-20050411-combo-xml.patch
257- added foomatic-db-engine-3.1-20050411-perl-data.patch
258- fixed permission of %%{_datadir}/foomatic/db
259
260* Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
261- add BuildRequires: libxml2-devel, mpage, Omni
262- use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
263- run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
264- not create ppd-omni package if omni support is disabled
265
266* Mon Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
267- updated foomatic-db to 20050411
268- updated foomatic-db-engine to 3.1-20050411
269- updated foomatic-db-hpijs to 1.5-20050411
270- updated foomatic-filters to 3.1-20050411
271
272* Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
273- updated foomatic-db to 20050112
274- updated foomatic-db-engine to 3.1-20050112
275- updated foomatic-db-hpijs to 1.5-20050112
276
277* Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
278- updated foomatic-db to 20041220
279- updated foomatic-db-hpijs to 1.5-20041220
280
281* Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
282- updated foomatic-db to 20040919
283- updated foomatic-db-engine to 3.0.2
284- updated foomatic-db-hpijs to 1.5-20040919
285- updated foomatic-filters to 3.0.2
286
287* Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
288- update foomatic-db to 20040526
289- update foomatic-db-hpijs to 1.5-20040526
290
291* Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
292- sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
293  ppd-gimp-print-ijs
294- add Requires: to ppd-* subpackages.
295
296* Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
297- new upstream version
298        -- Omni-printers-0.9.1
299        -- gimp-print-foomatic-db-4.2.6
300- foomatic.spec -> foomatic-vl.spec
301
302* Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
303- new upstream version
304        -- foomatic-filters-3.0.1
305        -- foomatic-db-engine-3.0.1
306        -- foomatic-db-20040219
307        -- foomatic-db-hpijs-1.5-20040219
308
309* Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
310- new upstream version
311        -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
312        -- defined filterver
313- dropped patch101
314
315* Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
316- new upstream cvs version(foomatic-3.0.1rc2)
317        -- foomatic-db-20040125
318        -- foomatic-db-engine-3.0.1rc2
319        -- foomatic-db-hpijs-1.5-20040125
320        -- foomatic-filters-3.0.1rc2
321- added patch101
322        -- tests diris null in foomatic-filters-3.0.1rc2
323
324* Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
325- new upstream cvs version
326        -- foomatic-db-20040123
327        -- foomatic-db-engine-3.0-20040123
328        -- foomatic-db-hpijs-1.5-20040123
329        -- foomatic-filters-3.0-20040123
330- dropped old patches
331
332* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
333- built on perl-5.8.2
334
335* Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
336- separated foomatic-db package included xml files
337
338* Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
339- added description of ppd sub package
340
341* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
342- separated foomatic-ppd package included PPD files
343
344* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
345- new upstream version
346        -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
347        -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
348- dropped patches
349        -- foomatic-filters-path.patch(patch0)
350        -- foomatic-2.0.2-fontpath.patch(patch3)
351- updated patches
352        -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
353        -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
354        -- foomatic-filters-3.0-20031109-vine.patch (patch100)
355
356* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
357- built on perl-5.8.1
358- fixed install section in spec file
359
360* Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
361- fix some bugs of foomatic-filters.
362A
363
364* Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
365- new upstream version
366        -- rewrote spec file
367        -- added some patches from rawhide(foomatic-3.0.0-5)
368- enable cups support
369
370* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
371- imported some patches from foomatic-2.0.2-18
372        -- added foomatic-2.0.2-psc2210.patch
373        -- added foomatic-2.0.2-duplex184.patch
374
375* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
376- imported foomatic-2.0.2-15
377 
378* Tue Feb  4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
379- Update data-generators to CVS.
380
381* Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
382- Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
383
384* Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
385- Pacify printers that don't understand duplex (bug #82385).
386
387* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
388- rebuilt
389
390* Tue Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
391- Add autodetect info for HP DeskJet 656C.  It doesn't really do
392  IEEE 1284 IDs, but since it's a USB device we can figure out it's
393  manufacturer and model anyway.
394
395* Thu Jan  9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
396- Set GS_FONTPATH in gs wrapper (bug #81410).
397
398* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
399- use internal dep generator.
400
401* Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
402- Add several device IDs.
403
404* Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
405- Update Omni printers to 0.7.2.
406- No longer need Omni badxml patch.
407
408* Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
409- don't use rpms internal dep generator
410
411* Fri Dec  6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
412- Omni XML wasn't well-formed.
413
414* Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
415- Update gimp-print data.
416- Add 'generic postscript' model.
417
418* Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
419- Update Omni printers to 0.7.1.
420
421* Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
422- Fix file manifest for perl modules.
423- Add autodetect information for HP DeskJet 990C.
424
425* Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
426- 2.0.2.
427- No longer need 67973, 970c patches.
428- Remove cups-drivers-* packages (no longer needed).
429- Remove files not shipped.  Ship filter.conf.
430- Conditionally restart cups.
431- Use libdir.
432- Don't put things in site_perl; use vendor_perl instead (bug #73528).
433
434* Fri Aug  9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
435- Fix autodetect information for HPDJ970C.
436
437* Thu Aug  8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
438- For gimp-print, use the Ghostscript stp driver in preference to the
439  IJS interface.
440
441* Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
442- Quieten scriptlets.
443
444* Fri Jul  5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
445- Fix autodetect information for HPLJ2100/2100M.
446
447* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
448- automated rebuild
449
450* Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
451- Omni 0.7.0 printers.
452
453* Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
454- Update to CVS.
455- Remove some more explicit perl dependencies that are picked up
456  automatically.
457
458* Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
459- Remove explicit perl-Storable dependency; it should be perl(Storable),
460  and that is picked up automatically.
461
462* Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
463- Fix release number.
464- Drop gen-ppds from the file manifest---use foomatic-compiledb instead
465  (bug #63622).
466
467* Sun May 26 2002 Tim Powers <timp@redhat.com>
468- automated rebuild
469
470* Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
471- Remove ghostscript UPP drivers that are gone in 7.05.
472
473* Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
474- Update to CVS.
475- Updated requirements.
476- Updated path and libdir patches.
477- Drop hpijs 1.0.2 patch.
478- foomatic-datafile has moved to %%{_bindir}.
479- Update gimp-print data to 4.2.1.
480- Update Omni printer data to 0.6.1.
481
482* Thu Apr  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
483- Fix the hpijs option data too (bug #62587).
484
485* Wed Apr  3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
486- Back off to 1.0.2 for hpijs driver data (bug #62587).
487
488* Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
489- Update to CVS.
490
491* Wed Mar  6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
492- Update to CVS.
493- Patches no longer needed: conffile, sys, cachedir, fd0.
494- Adapted path patch.
495
496* Tue Mar  5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
497- Fix bug #58319.
498- Drop dbg patch.
499
500* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
501- Fix file lists.
502
503* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
504- Fix %post scriplet bug (bug #59942).
505
506* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
507- Rebuild in new environment.
508
509* Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
510- Merge cups-drivers.  No epoch needed.
511- Require perl-URI.
512
513* Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
514- Cache fix.
515
516* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
517- Don't ship backup files.
518
519* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
520- Rebuild to pick up new perl installsitelib.
521
522* Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
523- Fix a thinko in DB.pl.
524
525* Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
526- Update to CVS.
527- No longer need the cachedir patch.
528- Fix config file path.
529- Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
530
531* Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
532- Update to CVS.
533- Patches no longer needed: prepend, fd3.
534- Use RPM_OPT_FLAGS.
535- Allow non-root users to use foomatic-datafile (bug #58956).
536
537* Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
538- added Provides: perl(Foomatic::GrovePath)
539
540* Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
541- Update to CVS.
542- Updated Omni printers to those in Omni 0.5.1.
543- Updated patches: prepend, fd3.
544- Patches no longer needed: utf8, lpdomatic.
545- Added gimp-print (formerly stp) foomatic db info, and removed the old
546  stp.xml file.
547- Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
548
549* Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
550- REALLY fix PCL fixup code (bug #55909, others).
551- PreReq fileutils, initscripts (bug #56984).
552- Fix prepends in lpdomatic (bug #57371).
553- Run foomatic-cleanupdrivers during install, to remove driver entries
554  with no command line.
555- Put lpdomatic in /usr/sbin again.
556- Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
557
558* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
559- re-imported from upstream to fix some perl fixup code on pcl printers.
560
561* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
562- fix the rest of the quoting issues with foomatic-combo-xml with the patch
563- foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
564
565* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
566- respin to pull in latest foomatic database, fixes:
567-       properly use the cache in relation to foomatic-combo-xml's output
568-       fix _some_ of the quoting issues with calling foomatic-combo-xml
569
570* Wed Dec  5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
571- respin to pull in latest foomatic database, fixes:
572-       droping half of a large job
573-       -Mutf8 added to the upstream filters
574-       miscelaneous printer db updates
575
576* Thu Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
577- added Requires: fileutils for the 'rm' in post
578
579* Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
580- /var/chache => /var/cache, doh!
581
582* Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
583- fix %%post scriptlet
584
585* Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
586- changed the patch to use the -Mutf8 command line option,
587- and to restart the printserver, after rebuilding the settings.
588
589* Fri Nov  9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
590- grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
591- pragma. Without it, they break on _some_ of their options.
592
593* Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
594- patched lpdomatic to prepend PostScript options in the _right_ place.
595
596* Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
597- zap the foomatic cache on install
598
599* Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
600- rolled to pull in latest information.
601- added Omni printers to the printer list.
602
603* Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
604- rolled to pull in an ia64 fix to foomatic-combo-xml.c
605
606* Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
607- rolled to pull in foomatic fixes to foomatic-combo-xml.c
608
609* Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
610- upgraded to latest foomatic, we now have fast overview generation!
611- this means that there is no prebuilt overview file.
612
613* Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
614- WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
615- It is now fast enough that there is no real benifit to precompiling.
616- NOTE: this forces the package to stop being noarched.
617
618* Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
619- fresh pull, maybe it fixes the build errors.
620
621* Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
622- did a fresh database pull, which contains the old japanese printers as well.
623- removed japanese hack.
624
625* Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
626- Add Japanese printer entry.
627
628* Mon Aug  6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
629- move the cache back to /var, sigh.
630
631* Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
632- made foomatic pre-compute its db
633
634* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
635- imported from mandrake.
636
637* Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
638- Added job listing/removal/manipulation and queue control to
639  foomatic-printjob
640- Support for printing multiple copies with PDQ
641
642* Sat Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
643- Included the cupsomatic filter script
644- When a queue is set up, default options can be set now
645- Help messages of foomatic-configure and foomatic-printjob cleaned up.
646
647* Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
648- Many bugfixes in "foomatic-printjob".
649- "foomatic-configure" adds the Foomatic config file directory automatically
650  to the search paths of PDQ.
651- Printing a help page under PDQ was broken.
652
653* Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
654- BuildRequires:        perl-devel
655
656* Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
657- initial release.
658- Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
659- Patch applied which flushes the memory cache regularly, otherwise
660  foomatic-configure would hang when the Foomatic data of GIMP-Print is
661  installed.
Note: See TracBrowser for help on using the repository browser.