source: projects/specs/trunk/f/foomatic/foomatic-vl.spec @ 8112

Revision 8112, 22.5 KB checked in by tomop, 10 years ago (diff)

foomatic-4.0.9-1

Line 
1%define dbver_rel 4.0
2%define dbver_snap 20140104
3%define enginever 4.0.9
4%define filtersver 4.0.17
5
6Summary: Foomatic printer database.
7Name:           foomatic
8Version:        %{enginever}
9Release:        1%{?_dist_release}
10License:        GPL
11Group: System Environment/Libraries
12
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: tomop, daisuke, machino
16
17Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
18Source1: http://www.linuxprinting.org/download/foomatic/foomatic-filters-%{filtersver}.tar.gz
19Source2: http://www.linuxprinting.org/download/foomatic/foomatic-db-%{dbver_rel}-%{dbver_snap}.tar.gz
20
21# Use libdir.
22Patch1: foomatic-filters-libdir.patch
23Patch2: foomatic-db-engine-libdir.patch
24
25# Handle non-UTF-8 encodings in imported PPD files.
26Patch15: foomatic-bad-utf8.patch
27
28Url:            http://www.linuxprinting.org
29Requires:       perl >= 5.12.3
30Requires:       %(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
31Requires:       hplip
32BuildRequires:  perl >= 5.12.3
33BuildRequires:  libxml2-devel
34BuildRequires:  ghostscript-devel
35BuildRequires:  autoconf, automake
36BuildRequires:  mpage
37BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
38Provides:       perl(Foomatic::GrovePath)
39# For 'rm' and '/sbin/service' in post
40Requires(pre):  coreutils initscripts
41Obsoletes: foomatic-db < 4.0.0
42Obsoletes: foomatic-ppd < 4.0.0
43Obsoletes: foomatic-ppd-gimp-print < 4.0.0
44Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0.0
45Obsoletes: foomatic-ppd-omni < 4.0.0
46
47# We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
48Conflicts: ghostscript < 7.05
49
50%description
51Foomatic is a comprehensive, spooler-independent database of printers,
52printer drivers, and driver descriptions. It contains utilities to
53generate driver description files and printer queues for CUPS, LPD,
54LPRng, and PDQ using the database. There is also the possibility to
55read the PJL options out of PJL-capable laser printers and take them
56into account at the driver description file generation.
57
58There are spooler-independent command line interfaces to manipulate
59queues (foomatic-configure) and to print files/manipulate jobs
60(foomatic printjob).
61
62The site http://www.linuxprinting.org/ is based on this database.
63
64%prep
65%setup -q  -c -a 1 -a 2
66
67#pushd foomatic-filters-%{filtersver}
68#%patch1 -p1 -b .libdir
69#popd
70
71pushd foomatic-db-engine-%{enginever}
72chmod a+x mkinstalldirs
73#%patch2 -p1 -b .libdir
74#%patch15 -p1
75popd
76
77pushd foomatic-db-%{dbver_snap}
78
79cd db/source
80
81# For gutenprint printers, use gutenprint-ijs-simplified.5.2.
82perl -pi -e 's,>gutenprint<,>gutenprint-ijs-simplified.5.2<,' printer/*.xml
83
84# Remove references to foo2zjs, foo2oak, foo2hp and foo2qpdl (bug #208851).
85# Also foo2lava, foo2kyo, foo2xqx (bug #438319).
86for x in zjs oak hp qpdl lava kyo xqx
87do
88  find printer -name '*.xml' |xargs grep -l "<driver>foo2${x}"|xargs rm -vf
89  rm -f driver/foo2${x}.xml opt/foo2${x}-*
90done
91# Same for m2300w/m2400w
92find printer -name '*.xml' |xargs grep -l '<driver>m2[34]00w<'|xargs rm -vf
93rm -f driver/m2300w.xml driver/m2400w.xml opt/m2300w-*
94# Same for all these.
95for x in drv_x125 ml85p pbm2lwxl pbmtozjs bjc800j
96do
97  find printer -name '*.xml' |xargs grep -l "<driver>${x}</driver>"|xargs rm -vf
98  rm -vf driver/${x}.xml opt/${x}-*
99done
100
101popd
102
103%build
104export LIB_CUPS=%{_libdir}/cups
105export CUPS_BACKENDS=%{_libdir}/cups/backend
106export CUPS_FILTERS=%{_libdir}/cups/filter
107export CUPS_PPDS=%{_datadir}/cups/model
108
109pushd foomatic-filters-%{filtersver}
110%configure
111make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
112        INSTALLDIRS=vendor
113popd
114
115pushd foomatic-db-engine-%{enginever}
116%configure --disable-xmltest
117make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
118        INSTALLDIRS=vendor defaults
119make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
120        INSTALLDIRS=vendor
121popd
122
123pushd foomatic-db-%{dbver_snap}
124%configure
125make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
126        INSTALLDIRS=vendor
127popd
128
129%install
130rm -rf %{buildroot}
131
132pushd foomatic-filters-%{filtersver}
133eval `perl '-V:installvendorlib' '-V:installvendorarch'`
134mkdir -p %{buildroot}/$installvendorlib
135
136
137echo %{buildroot}
138
139make    DESTDIR=%{buildroot} PREFIX=%{_prefix} \
140        INSTALLDIRS=vendor \
141        INSTALLVENDORLIB=$installvendorlib \
142        INSTALLVENDORARCH=$installvendorarch \
143        install-main install-cups
144popd
145
146pushd foomatic-db-engine-%{enginever}
147make    DESTDIR=%buildroot PREFIX=%{_prefix} \
148        INSTALLDIRS=vendor \
149        INSTALLVENDORLIB=$installvendorlib \
150        INSTALLVENDORARCH=$installvendorarch \
151        install
152popd
153
154pushd foomatic-db-%{dbver_snap}
155make    DESTDIR=%buildroot PREFIX=%{_prefix} \
156        INSTALLDIRS=vendor \
157        INSTALLVENDORLIB=$installvendorlib \
158        INSTALLVENDORARCH=$installvendorarch \
159        install
160popd
161
162# Remove ghostscript UPP drivers that are gone in 7.07
163rm -f %buildroot%{_datadir}/foomatic/db/source/driver/{bjc6000a1,PM760p,PM820p,s400a1,sharp,Stc670pl,Stc670p,Stc680p,Stc760p,Stc777p,Stp720p,Stp870p}.upp.xml
164
165# Remove drivers with no command line.
166pushd foomatic-db-engine-%{enginever}
167perl -Ilib ./foomatic-cleanupdrivers %buildroot%{_datadir}/foomatic
168popd
169
170# Update any old-style printer IDs still left around.
171echo '#!/usr/bin/perl -pi' > convert-printerids.pl
172sed -e 's|^\(.*\) \(.*\)$|s,printer/\1,printer/\2,g;|' \
173        %{buildroot}%{_datadir}/foomatic/db/oldprinterids \
174        >> convert-printerids.pl
175chmod a+x convert-printerids.pl
176./convert-printerids.pl %{buildroot}%{_datadir}/foomatic/db/source/{opt,driver}/*.xml
177find %{buildroot}%{_datadir}/foomatic/db/source/ -type f | xargs chmod 0644
178
179# Use relative, not absolute, symlink for CUPS filter.
180ln -sf ../../../bin/foomatic-rip %{buildroot}%{_libdir}/cups/filter/foomatic-rip
181
182mkdir %{buildroot}%{_datadir}/foomatic/db/source/PPD/Custom
183mkdir -p %{buildroot}%{_var}/cache/foomatic
184
185echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
186
187# Remove things we don't ship.
188rm -rf  %{buildroot}%{_libdir}/perl5/site_perl \
189        %{buildroot}%{_libdir}/ppr \
190        %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample
191find %{buildroot} -name .packlist -o -name '*.xml.*' | xargs rm -f
192
193
194%post
195/bin/rm -f /var/cache/foomatic/*
196
197# restart the print server if it is running now
198/sbin/service lpd condrestart >/dev/null 2>&1
199/sbin/service cups condrestart >/dev/null 2>&1
200
201exit 0
202
203%clean
204rm -fr %buildroot $RPM_BUILD_DIR/%{name}
205
206%files
207%defattr(-,root,root)
208%doc --parents */README */USAGE */ChangeLog
209%dir %{_sysconfdir}/foomatic
210%config(noreplace) %{_sysconfdir}/foomatic/filter.conf
211%config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
212%{_bindir}/*
213%{_sbindir}/*
214%{perl_vendorlib}/Foomatic
215%{_libdir}/cups/backend/*
216%{_libdir}/cups/driver/*
217%{_libdir}/cups/filter/*
218%{_datadir}/foomatic
219%{_datadir}/cups/model/foomatic-db-ppds
220%{_mandir}/*/*
221%{_var}/cache/foomatic
222
223%changelog
224* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
225- new upstream release.
226
227* Mon Jun 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
228- added hplip and coreutils to "Requires:".
229- removed hpijs and fileutils from "Requires:".
230
231* Wed Apr 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
232- new upstream release.
233- dropped Source3 (no longer provided by upstream).
234- updated Patch2.
235
236* Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
237- rebuild with perl 5.12.3
238
239* Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
240- add Requires: hpijs
241
242* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
243- new upstream release
244
245* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
246- new upstream release.
247- applied some patches from Fedora development.
248- remove subpackages.
249
250* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
251- applied new versioning policy
252- used rpm macros: %%perl_sitelib %%perl_sitearch
253- added foomatic-db-engine-3.1-20050411-combo-xml.patch
254- added foomatic-db-engine-3.1-20050411-perl-data.patch
255- fixed permission of %%{_datadir}/foomatic/db
256
257* Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
258- add BuildRequires: libxml2-devel, mpage, Omni
259- use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
260- run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
261- not create ppd-omni package if omni support is disabled
262
263* Mon Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
264- updated foomatic-db to 20050411
265- updated foomatic-db-engine to 3.1-20050411
266- updated foomatic-db-hpijs to 1.5-20050411
267- updated foomatic-filters to 3.1-20050411
268
269* Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
270- updated foomatic-db to 20050112
271- updated foomatic-db-engine to 3.1-20050112
272- updated foomatic-db-hpijs to 1.5-20050112
273
274* Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
275- updated foomatic-db to 20041220
276- updated foomatic-db-hpijs to 1.5-20041220
277
278* Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
279- updated foomatic-db to 20040919
280- updated foomatic-db-engine to 3.0.2
281- updated foomatic-db-hpijs to 1.5-20040919
282- updated foomatic-filters to 3.0.2
283
284* Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
285- update foomatic-db to 20040526
286- update foomatic-db-hpijs to 1.5-20040526
287
288* Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
289- sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
290  ppd-gimp-print-ijs
291- add Requires: to ppd-* subpackages.
292
293* Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
294- new upstream version
295        -- Omni-printers-0.9.1
296        -- gimp-print-foomatic-db-4.2.6
297- foomatic.spec -> foomatic-vl.spec
298
299* Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
300- new upstream version
301        -- foomatic-filters-3.0.1
302        -- foomatic-db-engine-3.0.1
303        -- foomatic-db-20040219
304        -- foomatic-db-hpijs-1.5-20040219
305
306* Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
307- new upstream version
308        -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
309        -- defined filterver
310- dropped patch101
311
312* Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
313- new upstream cvs version(foomatic-3.0.1rc2)
314        -- foomatic-db-20040125
315        -- foomatic-db-engine-3.0.1rc2
316        -- foomatic-db-hpijs-1.5-20040125
317        -- foomatic-filters-3.0.1rc2
318- added patch101
319        -- tests diris null in foomatic-filters-3.0.1rc2
320
321* Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
322- new upstream cvs version
323        -- foomatic-db-20040123
324        -- foomatic-db-engine-3.0-20040123
325        -- foomatic-db-hpijs-1.5-20040123
326        -- foomatic-filters-3.0-20040123
327- dropped old patches
328
329* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
330- built on perl-5.8.2
331
332* Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
333- separated foomatic-db package included xml files
334
335* Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
336- added description of ppd sub package
337
338* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
339- separated foomatic-ppd package included PPD files
340
341* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
342- new upstream version
343        -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
344        -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
345- dropped patches
346        -- foomatic-filters-path.patch(patch0)
347        -- foomatic-2.0.2-fontpath.patch(patch3)
348- updated patches
349        -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
350        -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
351        -- foomatic-filters-3.0-20031109-vine.patch (patch100)
352
353* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
354- built on perl-5.8.1
355- fixed install section in spec file
356
357* Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
358- fix some bugs of foomatic-filters.
359A
360
361* Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
362- new upstream version
363        -- rewrote spec file
364        -- added some patches from rawhide(foomatic-3.0.0-5)
365- enable cups support
366
367* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
368- imported some patches from foomatic-2.0.2-18
369        -- added foomatic-2.0.2-psc2210.patch
370        -- added foomatic-2.0.2-duplex184.patch
371
372* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
373- imported foomatic-2.0.2-15
374 
375* Tue Feb  4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
376- Update data-generators to CVS.
377
378* Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
379- Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
380
381* Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
382- Pacify printers that don't understand duplex (bug #82385).
383
384* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
385- rebuilt
386
387* Tue Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
388- Add autodetect info for HP DeskJet 656C.  It doesn't really do
389  IEEE 1284 IDs, but since it's a USB device we can figure out it's
390  manufacturer and model anyway.
391
392* Thu Jan  9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
393- Set GS_FONTPATH in gs wrapper (bug #81410).
394
395* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
396- use internal dep generator.
397
398* Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
399- Add several device IDs.
400
401* Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
402- Update Omni printers to 0.7.2.
403- No longer need Omni badxml patch.
404
405* Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
406- don't use rpms internal dep generator
407
408* Fri Dec  6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
409- Omni XML wasn't well-formed.
410
411* Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
412- Update gimp-print data.
413- Add 'generic postscript' model.
414
415* Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
416- Update Omni printers to 0.7.1.
417
418* Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
419- Fix file manifest for perl modules.
420- Add autodetect information for HP DeskJet 990C.
421
422* Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
423- 2.0.2.
424- No longer need 67973, 970c patches.
425- Remove cups-drivers-* packages (no longer needed).
426- Remove files not shipped.  Ship filter.conf.
427- Conditionally restart cups.
428- Use libdir.
429- Don't put things in site_perl; use vendor_perl instead (bug #73528).
430
431* Fri Aug  9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
432- Fix autodetect information for HPDJ970C.
433
434* Thu Aug  8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
435- For gimp-print, use the Ghostscript stp driver in preference to the
436  IJS interface.
437
438* Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
439- Quieten scriptlets.
440
441* Fri Jul  5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
442- Fix autodetect information for HPLJ2100/2100M.
443
444* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
445- automated rebuild
446
447* Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
448- Omni 0.7.0 printers.
449
450* Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
451- Update to CVS.
452- Remove some more explicit perl dependencies that are picked up
453  automatically.
454
455* Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
456- Remove explicit perl-Storable dependency; it should be perl(Storable),
457  and that is picked up automatically.
458
459* Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
460- Fix release number.
461- Drop gen-ppds from the file manifest---use foomatic-compiledb instead
462  (bug #63622).
463
464* Sun May 26 2002 Tim Powers <timp@redhat.com>
465- automated rebuild
466
467* Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
468- Remove ghostscript UPP drivers that are gone in 7.05.
469
470* Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
471- Update to CVS.
472- Updated requirements.
473- Updated path and libdir patches.
474- Drop hpijs 1.0.2 patch.
475- foomatic-datafile has moved to %%{_bindir}.
476- Update gimp-print data to 4.2.1.
477- Update Omni printer data to 0.6.1.
478
479* Thu Apr  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
480- Fix the hpijs option data too (bug #62587).
481
482* Wed Apr  3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
483- Back off to 1.0.2 for hpijs driver data (bug #62587).
484
485* Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
486- Update to CVS.
487
488* Wed Mar  6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
489- Update to CVS.
490- Patches no longer needed: conffile, sys, cachedir, fd0.
491- Adapted path patch.
492
493* Tue Mar  5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
494- Fix bug #58319.
495- Drop dbg patch.
496
497* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
498- Fix file lists.
499
500* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
501- Fix %post scriplet bug (bug #59942).
502
503* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
504- Rebuild in new environment.
505
506* Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
507- Merge cups-drivers.  No epoch needed.
508- Require perl-URI.
509
510* Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
511- Cache fix.
512
513* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
514- Don't ship backup files.
515
516* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
517- Rebuild to pick up new perl installsitelib.
518
519* Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
520- Fix a thinko in DB.pl.
521
522* Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
523- Update to CVS.
524- No longer need the cachedir patch.
525- Fix config file path.
526- Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
527
528* Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
529- Update to CVS.
530- Patches no longer needed: prepend, fd3.
531- Use RPM_OPT_FLAGS.
532- Allow non-root users to use foomatic-datafile (bug #58956).
533
534* Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
535- added Provides: perl(Foomatic::GrovePath)
536
537* Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
538- Update to CVS.
539- Updated Omni printers to those in Omni 0.5.1.
540- Updated patches: prepend, fd3.
541- Patches no longer needed: utf8, lpdomatic.
542- Added gimp-print (formerly stp) foomatic db info, and removed the old
543  stp.xml file.
544- Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
545
546* Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
547- REALLY fix PCL fixup code (bug #55909, others).
548- PreReq fileutils, initscripts (bug #56984).
549- Fix prepends in lpdomatic (bug #57371).
550- Run foomatic-cleanupdrivers during install, to remove driver entries
551  with no command line.
552- Put lpdomatic in /usr/sbin again.
553- Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
554
555* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
556- re-imported from upstream to fix some perl fixup code on pcl printers.
557
558* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
559- fix the rest of the quoting issues with foomatic-combo-xml with the patch
560- foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
561
562* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
563- respin to pull in latest foomatic database, fixes:
564-       properly use the cache in relation to foomatic-combo-xml's output
565-       fix _some_ of the quoting issues with calling foomatic-combo-xml
566
567* Wed Dec  5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
568- respin to pull in latest foomatic database, fixes:
569-       droping half of a large job
570-       -Mutf8 added to the upstream filters
571-       miscelaneous printer db updates
572
573* Thu Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
574- added Requires: fileutils for the 'rm' in post
575
576* Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
577- /var/chache => /var/cache, doh!
578
579* Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
580- fix %%post scriptlet
581
582* Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
583- changed the patch to use the -Mutf8 command line option,
584- and to restart the printserver, after rebuilding the settings.
585
586* Fri Nov  9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
587- grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
588- pragma. Without it, they break on _some_ of their options.
589
590* Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
591- patched lpdomatic to prepend PostScript options in the _right_ place.
592
593* Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
594- zap the foomatic cache on install
595
596* Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
597- rolled to pull in latest information.
598- added Omni printers to the printer list.
599
600* Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
601- rolled to pull in an ia64 fix to foomatic-combo-xml.c
602
603* Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
604- rolled to pull in foomatic fixes to foomatic-combo-xml.c
605
606* Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
607- upgraded to latest foomatic, we now have fast overview generation!
608- this means that there is no prebuilt overview file.
609
610* Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
611- WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
612- It is now fast enough that there is no real benifit to precompiling.
613- NOTE: this forces the package to stop being noarched.
614
615* Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
616- fresh pull, maybe it fixes the build errors.
617
618* Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
619- did a fresh database pull, which contains the old japanese printers as well.
620- removed japanese hack.
621
622* Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
623- Add Japanese printer entry.
624
625* Mon Aug  6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
626- move the cache back to /var, sigh.
627
628* Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
629- made foomatic pre-compute its db
630
631* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
632- imported from mandrake.
633
634* Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
635- Added job listing/removal/manipulation and queue control to
636  foomatic-printjob
637- Support for printing multiple copies with PDQ
638
639* Sat Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
640- Included the cupsomatic filter script
641- When a queue is set up, default options can be set now
642- Help messages of foomatic-configure and foomatic-printjob cleaned up.
643
644* Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
645- Many bugfixes in "foomatic-printjob".
646- "foomatic-configure" adds the Foomatic config file directory automatically
647  to the search paths of PDQ.
648- Printing a help page under PDQ was broken.
649
650* Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
651- BuildRequires:        perl-devel
652
653* Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
654- initial release.
655- Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
656- Patch applied which flushes the memory cache regularly, otherwise
657  foomatic-configure would hang when the Foomatic data of GIMP-Print is
658  installed.
Note: See TracBrowser for help on using the repository browser.