source: projects/specs/trunk/f/foomatic/foomatic-vl.spec @ 3104

Revision 3104, 22.5 KB checked in by iwaim, 13 years ago (diff)

foomatic-4.0.1-3

Line 
1%define dbver_rel 4.0
2%define dbver_snap 20090529
3%define enginever 4.0.1
4%define filtersver 4.0.1
5%define hpijsver 20090529
6
7Summary: Foomatic printer database.
8Name:           foomatic
9Version:        %{enginever}
10Release:        3%{?_dist_release}
11License:        GPL
12Group: System Environment/Libraries
13
14Vendor: Project Vine
15Distribution: Vine Linux
16Packager: tomop, daisuke, machino
17
18Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
19Source1: http://www.linuxprinting.org/download/foomatic/foomatic-filters-%{filtersver}.tar.gz
20Source2: http://www.linuxprinting.org/download/foomatic/foomatic-db-%{dbver_rel}-%{dbver_snap}.tar.gz
21Source3: http://www.linuxprinting.org/download/foomatic/foomatic-db-hpijs-%{hpijsver}.tar.gz
22
23# Use libdir.
24Patch1: foomatic-filters-libdir.patch
25Patch2: foomatic-db-engine-libdir.patch
26
27# Handle non-UTF-8 encodings in imported PPD files.
28Patch15: foomatic-bad-utf8.patch
29
30Url:            http://www.linuxprinting.org
31Requires:       perl >= 5.10.0
32Requires:       %(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
33Requires:       hpijs
34BuildRequires:  perl >= 5.10.0
35BuildRequires:  libxml2-devel
36BuildRequires:  ghostscript-devel
37BuildRequires:  autoconf, automake
38BuildRequires:  mpage
39BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
40Provides:       perl(Foomatic::GrovePath)
41# For 'rm' and '/sbin/service' in post
42PreReq:         fileutils initscripts
43Obsoletes: foomatic-db < 4.0.0
44Obsoletes: foomatic-ppd < 4.0.0
45Obsoletes: foomatic-ppd-gimp-print < 4.0.0
46Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0.0
47Obsoletes: foomatic-ppd-omni < 4.0.0
48
49# We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
50Conflicts: ghostscript < 7.05
51
52%description
53Foomatic is a comprehensive, spooler-independent database of printers,
54printer drivers, and driver descriptions. It contains utilities to
55generate driver description files and printer queues for CUPS, LPD,
56LPRng, and PDQ using the database. There is also the possibility to
57read the PJL options out of PJL-capable laser printers and take them
58into account at the driver description file generation.
59
60There are spooler-independent command line interfaces to manipulate
61queues (foomatic-configure) and to print files/manipulate jobs
62(foomatic printjob).
63
64The site http://www.linuxprinting.org/ is based on this database.
65
66%prep
67%setup -q  -c -a 1 -a 2 -a 3
68
69pushd foomatic-filters-%{filtersver}
70%patch1 -p1 -b .libdir
71popd
72
73pushd foomatic-db-engine-%{enginever}
74chmod a+x mkinstalldirs
75%patch2 -p1 -b .libdir
76%patch15 -p1
77popd
78
79pushd foomatic-db-hpijs-%{hpijsver}
80popd
81
82pushd foomatic-db-%{dbver_snap}
83
84cd db/source
85
86# For gutenprint printers, use gutenprint-ijs-simplified.5.2.
87perl -pi -e 's,>gutenprint<,>gutenprint-ijs-simplified.5.2<,' printer/*.xml
88
89# Remove references to foo2zjs, foo2oak, foo2hp and foo2qpdl (bug #208851).
90# Also foo2lava, foo2kyo, foo2xqx (bug #438319).
91for x in zjs oak hp qpdl lava kyo xqx
92do
93  find printer -name '*.xml' |xargs grep -l "<driver>foo2${x}"|xargs rm -vf
94  rm -f driver/foo2${x}.xml opt/foo2${x}-*
95done
96# Same for m2300w/m2400w
97find printer -name '*.xml' |xargs grep -l '<driver>m2[34]00w<'|xargs rm -vf
98rm -f driver/m2300w.xml driver/m2400w.xml opt/m2300w-*
99# Same for all these.
100for x in drv_x125 ml85p pbm2lwxl pbmtozjs bjc800j
101do
102  find printer -name '*.xml' |xargs grep -l "<driver>${x}</driver>"|xargs rm -vf
103  rm -vf driver/${x}.xml opt/${x}-*
104done
105
106popd
107
108%build
109export LIB_CUPS=%{_libdir}/cups
110export CUPS_BACKENDS=%{_libdir}/cups/backend
111export CUPS_FILTERS=%{_libdir}/cups/filter
112export CUPS_PPDS=%{_datadir}/cups/model
113
114pushd foomatic-filters-%{filtersver}
115%configure
116make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
117        INSTALLDIRS=vendor
118popd
119
120pushd foomatic-db-engine-%{enginever}
121%configure --disable-xmltest
122make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
123        INSTALLDIRS=vendor defaults
124make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
125        INSTALLDIRS=vendor
126popd
127
128pushd foomatic-db-%{dbver_snap}
129%configure
130make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
131        INSTALLDIRS=vendor
132popd
133
134pushd foomatic-db-hpijs-%{hpijsver}
135%configure
136make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
137        INSTALLDIRS=vendor
138popd
139
140%install
141rm -rf %{buildroot}
142
143pushd foomatic-filters-%{filtersver}
144eval `perl '-V:installvendorlib' '-V:installvendorarch'`
145mkdir -p %{buildroot}/$installvendorlib
146
147
148echo %{buildroot}
149
150make    DESTDIR=%{buildroot} PREFIX=%{_prefix} \
151        INSTALLDIRS=vendor \
152        INSTALLVENDORLIB=$installvendorlib \
153        INSTALLVENDORARCH=$installvendorarch \
154        install-main install-cups
155popd
156
157pushd foomatic-db-engine-%{enginever}
158make    DESTDIR=%buildroot PREFIX=%{_prefix} \
159        INSTALLDIRS=vendor \
160        INSTALLVENDORLIB=$installvendorlib \
161        INSTALLVENDORARCH=$installvendorarch \
162        install
163popd
164
165pushd foomatic-db-%{dbver_snap}
166make    DESTDIR=%buildroot PREFIX=%{_prefix} \
167        INSTALLDIRS=vendor \
168        INSTALLVENDORLIB=$installvendorlib \
169        INSTALLVENDORARCH=$installvendorarch \
170        install
171popd
172
173pushd foomatic-db-hpijs-%{hpijsver}
174make    DESTDIR=%buildroot PREFIX=%{_prefix} \
175        INSTALLDIRS=vendor \
176        INSTALLVENDORLIB=$installvendorlib \
177        INSTALLVENDORARCH=$installvendorarch \
178        install
179popd
180
181# Remove ghostscript UPP drivers that are gone in 7.07
182rm -f %buildroot%{_datadir}/foomatic/db/source/driver/{bjc6000a1,PM760p,PM820p,s400a1,sharp,Stc670pl,Stc670p,Stc680p,Stc760p,Stc777p,Stp720p,Stp870p}.upp.xml
183
184# Remove drivers with no command line.
185pushd foomatic-db-engine-%{enginever}
186perl -Ilib ./foomatic-cleanupdrivers %buildroot%{_datadir}/foomatic
187popd
188
189# Update any old-style printer IDs still left around.
190echo '#!/usr/bin/perl -pi' > convert-printerids.pl
191sed -e 's|^\(.*\) \(.*\)$|s,printer/\1,printer/\2,g;|' \
192        %{buildroot}%{_datadir}/foomatic/db/oldprinterids \
193        >> convert-printerids.pl
194chmod a+x convert-printerids.pl
195./convert-printerids.pl %{buildroot}%{_datadir}/foomatic/db/source/{opt,driver}/*.xml
196find %{buildroot}%{_datadir}/foomatic/db/source/ -type f | xargs chmod 0644
197
198# Use relative, not absolute, symlink for CUPS filter.
199ln -sf ../../../bin/foomatic-rip %{buildroot}%{_libdir}/cups/filter/foomatic-rip
200
201mkdir %{buildroot}%{_datadir}/foomatic/db/source/PPD/Custom
202mkdir -p %{buildroot}%{_var}/cache/foomatic
203
204echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
205
206# Remove things we don't ship.
207rm -rf  %{buildroot}%{_libdir}/perl5/site_perl \
208        %{buildroot}%{_libdir}/ppr \
209        %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample
210find %{buildroot} -name .packlist -o -name '*.xml.*' | xargs rm -f
211
212
213%post
214/bin/rm -f /var/cache/foomatic/*
215
216# restart the print server if it is running now
217/sbin/service lpd condrestart >/dev/null 2>&1
218/sbin/service cups condrestart >/dev/null 2>&1
219
220exit 0
221
222%clean
223rm -fr %buildroot $RPM_BUILD_DIR/%{name}
224
225%files
226%defattr(-,root,root)
227%doc --parents */README */USAGE */ChangeLog
228%dir %{_sysconfdir}/foomatic
229%config(noreplace) %{_sysconfdir}/foomatic/filter.conf
230%config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
231%{_bindir}/*
232%{_sbindir}/*
233%{perl_vendorlib}/Foomatic
234%{_libdir}/cups/backend/*
235%{_libdir}/cups/driver/*
236%{_libdir}/cups/filter/*
237%{_datadir}/foomatic
238%{_datadir}/cups/model/foomatic-db-ppds
239%{_mandir}/*/*
240%{_var}/cache/foomatic
241
242%changelog
243* Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
244- rebuild with perl 5.12.3
245
246* Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
247- add Requires: hpijs
248
249* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
250- new upstream release
251
252* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
253- new upstream release.
254- applied some patches from Fedora development.
255- remove subpackages.
256
257* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
258- applied new versioning policy
259- used rpm macros: %%perl_sitelib %%perl_sitearch
260- added foomatic-db-engine-3.1-20050411-combo-xml.patch
261- added foomatic-db-engine-3.1-20050411-perl-data.patch
262- fixed permission of %%{_datadir}/foomatic/db
263
264* Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
265- add BuildRequires: libxml2-devel, mpage, Omni
266- use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
267- run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
268- not create ppd-omni package if omni support is disabled
269
270* Tue Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
271- updated foomatic-db to 20050411
272- updated foomatic-db-engine to 3.1-20050411
273- updated foomatic-db-hpijs to 1.5-20050411
274- updated foomatic-filters to 3.1-20050411
275
276* Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
277- updated foomatic-db to 20050112
278- updated foomatic-db-engine to 3.1-20050112
279- updated foomatic-db-hpijs to 1.5-20050112
280
281* Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
282- updated foomatic-db to 20041220
283- updated foomatic-db-hpijs to 1.5-20041220
284
285* Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
286- updated foomatic-db to 20040919
287- updated foomatic-db-engine to 3.0.2
288- updated foomatic-db-hpijs to 1.5-20040919
289- updated foomatic-filters to 3.0.2
290
291* Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
292- update foomatic-db to 20040526
293- update foomatic-db-hpijs to 1.5-20040526
294
295* Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
296- sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
297  ppd-gimp-print-ijs
298- add Requires: to ppd-* subpackages.
299
300* Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
301- new upstream version
302        -- Omni-printers-0.9.1
303        -- gimp-print-foomatic-db-4.2.6
304- foomatic.spec -> foomatic-vl.spec
305
306* Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
307- new upstream version
308        -- foomatic-filters-3.0.1
309        -- foomatic-db-engine-3.0.1
310        -- foomatic-db-20040219
311        -- foomatic-db-hpijs-1.5-20040219
312
313* Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
314- new upstream version
315        -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
316        -- defined filterver
317- dropped patch101
318
319* Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
320- new upstream cvs version(foomatic-3.0.1rc2)
321        -- foomatic-db-20040125
322        -- foomatic-db-engine-3.0.1rc2
323        -- foomatic-db-hpijs-1.5-20040125
324        -- foomatic-filters-3.0.1rc2
325- added patch101
326        -- tests diris null in foomatic-filters-3.0.1rc2
327
328* Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
329- new upstream cvs version
330        -- foomatic-db-20040123
331        -- foomatic-db-engine-3.0-20040123
332        -- foomatic-db-hpijs-1.5-20040123
333        -- foomatic-filters-3.0-20040123
334- dropped old patches
335
336* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
337- built on perl-5.8.2
338
339* Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
340- separated foomatic-db package included xml files
341
342* Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
343- added description of ppd sub package
344
345* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
346- separated foomatic-ppd package included PPD files
347
348* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
349- new upstream version
350        -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
351        -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
352- dropped patches
353        -- foomatic-filters-path.patch(patch0)
354        -- foomatic-2.0.2-fontpath.patch(patch3)
355- updated patches
356        -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
357        -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
358        -- foomatic-filters-3.0-20031109-vine.patch (patch100)
359
360* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
361- built on perl-5.8.1
362- fixed install section in spec file
363
364* Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
365- fix some bugs of foomatic-filters.
366A
367
368* Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
369- new upstream version
370        -- rewrote spec file
371        -- added some patches from rawhide(foomatic-3.0.0-5)
372- enable cups support
373
374* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
375- imported some patches from foomatic-2.0.2-18
376        -- added foomatic-2.0.2-psc2210.patch
377        -- added foomatic-2.0.2-duplex184.patch
378
379* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
380- imported foomatic-2.0.2-15
381 
382* Tue Feb  4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
383- Update data-generators to CVS.
384
385* Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
386- Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
387
388* Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
389- Pacify printers that don't understand duplex (bug #82385).
390
391* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
392- rebuilt
393
394* Thu Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
395- Add autodetect info for HP DeskJet 656C.  It doesn't really do
396  IEEE 1284 IDs, but since it's a USB device we can figure out it's
397  manufacturer and model anyway.
398
399* Thu Jan  9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
400- Set GS_FONTPATH in gs wrapper (bug #81410).
401
402* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
403- use internal dep generator.
404
405* Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
406- Add several device IDs.
407
408* Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
409- Update Omni printers to 0.7.2.
410- No longer need Omni badxml patch.
411
412* Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
413- don't use rpms internal dep generator
414
415* Fri Dec  6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
416- Omni XML wasn't well-formed.
417
418* Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
419- Update gimp-print data.
420- Add 'generic postscript' model.
421
422* Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
423- Update Omni printers to 0.7.1.
424
425* Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
426- Fix file manifest for perl modules.
427- Add autodetect information for HP DeskJet 990C.
428
429* Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
430- 2.0.2.
431- No longer need 67973, 970c patches.
432- Remove cups-drivers-* packages (no longer needed).
433- Remove files not shipped.  Ship filter.conf.
434- Conditionally restart cups.
435- Use libdir.
436- Don't put things in site_perl; use vendor_perl instead (bug #73528).
437
438* Fri Aug  9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
439- Fix autodetect information for HPDJ970C.
440
441* Thu Aug  8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
442- For gimp-print, use the Ghostscript stp driver in preference to the
443  IJS interface.
444
445* Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
446- Quieten scriptlets.
447
448* Fri Jul  5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
449- Fix autodetect information for HPLJ2100/2100M.
450
451* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
452- automated rebuild
453
454* Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
455- Omni 0.7.0 printers.
456
457* Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
458- Update to CVS.
459- Remove some more explicit perl dependencies that are picked up
460  automatically.
461
462* Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
463- Remove explicit perl-Storable dependency; it should be perl(Storable),
464  and that is picked up automatically.
465
466* Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
467- Fix release number.
468- Drop gen-ppds from the file manifest---use foomatic-compiledb instead
469  (bug #63622).
470
471* Sun May 26 2002 Tim Powers <timp@redhat.com>
472- automated rebuild
473
474* Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
475- Remove ghostscript UPP drivers that are gone in 7.05.
476
477* Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
478- Update to CVS.
479- Updated requirements.
480- Updated path and libdir patches.
481- Drop hpijs 1.0.2 patch.
482- foomatic-datafile has moved to %%{_bindir}.
483- Update gimp-print data to 4.2.1.
484- Update Omni printer data to 0.6.1.
485
486* Thu Apr  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
487- Fix the hpijs option data too (bug #62587).
488
489* Wed Apr  3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
490- Back off to 1.0.2 for hpijs driver data (bug #62587).
491
492* Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
493- Update to CVS.
494
495* Wed Mar  6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
496- Update to CVS.
497- Patches no longer needed: conffile, sys, cachedir, fd0.
498- Adapted path patch.
499
500* Tue Mar  5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
501- Fix bug #58319.
502- Drop dbg patch.
503
504* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
505- Fix file lists.
506
507* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
508- Fix %post scriplet bug (bug #59942).
509
510* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
511- Rebuild in new environment.
512
513* Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
514- Merge cups-drivers.  No epoch needed.
515- Require perl-URI.
516
517* Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
518- Cache fix.
519
520* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
521- Don't ship backup files.
522
523* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
524- Rebuild to pick up new perl installsitelib.
525
526* Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
527- Fix a thinko in DB.pl.
528
529* Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
530- Update to CVS.
531- No longer need the cachedir patch.
532- Fix config file path.
533- Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
534
535* Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
536- Update to CVS.
537- Patches no longer needed: prepend, fd3.
538- Use RPM_OPT_FLAGS.
539- Allow non-root users to use foomatic-datafile (bug #58956).
540
541* Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
542- added Provides: perl(Foomatic::GrovePath)
543
544* Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
545- Update to CVS.
546- Updated Omni printers to those in Omni 0.5.1.
547- Updated patches: prepend, fd3.
548- Patches no longer needed: utf8, lpdomatic.
549- Added gimp-print (formerly stp) foomatic db info, and removed the old
550  stp.xml file.
551- Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
552
553* Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
554- REALLY fix PCL fixup code (bug #55909, others).
555- PreReq fileutils, initscripts (bug #56984).
556- Fix prepends in lpdomatic (bug #57371).
557- Run foomatic-cleanupdrivers during install, to remove driver entries
558  with no command line.
559- Put lpdomatic in /usr/sbin again.
560- Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
561
562* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
563- re-imported from upstream to fix some perl fixup code on pcl printers.
564
565* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
566- fix the rest of the quoting issues with foomatic-combo-xml with the patch
567- foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
568
569* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
570- respin to pull in latest foomatic database, fixes:
571-       properly use the cache in relation to foomatic-combo-xml's output
572-       fix _some_ of the quoting issues with calling foomatic-combo-xml
573
574* Thu Dec  5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
575- respin to pull in latest foomatic database, fixes:
576-       droping half of a large job
577-       -Mutf8 added to the upstream filters
578-       miscelaneous printer db updates
579
580* Mon Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
581- added Requires: fileutils for the 'rm' in post
582
583* Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
584- /var/chache => /var/cache, doh!
585
586* Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
587- fix %%post scriptlet
588
589* Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
590- changed the patch to use the -Mutf8 command line option,
591- and to restart the printserver, after rebuilding the settings.
592
593* Fri Nov  9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
594- grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
595- pragma. Without it, they break on _some_ of their options.
596
597* Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
598- patched lpdomatic to prepend PostScript options in the _right_ place.
599
600* Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
601- zap the foomatic cache on install
602
603* Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
604- rolled to pull in latest information.
605- added Omni printers to the printer list.
606
607* Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
608- rolled to pull in an ia64 fix to foomatic-combo-xml.c
609
610* Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
611- rolled to pull in foomatic fixes to foomatic-combo-xml.c
612
613* Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
614- upgraded to latest foomatic, we now have fast overview generation!
615- this means that there is no prebuilt overview file.
616
617* Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
618- WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
619- It is now fast enough that there is no real benifit to precompiling.
620- NOTE: this forces the package to stop being noarched.
621
622* Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
623- fresh pull, maybe it fixes the build errors.
624
625* Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
626- did a fresh database pull, which contains the old japanese printers as well.
627- removed japanese hack.
628
629* Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
630- Add Japanese printer entry.
631
632* Mon Aug  6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
633- move the cache back to /var, sigh.
634
635* Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
636- made foomatic pre-compute its db
637
638* Thu Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
639- imported from mandrake.
640
641* Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
642- Added job listing/removal/manipulation and queue control to
643  foomatic-printjob
644- Support for printing multiple copies with PDQ
645
646* Fri Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
647- Included the cupsomatic filter script
648- When a queue is set up, default options can be set now
649- Help messages of foomatic-configure and foomatic-printjob cleaned up.
650
651* Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
652- Many bugfixes in "foomatic-printjob".
653- "foomatic-configure" adds the Foomatic config file directory automatically
654  to the search paths of PDQ.
655- Printing a help page under PDQ was broken.
656
657* Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
658- BuildRequires:        perl-devel
659
660* Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
661- initial release.
662- Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
663- Patch applied which flushes the memory cache regularly, otherwise
664  foomatic-configure would hang when the Foomatic data of GIMP-Print is
665  installed.
Note: See TracBrowser for help on using the repository browser.