source: projects/specs/trunk/f/foomatic/foomatic-vl.spec @ 3326

Revision 3326, 22.2 KB checked in by tomop, 13 years ago (diff)

foomatic-4.0.7-1

Line 
1%define dbver_rel 4.0
2%define dbver_snap 20110405
3%define enginever 4.0.7
4%define filtersver 4.0.7
5
6Summary: Foomatic printer database.
7Name:           foomatic
8Version:        %{enginever}
9Release:        1%{?_dist_release}
10License:        GPL
11Group: System Environment/Libraries
12
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: tomop, daisuke, machino
16
17Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
18Source1: http://www.linuxprinting.org/download/foomatic/foomatic-filters-%{filtersver}.tar.gz
19Source2: http://www.linuxprinting.org/download/foomatic/foomatic-db-%{dbver_rel}-%{dbver_snap}.tar.gz
20
21# Use libdir.
22Patch1: foomatic-filters-libdir.patch
23Patch2: foomatic-db-engine-libdir.patch
24
25# Handle non-UTF-8 encodings in imported PPD files.
26Patch15: foomatic-bad-utf8.patch
27
28Url:            http://www.linuxprinting.org
29Requires:       perl >= 5.12.3
30Requires:       %(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
31Requires:       hpijs
32BuildRequires:  perl >= 5.12.3
33BuildRequires:  libxml2-devel
34BuildRequires:  ghostscript-devel
35BuildRequires:  autoconf, automake
36BuildRequires:  mpage
37BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
38Provides:       perl(Foomatic::GrovePath)
39# For 'rm' and '/sbin/service' in post
40Requires(pre):  fileutils initscripts
41Obsoletes: foomatic-db < 4.0.0
42Obsoletes: foomatic-ppd < 4.0.0
43Obsoletes: foomatic-ppd-gimp-print < 4.0.0
44Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0.0
45Obsoletes: foomatic-ppd-omni < 4.0.0
46
47# We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
48Conflicts: ghostscript < 7.05
49
50%description
51Foomatic is a comprehensive, spooler-independent database of printers,
52printer drivers, and driver descriptions. It contains utilities to
53generate driver description files and printer queues for CUPS, LPD,
54LPRng, and PDQ using the database. There is also the possibility to
55read the PJL options out of PJL-capable laser printers and take them
56into account at the driver description file generation.
57
58There are spooler-independent command line interfaces to manipulate
59queues (foomatic-configure) and to print files/manipulate jobs
60(foomatic printjob).
61
62The site http://www.linuxprinting.org/ is based on this database.
63
64%prep
65%setup -q  -c -a 1 -a 2
66
67pushd foomatic-filters-%{filtersver}
68%patch1 -p1 -b .libdir
69popd
70
71pushd foomatic-db-engine-%{enginever}
72chmod a+x mkinstalldirs
73%patch2 -p1 -b .libdir
74%patch15 -p1
75popd
76
77pushd foomatic-db-%{dbver_snap}
78
79cd db/source
80
81# For gutenprint printers, use gutenprint-ijs-simplified.5.2.
82perl -pi -e 's,>gutenprint<,>gutenprint-ijs-simplified.5.2<,' printer/*.xml
83
84# Remove references to foo2zjs, foo2oak, foo2hp and foo2qpdl (bug #208851).
85# Also foo2lava, foo2kyo, foo2xqx (bug #438319).
86for x in zjs oak hp qpdl lava kyo xqx
87do
88  find printer -name '*.xml' |xargs grep -l "<driver>foo2${x}"|xargs rm -vf
89  rm -f driver/foo2${x}.xml opt/foo2${x}-*
90done
91# Same for m2300w/m2400w
92find printer -name '*.xml' |xargs grep -l '<driver>m2[34]00w<'|xargs rm -vf
93rm -f driver/m2300w.xml driver/m2400w.xml opt/m2300w-*
94# Same for all these.
95for x in drv_x125 ml85p pbm2lwxl pbmtozjs bjc800j
96do
97  find printer -name '*.xml' |xargs grep -l "<driver>${x}</driver>"|xargs rm -vf
98  rm -vf driver/${x}.xml opt/${x}-*
99done
100
101popd
102
103%build
104export LIB_CUPS=%{_libdir}/cups
105export CUPS_BACKENDS=%{_libdir}/cups/backend
106export CUPS_FILTERS=%{_libdir}/cups/filter
107export CUPS_PPDS=%{_datadir}/cups/model
108
109pushd foomatic-filters-%{filtersver}
110%configure
111make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
112        INSTALLDIRS=vendor
113popd
114
115pushd foomatic-db-engine-%{enginever}
116%configure --disable-xmltest
117make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
118        INSTALLDIRS=vendor defaults
119make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
120        INSTALLDIRS=vendor
121popd
122
123pushd foomatic-db-%{dbver_snap}
124%configure
125make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
126        INSTALLDIRS=vendor
127popd
128
129%install
130rm -rf %{buildroot}
131
132pushd foomatic-filters-%{filtersver}
133eval `perl '-V:installvendorlib' '-V:installvendorarch'`
134mkdir -p %{buildroot}/$installvendorlib
135
136
137echo %{buildroot}
138
139make    DESTDIR=%{buildroot} PREFIX=%{_prefix} \
140        INSTALLDIRS=vendor \
141        INSTALLVENDORLIB=$installvendorlib \
142        INSTALLVENDORARCH=$installvendorarch \
143        install-main install-cups
144popd
145
146pushd foomatic-db-engine-%{enginever}
147make    DESTDIR=%buildroot PREFIX=%{_prefix} \
148        INSTALLDIRS=vendor \
149        INSTALLVENDORLIB=$installvendorlib \
150        INSTALLVENDORARCH=$installvendorarch \
151        install
152popd
153
154pushd foomatic-db-%{dbver_snap}
155make    DESTDIR=%buildroot PREFIX=%{_prefix} \
156        INSTALLDIRS=vendor \
157        INSTALLVENDORLIB=$installvendorlib \
158        INSTALLVENDORARCH=$installvendorarch \
159        install
160popd
161
162# Remove ghostscript UPP drivers that are gone in 7.07
163rm -f %buildroot%{_datadir}/foomatic/db/source/driver/{bjc6000a1,PM760p,PM820p,s400a1,sharp,Stc670pl,Stc670p,Stc680p,Stc760p,Stc777p,Stp720p,Stp870p}.upp.xml
164
165# Remove drivers with no command line.
166pushd foomatic-db-engine-%{enginever}
167perl -Ilib ./foomatic-cleanupdrivers %buildroot%{_datadir}/foomatic
168popd
169
170# Update any old-style printer IDs still left around.
171echo '#!/usr/bin/perl -pi' > convert-printerids.pl
172sed -e 's|^\(.*\) \(.*\)$|s,printer/\1,printer/\2,g;|' \
173        %{buildroot}%{_datadir}/foomatic/db/oldprinterids \
174        >> convert-printerids.pl
175chmod a+x convert-printerids.pl
176./convert-printerids.pl %{buildroot}%{_datadir}/foomatic/db/source/{opt,driver}/*.xml
177find %{buildroot}%{_datadir}/foomatic/db/source/ -type f | xargs chmod 0644
178
179# Use relative, not absolute, symlink for CUPS filter.
180ln -sf ../../../bin/foomatic-rip %{buildroot}%{_libdir}/cups/filter/foomatic-rip
181
182mkdir %{buildroot}%{_datadir}/foomatic/db/source/PPD/Custom
183mkdir -p %{buildroot}%{_var}/cache/foomatic
184
185echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
186
187# Remove things we don't ship.
188rm -rf  %{buildroot}%{_libdir}/perl5/site_perl \
189        %{buildroot}%{_libdir}/ppr \
190        %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample
191find %{buildroot} -name .packlist -o -name '*.xml.*' | xargs rm -f
192
193
194%post
195/bin/rm -f /var/cache/foomatic/*
196
197# restart the print server if it is running now
198/sbin/service lpd condrestart >/dev/null 2>&1
199/sbin/service cups condrestart >/dev/null 2>&1
200
201exit 0
202
203%clean
204rm -fr %buildroot $RPM_BUILD_DIR/%{name}
205
206%files
207%defattr(-,root,root)
208%doc --parents */README */USAGE */ChangeLog
209%dir %{_sysconfdir}/foomatic
210%config(noreplace) %{_sysconfdir}/foomatic/filter.conf
211%config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
212%{_bindir}/*
213%{_sbindir}/*
214%{perl_vendorlib}/Foomatic
215%{_libdir}/cups/backend/*
216%{_libdir}/cups/driver/*
217%{_libdir}/cups/filter/*
218%{_datadir}/foomatic
219%{_datadir}/cups/model/foomatic-db-ppds
220%{_mandir}/*/*
221%{_var}/cache/foomatic
222
223%changelog
224* Wed Apr 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
225- new upstream release.
226- dropped Source3 (no longer provided by upstream).
227- updated Patch2.
228
229* Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
230- rebuild with perl 5.12.3
231
232* Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
233- add Requires: hpijs
234
235* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
236- new upstream release
237
238* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
239- new upstream release.
240- applied some patches from Fedora development.
241- remove subpackages.
242
243* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
244- applied new versioning policy
245- used rpm macros: %%perl_sitelib %%perl_sitearch
246- added foomatic-db-engine-3.1-20050411-combo-xml.patch
247- added foomatic-db-engine-3.1-20050411-perl-data.patch
248- fixed permission of %%{_datadir}/foomatic/db
249
250* Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
251- add BuildRequires: libxml2-devel, mpage, Omni
252- use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
253- run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
254- not create ppd-omni package if omni support is disabled
255
256* Tue Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
257- updated foomatic-db to 20050411
258- updated foomatic-db-engine to 3.1-20050411
259- updated foomatic-db-hpijs to 1.5-20050411
260- updated foomatic-filters to 3.1-20050411
261
262* Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
263- updated foomatic-db to 20050112
264- updated foomatic-db-engine to 3.1-20050112
265- updated foomatic-db-hpijs to 1.5-20050112
266
267* Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
268- updated foomatic-db to 20041220
269- updated foomatic-db-hpijs to 1.5-20041220
270
271* Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
272- updated foomatic-db to 20040919
273- updated foomatic-db-engine to 3.0.2
274- updated foomatic-db-hpijs to 1.5-20040919
275- updated foomatic-filters to 3.0.2
276
277* Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
278- update foomatic-db to 20040526
279- update foomatic-db-hpijs to 1.5-20040526
280
281* Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
282- sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
283  ppd-gimp-print-ijs
284- add Requires: to ppd-* subpackages.
285
286* Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
287- new upstream version
288        -- Omni-printers-0.9.1
289        -- gimp-print-foomatic-db-4.2.6
290- foomatic.spec -> foomatic-vl.spec
291
292* Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
293- new upstream version
294        -- foomatic-filters-3.0.1
295        -- foomatic-db-engine-3.0.1
296        -- foomatic-db-20040219
297        -- foomatic-db-hpijs-1.5-20040219
298
299* Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
300- new upstream version
301        -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
302        -- defined filterver
303- dropped patch101
304
305* Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
306- new upstream cvs version(foomatic-3.0.1rc2)
307        -- foomatic-db-20040125
308        -- foomatic-db-engine-3.0.1rc2
309        -- foomatic-db-hpijs-1.5-20040125
310        -- foomatic-filters-3.0.1rc2
311- added patch101
312        -- tests diris null in foomatic-filters-3.0.1rc2
313
314* Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
315- new upstream cvs version
316        -- foomatic-db-20040123
317        -- foomatic-db-engine-3.0-20040123
318        -- foomatic-db-hpijs-1.5-20040123
319        -- foomatic-filters-3.0-20040123
320- dropped old patches
321
322* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
323- built on perl-5.8.2
324
325* Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
326- separated foomatic-db package included xml files
327
328* Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
329- added description of ppd sub package
330
331* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
332- separated foomatic-ppd package included PPD files
333
334* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
335- new upstream version
336        -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
337        -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
338- dropped patches
339        -- foomatic-filters-path.patch(patch0)
340        -- foomatic-2.0.2-fontpath.patch(patch3)
341- updated patches
342        -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
343        -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
344        -- foomatic-filters-3.0-20031109-vine.patch (patch100)
345
346* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
347- built on perl-5.8.1
348- fixed install section in spec file
349
350* Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
351- fix some bugs of foomatic-filters.
352A
353
354* Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
355- new upstream version
356        -- rewrote spec file
357        -- added some patches from rawhide(foomatic-3.0.0-5)
358- enable cups support
359
360* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
361- imported some patches from foomatic-2.0.2-18
362        -- added foomatic-2.0.2-psc2210.patch
363        -- added foomatic-2.0.2-duplex184.patch
364
365* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
366- imported foomatic-2.0.2-15
367 
368* Tue Feb  4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
369- Update data-generators to CVS.
370
371* Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
372- Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
373
374* Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
375- Pacify printers that don't understand duplex (bug #82385).
376
377* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
378- rebuilt
379
380* Thu Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
381- Add autodetect info for HP DeskJet 656C.  It doesn't really do
382  IEEE 1284 IDs, but since it's a USB device we can figure out it's
383  manufacturer and model anyway.
384
385* Thu Jan  9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
386- Set GS_FONTPATH in gs wrapper (bug #81410).
387
388* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
389- use internal dep generator.
390
391* Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
392- Add several device IDs.
393
394* Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
395- Update Omni printers to 0.7.2.
396- No longer need Omni badxml patch.
397
398* Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
399- don't use rpms internal dep generator
400
401* Fri Dec  6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
402- Omni XML wasn't well-formed.
403
404* Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
405- Update gimp-print data.
406- Add 'generic postscript' model.
407
408* Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
409- Update Omni printers to 0.7.1.
410
411* Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
412- Fix file manifest for perl modules.
413- Add autodetect information for HP DeskJet 990C.
414
415* Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
416- 2.0.2.
417- No longer need 67973, 970c patches.
418- Remove cups-drivers-* packages (no longer needed).
419- Remove files not shipped.  Ship filter.conf.
420- Conditionally restart cups.
421- Use libdir.
422- Don't put things in site_perl; use vendor_perl instead (bug #73528).
423
424* Fri Aug  9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
425- Fix autodetect information for HPDJ970C.
426
427* Thu Aug  8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
428- For gimp-print, use the Ghostscript stp driver in preference to the
429  IJS interface.
430
431* Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
432- Quieten scriptlets.
433
434* Fri Jul  5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
435- Fix autodetect information for HPLJ2100/2100M.
436
437* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
438- automated rebuild
439
440* Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
441- Omni 0.7.0 printers.
442
443* Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
444- Update to CVS.
445- Remove some more explicit perl dependencies that are picked up
446  automatically.
447
448* Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
449- Remove explicit perl-Storable dependency; it should be perl(Storable),
450  and that is picked up automatically.
451
452* Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
453- Fix release number.
454- Drop gen-ppds from the file manifest---use foomatic-compiledb instead
455  (bug #63622).
456
457* Sun May 26 2002 Tim Powers <timp@redhat.com>
458- automated rebuild
459
460* Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
461- Remove ghostscript UPP drivers that are gone in 7.05.
462
463* Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
464- Update to CVS.
465- Updated requirements.
466- Updated path and libdir patches.
467- Drop hpijs 1.0.2 patch.
468- foomatic-datafile has moved to %%{_bindir}.
469- Update gimp-print data to 4.2.1.
470- Update Omni printer data to 0.6.1.
471
472* Thu Apr  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
473- Fix the hpijs option data too (bug #62587).
474
475* Wed Apr  3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
476- Back off to 1.0.2 for hpijs driver data (bug #62587).
477
478* Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
479- Update to CVS.
480
481* Wed Mar  6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
482- Update to CVS.
483- Patches no longer needed: conffile, sys, cachedir, fd0.
484- Adapted path patch.
485
486* Tue Mar  5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
487- Fix bug #58319.
488- Drop dbg patch.
489
490* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
491- Fix file lists.
492
493* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
494- Fix %post scriplet bug (bug #59942).
495
496* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
497- Rebuild in new environment.
498
499* Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
500- Merge cups-drivers.  No epoch needed.
501- Require perl-URI.
502
503* Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
504- Cache fix.
505
506* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
507- Don't ship backup files.
508
509* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
510- Rebuild to pick up new perl installsitelib.
511
512* Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
513- Fix a thinko in DB.pl.
514
515* Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
516- Update to CVS.
517- No longer need the cachedir patch.
518- Fix config file path.
519- Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
520
521* Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
522- Update to CVS.
523- Patches no longer needed: prepend, fd3.
524- Use RPM_OPT_FLAGS.
525- Allow non-root users to use foomatic-datafile (bug #58956).
526
527* Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
528- added Provides: perl(Foomatic::GrovePath)
529
530* Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
531- Update to CVS.
532- Updated Omni printers to those in Omni 0.5.1.
533- Updated patches: prepend, fd3.
534- Patches no longer needed: utf8, lpdomatic.
535- Added gimp-print (formerly stp) foomatic db info, and removed the old
536  stp.xml file.
537- Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
538
539* Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
540- REALLY fix PCL fixup code (bug #55909, others).
541- PreReq fileutils, initscripts (bug #56984).
542- Fix prepends in lpdomatic (bug #57371).
543- Run foomatic-cleanupdrivers during install, to remove driver entries
544  with no command line.
545- Put lpdomatic in /usr/sbin again.
546- Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
547
548* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
549- re-imported from upstream to fix some perl fixup code on pcl printers.
550
551* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
552- fix the rest of the quoting issues with foomatic-combo-xml with the patch
553- foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
554
555* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
556- respin to pull in latest foomatic database, fixes:
557-       properly use the cache in relation to foomatic-combo-xml's output
558-       fix _some_ of the quoting issues with calling foomatic-combo-xml
559
560* Thu Dec  5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
561- respin to pull in latest foomatic database, fixes:
562-       droping half of a large job
563-       -Mutf8 added to the upstream filters
564-       miscelaneous printer db updates
565
566* Mon Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
567- added Requires: fileutils for the 'rm' in post
568
569* Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
570- /var/chache => /var/cache, doh!
571
572* Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
573- fix %%post scriptlet
574
575* Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
576- changed the patch to use the -Mutf8 command line option,
577- and to restart the printserver, after rebuilding the settings.
578
579* Fri Nov  9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
580- grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
581- pragma. Without it, they break on _some_ of their options.
582
583* Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
584- patched lpdomatic to prepend PostScript options in the _right_ place.
585
586* Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
587- zap the foomatic cache on install
588
589* Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
590- rolled to pull in latest information.
591- added Omni printers to the printer list.
592
593* Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
594- rolled to pull in an ia64 fix to foomatic-combo-xml.c
595
596* Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
597- rolled to pull in foomatic fixes to foomatic-combo-xml.c
598
599* Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
600- upgraded to latest foomatic, we now have fast overview generation!
601- this means that there is no prebuilt overview file.
602
603* Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
604- WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
605- It is now fast enough that there is no real benifit to precompiling.
606- NOTE: this forces the package to stop being noarched.
607
608* Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
609- fresh pull, maybe it fixes the build errors.
610
611* Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
612- did a fresh database pull, which contains the old japanese printers as well.
613- removed japanese hack.
614
615* Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
616- Add Japanese printer entry.
617
618* Mon Aug  6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
619- move the cache back to /var, sigh.
620
621* Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
622- made foomatic pre-compute its db
623
624* Thu Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
625- imported from mandrake.
626
627* Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
628- Added job listing/removal/manipulation and queue control to
629  foomatic-printjob
630- Support for printing multiple copies with PDQ
631
632* Fri Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
633- Included the cupsomatic filter script
634- When a queue is set up, default options can be set now
635- Help messages of foomatic-configure and foomatic-printjob cleaned up.
636
637* Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
638- Many bugfixes in "foomatic-printjob".
639- "foomatic-configure" adds the Foomatic config file directory automatically
640  to the search paths of PDQ.
641- Printing a help page under PDQ was broken.
642
643* Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
644- BuildRequires:        perl-devel
645
646* Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
647- initial release.
648- Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
649- Patch applied which flushes the memory cache regularly, otherwise
650  foomatic-configure would hang when the Foomatic data of GIMP-Print is
651  installed.
Note: See TracBrowser for help on using the repository browser.