source: projects/specs/trunk/f/fontconfig/fontconfig-vl.spec @ 7657

Revision 7657, 23.9 KB checked in by daisuke, 11 years ago (diff)

fontconfig:

  • install/enable 70-prefer-ja-font.conf and 59-morisawa-font-alias.conf (again)
  • enable 25-unhint-nonlatin.conf (again)
  • add patch0-2 from fedora package
    • patch0: less sleep in fc-cache
    • patch1: fix font matching issue
    • patch2: fix web font issue in firefox
Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define freetype_version 2.4.11
3
4Summary: Font configuration and customization library
5Summary(ja): フォント設定/カスタマイズライブラリ
6Name: fontconfig
7Version: 2.10.92
8Release: 2%{?_dist_release}
9License: MIT
10Group: System Environment/Libraries
11URL: http://fontconfig.org/
12
13Source: http://fontconfig.org/release/fontconfig-%{version}.tar.bz2
14Source10: 70-prefer-ja-font.conf
15Source11: 59-morisawa-font-alias.conf
16
17# from fedora
18# https://bugzilla.redhat.com/show_bug.cgi?id=140335
19Patch0:         fontconfig-2.8.0-sleep-less.patch
20# https://bugzilla.redhat.com/show_bug.cgi?id=929372
21Patch1:         %{name}-929372.patch
22# https://bugzilla.redhat.com/show_bug.cgi?id=946859
23Patch2:         %{name}-fix-woff.patch
24
25# vine
26Patch4: fontconfig-2.3.2-subst-ja-font.patch
27Patch10: fontconfig-2.6.0-vine.patch
28
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: gawk
32BuildRequires: expat-devel
33BuildRequires: freetype2-devel >= %{freetype_version}
34BuildRequires: perl
35
36Requires(pre): freetype2 >= %{freetype_version}, coreutils
37Conflicts: XOrg-libs <= 6.9.0
38Obsoletes: XOrg-libs <= 6.9.0
39Conflicts: XOrg-font-utils <= 6.9.0
40Obsoletes: XOrg-font-utils <= 6.9.0
41
42%description
43Fontconfig is designed to locate fonts within the
44system and select them according to requirements specified by
45applications.
46
47%description -l ja
48Fontconfig は、システム内のフォントを把握し、アプリケーション
49が指定した要求に応じてそれらを選択するためのライブラリです。
50
51%package devel
52Summary: Development files for %{name}
53Summary(ja): Fontconfig の開発ファイル
54Group: Development/Libraries
55Requires: fontconfig = %{version}-%{release}
56Requires: freetype2-devel >= %{freetype_version}
57Requires: expat-devel
58Requires: pkgconfig
59Conflicts: XOrg-devel <= 6.9.0
60Obsoletes: XOrg-devel <= 6.9.0
61
62%description devel
63The fontconfig-devel package includes the header files,
64and developer docs for the fontconfig package.
65
66%description -l ja devel
67fontconfig-devel パッケージには fontconfig を使ったソフトウエア
68を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
69ントが含まれています。
70
71# compat32
72%package -n compat32-%{name}
73Summary: Font configuration and customization library
74Summary(ja): フォント設定/カスタマイズライブラリ
75Group: System Environment/Libraries
76
77%description -n compat32-%{name}
78Fontconfig is designed to locate fonts within the
79system and select them according to requirements specified by
80applications.
81
82%description -l ja -n compat32-%{name}
83Fontconfig は、システム内のフォントを把握し、アプリケーション
84が指定した要求に応じてそれらを選択するためのライブラリです。
85
86%package -n compat32-%{name}-devel
87Summary: Font configuration and customization library
88Group: Development/Libraries
89Requires: compat32-%{name} = %{version}-%{release}
90Requires: %{name}-devel = %{version}-%{release}
91Requires: compat32-freetype2-devel >= %{freetype_version}
92Requires: compat32-expat-devel
93
94%description -n compat32-%{name}-devel
95The fontconfig-devel package includes the header files,
96and developer docs for the fontconfig package.
97
98%description -l ja -n compat32-%{name}-devel
99fontconfig-devel パッケージには fontconfig を使ったソフトウエア
100を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
101ントが含まれています。
102
103%prep
104%setup -q
105
106%patch0 -p1 -b .sleep-less
107%patch1 -p1 -b .929372
108%patch2 -p1 -b .fix-woff
109
110%patch4 -p1 -b .subst-ja-font
111%patch10 -p1 -b .vine
112
113%build
114
115# We don't want to rebuild the docs, but we want to install the included ones.
116export HASDOCBOOK=no
117
118%configure \
119  --with-add-fonts=/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/TTF,/usr/local/share/fonts
120
121%__make %{?_smp_mflags}
122
123%install
124rm -rf $RPM_BUILD_ROOT
125
126%__make install DESTDIR=$RPM_BUILD_ROOT
127
128ln -s %{_datadir}/fontconfig/conf.avail/25-unhint-nonlatin.conf $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.d
129install -m664 %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT/%{_datadir}/fontconfig/conf.avail/
130for i in 70-prefer-ja-font.conf 59-morisawa-font-alias.conf
131do
132  ln -sf %{_datadir}/fontconfig/conf.avail/$i $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
133done
134
135# move installed doc files back to build directory to package themm
136# in the right place
137mv $RPM_BUILD_ROOT%{_docdir}/fontconfig/* .
138rmdir $RPM_BUILD_ROOT%{_docdir}/fontconfig/
139
140# All font packages depend on this package, so we create
141# and own /usr/share/fonts
142mkdir -p $RPM_BUILD_ROOT%{_datadir}/fonts
143
144# Remove unpackaged files
145rm $RPM_BUILD_ROOT%{_libdir}/*.la
146rm $RPM_BUILD_ROOT%{_libdir}/*.a
147
148%clean
149rm -rf $RPM_BUILD_ROOT
150
151%post
152/sbin/ldconfig
153umask 0022
154# Remove stale caches
155rm -f %{_localstatedir}/cache/fontconfig/????????????????????????????????-*.cache-2
156HOME=/root /usr/bin/fc-cache -f -s >& /dev/null
157
158
159%postun -p /sbin/ldconfig
160
161%post -n compat32-%{name} -p /sbin/ldconfig
162
163%postun -n compat32-%{name} -p /sbin/ldconfig
164
165%files
166%defattr(-, root, root)
167%doc README AUTHORS COPYING
168%doc fontconfig-user.txt fontconfig-user.html
169%doc %{_sysconfdir}/fonts/conf.d/README
170%{_libdir}/libfontconfig.so.*
171%{_bindir}/fc-cache
172%{_bindir}/fc-list
173%{_bindir}/fc-match
174%{_bindir}/fc-cat
175%{_bindir}/fc-query
176%{_bindir}/fc-scan
177%{_bindir}/fc-pattern
178%{_bindir}/fc-validate
179%dir %{_datadir}/fonts
180%{_datadir}/%{name}
181%{_datadir}/xml/%{name}/fonts.dtd
182%config %{_sysconfdir}/fonts/fonts.conf
183%config(noreplace) %{_sysconfdir}/fonts/conf.d/*.conf
184%dir %{_localstatedir}/cache/fontconfig
185
186%{_mandir}/man1/*
187%{_mandir}/man5/*
188
189%files devel
190%defattr(-, root, root)
191%doc fontconfig-devel.txt fontconfig-devel
192%{_libdir}/libfontconfig.so
193%{_libdir}/pkgconfig/*
194%{_includedir}/fontconfig
195%{_mandir}/man3/*
196
197# compat32
198%if %{build_compat32}
199%files -n compat32-%{name}
200%defattr(-, root, root)
201%{_libdir}/libfontconfig.so.*
202
203%files -n compat32-%{name}-devel
204%defattr(-, root, root)
205%{_libdir}/libfontconfig.so
206%{_libdir}/pkgconfig/*
207%endif
208
209%changelog
210* Tue May 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.92-2
211- install/enable 70-prefer-ja-font.conf and 59-morisawa-font-alias.conf (again)
212- enable 25-unhint-nonlatin.conf (again)
213- add patch0-2 from fedora package
214  - patch0: less sleep in fc-cache
215  - patch1: fix font matching issue
216  - patch2: fix web font issue in firefox
217
218* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.92-1
219- new upstream release
220- remove Patch1 (fontconfig-2.2.1-AppleRoman-DynaFont.patch)
221
222* Fri Dec 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-3
223- rebuild with freetype2-2.4.8
224- add Requires: expat-devel (-devel package)
225
226* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.0-2
227- build with rpm-4.8.1-1 for pkg-config file
228
229* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-1
230- new upstream release
231- remove static libs
232
233* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-3
234- update %%post
235
236* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-2
237- add translated summary and description
238
239* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-1
240- new upstream release
241
242* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-2
243- add fc-query and fc-scan to %%files
244
245* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
246- new upstream release
247- update 59-morisawa-font-alias.conf
248
249* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.0-3
250- added compat32 package for x86_64 arch support
251
252* Tue Jan 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-2
253- update 59-morisawa-font-alias.conf
254  - add FutoMin, FutoGo, Jun alias
255
256* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-1
257- new upstream release
258- rename 10-prefer-ja-font.conf to 70-prefer-ja-font.conf
259
260* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-3
261- add 10-prefer-ja-font.conf to prefer Japanese fonts.
262- add 59-morisawa-font-alias.conf
263  - bind Ryumin to serif and GothicBBB to sans-serif
264
265* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
266- add legacy font path for compatibility
267
268* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
269- add Conflits/Obsoletes: XOrg-font-utils <= 6.9.0
270
271* Mon Dec 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-0vl1
272- initial build for Vine Linux
273  - splitted from XOrg package.
274
275* Tue Nov 13 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.5.0-1
276- Update to 2.5.0.
277
278* Tue Nov 06 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.92-1
279- Update to 2.4.92.
280- Mark /etc/fonts/conf.d/* as config(noreplace).
281- Remove most of our conf file, all upstreamed except for
282  75-blacklist-fedora.conf that I'm happily dropping.  Who has
283  Hershey fonts these days...
284- ln upstream'ed 25-unhint-nonlatin.conf from conf.avail in conf.d
285- Add 25-no-bitmap-fedora.conf which is the tiny remaining bit
286  of conf that didn't end up upstream.  Can get rid of it in the
287  future, but not just yet.
288
289* Thu Oct 25 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.91-1
290- Update to 2.4.91.
291- Add /usr/local/share/fonts to default config. (#147004)
292- Don't rebuild docs, to fix multilib conflicts. (#313011)
293- Remove docbook and elinks BuildRequires and stuff as we don't
294  rebuild docs.
295
296* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 2.4.2-5
297- Rebuild for PPC toolchain bug
298- Add BuildRequires: gawk
299
300* Sun Jun 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-4
301- /etc/fonts/conf.d is now owned by filesystem
302
303* Fri May 11 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-3
304- Add Liberation fonts to 30-aliases-fedora.conf
305
306* Fri Jan 12 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.2-2
307- Change /usr/share/X11/fonts/OTF to /usr/share/X11/fonts/TTF
308- Resolves: #220809
309
310* Tue Dec  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.2-1
311- Update to 2.4.2
312
313* Wed Oct  4 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.1-4
314- Fix a multilib upgrade problem (#208151)
315
316* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.4.1-3
317- rebuilt for unwind info generation, broken in gcc-4.1.1-21
318
319* Fri Sep 22 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-2
320- Update 30-aliases-fedora.conf to correctly alias MS and StarOffice
321  fonts. (#207460)
322
323* Fri Sep 15 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-1
324- Update to 2.4.1, a public API was dropped from 2.4.0
325- Remove upstreamed patch
326
327* Mon Sep 11 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.0-1
328- Update to 2.4.0
329- Rename/order our configuration stuff to match the new scheme.
330  Breaks expected :-(
331
332* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-3
333- Add missing file.  Previous update didn't go through
334
335* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-2
336- Add fontconfig-2.3.97-ppc64.patch, for ppc64 arch signature
337
338* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-1
339- update to 2.3.97
340- Drop upstreamed patches
341- Regenerate defaultconfig patch
342- Don't touch stamp as it was not ever needed
343
344* Thu Aug 17 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-11
345- inclusion of zhong yi font and rearranged font prefer list. (bug# 201300)
346
347* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-10
348- use "%5x" instead of " %4x" to support 64k instead of
349  clamping.  Idea from Behdad.
350
351* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-9
352- tweak last patch to give a more reasonable page size
353  value if 64k page size is in effect.
354
355* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-8
356- maybe fix buffer overflow (bug 202152).
357
358* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-7
359- Update configs to provide better openoffice/staroffice
360  compatibility (bug 200723)
361
362* Thu Jul 27 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-6
363- Do umask 0022 in post
364- Update configs to reflect addition of new Indic fonts (#200381, #200397)
365
366* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-5
367- Plug a small memory leak
368
369* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1.1
370- rebuild
371
372* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1
373- rebuild
374
375* Fri Jun  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-4
376- Fix the handling of TTF font collections
377
378* Thu May 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-3
379- Apply a patch by David Turner to speed up cache generation
380
381* Wed Apr 26 2006 Bill Nottingham <notting@redhat.com> - 2.3.95-2
382- fix fonts.conf typo
383
384* Wed Apr 26 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-1
385- Update to 2.3.95
386
387* Fri Feb 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.94-1
388- Update to 2.3.94
389
390* Sat Feb 11 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060211-1
391- Newer cvs snapshot
392
393* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060208-1.1
394- bump again for double-long bug on ppc(64)
395
396* Wed Feb  8 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060208-1
397- Newer cvs snapshot
398
399* Tue Feb  7 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060207-1
400- Newer cvs snapshot
401- Drop upstreamed patches, pick up some new ones
402
403* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060131-3.1
404- rebuilt for new gcc4.1 snapshot and glibc changes
405
406* Thu Feb  2 2006 Ray Strode <rstrode@redhat.com> - 2.3.93.cvs20060131-3
407- Move user cache to a subdirectory (bug 160275)
408
409* Thu Feb  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-2
410- Accumulated patches
411
412* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-1
413- Newer cvs snapshot
414
415* Tue Jan 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060124-1
416- Newer cvs snapshot
417
418* Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 2.3.93-4
419- apply patch from Tim Mayberry to correct aliasing and disable
420  hinting for the two Chinese font names AR PL ShanHeiSun Uni
421  and AR PL Zenkai Uni
422
423* Tue Jan 10 2006 Bill Nottingham <notting@redhat.com> - 2.3.93-3
424- prereq coreutils for mkdir/touch in %%post
425
426* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-2
427- Fix to create /var/cache/fontconfig/stamp in the post install stage.
428
429* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-1
430- New upstream version.
431
432* Tue Dec 13 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-3
433- Disable hinting for Lohit Gujarati
434
435* Fri Dec  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-2
436- Add two new Chinese font names to the default fonts.conf file:
437        AR PL ShanHeiSun Uni
438        AR PL Zenkai Uni
439
440* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
441- rebuilt
442
443* Mon Nov 28 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051129-1
444- Update to a newer cvs snapshot
445
446* Sat Nov 19 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051119-1
447- Update to a newer cvs snapshot
448
449* Wed Nov 16 2005 Bill Nottingham <notting@redhat.com> - 2.3.93-3
450- modular X moved fonts from /usr/X11R6/lib/X11/fonts to
451  /usr/share/X11/fonts, adjust %%configure accordingly and
452  conflict with older font packages
453
454* Wed Nov  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92-2
455- Remove inadvertent rejection of Luxi Mono from 40-blacklist-fonts.conf.
456  Fixes #172437
457
458* Fri Nov  4 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92-1
459- Update to 2.3.92
460
461* Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051031-1
462- Update to a newer cvs snapshot
463- Add a patch which should help to understand broken cache problems
464
465* Fri Oct 21 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-2
466- Add new Chinese fonts
467- Fix the 40-blacklist-fonts.conf file to use the documented
468  fonts.conf syntax, and exclude the Hershey fonts by family
469  name.
470
471* Fri Oct 14 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-1
472- Update to the mmap branch of fontconfig
473
474* Fri Jul 22 2005 Kristian H淡gsberg <krh@redhat.com> - 2.3.2-1
475- Update to fontconfig-2.3.2.  Drop
476
477        fontconfig-2.1-slighthint.patch,
478        fontconfig-2.2.3-timestamp.patch,
479        fontconfig-2.2.3-names.patch,
480        fontconfig-2.2.3-ta-pa-orth.patch, and
481        fontconfig-2.2.3-timestamp.patch,
482
483  as they are now merged upstream.
484
485- Fold fontconfig-2.2.3-add-sazanami.patch into
486  fontconfig-2.3.2-defaultconfig.patch and split rules to disable CJK
487  hinting out into /etc/fonts/conf.d/50-no-hint-fonts.conf.
488
489- Drop fontconfig-0.0.1.020826.1330-blacklist.patch and use the new
490  rejectfont directive to reject those fonts in 40-blacklist-fonts.conf.
491
492- Add fontconfig-2.3.2-only-parse-conf-files.patch to avoid parsing
493  .rpmsave files.
494
495- Renable s390 documentation now that #97079 has been fixed and add
496  BuildRequires: for docbook-utils and docbook-utils-pdf.
497
498- Drop code to iconv and custom install man pages, upstream does the
499  right thing now.
500
501- Add workaround from hell to make elinks cooperate so we can build
502  txt documentation.
503
504* Tue Apr 19 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-13
505- Add another font family name Sazanami Gothic/Mincho (#148748)
506
507* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-12
508- Rebuild
509
510* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-11
511- Rebuild
512
513* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-10
514- Rebuild
515
516* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-9
517- Disable docs for s390 for now
518
519* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-8
520- Rebuild
521
522* Wed Dec  1 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-6
523- Sleep a second before the exit of fc-cache to fix problems with fast
524  serial installs of fonts (#140335)
525- Turn off hinting for Lohit Hindi/Bengali/Punjabi (#139816)
526
527* Tue Oct 19 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-5
528- Add Lohit fonts for Indic languages (#134492)
529- Add Punjabi converage, fix Tamil coverage
530
531* Wed Sep 22 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-4
532- Update fonts-hebrew names to include CLM suffix
533
534* Thu Sep  2 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-3
535- Backport code from head branch of fontconfig CVS to parse names
536  for postscript fonts (fixes #127500, J. J. Ramsey)
537- Own /usr/share/fonts (#110956, David K. Levine)
538- Add KacstQura to serif/sans-serif/monospace aliases (#101182)
539
540* Mon Aug 16 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-2
541- Don't run fc-cache if the binary isn't there (#128072, tracked
542  down by Jay Turner)
543
544* Tue Aug  3 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-1
545- Upgrade to 2.2.3
546- Convert man pages to UTF-8 (#108730, Peter van Egdom)
547- Renable docs on s390
548
549* Mon Jul 26 2004 Owen Taylor <otaylor@redhat.com> - 2.2.1-12
550- Rebuild for RHEL
551- Back freetype required version down to 2.1.4
552
553* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
554- rebuilt
555
556* Mon Apr 19 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-10
557- Require recent freetype (#109592, Peter Oliver)
558- Remove fonts.conf timestamp to fix multiarch conflict (#118182)
559- Disable hinting for Mukti Narrow (#120915, Sayamindu Dasgupta)
560
561* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.1
562- Rebuild
563
564* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.0
565- Add Albany/Cumberland/Thorndale as fallbacks for Microsoft core fonts and
566  as non-preferred alternatives for Sans/Serif/Monospace
567- Fix FreeType includes for recent FreeType
568
569* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
570- rebuilt
571
572* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
573- rebuilt
574
575* Mon Sep 22 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-6.0
576- Should have been passing --with-add-fonts, not --with-add-dirs to
577  configure ... caused wrong version of Luxi to be used. (#100862)
578
579* Fri Sep 19 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-5.0
580- Tweak fonts.conf to get right hinting for CJK fonts (#97337)
581
582* Tue Jun 17 2003 Bill Nottingham <notting@redhat.com> 2.2.1-3
583- handle null config->cache correctly
584
585* Thu Jun 12 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
586- Update default config to include Hebrew fonts (#90501, Dov Grobgeld)
587
588* Tue Jun 10 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
589- As a workaround disable doc builds on s390
590
591* Mon Jun  9 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-1
592- Version 2.2.1
593
594* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
595- rebuilt
596
597* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
598- debuginfo rebuild
599
600* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com> 2.1-8
601- Fix segfault in fc-cache from .dircache patch
602
603* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com>
604- Back out patch that wrote fonts.conf entries that crash RH-8.0
605  gnome-terminal, go with patch from fontconfig CVS instead.
606  (#84863)
607
608* Tue Feb 11 2003 Owen Taylor <otaylor@redhat.com>
609- Move fontconfig man page to main package, since it contains non-devel
610  information (#76189)
611- Look in the OTF subdirectory of /usr/X11R6/lib/fonts as well
612  so we find Syriac fonts (#82627)
613
614* Thu Feb  6 2003 Matt Wilson <msw@redhat.com> 2.1-5
615- modified fontconfig-0.0.1.020626.1517-fontdir.patch to hard code
616  /usr/X11R6/lib/X11/fonts instead of using $(X_FONT_DIR).  This is
617  because on lib64 machines, fonts are not in /usr/X11R6/lib64/....
618
619* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
620- rebuilt
621
622* Wed Jan 15 2003 Owen Taylor <otaylor@redhat.com>
623- Try a different tack when fixing cache problem
624
625* Tue Jan 14 2003 Owen Taylor <otaylor@redhat.com>
626- Try to fix bug where empty cache entries would be found in
627  ~/.fonts.cache-1 during scanning (#81335)
628
629* Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 2.1-1
630- Updated to version 2.1
631- Updated slighthint patch to fontconfig-2.1-slighthint.patch
632- Updated freetype version required to 2.1.2-7
633
634* Mon Sep  2 2002 Owen Taylor <otaylor@redhat.com>
635- Version 2.0
636- Correct capitalization/spacing for ZYSong18030 name (#73272)
637
638* Fri Aug 30 2002 Owen Taylor <otaylor@redhat.com>
639- Blacklist fonts from ghostscript-fonts that don't render correctly
640
641* Mon Aug 26 2002 Owen Taylor <otaylor@redhat.com>
642- Upgrade to fcpackage rc3
643- Fix bug in comparisons for xx_XX language tags
644- Compensate for a minor config file change in rc3
645
646* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
647- Add an explicit PreReq for freetype
648- Move fonts we don't ship to the end of the fonts.conf aliases so
649  installing them doesn't change the look.
650
651* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
652- Memory leak fix when parsing config files
653- Set rh_prefer_bitmaps for .ja fonts to key off of in Xft
654- Fix some groff warnings for fontconfig.man (#72138)
655
656* Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
657- Try once more to get the right default Sans-serif font :-(
658- Switch the Sans/Monospace aliases for Korean to Gulim, not Dotum
659
660* Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
661- Fix %%post
662
663* Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
664- Fix lost Luxi Sans default
665
666* Mon Aug 12 2002 Owen Taylor <otaylor@redhat.com>
667- Upgrade to rc2
668- Turn off hinting for all CJK fonts
669- Fix typo in %%post
670- Remove the custom language tag stuff in favor of Keith's standard
671  solution.
672
673* Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
674- Prefer Luxi Sans to Nimbus Sans again
675
676* Fri Jul 12 2002 Owen Taylor <otaylor@redhat.com>
677- Add FC_HINT_STYLE to FcBaseObjectTypes
678- Switch Chinese fonts to always using Sung-ti / Ming-ti, and never Kai-ti
679- Add ZYSong18030 to aliases (#68428)
680
681* Wed Jul 10 2002 Owen Taylor <otaylor@redhat.com>
682- Fix a typo in the langtag patch (caught by Erik van der Poel)
683
684* Wed Jul  3 2002 Owen Taylor <otaylor@redhat.com>
685- Add FC_HINT_STYLE tag
686
687* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
688- New upstream version, with fix for problems with
689  ghostscript-fonts (Fonts don't work for Qt+CJK,
690  etc.)
691
692* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
693- New upstream version, fixing locale problem
694
695* Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
696- Add a hack where we set the "language" fontconfig property based on the locale, then
697  we conditionalize base on that in the fonts.conf file.
698
699* Sun Jun 23 2002 Owen Taylor <otaylor@redhat.com>
700- New upstream version
701
702* Tue Jun 18 2002 Owen Taylor <otaylor@redhat.com>
703- Fix crash from FcObjectSetAdd
704
705* Tue Jun 11 2002 Owen Taylor <otaylor@redhat.com>
706- make fonts.conf %%config, not %%config(noreplace)
707- Another try at the CJK aliases
708- Add some CJK fonts to the config
709- Prefer Luxi Mono to Nimbus Mono
710
711* Mon Jun 10 2002 Owen Taylor <otaylor@redhat.com>
712- New upstream version
713- Fix matching for bitmap fonts
714
715* Mon Jun  3 2002 Owen Taylor <otaylor@redhat.com>
716- New version, new upstream mega-tarball
717
718* Tue May 28 2002 Owen Taylor <otaylor@redhat.com>
719- Fix problem with FcConfigSort
720
721* Fri May 24 2002 Owen Taylor <otaylor@redhat.com>
722- Initial specfile
723
Note: See TracBrowser for help on using the repository browser.