source: projects/specs/trunk/f/fluxbox/fluxbox-vl.spec @ 5201

Revision 5201, 13.2 KB checked in by mkato, 12 years ago (diff)
Line 
1%define FBversion 1.3.2
2%define pversion 1.3.0
3%define patchversion 1.1.0.1
4
5%define fbumenu_version 0.5.5
6%define vinefiles_version 11.3
7
8Summary:        Fluxbox is a windowmanager that is based on Blackbox.
9summary(ja):    Fluxbox は Blackbox から派生したウインドウマネージャです。
10Name:           fluxbox
11Version:        %{FBversion}
12Release:        2%{?_dist_release}
13Group:          User Interface/Desktops
14License:        MIT
15URL:            http://fluxbox.org/
16Vendor:         Project Vine
17Distribution:   Vine Linux
18Source0:        http://sourceforge.net/projects/fluxbox/files/fluxbox/%{version}/fluxbox-%{version}.tar.bz2
19# styles & scripts
20Source1:        %{name}-vinefiles-%{vinefiles_version}.tar.bz2
21Source2:        styles2-2.tar.bz2
22Source3:        fb_libexec.tar.bz2
23Source4:        fb_extend_menu
24
25### data/init.in
26Patch0:         fluxbox-init_in.patch
27### nls/Translation.m
28Patch3:         fluxbox-%{pversion}.nls-ja.patch
29### util/startfluxbox.in
30Patch4:         fluxbox-%{pversion}-2.startfb.patch
31### util/sfluxbox-generate_menu
32Patch92:        fluxbox-1.3.2.menugen.patch
33### util/fbsetbg
34Patch10:        fbsetbg_setter_priority.patch
35### nls/ja_JP/Makefile.in
36Patch40:        fluxbox-%{patchversion}.nls-ja-make.patch
37### util/fluxbox-update_configs.cc
38Patch41:        fluxbox-%{pversion}.update_cfg.patch
39### data/windowmenu
40Patch50:        fluxbox.windowmenu-1.patch
41### data/keys
42Patch51:        fluxbox.keys-1.patch
43
44BuildRoot:      %{_tmppath}/%{name}-buildroot
45BuildRequires:  libX11-devel libXext-devel
46BuildRequires:  bzip2 imlib2-devel zlib-devel freetype2-devel
47BuildRequires:  libXpm-devel nkf libXft-devel
48BuildRequires:  libICE-devel libSM-devel libXinerama-devel
49BuildRequires:  libXrandr-devel libXrender-devel
50BuildRequires:  fontconfig-devel libtool
51Requires:       imlib2 imlib2-loader ImageMagick nkf xsri task-xorg-x11
52Requires:       zenity bash
53
54%description
55
56Fluxbox is yet another windowmanager for X.
57It's based on the Blackbox 0.61.1 code.
58Fluxbox looks like blackbox and handles styles, colors, window
59placement and similar thing exactly like blackbox
60    (100% theme/style compability).
61So what's the difference between fluxbox and blackbox then?
62The answer is: LOTS!
63Here is a list of features that fluxbox already has, or is in the works...
64
65%description -l ja
66
67fluxbox は X Window System 用の、一味違ったウィンドウマネージャです。
68それは blackbox-0.61.1 のプログラムコードをベースに開発されています。
69fluxbox は blackbox によく似ていて、スタイル、カラーリング、ウィンドウ
70の配置などを blackbox 同様に処理します。(スタイル(テーマ)は 100% 互換)
71では、fluxbox と blackbox の違いは?  ...  その答えは「いっぱい」!
72
73fluxbox に何が出来るか、今後何を計画しているのか?
74詳しくは http://fluxbox.sourceforge.net/ をご覧下さい。
75
76%prep
77%__rm -rf %{buildroot}
78%setup -q -a 1 -a 2 -a 3
79
80## init
81%patch0 -p1
82## nls
83%patch3 -p1
84## startfluxbox
85%patch4 -p1
86## fluxbox-generete_menu
87%patch92 -p1
88## fbsetbg_setter_priority
89%patch10 -p1
90## nls Makefile.in
91%patch40 -p1
92## fluxbox-update_configs.cc
93%patch41 -p1
94## windowmenu
95%patch50 -p1
96## keys
97%patch51 -p1
98
99%build
100
101CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; \
102    CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; \
103    FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; \
104    ./configure --enable-nls \
105    --prefix=%{_prefix} \
106    --exec-prefix=%{_exec_prefix} \
107    --bindir=%{_bindir} \
108    --sbindir=%{_sbindir} \
109    --sysconfdir=%{_sysconfdir} \
110    --datadir=%{_datadir} \
111    --includedir=%{_includedir} \
112    --libdir=%{_libdir} \
113    --libexecdir=%{_libexecdir} \
114    --localstatedir=%{_localstatedir} \
115    --sharedstatedir=%{_sharedstatedir} \
116    --mandir=%{_mandir} \
117    --infodir=%{_infodir}
118
119%__make
120
121%install
122%__rm -rf  %{buildroot}
123# fluxbox installation
124make "DESTDIR=%{buildroot}" install
125
126# styles
127%__rm data/styles/Makefile*
128%__cp -a data/styles                %{buildroot}%{_datadir}/%{name}/
129%__cp -a data/styles2               %{buildroot}%{_datadir}/%{name}/
130# wallpapers
131%__cp -a data/backgrounds           %{buildroot}%{_datadir}/%{name}/
132# HTML images
133%__cp -a data/images                %{buildroot}%{_datadir}/%{name}/
134# UserMenu samples
135%__cp -a data/UserMenu              %{buildroot}%{_datadir}/%{name}/
136# HTML docs
137%__cp data/*.html                   %{buildroot}%{_datadir}/%{name}/
138# scripts
139%__cp data/fb_welcome               %{buildroot}%{_datadir}/%{name}/
140%__cp data/cng_fbtips               %{buildroot}%{_datadir}/%{name}/
141%__cp data/change-rootcmd           %{buildroot}%{_datadir}/%{name}/
142%__cp data/change-init_rootcmd      %{buildroot}%{_datadir}/%{name}/
143%__cp data/applyoldstyle            %{buildroot}%{_datadir}/%{name}/
144%__cp data/mk-rootcmds              %{buildroot}%{_bindir}/
145%__cp data/fbumenu_gen-%{fbumenu_version} %{buildroot}%{_bindir}/fbumenu_gen
146# changelog
147%__cp ChangeLog                     %{buildroot}%{_datadir}/%{name}/
148
149# xsession desktop entry
150%__mkdir_p %{buildroot}%{_datadir}/xsessions/
151#%__cp data/fluxbox.desktop %{buildroot}%{_datadir}/xsessions/
152%__install -m 644 data/fluxbox.desktop %{buildroot}%{_datadir}/xsessions/
153# logout, reboot, shutdown commands
154%__mkdir_p %{buildroot}%{_libexecdir}/%{name}
155%__install -m 755 fb_libexec/* %{buildroot}%{_libexecdir}/%{name}/
156# extend menu
157%__mkdir_p %{buildroot}%{_datadir}/%{name}/
158%__install -m 755 %{SOURCE4} %{buildroot}%{_datadir}/%{name}/
159
160if [ -z "$DEBUG" ]; then
161    strip   %{buildroot}%{_bindir}/fluxbox \
162        %{buildroot}%{_bindir}/fbsetroot \
163        %{buildroot}%{_bindir}/fbrun
164fi
165
166bzip2 %{buildroot}%{_mandir}/man1/*.1
167
168%post
169
170# New menu-system
171%__rm %{_datadir}/fluxbox/menu*
172%{_bindir}/fluxbox-generate_menu \
173    -in -B \
174    -p %{_prefix} \
175    -o %{_datadir}/fluxbox/menu 2> /dev/null
176
177%clean
178
179%__rm -rf %{buildroot}
180
181%files
182%defattr(-,root,root,755)
183%doc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
184%{_bindir}/*
185%{_datadir}/*
186%{_libexecdir}/*
187
188
189%changelog
190* Mon Nov 14 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.2-2
191- rewrited spec file
192  (reformat %changelog)
193
194* Mon Nov 14 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.2-1
195- new upstream release.
196
197* Sat Mar 26 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.1-2
198- added wide wall paper
199- update documents(flux_news.html)
200
201* Mon Mar  7 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.1-1
202- new upstream release.
203
204* Tue Mar  1 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.0-1
205- new upstream release.
206- updated patchs.
207- added keys & windowmenu patch.
208- update documents(flux_news.html,styles.html)
209
210* Tue Oct  5 2010 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-5
211- added BR: libICE-devel libSM-devel libXinerama-devel
212            libXrandr-devel libXrender-devel fontconfig-devel libtool
213- added Requires: task-xorg-x11 bash
214- dropped Requires: xinitrc libXpm
215
216* Mon Oct  4 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.1-4
217- add BR: libXft-devel (1.1.1-3.ppc was built w/o libXft-devel)
218
219* Wed May 26 2010 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-3
220- update & added Vine documents. (apps.html, config_files.html)
221- Combined some of patches.
222- update fbumenu_gen script(usermenu generator).
223- added menu commands. (logout, reboot, shutdown)
224- added extend application menu script. (%{SOURCE4})
225
226* Tue Mar 16 2010 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-2
227- updated wallpapers.
228- moved desktop-entry to %{_datadir}/xsessions/ .
229
230* Fri Sep 19 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-1
231- new upstream release.
232- removed upstream patchs.
233- rewrote Vine documents.
234
235* Sat Sep 14 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-3
236- Applied upstream patchs.
237
238* Fri Sep 12 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-2
239- updated mk-rootcmds
240- updated vine documents. (keys.html, flux_news.html)
241
242* Thu Sep 11 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-1
243- new upstream release
244- removed fluxbox-%{FBversion}.nls-hh.patch
245- rewrote documents. (keys.html, flux_news.html)
246- added new default keys file
247
248* Sun Aug 24 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-6
249- fixed locale problem
250-     rewrote scripts for eucJP and UTF-8
251- revived fluxbox-%{FBversion}.Xclients.patch. (for startx)
252
253* Sun Jun 22 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-5
254- add new style. (tux)
255
256* Mon Jun 16 2008  KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-3
257- corrected line gap of nls-header
258-   (fluxbox-1.0.0.nls-hh.patch)
259
260* Tue May 27 2008  KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-2
261- adjust startup sequence
262-   (rewrite desktop entry file for dm sessions)
263-   (remove fluxbox-%{FBversion}.Xclients.patch)
264
265* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-1
266- applied new versioning policy
267- rebuilt with xorg-x11 7.3
268- spec in UTF-8
269
270* Tue Dec  4 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-0vl3, 4
271- retouch patchs for ja_JP.UTF-8 locale
272-     : for root menu & help message
273- rewrite vine documents
274
275* Mon Oct 15 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-0vl1, 2
276- new upstream 'stable' release
277- add new documents(styles tips, keys tips).
278- add new styles
279- update patch files, vine documents, vine scripts
280
281* Wed Apr 11 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc3.1, 2
282- new upstream release
283- add rewrited system styles
284- update patch files
285- update vine documents
286
287* Sun Dec 24 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc2.3, 4
288- add BuildRequires: zlib-devel freetype2-devel
289- add Requires: xsri
290- Change wpsetter''s priority (fbsetbg_setter_priority.patch)
291
292* Thu Jul 20 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc2.1, 2
293- new upstream release
294- update patch files
295- update vine documents
296
297* Thu Jul  6 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc0.1, 2
298- new upstream release
299- update patch files
300- added 'additional applications' extension to fluxbox-generate_menu
301
302* Tue Apr  8 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.15.1-0vl1, 2
303- new upstream release
304- add 'init file rewrite' script for back-compatible
305- rewrite documents
306
307* Wed Mar 29 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.15-0vl1, 2
308- new upstream release
309- update *tips*
310- update patch files
311- add & update script files
312- update & retouch style files (VineStyle*, BlueStar*)
313- retouch menu structure (Vine tools)
314- add script for back compatible to background-style
315
316* Sun Mar 19 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.14-0vl1.1, 2.2
317- update *_tips.html
318    (retouch link errors)
319- retouch ja_JP/Translation.m
320- update menugen patch
321- update style file (VineStyle, BlueStar)
322- add index.html, scripts for 'wellcome'
323
324* Tue Oct 25 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.14-0vl1, 2
325- new upstream release
326- update vine patch
327  (retouch init file for new spec.)
328- update vinefiles
329  (update fbumenu_gen(usermenu generator))
330    (update 2 style files for new spec.)
331    (update fluxtips.txt)
332- update fluxbox_menu_tips.html
333
334* Sun Jun  5 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.13-0vl3, 4
335- update vine patch
336  (add some menu items to fluxbox-generate_menu)
337    (retouch menu structure)
338      (rewrite 'about menu')
339- update vinefiles
340    (add usermenu generator to x-utilus)
341- update fluxbox_menu_tips.html
342
343* Fri May 27 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.13-0vl1
344- new upstream release
345- update vine patch
346        (add some menu items to fluxbox-generate_menu)
347                (extend 'about toolbar')
348- update nls-ja patch
349- update fluxtips.txt
350    (rewrite, add '0.9.13 news')
351
352* Sun Feb  6 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.12-0vl1
353- new upstream release
354- update vine patch
355  (add some menu items to fluxbox-generate_menu)
356    (include blackbox styles)
357      (extend 'my_mail')
358      (extend 'about menu')
359- add nls-ja patch
360
361* Sun Dec 12 2004 KATO Masashi <mkato@par.odn.ne.jp> 0.9.11-0vl1
362- new upstream release
363- update vine patch
364  (generate japanese menu)
365    (add some menu items to fluxbox-generate_menu)
366    (retouch menu structure)
367    (fix menu backup problem)
368
369* Wed Nov 24 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.10-0vl1
370- new upstream release
371- update vine patch ( merged vine patches )
372- add font_locale patch ( Patch100 )
373- fix typo: s/buidroot/buildroot/g
374
375* Sun Jun 20 2004 KATO Masashi <mkato@par.odn.ne.jp> 0.9.9-0vl2
376- rewrite 2 styles (VineStyleII, BlueStarII)
377- rewrite fluxtips.txt(for 0.9.x)
378- modifying menu-generator
379    (fix problems of 'can't generates some menus'')
380    (add some menu items)
381    (Japanese help messages)
382- modifying 'init' file(default style, menu-alpha)
383- append sample of 'keys' file
384
385* Sun May  2 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.9-0vl1
386- new upstream release
387
388* Sun Mar 14 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.8-0vl2
389- using rpm macros
390- fix nonexistent directory for styles in postscript
391- add BuildRequires: bzip2
392- drop Prefix tag
393
394* Sat Mar  6 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.8-0vl1
395- new upstream release
396- update vine patch (Patch101)
397
398* Mon Aug 11 2003 IWAI, Masaharu <iwai@alib.jp> 0.1.14-1_0vl2
399- build for VineSeed
400- fix Group tag for VineLinux:
401  Graphical desktop/Other -> User Interface/Desktops
402- add /usr/share/%%{name} directory in %%files section
403
404* Sat May 31 2003 KATO Masashi <mkato@par.odn.ne.jp> 0.1.14-1_0vl1
405- fluxbox for Vine Linux. Japanese menu enabled at default.
406  (initial package for Vine Linux)
407- modified menu-generator patch (x-terminals)
408- modified init.in patch (date,workspace name,default style)
409- added 2 styles (VineStyle, BlueStar)
Note: See TracBrowser for help on using the repository browser.