source: projects/specs/trunk/f/fluxbox/fluxbox-vl.spec @ 7713

Revision 7713, 13.4 KB checked in by tanakanata, 11 years ago (diff)

update source

Line 
1%define FBversion 1.3.5
2%define pversion 1.3.0
3%define patchversion 1.1.0.1
4
5%define fbumenu_version 0.5.5
6%define vinefiles_version 11.4
7
8Summary:        Fluxbox is a windowmanager that is based on Blackbox.
9summary(ja):    Fluxbox は Blackbox から派生したウインドウマネージャです。
10Name:           fluxbox
11Version:        %{FBversion}
12Release:        1%{?_dist_release}
13Group:          User Interface/Desktops
14License:        MIT
15URL:            http://fluxbox.org/
16Vendor:         Project Vine
17Distribution:   Vine Linux
18Source0:        http://sourceforge.net/projects/fluxbox/files/fluxbox/%{version}/fluxbox-%{version}.tar.bz2
19# styles & scripts
20Source1:        %{name}-vinefiles-%{vinefiles_version}.tar.bz2
21Source2:        styles2-2.tar.bz2
22Source3:        fb_libexec.tar.bz2
23Source4:        fb_extend_menu
24
25### data/init.in
26Patch0:         fluxbox-init_in.patch
27### nls/Translation.m
28Patch3:         fluxbox-%{pversion}.nls-ja.patch
29### util/startfluxbox.in
30Patch4:         fluxbox-%{pversion}-2.startfb.patch
31### util/sfluxbox-generate_menu
32Patch93:        fluxbox-1.3.5.menugen.patch
33### util/fbsetbg
34Patch10:        fbsetbg_setter_priority.patch
35### nls/ja_JP/Makefile.in
36Patch40:        fluxbox-%{patchversion}.nls-ja-make.patch
37### util/fluxbox-update_configs.cc
38Patch41:        fluxbox-%{pversion}.update_cfg.patch
39### data/windowmenu
40Patch50:        fluxbox.windowmenu-1.patch
41### data/keys
42Patch51:        fluxbox.keys-1.patch
43
44BuildRoot:      %{_tmppath}/%{name}-buildroot
45BuildRequires:  libX11-devel libXext-devel
46BuildRequires:  bzip2 imlib2-devel zlib-devel freetype2-devel
47BuildRequires:  libXpm-devel nkf libXft-devel
48BuildRequires:  libICE-devel libSM-devel libXinerama-devel
49BuildRequires:  libXrandr-devel libXrender-devel
50BuildRequires:  fontconfig-devel libtool
51Requires:       imlib2 imlib2-loader ImageMagick nkf task-xorg-x11
52Requires:       zenity bash feh
53
54%description
55
56Fluxbox is yet another windowmanager for X.
57It's based on the Blackbox 0.61.1 code.
58Fluxbox looks like blackbox and handles styles, colors, window
59placement and similar thing exactly like blackbox
60    (100% theme/style compability).
61So what's the difference between fluxbox and blackbox then?
62The answer is: LOTS!
63Here is a list of features that fluxbox already has, or is in the works...
64
65%description -l ja
66
67fluxbox は X Window System 用の、一味違ったウィンドウマネージャです。
68それは blackbox-0.61.1 のプログラムコードをベースに開発されています。
69fluxbox は blackbox によく似ていて、スタイル、カラーリング、ウィンドウ
70の配置などを blackbox 同様に処理します。(スタイル(テーマ)は 100% 互換)
71では、fluxbox と blackbox の違いは?  ...  その答えは「いっぱい」!
72
73fluxbox に何が出来るか、今後何を計画しているのか?
74詳しくは http://fluxbox.sourceforge.net/ をご覧下さい。
75
76%prep
77%__rm -rf %{buildroot}
78%setup -q -a 1 -a 2 -a 3
79
80## init
81%patch0 -p1
82## nls
83%patch3 -p1
84## startfluxbox
85%patch4 -p1
86## fluxbox-generete_menu
87%patch93 -p1
88## fbsetbg_setter_priority
89%patch10 -p1
90## nls Makefile.in
91%patch40 -p1
92## fluxbox-update_configs.cc
93%patch41 -p1
94## windowmenu
95%patch50 -p1
96## keys
97%patch51 -p1
98
99%build
100
101CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; \
102    CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; \
103    FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; \
104    ./configure --enable-nls \
105    --prefix=%{_prefix} \
106    --exec-prefix=%{_exec_prefix} \
107    --bindir=%{_bindir} \
108    --sbindir=%{_sbindir} \
109    --sysconfdir=%{_sysconfdir} \
110    --datadir=%{_datadir} \
111    --includedir=%{_includedir} \
112    --libdir=%{_libdir} \
113    --libexecdir=%{_libexecdir} \
114    --localstatedir=%{_localstatedir} \
115    --sharedstatedir=%{_sharedstatedir} \
116    --mandir=%{_mandir} \
117    --infodir=%{_infodir}
118
119%__make
120
121%install
122%__rm -rf  %{buildroot}
123# fluxbox installation
124make "DESTDIR=%{buildroot}" install
125
126# styles
127%__rm data/styles/Makefile*
128%__cp -a data/styles                %{buildroot}%{_datadir}/%{name}/
129%__cp -a data/styles2               %{buildroot}%{_datadir}/%{name}/
130# wallpapers
131%__cp -a data/backgrounds           %{buildroot}%{_datadir}/%{name}/
132# HTML images
133%__cp -a data/images                %{buildroot}%{_datadir}/%{name}/
134# UserMenu samples
135%__cp -a data/UserMenu              %{buildroot}%{_datadir}/%{name}/
136# HTML docs
137%__cp data/*.html                   %{buildroot}%{_datadir}/%{name}/
138# scripts
139%__cp data/fb_welcome               %{buildroot}%{_datadir}/%{name}/
140%__cp data/cng_fbtips               %{buildroot}%{_datadir}/%{name}/
141%__cp data/change-rootcmd           %{buildroot}%{_datadir}/%{name}/
142%__cp data/change-init_rootcmd      %{buildroot}%{_datadir}/%{name}/
143%__cp data/applyoldstyle            %{buildroot}%{_datadir}/%{name}/
144%__cp data/mk-rootcmds              %{buildroot}%{_bindir}/
145%__cp data/fbumenu_gen-%{fbumenu_version} %{buildroot}%{_bindir}/fbumenu_gen
146# changelog
147%__cp ChangeLog                     %{buildroot}%{_datadir}/%{name}/
148
149# xsession desktop entry
150%__mkdir_p %{buildroot}%{_datadir}/xsessions/
151#%__cp data/fluxbox.desktop %{buildroot}%{_datadir}/xsessions/
152%__install -m 644 data/fluxbox.desktop %{buildroot}%{_datadir}/xsessions/
153# logout, reboot, shutdown commands
154%__mkdir_p %{buildroot}%{_libexecdir}/%{name}
155%__install -m 755 fb_libexec/* %{buildroot}%{_libexecdir}/%{name}/
156# extend menu
157%__mkdir_p %{buildroot}%{_datadir}/%{name}/
158%__install -m 755 %{SOURCE4} %{buildroot}%{_datadir}/%{name}/
159
160if [ -z "$DEBUG" ]; then
161    strip   %{buildroot}%{_bindir}/fluxbox \
162        %{buildroot}%{_bindir}/fbsetroot \
163        %{buildroot}%{_bindir}/fbrun
164fi
165
166bzip2 %{buildroot}%{_mandir}/man1/*.1
167
168%post
169
170# New menu-system
171%__rm %{_datadir}/fluxbox/menu*
172%{_bindir}/fluxbox-generate_menu \
173    -in -B \
174    -p %{_prefix} \
175    -o %{_datadir}/fluxbox/menu 2> /dev/null
176
177%clean
178
179%__rm -rf %{buildroot}
180
181%files
182%defattr(-,root,root,755)
183%doc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
184%{_bindir}/*
185%{_datadir}/*
186%{_libexecdir}/*
187
188
189%changelog
190* Wed Jun 12 2013 TANAKA hiroaki mosaicist@jcom.home.ne.jp > 1.3.5-1
191- new upstream release
192- update fluxbox-%version.menugen.patch
193
194* Mon Feb 13 2012 KATO Masashi <mkato@par.odn.ne.jp> 1.3.2-3
195- replaced wallpaper setter "xsri" with "feh"
196- update documents(fluxtips.html)
197
198* Mon Nov 14 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.2-2
199- rewrited spec file
200  (reformat %changelog)
201
202* Mon Nov 14 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.2-1
203- new upstream release.
204
205* Sat Mar 26 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.1-2
206- added wide wall paper
207- update documents(flux_news.html)
208
209* Mon Mar  7 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.1-1
210- new upstream release.
211
212* Tue Mar  1 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.0-1
213- new upstream release.
214- updated patchs.
215- added keys & windowmenu patch.
216- update documents(flux_news.html,styles.html)
217
218* Tue Oct  5 2010 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-5
219- added BR: libICE-devel libSM-devel libXinerama-devel
220            libXrandr-devel libXrender-devel fontconfig-devel libtool
221- added Requires: task-xorg-x11 bash
222- dropped Requires: xinitrc libXpm
223
224* Mon Oct  4 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.1-4
225- add BR: libXft-devel (1.1.1-3.ppc was built w/o libXft-devel)
226
227* Wed May 26 2010 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-3
228- update & added Vine documents. (apps.html, config_files.html)
229- Combined some of patches.
230- update fbumenu_gen script(usermenu generator).
231- added menu commands. (logout, reboot, shutdown)
232- added extend application menu script. (%{SOURCE4})
233
234* Tue Mar 16 2010 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-2
235- updated wallpapers.
236- moved desktop-entry to %{_datadir}/xsessions/ .
237
238* Fri Sep 19 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-1
239- new upstream release.
240- removed upstream patchs.
241- rewrote Vine documents.
242
243* Sat Sep 14 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-3
244- Applied upstream patchs.
245
246* Fri Sep 12 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-2
247- updated mk-rootcmds
248- updated vine documents. (keys.html, flux_news.html)
249
250* Thu Sep 11 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-1
251- new upstream release
252- removed fluxbox-%{FBversion}.nls-hh.patch
253- rewrote documents. (keys.html, flux_news.html)
254- added new default keys file
255
256* Sun Aug 24 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-6
257- fixed locale problem
258-     rewrote scripts for eucJP and UTF-8
259- revived fluxbox-%{FBversion}.Xclients.patch. (for startx)
260
261* Sun Jun 22 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-5
262- add new style. (tux)
263
264* Mon Jun 16 2008  KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-3
265- corrected line gap of nls-header
266-   (fluxbox-1.0.0.nls-hh.patch)
267
268* Tue May 27 2008  KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-2
269- adjust startup sequence
270-   (rewrite desktop entry file for dm sessions)
271-   (remove fluxbox-%{FBversion}.Xclients.patch)
272
273* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-1
274- applied new versioning policy
275- rebuilt with xorg-x11 7.3
276- spec in UTF-8
277
278* Tue Dec  4 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-0vl3, 4
279- retouch patchs for ja_JP.UTF-8 locale
280-     : for root menu & help message
281- rewrite vine documents
282
283* Mon Oct 15 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-0vl1, 2
284- new upstream 'stable' release
285- add new documents(styles tips, keys tips).
286- add new styles
287- update patch files, vine documents, vine scripts
288
289* Wed Apr 11 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc3.1, 2
290- new upstream release
291- add rewrited system styles
292- update patch files
293- update vine documents
294
295* Sun Dec 24 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc2.3, 4
296- add BuildRequires: zlib-devel freetype2-devel
297- add Requires: xsri
298- Change wpsetter''s priority (fbsetbg_setter_priority.patch)
299
300* Thu Jul 20 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc2.1, 2
301- new upstream release
302- update patch files
303- update vine documents
304
305* Thu Jul  6 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc0.1, 2
306- new upstream release
307- update patch files
308- added 'additional applications' extension to fluxbox-generate_menu
309
310* Tue Apr  8 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.15.1-0vl1, 2
311- new upstream release
312- add 'init file rewrite' script for back-compatible
313- rewrite documents
314
315* Wed Mar 29 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.15-0vl1, 2
316- new upstream release
317- update *tips*
318- update patch files
319- add & update script files
320- update & retouch style files (VineStyle*, BlueStar*)
321- retouch menu structure (Vine tools)
322- add script for back compatible to background-style
323
324* Sun Mar 19 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.14-0vl1.1, 2.2
325- update *_tips.html
326    (retouch link errors)
327- retouch ja_JP/Translation.m
328- update menugen patch
329- update style file (VineStyle, BlueStar)
330- add index.html, scripts for 'wellcome'
331
332* Tue Oct 25 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.14-0vl1, 2
333- new upstream release
334- update vine patch
335  (retouch init file for new spec.)
336- update vinefiles
337  (update fbumenu_gen(usermenu generator))
338    (update 2 style files for new spec.)
339    (update fluxtips.txt)
340- update fluxbox_menu_tips.html
341
342* Sun Jun  5 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.13-0vl3, 4
343- update vine patch
344  (add some menu items to fluxbox-generate_menu)
345    (retouch menu structure)
346      (rewrite 'about menu')
347- update vinefiles
348    (add usermenu generator to x-utilus)
349- update fluxbox_menu_tips.html
350
351* Fri May 27 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.13-0vl1
352- new upstream release
353- update vine patch
354        (add some menu items to fluxbox-generate_menu)
355                (extend 'about toolbar')
356- update nls-ja patch
357- update fluxtips.txt
358    (rewrite, add '0.9.13 news')
359
360* Sun Feb  6 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.12-0vl1
361- new upstream release
362- update vine patch
363  (add some menu items to fluxbox-generate_menu)
364    (include blackbox styles)
365      (extend 'my_mail')
366      (extend 'about menu')
367- add nls-ja patch
368
369* Sun Dec 12 2004 KATO Masashi <mkato@par.odn.ne.jp> 0.9.11-0vl1
370- new upstream release
371- update vine patch
372  (generate japanese menu)
373    (add some menu items to fluxbox-generate_menu)
374    (retouch menu structure)
375    (fix menu backup problem)
376
377* Wed Nov 24 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.10-0vl1
378- new upstream release
379- update vine patch ( merged vine patches )
380- add font_locale patch ( Patch100 )
381- fix typo: s/buidroot/buildroot/g
382
383* Sun Jun 20 2004 KATO Masashi <mkato@par.odn.ne.jp> 0.9.9-0vl2
384- rewrite 2 styles (VineStyleII, BlueStarII)
385- rewrite fluxtips.txt(for 0.9.x)
386- modifying menu-generator
387    (fix problems of 'can't generates some menus'')
388    (add some menu items)
389    (Japanese help messages)
390- modifying 'init' file(default style, menu-alpha)
391- append sample of 'keys' file
392
393* Sun May  2 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.9-0vl1
394- new upstream release
395
396* Sun Mar 14 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.8-0vl2
397- using rpm macros
398- fix nonexistent directory for styles in postscript
399- add BuildRequires: bzip2
400- drop Prefix tag
401
402* Sat Mar  6 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.8-0vl1
403- new upstream release
404- update vine patch (Patch101)
405
406* Mon Aug 11 2003 IWAI, Masaharu <iwai@alib.jp> 0.1.14-1_0vl2
407- build for VineSeed
408- fix Group tag for VineLinux:
409  Graphical desktop/Other -> User Interface/Desktops
410- add /usr/share/%%{name} directory in %%files section
411
412* Sat May 31 2003 KATO Masashi <mkato@par.odn.ne.jp> 0.1.14-1_0vl1
413- fluxbox for Vine Linux. Japanese menu enabled at default.
414  (initial package for Vine Linux)
415- modified menu-generator patch (x-terminals)
416- modified init.in patch (date,workspace name,default style)
417- added 2 styles (VineStyle, BlueStar)
Note: See TracBrowser for help on using the repository browser.