source: projects/specs/trunk/f/flex/flex-vl.spec @ 12322

Revision 12322, 6.9 KB checked in by tomop, 4 years ago (diff)

updated 13 packages

cpio-2.13-1

curl-7.68.0-1

e2fsprogs-1.45.5-1

firefox-68.5.0-1

flex-2.6.4-1

libarchive-3.4.2-1

libogg-1.3.4-1

libssh-0.9.3-1

libtasn1-4.16.0-1

libvorbis-1.3.6-1

nghttp2-1.40.0-1

thunderbird-68.5.0-1

vorbis-tools-1.4.0-5

Line 
1Summary: A tool for creating scanners (text pattern recognizers).
2Summary(ja): スキャナ (テキストパターン認識器) 作成ツール
3Name: flex
4Version: 2.6.4
5Release: 1%{?_dist_release}
6
7Group: Development/Tools
8License: BSD
9URL: https://github.com/westes/flex
10
11Source: https://github.com/westes/flex/releases/download/v%{version}/flex-%{version}.tar.gz
12Patch0: flex-rh1389575.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: gettext bison m4 help2man
16Requires: m4
17Requires(post): /sbin/install-info
18Requires(preun): /sbin/install-info
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24The flex program generates scanners.  Scanners are programs which can
25recognize lexical patterns in text.  Flex takes pairs of regular
26expressions and C code as input and generates a C source file as
27output.  The output file is compiled and linked with a library to
28produce an executable.  The executable searches through its input for
29occurrences of the regular expressions.  When a match is found, it
30executes the corresponding C code.  Flex was designed to work with
31both Yacc and Bison, and is used by many programs as part of their
32build process.
33
34You should install flex if you are going to use your system for
35application development.
36
37%description -l ja
38flex はスキャナを生成するプログラムです.スキャナとは,
39テキストの語彙を認識するプログラムです.flex は正規表現と
40C のコードを入力とし,C のソースファイルを出力します.
41出力されたファイルはコンパイルされ,ライブラリとリンクされて
42実行ファイルが作られます.この実行ファイルは入力を調べ,正規表現に
43マッチするものがないか探します.もしマッチするものが見付かれば,
44対応する C コードが実行されます.flex は yacc と bison と共に
45動作する様設計されており,多くのプログラムを作成する際に使われます.
46
47アプリケーション開発を行う場合は flex をインストールして下さい.
48
49
50%prep
51%setup -q
52%patch0 -p1
53
54autoreconf -ivf
55
56%build
57%configure --disable-dependency-tracking CFLAGS="-fPIC $RPM_OPT_FLAGS"
58make %{?_smp_mflags}
59
60%install
61rm -rf %{buildroot}
62make DESTDIR=%{buildroot} install
63rm -f %{buildroot}/%{_infodir}/dir
64
65( cd %{buildroot}
66  strip .%{_bindir}/flex
67  ln -sf flex .%{_bindir}/lex
68  ln -s flex.1 .%{_mandir}/man1/lex.1
69  ln -s flex.1 .%{_mandir}/man1/flex++.1
70  ln -s libfl.a .%{_libdir}/libl.a
71)
72
73rm -f %{buildroot}%{_libdir}/libfl.so*
74rm -f %{buildroot}%{_libdir}/libfl.la
75
76%find_lang %{name}
77
78rm -rf %{buildroot}%{_docdir}/%{name}
79
80%check
81echo ============TESTING===============
82make check
83echo ============END TESTING===========
84
85%clean
86rm -rf %{buildroot}
87
88%post
89/sbin/install-info %{_infodir}/flex.info.gz --dir-file=%{_infodir}/dir ||:
90
91%preun
92if [ $1 = 0 ]; then
93    /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir ||:
94fi
95
96%files -f %{name}.lang
97%defattr(-,root,root)
98%license COPYING
99%doc NEWS README.md
100%{_bindir}/*
101%{_mandir}/man1/*
102%{_libdir}/*.a
103%{_includedir}/FlexLexer.h
104%{_infodir}/flex.info*
105
106%changelog
107* Mon Feb 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.4-1
108- updated to 2.6.4.
109- dropped Patch0.
110- imported Patch0 (flex-rh1389575.patch) from rawhide.
111
112* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.37-1
113- update to 2.5.37
114- remove old patches
115- add Patch0 (flex-2.5.36-bison-2.6.1.patch) from Fedora
116
117* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.35-3
118- rebuilt with current VineSeed
119- inserted the "-fPIC" on configure command-line and dropt the -fPIC patch.
120- removed BR: info
121- added Patch0-3 from Fedora
122  * Tue Jul 13 2010 Petr Machata <pmachata@redhat.com> - 2.5.35-10
123  - Declare yyget_column and yyset_column in reentrant mode.
124  - Resolves: #612465
125  * Mon Apr 20 2009 Debarshi Ray <rishi@fedoraproject.org> - 2.5.35-5
126  - Resolves: #496548.
127  * Mon Apr 20 2009 Petr Machata <pmachata@redhat.com> - 2.5.35-4
128  - Get rid of warning caused by ignoring return value of fwrite() in
129    ECHO macro.  Debian patch.
130  - Resolves: #484961
131  * Mon May 12 2008 Petr Machata <pmachata@redhat.com> - 2.5.35-2
132  - Resolves: #445950
133
134* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.35-2
135- spec in utf-8
136
137* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.35-1
138- new upstream release
139- updated Patch0, dropped Patch1
140
141* Tue Nov 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.33-5vl1
142- rebuilt with new toolchains
143- updated to 2.5.33 based on Fedora packages
144  * Fri Mar 30 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-5
145  - Make yy-prefixed variables available to scanner even with -P.
146  * Fri Feb  2 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-4
147  - Use %%find_lang to package locale files.
148  * Wed Jan 31 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-3
149  - Compile with -fPIC.
150  * Fri Jan 19 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-1
151  - Rebase to 2.5.33
152
153* Sat Jan 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl2
154- rebuild with gcc 3.3.6
155
156* Sun Jul  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl1
157- rebuild with new toolchains
158- based on Redhat Rawhide 2.5.4-30
159  - Mon Nov  4 2002 Than Ngo <than@redhat.com> 2.5.4a-27
160  - YY_NO_INPUT patch from Jean Marie
161  - Tue Apr  2 2002 Than Ngo <than@redhat.com> 2.5.4a-23
162  - More ISO C++ 98 fixes (#59670)
163  - Wed Feb 20 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.5.4a-21
164  - More ISO C++ 98 fixes (#59670)
165- s/Copyright/License/
166
167* Mon Feb 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
168- 2.5.4a-13vl1
169- based on 2.5.4a-13 from Rawhide
170- use better macros (%%{_tmppath})
171- added Japanese summary and description
172
173* Sat Sep 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
174- Fix generation of broken code (conflicting isatty() prototype w/ glibc 2.2)
175  This broke, among other things, the kdelibs 2.0 build
176- Fix source URL
177
178* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
179- FHS packaging (64bit systems need to use libdir).
180
181* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
182- automatic rebuild
183
184* Tue Jun  6 2000 Bill Nottingham <notting@redhat.com>
185- rebuild, FHS stuff.
186
187* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
188- handle compressed man pages
189
190* Fri Jan 28 2000 Bill Nottingham <notting@redhat.com>
191- add a libl.a link to libfl.a
192
193* Wed Aug 25 1999 Jeff Johnson <jbj@redhat.com>
194- avoid uninitialized variable warning (Erez Zadok).
195
196* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
197- auto rebuild in the new build environment (release 6)
198
199* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
200- build for 6.0 tree
201
202* Mon Aug 10 1998 Jeff Johnson <jbj@redhat.com>
203- build root
204
205* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
206- translations modified for de, fr, tr
207
208* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
209- updated from 2.5.4 to 2.5.4a
210
211* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
212- built against glibc
213
214* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
215- Updated to v. 2.5.4
Note: See TracBrowser for help on using the repository browser.