source: projects/specs/trunk/f/fftw/fftw-vl.spec @ 521

Revision 521, 6.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name fftw
2%define version 2.1.5
3%define release 1%{?_dist_release}
4
5Name: %{name}
6Summary:   C subroutines for computing the Discrete Fourier Transform.
7Version:   %{version}
8Release:   %{release}
9License:   GPL
10Icon:      fftw-logo-thumb.gif
11Group:     Development/Libraries
12Source:    %{name}-%{version}.tar.gz
13%{?nosrc:NoSource: 0}
14Patch0:    %{name}-%{version}-pentium.patch
15URL:       http://www.fftw.org/
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
17BuildRequires: glibc, gcc-gfortran
18Requires:  glibc
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24FFTW is a collection of fast C routines for computing the Discrete Fourier Transform in one or more dimensions.  It includes complex, real, and parallel transforms, and can handle arbitrary array sizes efficiently. This RPM package includes both the double- and single-precision FFTW uniprocessor and threads libraries.  (The single-precision files have an "s" prefix.)
25
26%description -l ja
27FFTWは、1次元または多次元の離散的フーリエ変換(DFT)を計算する高速なCルーチンのコレクションです。FFTWは複素数、実数、並列変換ができ、任意のサイズの配列を効果的に扱うことができます。このパッケージには、倍精度と単精度の単一CPUとスレッドに対応したFFTWのライブラリが収められています。(単精度用のファイル名にはsが最初に付けられています。)
28
29%package devel
30Summary:   Headers, libraries, & docs for FFTW fast fourier transform library
31Group:     Development/Libraries
32Prefix:    %{_prefix}
33Requires:  %{name} = %{version}-%{release}
34
35%description devel
36This package contains the additional header files, documentation, and
37libraries you need to develop programs using the FFTW fast fourier
38transform library.
39
40%description devel -l ja
41このパッケージには、高速フーリエ変換のライブラリであるFFTWを使ってプログラムを開発する際に必要となるヘッダーファイルやドキュメント、ライブラリが収められています。
42
43%prep
44rm -rf $RPM_BUILD_ROOT
45
46# We will be compiling two copies of FFTW, one for double precision and
47# one for single precision.  During the build process, these copies
48# will be stored in fftw-%{version}/double and fftw-%{version}/single
49
50# Unpack the tar archive, first (-c) creating a fftw-%{version}
51# directory and then unpacking in there.
52
53%setup -q -c
54# Now, rename the unpacked FFTW directory to "double":
55mv ${RPM_PACKAGE_NAME}-${RPM_PACKAGE_VERSION} double
56
57# Apply patch to enable pentium optimizations
58cd double
59%patch0 -p1
60cd ..
61
62# Last, make a copy of this directory in "single":
63cp -r double single
64
65%build
66
67# Configure and build the double and single precision versions.
68# Notes:
69#  (1) We install into ${RPM_BUILD_ROOT}, which is set either
70#      by the BuildRoot option above or by --buildroot at build-time.
71#      This allows you to build the RPM without blowing away your existing
72#      FFTW installation, and even without being root.
73#  (2) The double-precision version is installed with the normal library
74#      names, while the single-precision version is installed with an "s"
75#      prefix.
76
77cd double
78%ifarch i386
79    %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir} --enable-i386-hacks
80%else
81    %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir}
82%endif
83make
84
85cd ../single
86%ifarch i386
87    %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir} --enable-i386-hacks --enable-float --enable-type-prefix
88%else
89    %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir} --enable-float --enable-type-prefix
90%endif
91make
92
93%install
94cd double
95%makeinstall
96cd ../single
97%makeinstall
98
99# copy doc files where RPM will find them
100# put the HTML stuff in a sperate dir, so it appears nicely in the docdir
101mkdir -p ../html
102cp doc/*html doc/*gif ../html
103# remove HTML files from doc so that they don't appear double
104rm -f doc/*html doc/*gif
105
106# place the doc directory in a "findable" location
107mkdir -p ../doc
108cp -a doc/* ../doc
109
110# the FAQ directory is also "nice" to have
111mkdir -p ../FAQ
112cp -a FAQ/* ../FAQ
113
114# do the same to the other %doc files
115cp AUTHORS ChangeLog NEWS README* TODO ..
116
117## remove unuse files
118rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%post
124/sbin/ldconfig
125
126%postun
127/sbin/ldconfig
128
129%files
130%defattr (-,root,root)
131%doc html FAQ doc/*ps doc/*fig doc/*tex* AUTHORS ChangeLog NEWS README* TODO
132%{_libdir}/lib*fftw*.so.2*
133
134%files devel
135%defattr (-,root,root)
136%{_includedir}/*fftw*.h
137%doc %{_infodir}/*
138%{_libdir}/lib*fftw*.a
139%{_libdir}/lib*fftw*.so
140
141%changelog
142* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.1.5-1vl5
143- applied new versioning policy, spec in utf-8
144- removed *.la
145
146* Wed Dec 19 2007 Shu KONNO <owa@bg.wakwak.com> 2.1.5-0vl2
147- s/gcc-f77/gcc-gfortran/
148- updated library file names in %%files section (for x86_64)
149
150* Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.1.5-0vl1
151- source update.
152
153* Thu Jul 18 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.3-0vl1
154- modified for Vine.
155
156* Mon Feb 25 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 2.1.3-12bw
157- rebuild for RH72.
158
159* Tue Oct 09 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-11bw
160- corrected some wrong descriptions in this spec for RH71
161
162* Tue Oct 09 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-10bw
163- corrected some wrong descriptions in this spec
164
165* Mon Oct 08 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-9bw
166- rebuilt for Vine Linux 2.1.5
167
168* Thu Jun 14 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-8mdk
169- fixed by Mika Korhonen <mikak@ee.oulu.fi> :
170- removed broken ld.so.conf test (/usr/lib is not listed there anyways)
171- made install-info work with RPM macros shipping with newer Mandrakes
172  and actually add an entry to the top dir file
173
174* Tue Jan 09 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-7mdk
175- rebuild
176
177* Tue Aug 31 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-6mdk
178- add installinfo
179
180* Wed Aug 30 2000 Alexander Skwar <ASkwar@DigitalProjects.com> 2.1.3-5mdk
181- Actually used macros
182- Added %doc files
183- Shortened %files section of the SPEC file a lot
184- Provide libfftw as eXtace requires it
185- Obsolote libfftw package
186- Optimized for Pentium builds per README.hacks
187
188* Wed Aug 30 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-4mdk
189- BM
190- macros
191
192* Wed Apr 26 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-3mdk
193- fix group
194- spec helper fixes
195
196* Tue Jan 25 2000 Lenny Cartier <lenny@mandrakesoft.com>
197- updated, installs in /usr instead of /usr/local by Dara Hazeghi
198  <dara@pacbell.net>
199
200* Thu Dec 16 1999 Lenny Cartier <lenny@mandrakesoft.com>
201- new in contribs
202- bz2 archive
203- add defattr
Note: See TracBrowser for help on using the repository browser.