source: projects/specs/trunk/f/fftw/fftw-vl.spec @ 9249

Revision 9249, 7.2 KB checked in by Takemikaduchi, 9 years ago (diff)

python3-{pyatspi,pycairo,pygobject},gedit,accerciser,eog-plugins: rebuild with python3
others: new upstream release

Line 
1%define name fftw
2%define version 2.1.5
3%define release 3%{?_dist_release}
4
5Name: %{name}
6Summary:   C subroutines for computing the Discrete Fourier Transform.
7Version:   %{version}
8Release:   %{release}
9
10Group:     System Environment/Libraries
11License:   GPLv2
12URL:       http://www.fftw.org/
13
14Source:    %{name}-%{version}.tar.gz
15%{?nosrc:NoSource: 0}
16Patch0:    %{name}-%{version}-pentium.patch
17Icon:      fftw-logo-thumb.gif
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: gcc-gfortran
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26FFTW is a collection of fast C routines for computing the Discrete Fourier Transform in one or more dimensions.  It includes complex, real, and parallel transforms, and can handle arbitrary array sizes efficiently. This RPM package includes both the double- and single-precision FFTW uniprocessor and threads libraries.  (The single-precision files have an "s" prefix.)
27
28%description -l ja
29FFTW は1次元または多次元の離散フーリエ変換(DFT)を計算する高速なCルーチンのコレクションです.FFTW は複素数、実数、並列変換ができ、任意のサイズの配列を効果的に扱うことができます.このパッケージには、倍精度と単精度の単一CPUとスレッドに対応した FFTW のライブラリが収められています。(単精度用のファイル名にはfが最後に付けられています。)
30
31%package devel
32Summary:   Headers, libraries, & docs for FFTW fast fourier transform library
33Group:     Development/Libraries
34Requires:  %{name} = %{version}-%{release}
35Requires(post): install-info
36Requires(preun): install-info
37
38%description devel
39This package contains the additional header files, documentation, and
40libraries you need to develop programs using the FFTW fast fourier
41transform library.
42
43%description devel -l ja
44このパッケージには、高速フーリエ変換のライブラリであるFFTWを使ってプログラムを開発する際に必要となるヘッダーファイルやドキュメント、ライブラリが収められています。
45
46%package        static
47Summary:        Static version of the FFTW library
48Group:          Development/Libraries
49Requires:       %{name}-devel = %{version}-%{release}
50
51%description    static
52This package contains the statically linkable version of
53the FFTW fast Fourier transform library.
54
55%prep
56# We will be compiling two copies of FFTW, one for double precision and
57# one for single precision.  During the build process, these copies
58# will be stored in fftw-%{version}/double and fftw-%{version}/single
59
60# Unpack the tar archive, first (-c) creating a fftw-%{version}
61# directory and then unpacking in there.
62
63%setup -q -c
64# Now, rename the unpacked FFTW directory to "double":
65mv ${RPM_PACKAGE_NAME}-${RPM_PACKAGE_VERSION} double
66
67# Apply patch to enable pentium optimizations
68pushd double
69%patch0 -p1
70popd
71
72# Last, make a copy of this directory in "single":
73cp -r double single
74
75%build
76# Configure and build the double and single precision versions.
77# Notes:
78#  (1) We install into ${RPM_BUILD_ROOT}, which is set either
79#      by the BuildRoot option above or by --buildroot at build-time.
80#      This allows you to build the RPM without blowing away your existing
81#      FFTW installation, and even without being root.
82#  (2) The double-precision version is installed with the normal library
83#      names, while the single-precision version is installed with an "s"
84#      prefix.
85
86# Configure uses g77 by default, if present on system
87export F77=gfortran
88
89pushd double
90%ifarch i386
91    %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir} --enable-i386-hacks
92%else
93    %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir}
94%endif
95make %{?_smp_mflags}
96popd
97
98pushd single
99%ifarch i386
100    %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir} --enable-i386-hacks --enable-float --enable-type-prefix
101%else
102    %configure --enable-shared --enable-threads --infodir=$RPM_BUILD_ROOT%{_infodir} --enable-float --enable-type-prefix
103%endif
104make %{?_smp_mflags}
105popd
106
107%install
108rm -rf $RPM_BUILD_ROOT doc
109pushd double
110    %makeinstall
111    cp -a AUTHORS COPYING COPYRIGHT ChangeLog NEWS README* TODO ../
112    cp -a FAQ/fftw-faq.html/ doc/ ../
113popd
114pushd single
115    %makeinstall
116popd
117rm -f doc/Makefile*
118
119## remove unuse files
120rm -f $RPM_BUILD_ROOT%{_infodir}/dir
121rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%post -p /sbin/ldconfig
127
128%postun -p /sbin/ldconfig
129
130%post devel
131/sbin/install-info --section="Math" %{_infodir}/%{name}.info.gz %{_infodir}/dir  2>/dev/null || :
132
133%preun devel
134if [ "$1" = 0 ]; then
135  /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir 2>/dev/null || :
136fi
137
138%files
139%defattr (-,root,root)
140%doc AUTHORS COPYING COPYRIGHT ChangeLog NEWS README* TODO
141%{_libdir}/lib*fftw*.so.2*
142
143%files devel
144%defattr (-,root,root)
145%doc  doc/
146%{_includedir}/*fftw*.h
147%doc %{_infodir}/*
148%{_libdir}/lib*fftw*.so
149
150%files static
151%defattr (-,root,root)
152%{_libdir}/lib*fftw*.a
153
154
155%changelog
156* Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.5-3
157- rebuild with VineSeed environment
158
159* Sun Oct 03 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.5-2
160- rebuilt with new toolchain
161- split static libraries
162
163* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.1.5-1vl5
164- applied new versioning policy, spec in utf-8
165- removed *.la
166
167* Wed Dec 19 2007 Shu KONNO <owa@bg.wakwak.com> 2.1.5-0vl2
168- s/gcc-f77/gcc-gfortran/
169- updated library file names in %%files section (for x86_64)
170
171* Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.1.5-0vl1
172- source update.
173
174* Thu Jul 18 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.3-0vl1
175- modified for Vine.
176
177* Mon Feb 25 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 2.1.3-12bw
178- rebuild for RH72.
179
180* Tue Oct 09 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-11bw
181- corrected some wrong descriptions in this spec for RH71
182
183* Tue Oct 09 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-10bw
184- corrected some wrong descriptions in this spec
185
186* Mon Oct 08 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 2.1.3-9bw
187- rebuilt for Vine Linux 2.1.5
188
189* Thu Jun 14 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-8mdk
190- fixed by Mika Korhonen <mikak@ee.oulu.fi> :
191- removed broken ld.so.conf test (/usr/lib is not listed there anyways)
192- made install-info work with RPM macros shipping with newer Mandrakes
193  and actually add an entry to the top dir file
194
195* Tue Jan 09 2001 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-7mdk
196- rebuild
197
198* Thu Aug 31 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-6mdk
199- add installinfo
200
201* Wed Aug 30 2000 Alexander Skwar <ASkwar@DigitalProjects.com> 2.1.3-5mdk
202- Actually used macros
203- Added %doc files
204- Shortened %files section of the SPEC file a lot
205- Provide libfftw as eXtace requires it
206- Obsolote libfftw package
207- Optimized for Pentium builds per README.hacks
208
209* Wed Aug 30 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-4mdk
210- BM
211- macros
212
213* Wed Apr 26 2000 Lenny Cartier <lenny@mandrakesoft.com> 2.1.3-3mdk
214- fix group
215- spec helper fixes
216
217* Tue Jan 25 2000 Lenny Cartier <lenny@mandrakesoft.com>
218- updated, installs in /usr instead of /usr/local by Dara Hazeghi
219  <dara@pacbell.net>
220
221* Thu Dec 16 1999 Lenny Cartier <lenny@mandrakesoft.com>
222- new in contribs
223- bz2 archive
224- add defattr
Note: See TracBrowser for help on using the repository browser.