source: projects/specs/trunk/f/f-spot/f-spot-vl.spec @ 919

Revision 919, 12.7 KB checked in by daisuke, 14 years ago (diff)

f-spot: add BR: gconf-sharp2

Line 
1Name:           f-spot
2Version:        0.6.1.5
3Release:        1%{?_dist_release}
4Summary:        Photo management application
5Summary(ja):    写真管理アプリケーション
6
7Group:          Applications/Multimedia
8License:        GPLv2+ and LGPLv2+ and CPL and MIT
9URL:            http://f-spot.org/
10Source0:        http://ftp.gnome.org/pub/gnome/sources/f-spot/0.6/f-spot-%{version}.tar.bz2
11# Use system mono-addins
12Patch2:         0001-use-system-Mono.Addins-if-available.patch
13# unmount cameras before importing
14Patch3:         0002-enhance-the-f-spot-import-script.patch
15# Use system gnome-keyring
16Patch4:         0003-use-system-Gnome.Keyring-if-available.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19
20BuildRequires:  mono-devel mono-web mono-data mono-data-sqlite lcms-devel
21BuildRequires:  libexif-devel gphoto2-devel >= 2.1.4
22BuildRequires:  gtk-sharp2 libgnome-devel libgnomeui-devel
23BuildRequires:  gtk2-devel mono-devel libjpeg-devel sqlite3-devel
24BuildRequires:  gnome-sharp2 gnome-desktop-sharp2 gtk-sharp2-gapi
25BuildRequires:  gconf-sharp2
26BuildRequires:  gettext
27BuildRequires:  autoconf, automake, libtool, intltool
28BuildRequires:  perl-XML-Parser
29BuildRequires:  gnome-doc-utils
30BuildRequires:  ndesk-dbus-glib
31BuildRequires:  mono-addins
32BuildRequires:  desktop-file-utils
33BuildRequires:  gnome-keyring-sharp-devel
34Requires:       sqlite3
35Requires:       lcms
36Requires:       dcraw
37Requires:       hicolor-icon-theme
38Requires:       yelp
39Requires(post): desktop-file-utils
40Requires(postun): desktop-file-utils
41
42# no mono available
43ExcludeArch: sparc64
44
45# Some compiler segfault on ia64:
46ExcludeArch: ia64
47
48# No libgphoto etc on s390
49ExcludeArch: s390
50
51%description
52F-Spot is an application designed to provide personal photo management
53to the GNOME desktop. Features include import, export, printing and advanced
54sorting and tagging of digital images.
55
56%package screensaver
57Summary: F-Spot gnome-screensaver plugin
58Summary(ja): F-Spot gnome-screensaver plugin
59Group: Applications/Multimedia
60Requires: %{name} = %{version}-%{release}
61Requires: gnome-screensaver
62Obsoletes: f-spot < 0.6.1.1
63
64%description screensaver
65F-Spot provides a plugin for gnome-screensaver which displays parts of the
66photo collection in a slideshow as a screensaver.
67
68%prep
69%setup -q
70%patch2 -p1 -F 2 -b .link-system-mono-addins
71%patch3 -p1 -b .gvfs-gphoto
72%patch4 -p1 -b .link-system-keyring
73
74%build
75autoreconf -f -i
76export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
77%configure --disable-scrollkeeper
78make %{?_smp_mflags}
79
80
81%install
82rm -rf $RPM_BUILD_ROOT
83export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
84make install DESTDIR=$RPM_BUILD_ROOT
85
86rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
87rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
88rm $RPM_BUILD_ROOT%{_libdir}/pkgconfig/f-spot.pc
89
90# only files marked executable are used to auto-generate the
91# requires/provides of the package
92find $RPM_BUILD_ROOT \( -name '*.exe' -or -name '*.dll' \) \
93     -exec chmod a+x {} \;
94
95for file in $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
96do
97   desktop-file-validate $file
98done
99
100%find_lang %name
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post
106update-desktop-database &> /dev/null ||:
107touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
108
109%postun
110update-desktop-database &> /dev/null ||:
111if [ $1 -eq 0 ] ; then
112    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
113    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
114fi
115
116%posttrans
117gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
118
119%files -f %{name}.lang
120%defattr(-,root,root,-)
121%doc AUTHORS COPYING README NEWS
122%{_datadir}/applications/*.desktop
123%{_datadir}/gnome/help/f-spot/
124%{_datadir}/icons/hicolor/*/*/*.png
125%{_datadir}/f-spot/
126%dir %{_libdir}/f-spot/
127%{_libdir}/f-spot/*.dll
128%{_libdir}/f-spot/*.exe
129%{_libdir}/f-spot/*.addins
130%{_libdir}/f-spot/*.config
131%{_libdir}/f-spot/*.mdb
132%{_libdir}/f-spot/*.so
133%{_libdir}/f-spot/*.so.*
134%exclude %{_libdir}/f-spot/extensions/ScreensaverConfig.dll
135%{_libdir}/f-spot/extensions/
136%{_bindir}/f-spot
137%{_bindir}/f-spot-import
138%{_bindir}/f-spot-sqlite-upgrade
139%{_datadir}/omf/f-spot/
140
141%files screensaver
142%defattr(-,root,root,-)
143%{_libdir}/f-spot/extensions/ScreensaverConfig.dll
144%{_prefix}/libexec/gnome-screensaver/f-spot-screensaver
145%{_datadir}/applications/screensavers/f-spot-screensaver.desktop
146
147%changelog
148* Sun May 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1.5-1
149- initial build for Vine Linux
150
151* Mon Dec 14 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-2
152- Corrected the permission fix for all .exe and .dll files in order
153  to generate the dependencies correctly (BZ 547063)
154
155* Sun Nov 08 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-1
156- Update to 0.6.1.5 (BZ 531955)
157- Build f-spot against system gnome-keyring-sharp library (BZ 442343)
158- Make all .dll and .exe files executable so that they are respected
159  by the find-requires/find-provides scripts
160- Remove upstreamed patch
161
162* Mon Oct 26 2009 Dennis Gilmore <dennis@ausil.us> - 0.6.1.3-2
163- ExcludeArch sparc64
164
165* Sun Oct 04 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.3-1
166- Update to 0.6.1.3 (BZ 526217)
167- Remove two upstreamed patches
168- Use a slightly different fix for the cairo-devel dependency
169  (suggested by upstream)
170
171* Wed Sep 30 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-3
172- Add patch to fix f-spot crash when using "soft focus" and cairo-devel
173  was not installed (BZ 526563)
174- Minor spec file beautification
175
176* Tue Sep 22 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-2
177- Add upstream patches (
178  commit b87604bc9782bf92f053aaf3ceb739a32f44ea13
179  commit 807dab4344ecdadc7e46793369821de8b49692e5 )
180  to fix crash in facebook exporter (BZ 524860)
181
182* Thu Sep 17 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-1
183- Update to 0.6.1.2 (BZ 519290)
184
185* Fri Aug 28 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-2
186- Move the screensaver plugin into a sub-package (BZ 519640)
187- Let f-spot-screensaver obsolete older f-spot version so that it
188  is pulled in during update (fresh installations of f-spot will not
189  pull in gnome-screensaver)
190
191* Wed Aug 26 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-1
192- Update to 0.6.1.1
193- Remove upstreamed patch
194- Updated use-system-Mono.Addins-if-available patch
195- Add a patch to enable parallel build
196
197* Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-3
198- Build arch ppc64.
199
200* Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-2
201- Fix Icon Cache script in %%post section
202
203* Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-1
204- Update to new upstream version 0.6.0.0
205- Cleanup spec file
206
207* Sat Jul 25 2009 Christian Krause <chkr@fedoraproject.org> - 0.5.0.3-9
208- Avoid showing f-spot twice for photo imports
209- Make f-spot-import work with gvfs
210- Minor indentation fix
211
212* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-8
213- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
214
215* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-7
216- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
217
218* Sun Feb  8 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.5.0.3-6
219- Rebuild against new mono stack to fix broken deps
220
221* Thu Dec  4 2008 Matthias Clasen <mclasen@redhat.com> - 0.5.0.3-5
222- Update to 0.5.0.3
223
224* Fri Nov 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-8
225- Better URL
226- Tweak %%description
227
228* Tue Oct 28 2008 Orion Poplawski <orion@cora.nwra.com.com> - 0.4.4-7
229- Run desktop-file-validate against desktop files
230
231* Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-6
232- rebuild against new gnome-sharp
233
234* Thu Oct  2 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-5
235- Use a standard icon name instead of a non-existing one
236
237* Mon Jul 14 2008 Nigel Jones <dev@nigelj.com> - 0.4.4-4
238- Remove Tom's patch in -2, there is a gtk-sharp 2.12.1, just nobody bothered
239  packaging it.
240- Patch Makefile{.in,am} to use DESTDIR for the gio-sharp.dll, this is
241  effectively a backport of r4010 Upstream.
242- Patch libfspot/Makefile{.in,am} to remove -DGTK_DISABLE_DEPRECATED per
243  recommendation of upstream.
244- Re-add patch to use system mono-addins
245- Include GIO stuff for now (until it appears in gtk-sharp)
246
247* Wed Jul  5 2008 Alex Lancaster <alexlan[AT] fedoraproject org> - 0.4.4-3
248- gtkhtml dependency now provided by gnome-desktop-sharp-devel
249  rather than gnome-sharp-devel, so add as BuildRequires
250
251* Wed Jun  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-2
252- Fix it to not look for non-existant glib-sharp-2.12.1
253
254* Wed Jun  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-1
255- update to 0.4.4
256- fix license tag
257
258* Tue May 13 2008 Matthias Clasen <mclasne@redhat.com> - 0.4.3.1-1
259- Update to 0.4.3.1
260
261* Tue Apr 15 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.4.2-5
262- Add patch from Debian to use system mono-addins (from #442343)
263
264* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-4
265- Require dcraw
266
267* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-3
268- Fix the build
269
270* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
271- Autorebuild for GCC 4.3
272
273* Thu Feb 14 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.2-1
274- Update to 0.4.2
275
276* Fri Jan 18 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.1-2
277- Add support for content-types
278
279* Thu Dec  6 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.1-1
280- Update to 0.4.1
281
282* Sat Nov 17 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-4
283- Remove comments from ExclusiveArch line (#388581)
284
285* Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-3
286- Add alpha to ExclusiveArch
287
288* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 0.4.0-2
289- Rebuild for build ID
290
291* Sat Aug  4 2007 Matthis Clasen <mclasen@redhat.com> - 0.4.0-1
292- Update to 0.4.0
293
294* Mon Jul  2 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-3
295- Hack to get screensavers to work again (#221546)
296
297* Fri Apr 13 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-2
298- Now with validated desktop files!
299
300* Wed Mar  7 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-1
301- Update to 0.3.5
302
303* Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
304- Update to 0.3.4
305
306* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.3-1
307- Update to 0.3.3
308
309* Tue Jan 23 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
310- Update to 0.3.2
311
312* Fri Oct 20 2006 Christopher Aillon <caillon@redhat.com> - 0.2.2-1
313- Update to 0.2.2
314
315* Mon Oct 16 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.1-2
316- Fix a directory ownership issue (#211009)
317
318* Wed Sep 13 2006 Christopher Aillon <caillon@redhat.com> - 0.2.1-1
319- Update to 0.2.1
320
321* Tue Sep 12 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2
322- Add libgphoto2_port version to dll config (#205302)
323
324* Mon Sep  4 2006 Christopher Aillon <caillon@redhat.com> - 0.2.0-1
325- Update to 0.2.0
326
327* Fri Aug 18 2006 Alexander Larsson <alexl@redhat.com> - 0.1.11-5
328- Rebuild with new mono and gtk-sharp2
329
330* Thu Jul 27 2006 Matthias Clasen <mclasen@redhat.com> - 0.1.11-4
331- Fix dbus-sharp BR
332
333* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.1.11-3.1
334- rebuild
335
336* Sun Jun 24 2006 Jesse Keating <jkeating@redhat.com> 0.1.11-3
337- Add missing BR gettext
338
339* Wed May 31 2006 Alexander Larsson <alexl@redhat.com> 0.1.11-2
340- Rebuild for gmime update
341
342* Fri Mar 17 2006 Christopher Aillon <caillon@redhat.com> 0.1.11-1
343- Update to 0.1.11
344
345* Fri Feb 24 2006 Christopher Aillon <caillon@redhat.com> 0.1.10-1
346- Update to 0.1.10
347
348* Tue Feb 21 2006 Karsten Hopp <karsten@redhat.de> 0.1.9-2
349- add BuildRequires  libgnome-devel libgnomeui-devel
350  gtk2-devel mono-devel libjpeg-devel sqlite-devel
351
352* Fri Feb 17 2006 Christopher Aillon <caillon@redhat.com> - 0.1.9-1
353- Update to 0.1.9
354
355* Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-3
356- Rebuild
357
358* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.8-2.1
359- rebuilt for new gcc4.1 snapshot and glibc changes
360
361* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-2
362- Add sqlite3.patch to ensure that sqlite3 is used if both
363  sqlite2 and sqlite3 are installed.
364
365* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-1
366- Update to 0.1.8
367- Use sqlite3 instead of sqlite2
368
369* Tue Jan 31 2006 Ray Strode <rstrode@redhat.com> - 0.1.5-3
370- don't blindly run f-spot from current working directory
371  (bug 177407)
372
373* Tue Jan 10 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-2
374- Add lcms depencency
375
376* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-1
377- Update to 0.1.5
378
379* Thu Dec  8 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-3
380- Use sqlite2 to avoid problems with beagle
381
382* Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-2
383- Make exes and dlls executable to pick up dependencies
384- Remove .a and .la files
385
386* Wed Nov 16 2005 Alexander Larsson <alexl@redhat.com> - 0.1.3-1
387- Initial version
388
Note: See TracBrowser for help on using the repository browser.