source: projects/specs/trunk/f/f-spot/f-spot-vl.spec @ 7279

Revision 7279, 14.3 KB checked in by iwaim, 11 years ago (diff)

f-spot 0.8.2-2vl7

Line 
1Name:           f-spot
2Version:        0.8.2
3Release:        2%{?_dist_release}
4Summary:        Photo management application
5Summary(ja):    写真管理アプリケーション
6
7Group:          Applications/Multimedia
8License:        GPLv2+ and LGPLv2+ and CPL and MIT
9URL:            http://f-spot.org/
10Source0:        http://ftp.gnome.org/pub/gnome/sources/f-spot/0.8/f-spot-%{version}.tar.bz2
11Patch1:         f-spot-0.7.1-build-fixes.patch
12# unmount cameras before importing
13Patch3:         0002-enhance-the-f-spot-import-script.patch
14
15# Patch from fedora
16# two upstream patches to fix compile issue with Mono 2.8:
17# http://git.gnome.org/browse/f-spot/commit/?id=9d6e8052b188c2b1cb310ef05842da74a730a39f
18Patch13:         0001-PixbufLoader-from-gtk-sharp-master-does-not-have-a-C.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22BuildRequires:  mono-devel mono-web mono-data mono-data-sqlite lcms-devel
23BuildRequires:  libexif-devel gphoto2-devel >= 2.1.4
24BuildRequires:  gtk-sharp2 libgnome-devel libgnomeui-devel
25BuildRequires:  gtk2-devel mono-devel libjpeg-devel sqlite3-devel
26BuildRequires:  gnome-sharp2 gnome-desktop-sharp2 gtk-sharp2-gapi
27BuildRequires:  gconf-sharp2
28BuildRequires:  gettext
29BuildRequires:  autoconf, automake, libtool, intltool
30BuildRequires:  perl-XML-Parser
31BuildRequires:  gnome-doc-utils
32BuildRequires:  ndesk-dbus-glib
33BuildRequires:  mono-addins-devel >= 0.3
34BuildRequires:  desktop-file-utils
35BuildRequires:  gnome-keyring-sharp-devel
36BuildRequires:  unique-devel
37BuildRequires:  flickrnet-devel
38BuildRequires:  libSM-devel
39Requires:       sqlite3
40Requires:       lcms
41Requires:       dcraw
42Requires:       hicolor-icon-theme
43Requires:       yelp
44Requires(post): desktop-file-utils
45Requires(postun): desktop-file-utils
46
47# no mono available
48ExcludeArch: sparc64
49
50# Some compiler segfault on ia64:
51ExcludeArch: ia64
52
53# No libgphoto etc on s390
54ExcludeArch: s390
55
56Distribution: Vine Linux
57Vendor: Project Vine
58
59%description
60F-Spot is an application designed to provide personal photo management
61to the GNOME desktop. Features include import, export, printing and advanced
62sorting and tagging of digital images.
63
64%package screensaver
65Summary: F-Spot gnome-screensaver plugin
66Summary(ja): F-Spot gnome-screensaver plugin
67Group: Applications/Multimedia
68Requires: %{name} = %{version}-%{release}
69Requires: gnome-screensaver
70Obsoletes: f-spot < 0.6.1.1
71
72%description screensaver
73F-Spot provides a plugin for gnome-screensaver which displays parts of the
74photo collection in a slideshow as a screensaver.
75
76%prep
77%setup -q
78#%patch1 -p1 -b .buildfix
79%patch3 -p1 -b .gvfs-gphoto
80%patch13 -p1 -b mono28-compile-fix
81
82
83%build
84intltoolize --force --copy
85libtoolize --force --copy --automake
86aclocal -I build/m4/f-spot -I build/m4/shamrock -I build/m4/shave
87autoconf
88autoheader
89test -f config.h.in && touch config.h.in
90automake --gnu --add-missing --force --copy -Wno-portability
91
92export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
93%configure --disable-scrollkeeper
94make %{?_smp_mflags}
95
96
97%install
98rm -rf $RPM_BUILD_ROOT
99export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
100make install DESTDIR=$RPM_BUILD_ROOT
101
102rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
103rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
104rm $RPM_BUILD_ROOT%{_libdir}/pkgconfig/f-spot.pc
105
106# only files marked executable are used to auto-generate the
107# requires/provides of the package
108find $RPM_BUILD_ROOT \( -name '*.exe' -or -name '*.dll' \) \
109     -exec chmod a+x {} \;
110
111for file in $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
112do
113   desktop-file-validate $file
114done
115
116%find_lang %name
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%pre
122if [ "$1" -gt 1 ]; then
123  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
124  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
125fi
126
127%post
128update-desktop-database &> /dev/null ||:
129touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
130export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
131gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
132
133%preun
134if [ "$1" -eq 0 ]; then
135  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
136  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
137fi
138
139%postun
140update-desktop-database &> /dev/null ||:
141if [ $1 -eq 0 ] ; then
142    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
143    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
144fi
145
146%posttrans
147gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
148
149%files -f %{name}.lang
150%defattr(-,root,root,-)
151%doc AUTHORS COPYING README NEWS
152%{_sysconfdir}/gconf/schemas/*
153%{_datadir}/applications/*.desktop
154%{_datadir}/gnome/help/f-spot/
155%{_datadir}/icons/hicolor/*/*/*.png
156%{_datadir}/f-spot/
157%dir %{_libdir}/f-spot/
158%{_libdir}/f-spot/*.dll
159%{_libdir}/f-spot/*.exe
160%{_libdir}/f-spot/*.addins
161%{_libdir}/f-spot/*.config
162%{_libdir}/f-spot/*.mdb
163%{_libdir}/f-spot/*.so
164%{_libdir}/f-spot/*.so.*
165%exclude %{_libdir}/f-spot/Extensions/FSpot.Tools.ScreensaverConfig.dll*
166%{_libdir}/f-spot/Extensions/
167%{_bindir}/f-spot
168%{_bindir}/f-spot-import
169%{_bindir}/f-spot-sqlite-upgrade
170
171%files screensaver
172%defattr(-,root,root,-)
173%{_libdir}/f-spot/Extensions/FSpot.Tools.ScreensaverConfig.dll
174%{_prefix}/libexec/gnome-screensaver/f-spot-screensaver
175%{_datadir}/applications/screensavers/f-spot-screensaver.desktop
176
177%changelog
178* Sun Dec 30 2012 IWAI, Masaharu <iwai@alib.jp> 0.8.2-2vl7
179- build with mono-addins 0.6.2-2
180- add BuildRequires: mono-addins-devel >= 0.3
181- add Vendor and Distribution tags
182
183* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-1
184- new upstream release
185- delete Patch11,12
186
187* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
188- new upstream release
189- drop Patch1
190- add Patch11,12,13 from fedora
191- add BuildRequires: libSM-devel
192
193* Thu Aug 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.1-1
194- new upstream release
195- add patch1 to support parallel builds
196- add BR: unique-devel, flickrnet-devel
197
198* Sun May 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1.5-1
199- initial build for Vine Linux
200
201* Mon Dec 14 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-2
202- Corrected the permission fix for all .exe and .dll files in order
203  to generate the dependencies correctly (BZ 547063)
204
205* Sun Nov 08 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-1
206- Update to 0.6.1.5 (BZ 531955)
207- Build f-spot against system gnome-keyring-sharp library (BZ 442343)
208- Make all .dll and .exe files executable so that they are respected
209  by the find-requires/find-provides scripts
210- Remove upstreamed patch
211
212* Mon Oct 26 2009 Dennis Gilmore <dennis@ausil.us> - 0.6.1.3-2
213- ExcludeArch sparc64
214
215* Sun Oct 04 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.3-1
216- Update to 0.6.1.3 (BZ 526217)
217- Remove two upstreamed patches
218- Use a slightly different fix for the cairo-devel dependency
219  (suggested by upstream)
220
221* Wed Sep 30 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-3
222- Add patch to fix f-spot crash when using "soft focus" and cairo-devel
223  was not installed (BZ 526563)
224- Minor spec file beautification
225
226* Tue Sep 22 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-2
227- Add upstream patches (
228  commit b87604bc9782bf92f053aaf3ceb739a32f44ea13
229  commit 807dab4344ecdadc7e46793369821de8b49692e5 )
230  to fix crash in facebook exporter (BZ 524860)
231
232* Thu Sep 17 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-1
233- Update to 0.6.1.2 (BZ 519290)
234
235* Fri Aug 28 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-2
236- Move the screensaver plugin into a sub-package (BZ 519640)
237- Let f-spot-screensaver obsolete older f-spot version so that it
238  is pulled in during update (fresh installations of f-spot will not
239  pull in gnome-screensaver)
240
241* Wed Aug 26 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-1
242- Update to 0.6.1.1
243- Remove upstreamed patch
244- Updated use-system-Mono.Addins-if-available patch
245- Add a patch to enable parallel build
246
247* Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-3
248- Build arch ppc64.
249
250* Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-2
251- Fix Icon Cache script in %%post section
252
253* Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-1
254- Update to new upstream version 0.6.0.0
255- Cleanup spec file
256
257* Sat Jul 25 2009 Christian Krause <chkr@fedoraproject.org> - 0.5.0.3-9
258- Avoid showing f-spot twice for photo imports
259- Make f-spot-import work with gvfs
260- Minor indentation fix
261
262* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-8
263- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
264
265* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-7
266- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
267
268* Sun Feb  8 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.5.0.3-6
269- Rebuild against new mono stack to fix broken deps
270
271* Thu Dec  4 2008 Matthias Clasen <mclasen@redhat.com> - 0.5.0.3-5
272- Update to 0.5.0.3
273
274* Fri Nov 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-8
275- Better URL
276- Tweak %%description
277
278* Tue Oct 28 2008 Orion Poplawski <orion@cora.nwra.com.com> - 0.4.4-7
279- Run desktop-file-validate against desktop files
280
281* Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-6
282- rebuild against new gnome-sharp
283
284* Thu Oct  2 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-5
285- Use a standard icon name instead of a non-existing one
286
287* Mon Jul 14 2008 Nigel Jones <dev@nigelj.com> - 0.4.4-4
288- Remove Tom's patch in -2, there is a gtk-sharp 2.12.1, just nobody bothered
289  packaging it.
290- Patch Makefile{.in,am} to use DESTDIR for the gio-sharp.dll, this is
291  effectively a backport of r4010 Upstream.
292- Patch libfspot/Makefile{.in,am} to remove -DGTK_DISABLE_DEPRECATED per
293  recommendation of upstream.
294- Re-add patch to use system mono-addins
295- Include GIO stuff for now (until it appears in gtk-sharp)
296
297* Wed Jul  5 2008 Alex Lancaster <alexlan[AT] fedoraproject org> - 0.4.4-3
298- gtkhtml dependency now provided by gnome-desktop-sharp-devel
299  rather than gnome-sharp-devel, so add as BuildRequires
300
301* Wed Jun  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-2
302- Fix it to not look for non-existant glib-sharp-2.12.1
303
304* Wed Jun  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-1
305- update to 0.4.4
306- fix license tag
307
308* Tue May 13 2008 Matthias Clasen <mclasne@redhat.com> - 0.4.3.1-1
309- Update to 0.4.3.1
310
311* Tue Apr 15 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.4.2-5
312- Add patch from Debian to use system mono-addins (from #442343)
313
314* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-4
315- Require dcraw
316
317* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-3
318- Fix the build
319
320* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
321- Autorebuild for GCC 4.3
322
323* Thu Feb 14 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.2-1
324- Update to 0.4.2
325
326* Fri Jan 18 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.1-2
327- Add support for content-types
328
329* Thu Dec  6 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.1-1
330- Update to 0.4.1
331
332* Sat Nov 17 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-4
333- Remove comments from ExclusiveArch line (#388581)
334
335* Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-3
336- Add alpha to ExclusiveArch
337
338* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 0.4.0-2
339- Rebuild for build ID
340
341* Sat Aug  4 2007 Matthis Clasen <mclasen@redhat.com> - 0.4.0-1
342- Update to 0.4.0
343
344* Mon Jul  2 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-3
345- Hack to get screensavers to work again (#221546)
346
347* Fri Apr 13 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-2
348- Now with validated desktop files!
349
350* Wed Mar  7 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-1
351- Update to 0.3.5
352
353* Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
354- Update to 0.3.4
355
356* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.3-1
357- Update to 0.3.3
358
359* Tue Jan 23 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
360- Update to 0.3.2
361
362* Fri Oct 20 2006 Christopher Aillon <caillon@redhat.com> - 0.2.2-1
363- Update to 0.2.2
364
365* Mon Oct 16 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.1-2
366- Fix a directory ownership issue (#211009)
367
368* Wed Sep 13 2006 Christopher Aillon <caillon@redhat.com> - 0.2.1-1
369- Update to 0.2.1
370
371* Tue Sep 12 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2
372- Add libgphoto2_port version to dll config (#205302)
373
374* Mon Sep  4 2006 Christopher Aillon <caillon@redhat.com> - 0.2.0-1
375- Update to 0.2.0
376
377* Fri Aug 18 2006 Alexander Larsson <alexl@redhat.com> - 0.1.11-5
378- Rebuild with new mono and gtk-sharp2
379
380* Thu Jul 27 2006 Matthias Clasen <mclasen@redhat.com> - 0.1.11-4
381- Fix dbus-sharp BR
382
383* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.1.11-3.1
384- rebuild
385
386* Sun Jun 24 2006 Jesse Keating <jkeating@redhat.com> 0.1.11-3
387- Add missing BR gettext
388
389* Wed May 31 2006 Alexander Larsson <alexl@redhat.com> 0.1.11-2
390- Rebuild for gmime update
391
392* Fri Mar 17 2006 Christopher Aillon <caillon@redhat.com> 0.1.11-1
393- Update to 0.1.11
394
395* Fri Feb 24 2006 Christopher Aillon <caillon@redhat.com> 0.1.10-1
396- Update to 0.1.10
397
398* Tue Feb 21 2006 Karsten Hopp <karsten@redhat.de> 0.1.9-2
399- add BuildRequires  libgnome-devel libgnomeui-devel
400  gtk2-devel mono-devel libjpeg-devel sqlite-devel
401
402* Fri Feb 17 2006 Christopher Aillon <caillon@redhat.com> - 0.1.9-1
403- Update to 0.1.9
404
405* Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-3
406- Rebuild
407
408* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.8-2.1
409- rebuilt for new gcc4.1 snapshot and glibc changes
410
411* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-2
412- Add sqlite3.patch to ensure that sqlite3 is used if both
413  sqlite2 and sqlite3 are installed.
414
415* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-1
416- Update to 0.1.8
417- Use sqlite3 instead of sqlite2
418
419* Tue Jan 31 2006 Ray Strode <rstrode@redhat.com> - 0.1.5-3
420- don't blindly run f-spot from current working directory
421  (bug 177407)
422
423* Tue Jan 10 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-2
424- Add lcms depencency
425
426* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-1
427- Update to 0.1.5
428
429* Thu Dec  8 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-3
430- Use sqlite2 to avoid problems with beagle
431
432* Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-2
433- Make exes and dlls executable to pick up dependencies
434- Remove .a and .la files
435
436* Wed Nov 16 2005 Alexander Larsson <alexl@redhat.com> - 0.1.3-1
437- Initial version
438
Note: See TracBrowser for help on using the repository browser.