source: projects/specs/trunk/f/f-spot/f-spot-vl.spec @ 1547

Revision 1547, 13.5 KB checked in by daisuke, 14 years ago (diff)

f-spot: update to 0.7.1

Line 
1Name:           f-spot
2Version:        0.7.1
3Release:        1%{?_dist_release}
4Summary:        Photo management application
5Summary(ja):    写真管理アプリケーション
6
7Group:          Applications/Multimedia
8License:        GPLv2+ and LGPLv2+ and CPL and MIT
9URL:            http://f-spot.org/
10Source0:        http://ftp.gnome.org/pub/gnome/sources/f-spot/0.7/f-spot-%{version}.tar.bz2
11Patch1:         f-spot-0.7.1-build-fixes.patch
12# unmount cameras before importing
13Patch3:         0002-enhance-the-f-spot-import-script.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  mono-devel mono-web mono-data mono-data-sqlite lcms-devel
18BuildRequires:  libexif-devel gphoto2-devel >= 2.1.4
19BuildRequires:  gtk-sharp2 libgnome-devel libgnomeui-devel
20BuildRequires:  gtk2-devel mono-devel libjpeg-devel sqlite3-devel
21BuildRequires:  gnome-sharp2 gnome-desktop-sharp2 gtk-sharp2-gapi
22BuildRequires:  gconf-sharp2
23BuildRequires:  gettext
24BuildRequires:  autoconf, automake, libtool, intltool
25BuildRequires:  perl-XML-Parser
26BuildRequires:  gnome-doc-utils
27BuildRequires:  ndesk-dbus-glib
28BuildRequires:  mono-addins
29BuildRequires:  desktop-file-utils
30BuildRequires:  gnome-keyring-sharp-devel
31BuildRequires:  unique-devel
32BuildRequires:  flickrnet-devel
33Requires:       sqlite3
34Requires:       lcms
35Requires:       dcraw
36Requires:       hicolor-icon-theme
37Requires:       yelp
38Requires(post): desktop-file-utils
39Requires(postun): desktop-file-utils
40
41# no mono available
42ExcludeArch: sparc64
43
44# Some compiler segfault on ia64:
45ExcludeArch: ia64
46
47# No libgphoto etc on s390
48ExcludeArch: s390
49
50%description
51F-Spot is an application designed to provide personal photo management
52to the GNOME desktop. Features include import, export, printing and advanced
53sorting and tagging of digital images.
54
55%package screensaver
56Summary: F-Spot gnome-screensaver plugin
57Summary(ja): F-Spot gnome-screensaver plugin
58Group: Applications/Multimedia
59Requires: %{name} = %{version}-%{release}
60Requires: gnome-screensaver
61Obsoletes: f-spot < 0.6.1.1
62
63%description screensaver
64F-Spot provides a plugin for gnome-screensaver which displays parts of the
65photo collection in a slideshow as a screensaver.
66
67%prep
68%setup -q
69%patch1 -p1 -b .buildfix
70%patch3 -p1 -b .gvfs-gphoto
71
72%build
73intltoolize --force --copy
74libtoolize --force --copy --automake
75aclocal -I build/m4/f-spot -I build/m4/shamrock -I build/m4/shave
76autoconf
77autoheader
78test -f config.h.in && touch config.h.in
79automake --gnu --add-missing --force --copy -Wno-portability
80
81export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
82%configure --disable-scrollkeeper
83make %{?_smp_mflags}
84
85
86%install
87rm -rf $RPM_BUILD_ROOT
88export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
89make install DESTDIR=$RPM_BUILD_ROOT
90
91rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
92rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
93rm $RPM_BUILD_ROOT%{_libdir}/pkgconfig/f-spot.pc
94
95# only files marked executable are used to auto-generate the
96# requires/provides of the package
97find $RPM_BUILD_ROOT \( -name '*.exe' -or -name '*.dll' \) \
98     -exec chmod a+x {} \;
99
100for file in $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
101do
102   desktop-file-validate $file
103done
104
105%find_lang %name
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%pre
111if [ "$1" -gt 1 ]; then
112  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
113  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
114fi
115
116%post
117update-desktop-database &> /dev/null ||:
118touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
119export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
120gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
121
122%preun
123if [ "$1" -eq 0 ]; then
124  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
125  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
126fi
127
128%postun
129update-desktop-database &> /dev/null ||:
130if [ $1 -eq 0 ] ; then
131    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
132    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
133fi
134
135%posttrans
136gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
137
138%files -f %{name}.lang
139%defattr(-,root,root,-)
140%doc AUTHORS COPYING README NEWS
141%{_sysconfdir}/gconf/schemas/*
142%{_datadir}/applications/*.desktop
143%{_datadir}/gnome/help/f-spot/
144%{_datadir}/icons/hicolor/*/*/*.png
145%{_datadir}/f-spot/
146%dir %{_libdir}/f-spot/
147%{_libdir}/f-spot/*.dll
148%{_libdir}/f-spot/*.exe
149%{_libdir}/f-spot/*.addins
150%{_libdir}/f-spot/*.config
151%{_libdir}/f-spot/*.mdb
152%{_libdir}/f-spot/*.so
153%{_libdir}/f-spot/*.so.*
154%exclude %{_libdir}/f-spot/Extensions/FSpot.Exporters.ScreensaverConfig.dll*
155%{_libdir}/f-spot/Extensions/
156%{_bindir}/f-spot
157%{_bindir}/f-spot-import
158%{_bindir}/f-spot-sqlite-upgrade
159
160%files screensaver
161%defattr(-,root,root,-)
162%{_libdir}/f-spot/Extensions/FSpot.Exporters.ScreensaverConfig.dll
163%{_prefix}/libexec/gnome-screensaver/f-spot-screensaver
164%{_datadir}/applications/screensavers/f-spot-screensaver.desktop
165
166%changelog
167* Thu Aug 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.1-1
168- new upstream release
169- add patch1 to support parallel builds
170- add BR: unique-devel, flickrnet-devel
171
172* Sun May 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1.5-1
173- initial build for Vine Linux
174
175* Mon Dec 14 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-2
176- Corrected the permission fix for all .exe and .dll files in order
177  to generate the dependencies correctly (BZ 547063)
178
179* Sun Nov 08 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-1
180- Update to 0.6.1.5 (BZ 531955)
181- Build f-spot against system gnome-keyring-sharp library (BZ 442343)
182- Make all .dll and .exe files executable so that they are respected
183  by the find-requires/find-provides scripts
184- Remove upstreamed patch
185
186* Mon Oct 26 2009 Dennis Gilmore <dennis@ausil.us> - 0.6.1.3-2
187- ExcludeArch sparc64
188
189* Sun Oct 04 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.3-1
190- Update to 0.6.1.3 (BZ 526217)
191- Remove two upstreamed patches
192- Use a slightly different fix for the cairo-devel dependency
193  (suggested by upstream)
194
195* Wed Sep 30 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-3
196- Add patch to fix f-spot crash when using "soft focus" and cairo-devel
197  was not installed (BZ 526563)
198- Minor spec file beautification
199
200* Tue Sep 22 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-2
201- Add upstream patches (
202  commit b87604bc9782bf92f053aaf3ceb739a32f44ea13
203  commit 807dab4344ecdadc7e46793369821de8b49692e5 )
204  to fix crash in facebook exporter (BZ 524860)
205
206* Thu Sep 17 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-1
207- Update to 0.6.1.2 (BZ 519290)
208
209* Fri Aug 28 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-2
210- Move the screensaver plugin into a sub-package (BZ 519640)
211- Let f-spot-screensaver obsolete older f-spot version so that it
212  is pulled in during update (fresh installations of f-spot will not
213  pull in gnome-screensaver)
214
215* Wed Aug 26 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-1
216- Update to 0.6.1.1
217- Remove upstreamed patch
218- Updated use-system-Mono.Addins-if-available patch
219- Add a patch to enable parallel build
220
221* Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-3
222- Build arch ppc64.
223
224* Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-2
225- Fix Icon Cache script in %%post section
226
227* Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-1
228- Update to new upstream version 0.6.0.0
229- Cleanup spec file
230
231* Sat Jul 25 2009 Christian Krause <chkr@fedoraproject.org> - 0.5.0.3-9
232- Avoid showing f-spot twice for photo imports
233- Make f-spot-import work with gvfs
234- Minor indentation fix
235
236* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-8
237- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
238
239* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-7
240- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
241
242* Sun Feb  8 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.5.0.3-6
243- Rebuild against new mono stack to fix broken deps
244
245* Thu Dec  4 2008 Matthias Clasen <mclasen@redhat.com> - 0.5.0.3-5
246- Update to 0.5.0.3
247
248* Fri Nov 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-8
249- Better URL
250- Tweak %%description
251
252* Tue Oct 28 2008 Orion Poplawski <orion@cora.nwra.com.com> - 0.4.4-7
253- Run desktop-file-validate against desktop files
254
255* Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-6
256- rebuild against new gnome-sharp
257
258* Thu Oct  2 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-5
259- Use a standard icon name instead of a non-existing one
260
261* Mon Jul 14 2008 Nigel Jones <dev@nigelj.com> - 0.4.4-4
262- Remove Tom's patch in -2, there is a gtk-sharp 2.12.1, just nobody bothered
263  packaging it.
264- Patch Makefile{.in,am} to use DESTDIR for the gio-sharp.dll, this is
265  effectively a backport of r4010 Upstream.
266- Patch libfspot/Makefile{.in,am} to remove -DGTK_DISABLE_DEPRECATED per
267  recommendation of upstream.
268- Re-add patch to use system mono-addins
269- Include GIO stuff for now (until it appears in gtk-sharp)
270
271* Wed Jul  5 2008 Alex Lancaster <alexlan[AT] fedoraproject org> - 0.4.4-3
272- gtkhtml dependency now provided by gnome-desktop-sharp-devel
273  rather than gnome-sharp-devel, so add as BuildRequires
274
275* Wed Jun  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-2
276- Fix it to not look for non-existant glib-sharp-2.12.1
277
278* Wed Jun  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-1
279- update to 0.4.4
280- fix license tag
281
282* Tue May 13 2008 Matthias Clasen <mclasne@redhat.com> - 0.4.3.1-1
283- Update to 0.4.3.1
284
285* Tue Apr 15 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.4.2-5
286- Add patch from Debian to use system mono-addins (from #442343)
287
288* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-4
289- Require dcraw
290
291* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-3
292- Fix the build
293
294* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
295- Autorebuild for GCC 4.3
296
297* Thu Feb 14 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.2-1
298- Update to 0.4.2
299
300* Fri Jan 18 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.1-2
301- Add support for content-types
302
303* Thu Dec  6 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.1-1
304- Update to 0.4.1
305
306* Sat Nov 17 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-4
307- Remove comments from ExclusiveArch line (#388581)
308
309* Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-3
310- Add alpha to ExclusiveArch
311
312* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 0.4.0-2
313- Rebuild for build ID
314
315* Sat Aug  4 2007 Matthis Clasen <mclasen@redhat.com> - 0.4.0-1
316- Update to 0.4.0
317
318* Mon Jul  2 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-3
319- Hack to get screensavers to work again (#221546)
320
321* Fri Apr 13 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-2
322- Now with validated desktop files!
323
324* Wed Mar  7 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-1
325- Update to 0.3.5
326
327* Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
328- Update to 0.3.4
329
330* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.3-1
331- Update to 0.3.3
332
333* Tue Jan 23 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
334- Update to 0.3.2
335
336* Fri Oct 20 2006 Christopher Aillon <caillon@redhat.com> - 0.2.2-1
337- Update to 0.2.2
338
339* Mon Oct 16 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.1-2
340- Fix a directory ownership issue (#211009)
341
342* Wed Sep 13 2006 Christopher Aillon <caillon@redhat.com> - 0.2.1-1
343- Update to 0.2.1
344
345* Tue Sep 12 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2
346- Add libgphoto2_port version to dll config (#205302)
347
348* Mon Sep  4 2006 Christopher Aillon <caillon@redhat.com> - 0.2.0-1
349- Update to 0.2.0
350
351* Fri Aug 18 2006 Alexander Larsson <alexl@redhat.com> - 0.1.11-5
352- Rebuild with new mono and gtk-sharp2
353
354* Thu Jul 27 2006 Matthias Clasen <mclasen@redhat.com> - 0.1.11-4
355- Fix dbus-sharp BR
356
357* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.1.11-3.1
358- rebuild
359
360* Sun Jun 24 2006 Jesse Keating <jkeating@redhat.com> 0.1.11-3
361- Add missing BR gettext
362
363* Wed May 31 2006 Alexander Larsson <alexl@redhat.com> 0.1.11-2
364- Rebuild for gmime update
365
366* Fri Mar 17 2006 Christopher Aillon <caillon@redhat.com> 0.1.11-1
367- Update to 0.1.11
368
369* Fri Feb 24 2006 Christopher Aillon <caillon@redhat.com> 0.1.10-1
370- Update to 0.1.10
371
372* Tue Feb 21 2006 Karsten Hopp <karsten@redhat.de> 0.1.9-2
373- add BuildRequires  libgnome-devel libgnomeui-devel
374  gtk2-devel mono-devel libjpeg-devel sqlite-devel
375
376* Fri Feb 17 2006 Christopher Aillon <caillon@redhat.com> - 0.1.9-1
377- Update to 0.1.9
378
379* Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-3
380- Rebuild
381
382* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.8-2.1
383- rebuilt for new gcc4.1 snapshot and glibc changes
384
385* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-2
386- Add sqlite3.patch to ensure that sqlite3 is used if both
387  sqlite2 and sqlite3 are installed.
388
389* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-1
390- Update to 0.1.8
391- Use sqlite3 instead of sqlite2
392
393* Tue Jan 31 2006 Ray Strode <rstrode@redhat.com> - 0.1.5-3
394- don't blindly run f-spot from current working directory
395  (bug 177407)
396
397* Tue Jan 10 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-2
398- Add lcms depencency
399
400* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-1
401- Update to 0.1.5
402
403* Thu Dec  8 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-3
404- Use sqlite2 to avoid problems with beagle
405
406* Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-2
407- Make exes and dlls executable to pick up dependencies
408- Remove .a and .la files
409
410* Wed Nov 16 2005 Alexander Larsson <alexl@redhat.com> - 0.1.3-1
411- Initial version
412
Note: See TracBrowser for help on using the repository browser.