source: projects/specs/trunk/f/f-spot/f-spot-vl.spec @ 2362

Revision 2362, 14.4 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release

Line 
1Name:           f-spot
2Version:        0.8.0
3Release:        1%{?_dist_release}
4Summary:        Photo management application
5Summary(ja):    写真管理アプリケーション
6
7Group:          Applications/Multimedia
8License:        GPLv2+ and LGPLv2+ and CPL and MIT
9URL:            http://f-spot.org/
10Source0:        http://ftp.gnome.org/pub/gnome/sources/f-spot/0.8/f-spot-%{version}.tar.bz2
11Patch1:         f-spot-0.7.1-build-fixes.patch
12# unmount cameras before importing
13Patch3:         0002-enhance-the-f-spot-import-script.patch
14
15# Patch from fedora
16# upstream patch to prevent crash with empty databases
17# http://git.gnome.org/browse/f-spot/patch/?id=9054153b3b40f76f7e094ca8db98de0eaca62808
18Patch11:         0001-Don-t-crash-with-empty-databases.patch
19# two upstream patches to fix compile issue with Mono 2.8:
20# http://gitorious.org/taglib-sharp/mainline/commit/5b8a05f130d7e2bf6e284ae0486c9193112806fa
21Patch12:         0001-All-fields-of-a-struct-must-be-initialized-before-th.patch
22# http://git.gnome.org/browse/f-spot/commit/?id=9d6e8052b188c2b1cb310ef05842da74a730a39f
23Patch13:         0001-PixbufLoader-from-gtk-sharp-master-does-not-have-a-C.patch
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26
27BuildRequires:  mono-devel mono-web mono-data mono-data-sqlite lcms-devel
28BuildRequires:  libexif-devel gphoto2-devel >= 2.1.4
29BuildRequires:  gtk-sharp2 libgnome-devel libgnomeui-devel
30BuildRequires:  gtk2-devel mono-devel libjpeg-devel sqlite3-devel
31BuildRequires:  gnome-sharp2 gnome-desktop-sharp2 gtk-sharp2-gapi
32BuildRequires:  gconf-sharp2
33BuildRequires:  gettext
34BuildRequires:  autoconf, automake, libtool, intltool
35BuildRequires:  perl-XML-Parser
36BuildRequires:  gnome-doc-utils
37BuildRequires:  ndesk-dbus-glib
38BuildRequires:  mono-addins
39BuildRequires:  desktop-file-utils
40BuildRequires:  gnome-keyring-sharp-devel
41BuildRequires:  unique-devel
42BuildRequires:  flickrnet-devel
43BuildRequires:  libSM-devel
44Requires:       sqlite3
45Requires:       lcms
46Requires:       dcraw
47Requires:       hicolor-icon-theme
48Requires:       yelp
49Requires(post): desktop-file-utils
50Requires(postun): desktop-file-utils
51
52# no mono available
53ExcludeArch: sparc64
54
55# Some compiler segfault on ia64:
56ExcludeArch: ia64
57
58# No libgphoto etc on s390
59ExcludeArch: s390
60
61%description
62F-Spot is an application designed to provide personal photo management
63to the GNOME desktop. Features include import, export, printing and advanced
64sorting and tagging of digital images.
65
66%package screensaver
67Summary: F-Spot gnome-screensaver plugin
68Summary(ja): F-Spot gnome-screensaver plugin
69Group: Applications/Multimedia
70Requires: %{name} = %{version}-%{release}
71Requires: gnome-screensaver
72Obsoletes: f-spot < 0.6.1.1
73
74%description screensaver
75F-Spot provides a plugin for gnome-screensaver which displays parts of the
76photo collection in a slideshow as a screensaver.
77
78%prep
79%setup -q
80#%patch1 -p1 -b .buildfix
81%patch3 -p1 -b .gvfs-gphoto
82%patch11 -p1 -b db-fix
83pushd lib/TagLib/TagLib
84%patch12 -p1 -b mono28-compile-fix
85popd
86%patch13 -p1 -b mono28-compile-fix
87
88
89%build
90intltoolize --force --copy
91libtoolize --force --copy --automake
92aclocal -I build/m4/f-spot -I build/m4/shamrock -I build/m4/shave
93autoconf
94autoheader
95test -f config.h.in && touch config.h.in
96automake --gnu --add-missing --force --copy -Wno-portability
97
98export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
99%configure --disable-scrollkeeper
100make %{?_smp_mflags}
101
102
103%install
104rm -rf $RPM_BUILD_ROOT
105export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
106make install DESTDIR=$RPM_BUILD_ROOT
107
108rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
109rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
110rm $RPM_BUILD_ROOT%{_libdir}/pkgconfig/f-spot.pc
111
112# only files marked executable are used to auto-generate the
113# requires/provides of the package
114find $RPM_BUILD_ROOT \( -name '*.exe' -or -name '*.dll' \) \
115     -exec chmod a+x {} \;
116
117for file in $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
118do
119   desktop-file-validate $file
120done
121
122%find_lang %name
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%pre
128if [ "$1" -gt 1 ]; then
129  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
130  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
131fi
132
133%post
134update-desktop-database &> /dev/null ||:
135touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
136export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
137gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
138
139%preun
140if [ "$1" -eq 0 ]; then
141  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
142  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
143fi
144
145%postun
146update-desktop-database &> /dev/null ||:
147if [ $1 -eq 0 ] ; then
148    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
149    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
150fi
151
152%posttrans
153gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
154
155%files -f %{name}.lang
156%defattr(-,root,root,-)
157%doc AUTHORS COPYING README NEWS
158%{_sysconfdir}/gconf/schemas/*
159%{_datadir}/applications/*.desktop
160%{_datadir}/gnome/help/f-spot/
161%{_datadir}/icons/hicolor/*/*/*.png
162%{_datadir}/f-spot/
163%dir %{_libdir}/f-spot/
164%{_libdir}/f-spot/*.dll
165%{_libdir}/f-spot/*.exe
166%{_libdir}/f-spot/*.addins
167%{_libdir}/f-spot/*.config
168%{_libdir}/f-spot/*.mdb
169%{_libdir}/f-spot/*.so
170%{_libdir}/f-spot/*.so.*
171%exclude %{_libdir}/f-spot/Extensions/FSpot.Tools.ScreensaverConfig.dll*
172%{_libdir}/f-spot/Extensions/
173%{_bindir}/f-spot
174%{_bindir}/f-spot-import
175%{_bindir}/f-spot-sqlite-upgrade
176
177%files screensaver
178%defattr(-,root,root,-)
179%{_libdir}/f-spot/Extensions/FSpot.Tools.ScreensaverConfig.dll
180%{_prefix}/libexec/gnome-screensaver/f-spot-screensaver
181%{_datadir}/applications/screensavers/f-spot-screensaver.desktop
182
183%changelog
184* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
185- new upstream release
186- drop Patch1
187- add Patch11,12,13 from fedora
188- add BuildRequires: libSM-devel
189
190* Thu Aug 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.1-1
191- new upstream release
192- add patch1 to support parallel builds
193- add BR: unique-devel, flickrnet-devel
194
195* Sun May 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1.5-1
196- initial build for Vine Linux
197
198* Mon Dec 14 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-2
199- Corrected the permission fix for all .exe and .dll files in order
200  to generate the dependencies correctly (BZ 547063)
201
202* Sun Nov 08 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-1
203- Update to 0.6.1.5 (BZ 531955)
204- Build f-spot against system gnome-keyring-sharp library (BZ 442343)
205- Make all .dll and .exe files executable so that they are respected
206  by the find-requires/find-provides scripts
207- Remove upstreamed patch
208
209* Mon Oct 26 2009 Dennis Gilmore <dennis@ausil.us> - 0.6.1.3-2
210- ExcludeArch sparc64
211
212* Sun Oct 04 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.3-1
213- Update to 0.6.1.3 (BZ 526217)
214- Remove two upstreamed patches
215- Use a slightly different fix for the cairo-devel dependency
216  (suggested by upstream)
217
218* Wed Sep 30 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-3
219- Add patch to fix f-spot crash when using "soft focus" and cairo-devel
220  was not installed (BZ 526563)
221- Minor spec file beautification
222
223* Tue Sep 22 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-2
224- Add upstream patches (
225  commit b87604bc9782bf92f053aaf3ceb739a32f44ea13
226  commit 807dab4344ecdadc7e46793369821de8b49692e5 )
227  to fix crash in facebook exporter (BZ 524860)
228
229* Thu Sep 17 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-1
230- Update to 0.6.1.2 (BZ 519290)
231
232* Fri Aug 28 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-2
233- Move the screensaver plugin into a sub-package (BZ 519640)
234- Let f-spot-screensaver obsolete older f-spot version so that it
235  is pulled in during update (fresh installations of f-spot will not
236  pull in gnome-screensaver)
237
238* Wed Aug 26 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-1
239- Update to 0.6.1.1
240- Remove upstreamed patch
241- Updated use-system-Mono.Addins-if-available patch
242- Add a patch to enable parallel build
243
244* Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-3
245- Build arch ppc64.
246
247* Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-2
248- Fix Icon Cache script in %%post section
249
250* Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-1
251- Update to new upstream version 0.6.0.0
252- Cleanup spec file
253
254* Sat Jul 25 2009 Christian Krause <chkr@fedoraproject.org> - 0.5.0.3-9
255- Avoid showing f-spot twice for photo imports
256- Make f-spot-import work with gvfs
257- Minor indentation fix
258
259* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-8
260- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
261
262* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-7
263- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
264
265* Sun Feb  8 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.5.0.3-6
266- Rebuild against new mono stack to fix broken deps
267
268* Thu Dec  4 2008 Matthias Clasen <mclasen@redhat.com> - 0.5.0.3-5
269- Update to 0.5.0.3
270
271* Fri Nov 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-8
272- Better URL
273- Tweak %%description
274
275* Tue Oct 28 2008 Orion Poplawski <orion@cora.nwra.com.com> - 0.4.4-7
276- Run desktop-file-validate against desktop files
277
278* Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-6
279- rebuild against new gnome-sharp
280
281* Thu Oct  2 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-5
282- Use a standard icon name instead of a non-existing one
283
284* Mon Jul 14 2008 Nigel Jones <dev@nigelj.com> - 0.4.4-4
285- Remove Tom's patch in -2, there is a gtk-sharp 2.12.1, just nobody bothered
286  packaging it.
287- Patch Makefile{.in,am} to use DESTDIR for the gio-sharp.dll, this is
288  effectively a backport of r4010 Upstream.
289- Patch libfspot/Makefile{.in,am} to remove -DGTK_DISABLE_DEPRECATED per
290  recommendation of upstream.
291- Re-add patch to use system mono-addins
292- Include GIO stuff for now (until it appears in gtk-sharp)
293
294* Wed Jul  5 2008 Alex Lancaster <alexlan[AT] fedoraproject org> - 0.4.4-3
295- gtkhtml dependency now provided by gnome-desktop-sharp-devel
296  rather than gnome-sharp-devel, so add as BuildRequires
297
298* Wed Jun  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-2
299- Fix it to not look for non-existant glib-sharp-2.12.1
300
301* Wed Jun  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-1
302- update to 0.4.4
303- fix license tag
304
305* Tue May 13 2008 Matthias Clasen <mclasne@redhat.com> - 0.4.3.1-1
306- Update to 0.4.3.1
307
308* Tue Apr 15 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.4.2-5
309- Add patch from Debian to use system mono-addins (from #442343)
310
311* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-4
312- Require dcraw
313
314* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-3
315- Fix the build
316
317* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
318- Autorebuild for GCC 4.3
319
320* Thu Feb 14 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.2-1
321- Update to 0.4.2
322
323* Fri Jan 18 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.1-2
324- Add support for content-types
325
326* Thu Dec  6 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.1-1
327- Update to 0.4.1
328
329* Sat Nov 17 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-4
330- Remove comments from ExclusiveArch line (#388581)
331
332* Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-3
333- Add alpha to ExclusiveArch
334
335* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 0.4.0-2
336- Rebuild for build ID
337
338* Sat Aug  4 2007 Matthis Clasen <mclasen@redhat.com> - 0.4.0-1
339- Update to 0.4.0
340
341* Mon Jul  2 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-3
342- Hack to get screensavers to work again (#221546)
343
344* Fri Apr 13 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-2
345- Now with validated desktop files!
346
347* Wed Mar  7 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-1
348- Update to 0.3.5
349
350* Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
351- Update to 0.3.4
352
353* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.3-1
354- Update to 0.3.3
355
356* Tue Jan 23 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
357- Update to 0.3.2
358
359* Fri Oct 20 2006 Christopher Aillon <caillon@redhat.com> - 0.2.2-1
360- Update to 0.2.2
361
362* Mon Oct 16 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.1-2
363- Fix a directory ownership issue (#211009)
364
365* Wed Sep 13 2006 Christopher Aillon <caillon@redhat.com> - 0.2.1-1
366- Update to 0.2.1
367
368* Tue Sep 12 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2
369- Add libgphoto2_port version to dll config (#205302)
370
371* Mon Sep  4 2006 Christopher Aillon <caillon@redhat.com> - 0.2.0-1
372- Update to 0.2.0
373
374* Fri Aug 18 2006 Alexander Larsson <alexl@redhat.com> - 0.1.11-5
375- Rebuild with new mono and gtk-sharp2
376
377* Thu Jul 27 2006 Matthias Clasen <mclasen@redhat.com> - 0.1.11-4
378- Fix dbus-sharp BR
379
380* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.1.11-3.1
381- rebuild
382
383* Sun Jun 24 2006 Jesse Keating <jkeating@redhat.com> 0.1.11-3
384- Add missing BR gettext
385
386* Wed May 31 2006 Alexander Larsson <alexl@redhat.com> 0.1.11-2
387- Rebuild for gmime update
388
389* Fri Mar 17 2006 Christopher Aillon <caillon@redhat.com> 0.1.11-1
390- Update to 0.1.11
391
392* Fri Feb 24 2006 Christopher Aillon <caillon@redhat.com> 0.1.10-1
393- Update to 0.1.10
394
395* Tue Feb 21 2006 Karsten Hopp <karsten@redhat.de> 0.1.9-2
396- add BuildRequires  libgnome-devel libgnomeui-devel
397  gtk2-devel mono-devel libjpeg-devel sqlite-devel
398
399* Fri Feb 17 2006 Christopher Aillon <caillon@redhat.com> - 0.1.9-1
400- Update to 0.1.9
401
402* Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-3
403- Rebuild
404
405* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.8-2.1
406- rebuilt for new gcc4.1 snapshot and glibc changes
407
408* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-2
409- Add sqlite3.patch to ensure that sqlite3 is used if both
410  sqlite2 and sqlite3 are installed.
411
412* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-1
413- Update to 0.1.8
414- Use sqlite3 instead of sqlite2
415
416* Tue Jan 31 2006 Ray Strode <rstrode@redhat.com> - 0.1.5-3
417- don't blindly run f-spot from current working directory
418  (bug 177407)
419
420* Tue Jan 10 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-2
421- Add lcms depencency
422
423* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-1
424- Update to 0.1.5
425
426* Thu Dec  8 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-3
427- Use sqlite2 to avoid problems with beagle
428
429* Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-2
430- Make exes and dlls executable to pick up dependencies
431- Remove .a and .la files
432
433* Wed Nov 16 2005 Alexander Larsson <alexl@redhat.com> - 0.1.3-1
434- Initial version
435
Note: See TracBrowser for help on using the repository browser.