source: projects/specs/trunk/e/extra-cmake-modules/extra-cmake-modules-vl.spec @ 10591

Revision 10591, 7.7 KB checked in by tomop, 8 years ago (diff)

extra-cmake-modules-5.24.0-1

Line 
1%bcond_without bootstrap
2# uncomment to enable bootstrap mode
3%if %{with bootstrap}
4%define bootstrap 1
5%endif
6
7%if !0%{?bootstrap}
8%global docs 1
9%global tests 1
10%endif
11
12Name:           extra-cmake-modules
13Summary:        Additional modules for CMake build system
14Version:        5.24.0
15Release:        1%{?_dist_release}
16
17License:        BSD
18URL:            https://quickgit.kde.org/?p=extra-cmake-modules.git
19
20Vendor:         Project Vine
21Distribution:   Vine Linux
22
23%global versiondir %(echo %{version} | cut -d. -f1-2)
24%global revision %(echo %{version} | cut -d. -f3)
25%if %{revision} >= 50
26%global stable unstable
27%else
28%global stable stable
29%endif
30Source0:        http://download.kde.org/%{stable}/frameworks/%{versiondir}/%{name}-%{version}.tar.xz
31BuildArch:      noarch
32
33BuildRequires: cmake
34
35#BuildRequires: kf5-rpm-macros
36#Requires: kf5-rpm-macros
37
38%if 0%{?docs}
39# qcollectiongenerator
40BuildRequires: qt5-qttools-devel
41# sphinx-build
42BuildRequires: python2-sphinx
43%endif
44
45%description
46Additional modules for CMake build system needed by KDE Frameworks.
47
48
49%prep
50%autosetup -p1
51
52
53%build
54mkdir %{_target_platform}
55pushd %{_target_platform}
56
57CFLAGS="${CFLAGS:-%optflags}"; export CFLAGS;
58CXXFLAGS="${CXXFLAGS:-%optflags}"; export CXXFLAGS;
59FFLAGS="${FFLAGS:-%optflags%{?_fmoddir: -I%_fmoddir}}"; export FFLAGS;
60%{?__global_ldflags:LDFLAGS="${LDFLAGS:-%__global_ldflags}"; export LDFLAGS;}
61
62cmake .. \
63  -DCMAKE_VERBOSE_MAKEFILE=ON \
64  -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
65  -DCMAKE_INSTALL_LIBDIR:PATH=%{_libdir} \
66  -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
67  -DLIB_INSTALL_DIR:PATH=%{_libdir} \
68  -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
69  -DSHARE_INSTALL_PREFIX:PATH=%{_datadir} \
70%if "%{?_lib}" == "lib64"
71  %{?_cmake_lib_suffix64} \
72%endif
73  %{?_cmake_skip_rpath} \
74  -DBUILD_SHARED_LIBS:BOOL=ON \
75  -DBUILD_TESTING:BOOL=%{?tests:ON}%{!?tests:OFF}
76popd
77
78make %{?_smp_mflags} -C %{_target_platform}
79
80
81%install
82make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
83
84
85%check
86%if 0%{?tests}
87export CTEST_OUTPUT_ON_FAILURE=1
88make test ARGS="--output-on-failure --timeout 300" -C %{_target_platform}
89%endif
90
91
92%files
93%doc README.rst
94%license COPYING-CMAKE-SCRIPTS
95%{_datadir}/ECM/
96%if 0%{?docs}
97%{_docdir}/ECM/html/
98%{_mandir}/man7/ecm*.7*
99%endif
100
101
102%changelog
103* Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.24.0-1
104- new upstream release.
105
106* Sun Jul 3 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.23.0-3
107- initial build for Vine Linux.
108
109* Tue Jun 07 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.23.0-2
110- support bootstrap, add docs/tests
111
112* Tue Jun 07 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.23.0-1
113- 5.23.0, relax kf5-rpm-macros dep
114
115* Mon May 16 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.22.0-1
116- KDE Frameworks 5.22.0
117
118* Mon Apr 04 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.21.0-2
119- Update URL
120
121* Mon Apr 04 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.21.0-1
122- KDE Frameworks 5.21.0
123
124* Mon Mar 14 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.20.0-1
125- KDE Frameworks 5.20.0
126
127* Thu Feb 11 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.19.0-1
128- KDE Frameworks 5.19.0
129
130* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.18.0-3
131- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
132
133* Thu Jan 14 2016 Rex Dieter <rdieter@fedoraproject.org> 5.18.0-2
134- use kf5-rpm-macros, update URL, use %%license
135
136* Sun Jan 03 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.18.0-1
137- KDE Frameworks 5.18.0
138
139* Sun Dec 13 2015 Helio Chissini de Castro <helio@kde.org> - 5.17.0-2
140- Adapt epel cmake3 changes
141
142* Tue Dec 08 2015 Daniel Vrátil <dvratil@fedoraproject.org> - 5.17.0-1
143- KDE Frameworks 5.17.0
144
145* Sun Nov 08 2015 Daniel Vrátil <dvratil@fedoraproject.org> - 5.16.0-1
146- KDE Frameworks 5.16.0
147
148* Thu Oct 08 2015 Daniel Vrátil <dvratil@redhat.com> - 5.15.0-1
149- KDE Frameworks 5.15.0
150
151* Wed Sep 16 2015 Daniel Vrátil <dvratil@redhat.com> - 5.14.0-1
152- KDE Frameworks 5.14.0
153
154* Wed Aug 19 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-1
155- KDE Frameworks 5.13.0
156
157* Wed Aug 19 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-1
158- KDE Frameworks 5.13.0
159
160* Tue Aug 11 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-0.1
161- KDE Frameworks 5.13
162
163* Thu Jul 09 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.12.0-1
164- 5.12.0, update URL (to reference projects.kde.org), .spec cosmetics
165
166* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.11.0-2
167- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
168
169* Wed Jun 10 2015 Daniel Vrátil <dvratil@redhat.com> - 5.11.0-1
170- KDE Frameworks 5.11.0
171
172* Mon May 11 2015 Daniel Vrátil <dvratil@redhat.com> - 5.10.0-1
173- KDE Frameworks 5.10.0
174
175* Tue Apr 07 2015 Daniel Vrátil <dvratil@redhat.com> - 5.9.0-1
176- KDE Frameworks 5.9.0
177
178* Mon Mar 16 2015 Daniel Vrátil <dvratil@redhat.com> - 1.8.0-1
179- extra-cmake-modules 1.8.0 (KDE Frameworks 5.8.0)
180
181* Fri Feb 13 2015 Daniel Vrátil <dvratil@redhat.com> - 1.7.0-1
182- extra-cmake-modules 1.7.0 (KDE Frameworks 5.7.0)
183
184* Mon Jan 12 2015 Daniel Vrátil <dvratil@redhat.com> - 1.6.1-1
185- Update to 1.6.1 which includes upstream fix for kde#341717
186
187* Sun Jan 11 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.6.0-3
188- Use upstream version of the kde#342717 patch by Alex Merry
189
190* Sun Jan 11 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.6.0-2
191- Do not unset old-style variables in KDEInstallDirs.cmake, it breaks projects
192  using GNUInstallDirs for some parts and KDEInstallDirs for others (kde#342717)
193
194* Thu Jan 08 2015 Daniel Vrátil <dvratil@redhat.com> - 1.6.0-1
195- extra-cmake-modules 1.6.0 (KDE Frameworks 5.6.0)
196
197* Thu Dec 11 2014 Daniel Vrátil <dvratil@redhat.com> - 1.5.0-1
198- extra-cmake-modules 1.5.0 (KDE Frameworks 5.5.0)
199
200* Mon Nov 03 2014 Daniel Vrátil <dvratil@redhat.com> - 1.4.0-1
201- extra-cmake-modules 1.4.0 (KDE Frameworks 5.4.0)
202
203* Tue Oct 07 2014 Daniel Vrátil <dvratil@redhat.com> - 1.3.0-1
204- extra-cmake-modules 1.3.0 (KDE Frameworks 5.3.0)
205
206* Tue Sep 16 2014 Daniel Vrátil <dvratil@redhat.com> - 1.2.1-1
207- extra-cmake-modules 1.2.1 (KDE Frameworks 5.2.0)
208
209* Mon Sep 15 2014 Daniel Vrátil <dvratil@redhat.com> - 1.2.0-1
210- extra-cmake-modules 1.2.0 (KDE Frameworks 5.2.0)
211
212* Wed Aug 06 2014 Daniel Vrátil <dvratil@redhat.com> - 1.1.0-1
213- extra-cmake-modules 1.1.0 (KDE Frameworks 5.1.0)
214
215* Thu Jul 10 2014 Daniel Vrátil <dvratil@redhat.com> - 1.0.0-1
216- extra-cmake-modules 1.0.0 (KDE Frameworks 5.0.0)
217
218* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.14-3
219- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
220
221* Tue Jun 03 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.14-2
222- Strip architecture check from a CMake-generated file to fix noarch build
223
224* Tue Jun 03 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.14-1
225- extra-cmake-modules 0.0.14 (KDE Frameworks 4.100.0)
226
227* Mon May 05 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.13-1
228- extra-cmake-modules 0.0.13 (KDE Frameworks 4.99.0)
229
230* Fri Apr 11 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.12-3
231- Remove debug_package, add %%{?dist} to Release
232
233* Fri Apr 11 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.12-2
234- Don't depend on kf5-filesystem
235
236* Mon Mar 31 2014 Jan Grulich <jgrulich@redhat.com> 0.0.12-1
237- Update to KDE Frameworks 5 Beta 1 (4.98.0)
238
239* Wed Mar 05 2014 Jan Grulich <jgrulich@redhat.com> 0.0.11-1
240- Update to KDE Frameworks 5 Alpha 2 (4.97.0)
241
242* Wed Feb 12 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.10-1
243- Update to KDE Frameworks 5 Alpha 1 (4.96.0)
244
245* Wed Feb 05 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.10-0.1.20140205git
246- Update to pre-relase snapshot of 0.0.10
247
248* Tue Feb 04 2014 Lubomir Rintel <lkundrak@v3.sk> - 0.0.9-1
249- Update to Jan 7 release
250
251* Mon Sep 16 2013 Lubomir Rintel <lkundrak@v3.sk> - 0.0.9-0.1.20130013git5367954
252- Initial packaging
Note: See TracBrowser for help on using the repository browser.