source: projects/specs/trunk/e/extra-cmake-modules/extra-cmake-modules-vl.spec @ 12299

Revision 12299, 7.8 KB checked in by tomop, 4 years ago (diff)

updated 15 packages

ant-1.9.14-1

ccid-1.4.31-1

extra-cmake-modules-5.63.0-1

file-5.37-2

iputils-20190709-1

libarchive-3.4.0-1

libidn2-2.2.0-1

libmodsecurity-3.0.3-4

libxslt-1.1.33-2

ncurses-6.1-3

pcsc-lite-1.8.25-1

polkit-qt-0.112.0-3

qca2-2.2.1-1

rdesktop-1.9.0-1

util-linux-2.34-1

Line 
1%bcond_without bootstrap
2# uncomment to enable bootstrap mode
3%if %{with bootstrap}
4%define bootstrap 1
5%endif
6
7%if !0%{?bootstrap}
8%global docs 1
9%global tests 1
10%endif
11
12Name:           extra-cmake-modules
13Summary:        Additional modules for CMake build system
14Version:        5.63.0
15Release:        1%{?_dist_release}
16
17License:        BSD
18URL:            https://quickgit.kde.org/?p=extra-cmake-modules.git
19
20Vendor:         Project Vine
21Distribution:   Vine Linux
22
23%global versiondir %(echo %{version} | cut -d. -f1-2)
24%global revision %(echo %{version} | cut -d. -f3)
25%if %{revision} >= 50
26%global stable unstable
27%else
28%global stable stable
29%endif
30Source0:        https://download.kde.org/%{stable}/frameworks/%{versiondir}/%{name}-%{version}.tar.xz
31BuildArch:      noarch
32
33BuildRequires: cmake
34
35#BuildRequires: kf5-rpm-macros
36#Requires: kf5-rpm-macros
37
38%if 0%{?docs}
39# qcollectiongenerator
40BuildRequires: qt5-qttools-devel
41# sphinx-build
42BuildRequires: python2-sphinx
43%endif
44
45%description
46Additional modules for CMake build system needed by KDE Frameworks.
47
48
49%prep
50%autosetup -p1
51
52
53%build
54mkdir %{_target_platform}
55pushd %{_target_platform}
56
57CFLAGS="${CFLAGS:-%optflags}"; export CFLAGS;
58CXXFLAGS="${CXXFLAGS:-%optflags}"; export CXXFLAGS;
59FFLAGS="${FFLAGS:-%optflags%{?_fmoddir: -I%_fmoddir}}"; export FFLAGS;
60%{?__global_ldflags:LDFLAGS="${LDFLAGS:-%__global_ldflags}"; export LDFLAGS;}
61
62cmake .. \
63  -DCMAKE_VERBOSE_MAKEFILE=ON \
64  -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
65  -DCMAKE_INSTALL_LIBDIR:PATH=%{_libdir} \
66  -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
67  -DLIB_INSTALL_DIR:PATH=%{_libdir} \
68  -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
69  -DSHARE_INSTALL_PREFIX:PATH=%{_datadir} \
70%if "%{?_lib}" == "lib64"
71  %{?_cmake_lib_suffix64} \
72%endif
73  %{?_cmake_skip_rpath} \
74  -DBUILD_SHARED_LIBS:BOOL=ON \
75  -DBUILD_TESTING:BOOL=%{?tests:ON}%{!?tests:OFF}
76popd
77
78make %{?_smp_mflags} -C %{_target_platform}
79
80
81%install
82make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
83
84
85%check
86%if 0%{?tests}
87export CTEST_OUTPUT_ON_FAILURE=1
88make test ARGS="--output-on-failure --timeout 300" -C %{_target_platform}
89%endif
90
91
92%files
93%doc README.rst
94%license COPYING-CMAKE-SCRIPTS
95%{_datadir}/ECM/
96%if 0%{?docs}
97%{_docdir}/ECM/html/
98%{_mandir}/man7/ecm*.7*
99%endif
100
101
102%changelog
103* Sun Oct 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.63.0-1
104- new upstream release.
105
106* Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.24.0-1
107- new upstream release.
108
109* Sun Jul 3 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.23.0-3
110- initial build for Vine Linux.
111
112* Tue Jun 07 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.23.0-2
113- support bootstrap, add docs/tests
114
115* Tue Jun 07 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.23.0-1
116- 5.23.0, relax kf5-rpm-macros dep
117
118* Mon May 16 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.22.0-1
119- KDE Frameworks 5.22.0
120
121* Mon Apr 04 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.21.0-2
122- Update URL
123
124* Mon Apr 04 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.21.0-1
125- KDE Frameworks 5.21.0
126
127* Mon Mar 14 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.20.0-1
128- KDE Frameworks 5.20.0
129
130* Thu Feb 11 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.19.0-1
131- KDE Frameworks 5.19.0
132
133* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.18.0-3
134- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
135
136* Thu Jan 14 2016 Rex Dieter <rdieter@fedoraproject.org> 5.18.0-2
137- use kf5-rpm-macros, update URL, use %%license
138
139* Sun Jan 03 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.18.0-1
140- KDE Frameworks 5.18.0
141
142* Sun Dec 13 2015 Helio Chissini de Castro <helio@kde.org> - 5.17.0-2
143- Adapt epel cmake3 changes
144
145* Tue Dec 08 2015 Daniel Vrátil <dvratil@fedoraproject.org> - 5.17.0-1
146- KDE Frameworks 5.17.0
147
148* Sun Nov 08 2015 Daniel Vrátil <dvratil@fedoraproject.org> - 5.16.0-1
149- KDE Frameworks 5.16.0
150
151* Thu Oct 08 2015 Daniel Vrátil <dvratil@redhat.com> - 5.15.0-1
152- KDE Frameworks 5.15.0
153
154* Wed Sep 16 2015 Daniel Vrátil <dvratil@redhat.com> - 5.14.0-1
155- KDE Frameworks 5.14.0
156
157* Wed Aug 19 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-1
158- KDE Frameworks 5.13.0
159
160* Wed Aug 19 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-1
161- KDE Frameworks 5.13.0
162
163* Tue Aug 11 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-0.1
164- KDE Frameworks 5.13
165
166* Thu Jul 09 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.12.0-1
167- 5.12.0, update URL (to reference projects.kde.org), .spec cosmetics
168
169* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.11.0-2
170- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
171
172* Wed Jun 10 2015 Daniel Vrátil <dvratil@redhat.com> - 5.11.0-1
173- KDE Frameworks 5.11.0
174
175* Mon May 11 2015 Daniel Vrátil <dvratil@redhat.com> - 5.10.0-1
176- KDE Frameworks 5.10.0
177
178* Tue Apr 07 2015 Daniel Vrátil <dvratil@redhat.com> - 5.9.0-1
179- KDE Frameworks 5.9.0
180
181* Mon Mar 16 2015 Daniel Vrátil <dvratil@redhat.com> - 1.8.0-1
182- extra-cmake-modules 1.8.0 (KDE Frameworks 5.8.0)
183
184* Fri Feb 13 2015 Daniel Vrátil <dvratil@redhat.com> - 1.7.0-1
185- extra-cmake-modules 1.7.0 (KDE Frameworks 5.7.0)
186
187* Mon Jan 12 2015 Daniel Vrátil <dvratil@redhat.com> - 1.6.1-1
188- Update to 1.6.1 which includes upstream fix for kde#341717
189
190* Sun Jan 11 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.6.0-3
191- Use upstream version of the kde#342717 patch by Alex Merry
192
193* Sun Jan 11 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.6.0-2
194- Do not unset old-style variables in KDEInstallDirs.cmake, it breaks projects
195  using GNUInstallDirs for some parts and KDEInstallDirs for others (kde#342717)
196
197* Thu Jan 08 2015 Daniel Vrátil <dvratil@redhat.com> - 1.6.0-1
198- extra-cmake-modules 1.6.0 (KDE Frameworks 5.6.0)
199
200* Thu Dec 11 2014 Daniel Vrátil <dvratil@redhat.com> - 1.5.0-1
201- extra-cmake-modules 1.5.0 (KDE Frameworks 5.5.0)
202
203* Mon Nov 03 2014 Daniel Vrátil <dvratil@redhat.com> - 1.4.0-1
204- extra-cmake-modules 1.4.0 (KDE Frameworks 5.4.0)
205
206* Tue Oct 07 2014 Daniel Vrátil <dvratil@redhat.com> - 1.3.0-1
207- extra-cmake-modules 1.3.0 (KDE Frameworks 5.3.0)
208
209* Tue Sep 16 2014 Daniel Vrátil <dvratil@redhat.com> - 1.2.1-1
210- extra-cmake-modules 1.2.1 (KDE Frameworks 5.2.0)
211
212* Mon Sep 15 2014 Daniel Vrátil <dvratil@redhat.com> - 1.2.0-1
213- extra-cmake-modules 1.2.0 (KDE Frameworks 5.2.0)
214
215* Wed Aug 06 2014 Daniel Vrátil <dvratil@redhat.com> - 1.1.0-1
216- extra-cmake-modules 1.1.0 (KDE Frameworks 5.1.0)
217
218* Thu Jul 10 2014 Daniel Vrátil <dvratil@redhat.com> - 1.0.0-1
219- extra-cmake-modules 1.0.0 (KDE Frameworks 5.0.0)
220
221* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.14-3
222- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
223
224* Tue Jun 03 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.14-2
225- Strip architecture check from a CMake-generated file to fix noarch build
226
227* Tue Jun 03 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.14-1
228- extra-cmake-modules 0.0.14 (KDE Frameworks 4.100.0)
229
230* Mon May 05 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.13-1
231- extra-cmake-modules 0.0.13 (KDE Frameworks 4.99.0)
232
233* Fri Apr 11 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.12-3
234- Remove debug_package, add %%{?dist} to Release
235
236* Fri Apr 11 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.12-2
237- Don't depend on kf5-filesystem
238
239* Mon Mar 31 2014 Jan Grulich <jgrulich@redhat.com> 0.0.12-1
240- Update to KDE Frameworks 5 Beta 1 (4.98.0)
241
242* Wed Mar 05 2014 Jan Grulich <jgrulich@redhat.com> 0.0.11-1
243- Update to KDE Frameworks 5 Alpha 2 (4.97.0)
244
245* Wed Feb 12 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.10-1
246- Update to KDE Frameworks 5 Alpha 1 (4.96.0)
247
248* Wed Feb 05 2014 Daniel Vrátil <dvratil@redhat.com> 0.0.10-0.1.20140205git
249- Update to pre-relase snapshot of 0.0.10
250
251* Tue Feb 04 2014 Lubomir Rintel <lkundrak@v3.sk> - 0.0.9-1
252- Update to Jan 7 release
253
254* Mon Sep 16 2013 Lubomir Rintel <lkundrak@v3.sk> - 0.0.9-0.1.20130013git5367954
255- Initial packaging
Note: See TracBrowser for help on using the repository browser.