source: projects/specs/trunk/e/expat/expat-vl.spec @ 12526

Revision 12526, 7.9 KB checked in by tomop, 3 years ago (diff)

updated 2 packages

expat-2.2.10-1

unbound-1.13.1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define name   expat
3%define version 2.2.10
4%define release 1%{?_dist_release}
5
6Summary:        Expat is an XML 1.0 parser written in C
7Summary(ja):    C で書かれた XML 1.0 パーサ
8Name:           %{name}
9Version:        %{version}
10Release:        %{release}
11License:        MIT/X
12Group:          accessories
13URL:            http://www.libexpat.org/
14Source:         http://download.sourceforge.net/expat/%{name}-%{version}.tar.bz2
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17Requires:       lib%{name} = %{version}-%{release}
18BuildRequires:  libtool
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24This is Expat, a C library for parsing XML, written by James Clark.
25Expat is a stream-oriented XML parser.  This means that you register
26handlers with the parser before starting the parse.  These handlers
27are called when the parser discovers the associated structures in the
28document being parsed.  A start tag is an example of the kind of
29structures for which you may register handlers.
30
31%package -n     lib%{name}
32Summary:        Runtime library of expat
33Summary(ja):    Expat のための実行ライブラリ
34Group:          system
35
36%description -n lib%{name}
37This package contains the runtime, shared library of expat, the C
38library for parsing XML.
39
40%description -n lib%{name} -l ja
41Expat を動作させるために必用となるライブラリです.
42
43
44%package        devel
45Summary:        Development environment for the expat XML parser
46Summary(ja):    expat XML パーサ用開発環境
47Group:          programming
48Requires:       lib%{name} = %{version}-%{release}
49Requires:       pkgconfig
50
51%description devel
52Development environment for the expat XML parser
53
54%description devel -l ja
55expat XML パーサ用開発環境です.
56
57
58## to build compat32 for x86_64 architecture support
59%package -n     compat32-lib%{name}
60Summary:        Runtime library of expat
61Summary(ja):    Expat のための実行ライブラリ
62Group:          system
63Requires:       lib%{name} = %{version}-%{release}
64
65%description -n compat32-lib%{name}
66This package contains the runtime, shared library of expat, the C
67library for parsing XML.
68
69%description -n compat32-lib%{name} -l ja
70Expat を動作させるために必用となるライブラリです.
71
72
73%package -n     compat32-%{name}-devel
74Summary:        Development environment for the expat XML parser
75Summary(ja):    expat XML パーサ用開発環境
76Group:          programming
77Requires:       %{name}-devel = %{version}-%{release}
78Requires:       compat32-lib%{name} = %{version}-%{release}
79
80%description -n compat32-%{name}-devel
81Development environment for the expat XML parser
82
83%description -n compat32-%{name}-devel -l ja
84expat XML パーサ用開発環境です.
85
86
87%debug_package
88
89
90%prep
91%setup -q
92
93
94%build
95export CFLAGS="$RPM_OPT_FLAGS -fPIC"
96%configure --enable-shared
97make %{?_smp_mflags}
98
99
100%install
101rm -rf $RPM_BUILD_ROOT
102
103rm -f examples/*.dsp
104chmod 644 AUTHORS README.md COPYING Changes doc/* examples/*
105
106make DESTDIR=$RPM_BUILD_ROOT install
107rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
108
109rm -rf $RPM_BUILD_ROOT/%{_datadir}/doc/expat
110
111mkdir -p %{buildroot}%{_mandir}/man1
112install -m644 doc/xmlwf.1 %{buildroot}%{_mandir}/man1/
113
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118
119%post -n lib%{name} -p /sbin/ldconfig
120%postun -n lib%{name} -p /sbin/ldconfig
121
122%post -n compat32-lib%{name} -p /sbin/ldconfig
123%postun -n compat32-lib%{name} -p /sbin/ldconfig
124
125
126%files
127%defattr(-,root,root)
128%license COPYING
129%doc AUTHORS Changes README.md
130%{_bindir}/xmlwf
131%{_mandir}/man1/xmlwf.1*
132
133%files -n lib%{name}
134%defattr(-,root,root)
135%license COPYING
136%doc AUTHORS Changes README.md
137%{_libdir}/libexpat.so.*
138
139%files devel
140%defattr(-,root,root)
141%license COPYING
142%doc AUTHORS Changes README.md
143%doc doc/* examples
144%{_includedir}/*
145%{_libdir}/libexpat.a
146%{_libdir}/libexpat.so
147%{_libdir}/pkgconfig/%{name}.pc
148
149## to build compat32 for x86_64 architecture support
150%if %{build_compat32}
151%files -n compat32-lib%{name}
152%defattr(-,root,root)
153%{_libdir}/libexpat.so.*
154
155%files -n compat32-%{name}-devel
156%defattr(-,root,root)
157%{_libdir}/libexpat.a
158%{_libdir}/libexpat.so
159%endif
160
161
162%changelog
163* Wed Feb 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.10-1
164- new upstream release.
165
166* Fri Oct 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9-1
167- new upstream release.
168
169* Wed May 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6-1
170- new upstream release.
171
172* Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.5-1
173- new upstream release.
174
175* Tue Jul  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.0-1
176- new upstream release.
177
178* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-2
179- rebuild with VineSeed environment
180
181* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
182- update to 2.1.0
183- remove old patches
184
185* Tue Apr 26 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.1-8
186- update patch100 to regrassion fix (same as debian bug #561658)
187- add Vendor and Distribution tags
188
189* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.0.1-7
190- rebuilt with rpm-4.8.1-3
191
192* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
193- rebuilt with gcc-4.4.3-3 on ppc
194
195* Mon Feb  1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
196- rebuilt with new toolchains (for VineSeed)
197
198* Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
199- add patch110 for fix CVE-2009-3720 (xml parser)
200
201* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
202- add Patch100 for fix CVE-2009-3560 (xml parser)
203
204* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
205- added Requires: tag to compat32-* sub-packages.
206- removed unnecessary %%configure CC='gcc -m32' option
207
208* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
209- applied new versioning policy and spec in utf-8
210
211* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
212- removed %%if !%%{build_compat32} case condition
213
214* Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
215- new upstream release
216- drop Patch0
217- drop .la
218- chmod 644 the documentation
219- strip DSP files from examples
220- update description and drop description-ja
221- add -fPIC
222
223* Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
224- rebuilt
225
226* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
227- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
228
229* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
230- added compat32* packages for x86_64 architecture support
231
232* Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
233- add missing header file (expat_external.h) to %%files.
234
235* Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
236- updated/revised Patch1 (%%install will fail without this patch)
237
238* Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
239- new upstream release
240        -- dropped patch1
241
242* Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
243- updated to 1.95.7
244- changed URL and Group
245- fixed License to MIT/X (based on rpm package at sourceforge)
246
247* Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
248- version up to 1.95.6
249- drop expat-xmlwf-dynamiclink.patch (Patch0)
250- add expat-1.95.6-mandir.patch for installing manpage (Patch0)
251- add manpage (xmlwf.1)
252
253* Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
254- fixed license ( s/MPL or GPL/distributable/ )
255- use License tag
256
257* Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
258- new sub-package libexpat.
259- added BuildPreReq: libtool
260
261* Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
262- updated to 1.95.2 release
263
264* Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
265- 1.95.1-3vl1
266- based on 1.95.1-3mdk from Mandrake 8.0
267- added Japanese summary and description
268- modified spec macros for Vine
269
270* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
271- real version is 1.95.1
272- reenable optimisations
273
274* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
275- release .
276
277* Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
278- Don't try to use optimizations
279- Bzip2 sources
280
281* Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
282- first version
Note: See TracBrowser for help on using the repository browser.