source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 8912

Revision 8912, 27.8 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.44
15%define libgdata_version 0.10.1
16
17%define eds_base_version 3.12
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
33Version: 3.12.5
34Release: 1%{?_dist_release}
35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.12/%{name}-%{version}.tar.xz
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
48#Requires: ORBit2 >= %{orbit2_version}
49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
53#BuildRequires: ORBit2-devel >= %{orbit2_version}
54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
59BuildRequires: gtk3-devel
60BuildRequires: dbus-glib-devel
61BuildRequires: gnutls-devel
62BuildRequires: intltool >= %{intltool_version}
63BuildRequires: libsoup-devel >= %{soup_version}
64BuildRequires: libtool
65BuildRequires: libgnome-keyring-devel
66BuildRequires: gtk-doc >= 1.14
67BuildRequires: sqlite3-devel
68BuildRequires: libgweather-devel >= %{libgweather_version}
69BuildRequires: libical-devel >= %{libical_version}
70BuildRequires: gperf
71BuildRequires: krb5-devel
72BuildRequires: libgdata-devel >= %{libgdata_version}
73BuildRequires: gnome-online-accounts-devel
74BuildRequires: liboauth-devel
75BuildRequires: libsecret-devel
76BuildRequires: libicu-devel
77BuildRequires: gnome-common
78
79BuildRequires: vala
80BuildRequires: vala-tools
81
82%if %{use_nss}
83BuildRequires: nspr-devel
84BuildRequires: nss-devel
85%else
86BuildRequires: openssl-devel
87%endif
88
89%if %{ldap_support}
90%if %{static_ldap}
91BuildRequires: openldap-evolution-devel
92BuildRequires: openssl-devel
93%else
94BuildRequires: openldap-devel >= 2.0.11
95%endif
96%endif
97
98%if %{krb5_support}
99BuildRequires: krb5-devel
100# tweak for krb5 1.2 vs 1.3
101%define krb5dir /usr/kerberos
102#define krb5dir `pwd`/krb5-fakeprefix
103%endif
104
105Vendor: Project Vine
106Distribution: Vine Linux
107
108%description
109The evolution-data-server package provides a unified backend for
110programs that work with contacts, tasks, and calendar information.
111
112It was originally developed for Evolution (hence the name), but
113is now used by other packages.
114
115
116%package devel
117Summary: Development files for building against evolution-data-server
118Group: Development/Libraries
119Requires: %{name} = %{version}-%{release}
120Requires: pkgconfig
121Requires: sqlite3-devel
122Requires: libgnome-keyring-devel
123
124%description devel
125Development files needed for building things which link against
126evolution-data-server.
127
128
129%package                doc
130Summary:                Documentation for %{name}
131Summary(ja):    %{name} 用のドキュメント
132Group:                  Documentation
133Requires:               %{name} = %{version}-%{release}
134BuildArch:              noarch
135
136%description doc
137This package contains documentation for %{name}.
138
139
140%package        vala
141Summary:        Vala bindings for %{name}
142Summary(ja):    %{name} の Vala バインディング
143Group:          Development/Libraries
144Requires:       %{name} = %{version}-%{release}
145Requires:       vala
146
147%description    vala
148Vala bindings for %{name}.
149
150
151%prep
152%setup -q
153
154%patch12 -p1 -b .fix-64bit-acinclude
155
156mkdir -p krb5-fakeprefix/include
157mkdir -p krb5-fakeprefix/lib
158mkdir -p krb5-fakeprefix/%{_lib}
159
160%build
161%if %{ldap_support}
162
163%if %{static_ldap}
164%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
165# Set LIBS so that configure will be able to link with static LDAP libraries,
166# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
167if pkg-config libssl ; then
168        export LIBS="-lsasl2 `pkg-config --libs libssl`"
169else
170        export LIBS="-lsasl2 -lssl -lcrypto"
171fi
172%else
173%define ldap_flags --with-openldap=yes
174%endif
175
176%else
177%define ldap_flags --without-openldap
178%endif
179
180%if %{krb5_support}
181%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
182%else
183%define krb5_flags --without-krb5
184%endif
185
186%if %{nntp_support}
187%define nntp_flags --enable-nntp=yes
188%else
189%define nntp_flags --enable-nntp=no
190%endif
191
192%if %{use_nss}
193%define ssl_flags --enable-nss=yes --enable-smime=yes
194%else
195%define ssl_flags --enable-openssl=yes
196%endif
197
198%if %{use_nss}
199if ! pkg-config --exists nss; then
200  echo "Unable to find suitable version of nss to use!"
201  exit 1
202fi
203%endif
204
205%if %{use_gnome_keyring}
206%define keyring_flags --enable-gnome-keyring
207%else
208%define keyring flags --disable-gnome-keyring
209%endif
210
211%if %{support_imap4_provider}
212%define imap4_flags --enable-imap4=yes
213%else
214%define imap4_flags --enable-imap4=no
215%endif
216
217export CPPFLAGS="-I%{_includedir}/et"
218export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
219
220# Regenerate configure to pick up configure.in and acinclude.m4 changes.
221autoreconf -if
222
223# See Ross Burton's blog entry for why we want --with-libdb.
224# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
225
226%configure \
227        --with-libdb=/usr \
228        --disable-uoa \
229        --enable-file-locking=fcntl \
230        --enable-dot-locking=no \
231        --enable-gtk-doc \
232        --enable-introspection=yes \
233        --enable-vala-bindings \
234        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
235        %keyring_flags
236export tagname=CC
237#make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
238make LIBTOOL=/usr/bin/libtool
239
240%install
241rm -rf $RPM_BUILD_ROOT
242export tagname=CC
243make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
244
245# remove libtool archives for importers and the like
246find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
247find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
248
249# give the libraries some executable bits
250find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
251
252%find_lang %{name}-%{eds_base_version}
253
254%clean
255rm -rf $RPM_BUILD_ROOT
256
257%post -p /sbin/ldconfig
258
259%postun
260/sbin/ldconfig
261if [ $1 -eq 0 ]; then
262  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
263fi
264
265%posttrans
266glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
267
268
269%files -f %{name}-%{eds_base_version}.lang
270%defattr(-,root,root,-)
271%doc README COPYING ChangeLog NEWS AUTHORS
272%{_libdir}/*.so.*
273%{_libdir}/girepository-1.0/*.typelib
274%{_libexecdir}/evolution-addressbook-factory
275%{_libexecdir}/evolution-calendar-factory
276%{_libexecdir}/evolution-scan-gconf-tree-xml
277%{_libexecdir}/evolution-source-registry
278%{_libexecdir}/evolution-user-prompter
279%{_libexecdir}/camel-index-control-%{eds_api_version}
280%{_libexecdir}/camel-lock-helper-%{eds_api_version}
281%{_datadir}/GConf/gsettings/evolution-data-server.convert
282%{_datadir}/dbus-1/services/*
283%{_datadir}/%{name}/evolutionperson.schema
284%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
285%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
286%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
287%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
288%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
289%{_datadir}/pixmaps/evolution-data-server
290
291%dir %{_libdir}/evolution-data-server
292%dir %{camel_provider_dir}
293%dir %{ebook_backends_dir}
294%dir %{ecal_backends_dir}
295%dir %{registry_modules_dir}
296
297%{camel_provider_dir}/libcamelimapx.so
298%{camel_provider_dir}/libcamelimapx.urls
299
300%{camel_provider_dir}/libcamellocal.so
301%{camel_provider_dir}/libcamellocal.urls
302
303%{camel_provider_dir}/libcamelnntp.so
304%{camel_provider_dir}/libcamelnntp.urls
305
306%{camel_provider_dir}/libcamelpop3.so
307%{camel_provider_dir}/libcamelpop3.urls
308
309%{camel_provider_dir}/libcamelsendmail.so
310%{camel_provider_dir}/libcamelsendmail.urls
311
312%{camel_provider_dir}/libcamelsmtp.so
313%{camel_provider_dir}/libcamelsmtp.urls
314
315# e-d-s extensions:
316%{ebook_backends_dir}/libebookbackendfile.so
317%{ebook_backends_dir}/libebookbackendgoogle.so
318%{ebook_backends_dir}/libebookbackendldap.so
319%{ebook_backends_dir}/libebookbackendwebdav.so
320
321%{ecal_backends_dir}/libecalbackendcaldav.so
322%{ecal_backends_dir}/libecalbackendcontacts.so
323%{ecal_backends_dir}/libecalbackendfile.so
324%{ecal_backends_dir}/libecalbackendhttp.so
325%{ecal_backends_dir}/libecalbackendweather.so
326
327%{registry_modules_dir}/module-cache-reaper.so
328%{registry_modules_dir}/module-google-backend.so
329%{registry_modules_dir}/module-gnome-online-accounts.so
330%{registry_modules_dir}/module-outlook-backend.so
331%{registry_modules_dir}/module-owncloud-backend.so
332%{registry_modules_dir}/module-secret-monitor.so
333%{registry_modules_dir}/module-trust-prompt.so
334%{registry_modules_dir}/module-yahoo-backend.so
335
336%files devel
337%defattr(-,root,root,-)
338%{_includedir}/%{name}
339%{_libdir}/*.so
340%{_libdir}/pkgconfig/*.pc
341%{_datadir}/gir-1.0/*.gir
342
343%files doc
344%defattr(-,root,root,-)
345%{_datadir}/gtk-doc/html/camel
346%{_datadir}/gtk-doc/html/eds
347
348%files vala
349%defattr(-,root,root,-)
350%{_datadir}/vala/vapi/libebook-1.2.deps
351%{_datadir}/vala/vapi/libebook-1.2.vapi
352%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
353%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
354%{_datadir}/vala/vapi/libedataserver-1.2.deps
355%{_datadir}/vala/vapi/libedataserver-1.2.vapi
356
357
358%changelog
359* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.5-1
360- new upstream release
361
362* Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
363- new upstream release
364
365* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.3-1
366- new upstream release
367
368* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
369- new upstream release
370
371* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
372- new upstream release
373
374* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
375- new upstream release
376- add BuildRequires: libicu-devel
377
378* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
379- new upstream release
380
381* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
382- new upstream release
383
384* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
385- new upstream release
386
387* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
388- new upstream release
389
390* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
391- new upstream release
392
393* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
394- new upstream release
395
396* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
397- new upstream release
398- add configure option (--disable-uoa)
399- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
400- create %%{name}-vala subpackage
401
402* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
403- new upstream release
404
405* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
406- new upstream release
407
408* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
409- new upstream release
410
411* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
412- new upstream release
413
414* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
415- new upstream release
416
417* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
418- new upstream release
419
420* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
421- new upstream release
422
423* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
424- new upstream release
425
426* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
427- new upstream release
428- add BuildRequires: dbus-glib-devel
429
430* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
431- new upstream release
432
433* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
434- new upstream release
435
436* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
437- new upstream release
438
439* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
440- new upstream release
441
442* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
443- new upstream release
444- remove Patch101
445
446* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
447- new upstream release
448
449* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
450- new upstream release
451- change BuildRequires: gtk3-devel instead of gtk2-devel
452- BuildRequires: gnome-online-accounts-devel
453- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
454- fix %%files
455
456* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
457- new upstream release
458
459* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
460- rebuild with openssl-1.0.0c
461
462* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
463- new upstream release
464- remove Requires: gnome-vfs2, libglade2, libgnomeui
465- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
466- add BuildRequires: libgdata
467- add Requires: nspr-devel, nss-devel (devel package)
468- drop Patch11
469
470* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
471- rebuild with rpm-4.8.1 for pkg-config file
472
473* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
474- new upstream release
475
476* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
477- new upstream release
478
479* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
480- new upstream release
481- remove BuildRequires: libbonobo-devel
482- remove Requires: libbonobo
483- drop Patch10
484- add configure option (--with-krb5-libs, --with-krb5-includes)
485
486* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
487- rebuilt with db4-4.8
488
489* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
490- new upstream release
491
492* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
493- new upstream release
494
495* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
496- new upstream release
497
498* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
499- new upstream release
500
501* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
502- added Requires: libical-devel >= 0.43 to devel package
503
504* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
505- new upstream release
506- add BR: libgweather-devel >= 2.26.0
507- add BR: libical-devel >= 0.43
508
509* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
510- new upstream release
511- added BuildRequires: sqlite3-devel
512
513* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
514- enabled krb5 support
515
516* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
517- new upstream release
518
519* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
520- new upstream release
521
522* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
523- new upstream release
524
525* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
526- new upstream release
527
528* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
529- rebuilt with db4-4.6.21
530
531* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
532- new upstream release
533
534* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
535- new upstream release
536
537* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
538- new upstream release
539
540* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
541- new upstream release based on Fedora package 2.20.0-3.fc9
542  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
543  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
544  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
545  - Add patch for RH bug #296671 (GC servers may not support NTLM).
546  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
547  - Try removing the ancient "ldap-x86_64-hack" patch.
548  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
549  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
550- split doc subpackage
551
552* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
553- fixed dependancy
554
555* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
556- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
557  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
558  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
559  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
560  - Make the new ESourceComboBox widget work properly (RH bug #234760).
561  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
562  - Link to static evolution-openldap library (RH bug #210126).
563  - Require openssl-devel when statically linking against openldap.
564  - Add -Wdeclaration-after-statement to strict build settings.
565  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
566  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
567  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
568  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
569  - Update to 1.10.0
570  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
571  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
572  - Patch by Kenny Root.
573- rebuilt with nss-devel and nspr-devel
574
575* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
576- rebuilt with new toolchain and db4-4.3.x
577
578* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
579- new upstream release
580
581* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
582- new upstream release
583- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
584
585* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
586- new upstream release
587- rebuilt with openssl instead of mozilla-nss
588
589* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
590- rebuilt with openldap-2.3.24-0vl4
591
592* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
593- new upstream release
594- build with libsoap-2.2.7
595
596* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
597- new upstream release
598
599* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
600- new upstream release
601- added/removed Patches based on Fedora packages
602  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
603  - Updated patch 102 to fix further implicit function declarations
604  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
605  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
606    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
607  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
608  - Removed upstreamed patch:
609    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
610  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
611  - added patch to calendar/libecal/e-cal.c to fix missing declaration
612    of open_calendar
613- rebuilt with mozilla-1.7.12
614
615* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
616- rebuilt with mozilla-1.7.7
617
618* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
619- initial build for Vine Linux based on FC package
620- disable krb5 support
621
622* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
623- 1.2.1
624
625* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
626- Removed explicit run-time spec-file requirement on mozilla.
627  The Mozilla NSS API/ABI stabilised by version 1.7.3
628  The libraries are always located in the libdir
629  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
630  and so they move each time the mozilla version changes.
631  So we no longer have an explicit mozilla run-time requirement in the specfile;
632  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
633  We have an explicit, exact build-time version, so that we can find the headers (without
634  invoking an RPM query from the spec file; to do so is considered bad practice)
635- Introduced mozilla_build_version, to replace mozilla_version
636- Set mozilla_build_version to 1.7.6 to reflect current state of tree
637
638* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
639- Added a patch to deal with glibc defining a macro called "read"
640
641* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
642- 1.2.0
643- Removed patch for GCC 4 as this is now in upstream tarball
644
645* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
646- rebuild to fix library linking silliness
647
648* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
649- disabling gtk-doc on ia64 and s390x
650
651* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
652- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
653
654* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
655- extended patch to deal with camel-groupwise-store-summary.c
656
657* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
658- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
659
660* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
661- 1.1.6
662
663* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
664- rebuild
665
666* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
667- forgot to fix sources
668
669* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
670- 1.1.5
671
672* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
673- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
674
675* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
676- disable gtk-doc generation on ia64 for now
677
678* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
679- Exclude ppc64 due to missing mozilla dependency
680
681* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
682- Update from 1.0.3 to 1.1.4.1
683- Updated eds_major from 1.0 to 1.2; fixed translation search path.
684- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
685- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
686- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
687- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
688- Camel code from evolution is now in evolution-data-server:
689  - Added camel-index-control and camel-lock-helper to packaged files
690  - Added mozilla dependency code from the evolution package
691  - Ditto for LDAP
692  - Ditto for krb5
693  - Ditto for NNTP support handling
694  - Ditto for --enable-file-locking and --enable-dot-locking
695- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
696- Updated libsoup requirement from 2.2.1 to 2.2.2
697- Enabled gtk-doc
698
699* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
700- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
701
702* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
703- update from upstream 1.0.2 to 1.0.3:
704  * Address Book
705    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
706    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
707
708  * Calendar
709    #XB59904 - Speed up calendar queries (Rodrigo)
710    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
711    - fix libical build for automake 1.9 (Rodney)
712    - fix putenv usage for portability (Julio M. Merino Vidal)
713
714  * Updated Translations:
715    - sv (Christian Rose)
716
717- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
718
719* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
720- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
721http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
722(The groupwise part of that patch did not cleanly apply, so I removed it).
723
724* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
725- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
726optimisation patch posted to upstream development mailing list here:
727http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
728
729* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
730- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
731
732* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
733- added workaround for a backend leak that causes the "contacts" calendar
734backend to hold open an EBook for the local contacts (filed upstream at:
735http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
736never lose its last addressbook, and hence never quit.  We workaround this by
737detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
738
739* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
740- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
741
742* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
743- update from 1.0.1 to 1.0.2
744- increased libsoup requirement to 2.2.1 to match configuration script
745
746* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
747- update from 1.0.0 to 1.0.1
748- removed patch that fixed warnings in calendar code (now in upstream tarball)
749
750* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
751- fixed various warnings in the calendar code
752  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
753
754* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
755- update from 0.0.99 to 1.0.0
756- changed path in FTP source location from 0.0 to 1.0
757
758* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
759- update from 0.0.98 to 0.0.99
760- increased libsoup requirement to 2.2.0 to match configuration script
761
762* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
763- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
764
765* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
766- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
767
768* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
769- upgraded to 0.0.97; rewrote the package's description
770
771* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
772- rebuilt
773
774* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
775- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
776
777* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
778- 0.0.96; libsoup required is now 2.1.12
779
780* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
781- rebuilt
782
783* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
784- rebuilt
785
786* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
787- 0.0.95
788
789* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
790- 0.0.94.1
791
792* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
793- rebuilt
794
795* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
796- 0.0.94
797
798* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
799- added ORBit2 requirement
800
801* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
802- rebuild again
803
804* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
805- rebuilt
806
807* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
808- 0.0.93; libsoup required is now 2.1.10
809
810* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
811- Update to 0.0.92; added a define and a requirement on the libsoup version
812
813* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
814- 0.0.90
815
816* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
817- rebuilt
818
819* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
820- 0.0.6
821
822* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
823- better fix by using system libtool
824
825* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
826- add some libdb linkage to make the build on x86_64 happy
827
828* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
829- update to 0.0.5
830
831* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
832- Initial build.
Note: See TracBrowser for help on using the repository browser.