source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 8836

Revision 8836, 27.7 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.44
15%define libgdata_version 0.10.1
16
17%define eds_base_version 3.12
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
33Version: 3.12.4
34Release: 1%{?_dist_release}
35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.12/%{name}-%{version}.tar.xz
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
48#Requires: ORBit2 >= %{orbit2_version}
49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
53#BuildRequires: ORBit2-devel >= %{orbit2_version}
54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
59BuildRequires: gtk3-devel
60BuildRequires: dbus-glib-devel
61BuildRequires: gnutls-devel
62BuildRequires: intltool >= %{intltool_version}
63BuildRequires: libsoup-devel >= %{soup_version}
64BuildRequires: libtool
65BuildRequires: libgnome-keyring-devel
66BuildRequires: gtk-doc >= 1.14
67BuildRequires: sqlite3-devel
68BuildRequires: libgweather-devel >= %{libgweather_version}
69BuildRequires: libical-devel >= %{libical_version}
70BuildRequires: gperf
71BuildRequires: krb5-devel
72BuildRequires: libgdata-devel >= %{libgdata_version}
73BuildRequires: gnome-online-accounts-devel
74BuildRequires: liboauth-devel
75BuildRequires: libsecret-devel
76BuildRequires: libicu-devel
77BuildRequires: gnome-common
78
79BuildRequires: vala
80BuildRequires: vala-tools
81
82%if %{use_nss}
83BuildRequires: nspr-devel
84BuildRequires: nss-devel
85%else
86BuildRequires: openssl-devel
87%endif
88
89%if %{ldap_support}
90%if %{static_ldap}
91BuildRequires: openldap-evolution-devel
92BuildRequires: openssl-devel
93%else
94BuildRequires: openldap-devel >= 2.0.11
95%endif
96%endif
97
98%if %{krb5_support}
99BuildRequires: krb5-devel
100# tweak for krb5 1.2 vs 1.3
101%define krb5dir /usr/kerberos
102#define krb5dir `pwd`/krb5-fakeprefix
103%endif
104
105Vendor: Project Vine
106Distribution: Vine Linux
107
108%description
109The evolution-data-server package provides a unified backend for
110programs that work with contacts, tasks, and calendar information.
111
112It was originally developed for Evolution (hence the name), but
113is now used by other packages.
114
115
116%package devel
117Summary: Development files for building against evolution-data-server
118Group: Development/Libraries
119Requires: %{name} = %{version}-%{release}
120Requires: pkgconfig
121Requires: sqlite3-devel
122Requires: libgnome-keyring-devel
123
124%description devel
125Development files needed for building things which link against
126evolution-data-server.
127
128
129%package                doc
130Summary:                Documentation for %{name}
131Summary(ja):    %{name} 用のドキュメント
132Group:                  Documentation
133Requires:               %{name} = %{version}-%{release}
134BuildArch:              noarch
135
136%description doc
137This package contains documentation for %{name}.
138
139
140%package        vala
141Summary:        Vala bindings for %{name}
142Summary(ja):    %{name} の Vala バインディング
143Group:          Development/Libraries
144Requires:       %{name} = %{version}-%{release}
145Requires:       vala
146
147%description    vala
148Vala bindings for %{name}.
149
150
151%prep
152%setup -q
153
154%patch12 -p1 -b .fix-64bit-acinclude
155
156mkdir -p krb5-fakeprefix/include
157mkdir -p krb5-fakeprefix/lib
158mkdir -p krb5-fakeprefix/%{_lib}
159
160%build
161%if %{ldap_support}
162
163%if %{static_ldap}
164%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
165# Set LIBS so that configure will be able to link with static LDAP libraries,
166# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
167if pkg-config libssl ; then
168        export LIBS="-lsasl2 `pkg-config --libs libssl`"
169else
170        export LIBS="-lsasl2 -lssl -lcrypto"
171fi
172%else
173%define ldap_flags --with-openldap=yes
174%endif
175
176%else
177%define ldap_flags --without-openldap
178%endif
179
180%if %{krb5_support}
181%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
182%else
183%define krb5_flags --without-krb5
184%endif
185
186%if %{nntp_support}
187%define nntp_flags --enable-nntp=yes
188%else
189%define nntp_flags --enable-nntp=no
190%endif
191
192%if %{use_nss}
193%define ssl_flags --enable-nss=yes --enable-smime=yes
194%else
195%define ssl_flags --enable-openssl=yes
196%endif
197
198%if %{use_nss}
199if ! pkg-config --exists nss; then
200  echo "Unable to find suitable version of nss to use!"
201  exit 1
202fi
203%endif
204
205%if %{use_gnome_keyring}
206%define keyring_flags --enable-gnome-keyring
207%else
208%define keyring flags --disable-gnome-keyring
209%endif
210
211%if %{support_imap4_provider}
212%define imap4_flags --enable-imap4=yes
213%else
214%define imap4_flags --enable-imap4=no
215%endif
216
217export CPPFLAGS="-I%{_includedir}/et"
218export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
219
220# Regenerate configure to pick up configure.in and acinclude.m4 changes.
221autoreconf -if
222
223# See Ross Burton's blog entry for why we want --with-libdb.
224# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
225
226%configure \
227        --with-libdb=/usr \
228        --disable-uoa \
229        --enable-file-locking=fcntl \
230        --enable-dot-locking=no \
231        --enable-gtk-doc \
232        --enable-introspection=yes \
233        --enable-vala-bindings \
234        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
235        %keyring_flags
236export tagname=CC
237#make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
238make LIBTOOL=/usr/bin/libtool
239
240%install
241rm -rf $RPM_BUILD_ROOT
242export tagname=CC
243make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
244
245# remove libtool archives for importers and the like
246find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
247find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
248
249# give the libraries some executable bits
250find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
251
252%find_lang %{name}-%{eds_base_version}
253
254%clean
255rm -rf $RPM_BUILD_ROOT
256
257%post -p /sbin/ldconfig
258
259%postun
260/sbin/ldconfig
261if [ $1 -eq 0 ]; then
262  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
263fi
264
265%posttrans
266glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
267
268
269%files -f %{name}-%{eds_base_version}.lang
270%defattr(-,root,root,-)
271%doc README COPYING ChangeLog NEWS AUTHORS
272%{_libdir}/*.so.*
273%{_libdir}/girepository-1.0/*.typelib
274%{_libexecdir}/evolution-addressbook-factory
275%{_libexecdir}/evolution-calendar-factory
276%{_libexecdir}/evolution-scan-gconf-tree-xml
277%{_libexecdir}/evolution-source-registry
278%{_libexecdir}/evolution-user-prompter
279%{_libexecdir}/camel-index-control-%{eds_api_version}
280%{_libexecdir}/camel-lock-helper-%{eds_api_version}
281%{_datadir}/GConf/gsettings/evolution-data-server.convert
282%{_datadir}/dbus-1/services/*
283%{_datadir}/%{name}/evolutionperson.schema
284%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
285%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
286%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
287%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
288%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
289%{_datadir}/pixmaps/evolution-data-server
290
291%dir %{_libdir}/evolution-data-server
292%dir %{camel_provider_dir}
293%dir %{ebook_backends_dir}
294%dir %{ecal_backends_dir}
295%dir %{registry_modules_dir}
296
297%{camel_provider_dir}/libcamelimapx.so
298%{camel_provider_dir}/libcamelimapx.urls
299
300%{camel_provider_dir}/libcamellocal.so
301%{camel_provider_dir}/libcamellocal.urls
302
303%{camel_provider_dir}/libcamelnntp.so
304%{camel_provider_dir}/libcamelnntp.urls
305
306%{camel_provider_dir}/libcamelpop3.so
307%{camel_provider_dir}/libcamelpop3.urls
308
309%{camel_provider_dir}/libcamelsendmail.so
310%{camel_provider_dir}/libcamelsendmail.urls
311
312%{camel_provider_dir}/libcamelsmtp.so
313%{camel_provider_dir}/libcamelsmtp.urls
314
315# e-d-s extensions:
316%{ebook_backends_dir}/libebookbackendfile.so
317%{ebook_backends_dir}/libebookbackendgoogle.so
318%{ebook_backends_dir}/libebookbackendldap.so
319%{ebook_backends_dir}/libebookbackendwebdav.so
320
321%{ecal_backends_dir}/libecalbackendcaldav.so
322%{ecal_backends_dir}/libecalbackendcontacts.so
323%{ecal_backends_dir}/libecalbackendfile.so
324%{ecal_backends_dir}/libecalbackendhttp.so
325%{ecal_backends_dir}/libecalbackendweather.so
326
327%{registry_modules_dir}/module-cache-reaper.so
328%{registry_modules_dir}/module-google-backend.so
329%{registry_modules_dir}/module-gnome-online-accounts.so
330%{registry_modules_dir}/module-outlook-backend.so
331%{registry_modules_dir}/module-owncloud-backend.so
332%{registry_modules_dir}/module-secret-monitor.so
333%{registry_modules_dir}/module-trust-prompt.so
334%{registry_modules_dir}/module-yahoo-backend.so
335
336%files devel
337%defattr(-,root,root,-)
338%{_includedir}/%{name}
339%{_libdir}/*.so
340%{_libdir}/pkgconfig/*.pc
341%{_datadir}/gir-1.0/*.gir
342
343%files doc
344%defattr(-,root,root,-)
345%{_datadir}/gtk-doc/html/camel
346%{_datadir}/gtk-doc/html/eds
347
348%files vala
349%defattr(-,root,root,-)
350%{_datadir}/vala/vapi/libebook-1.2.deps
351%{_datadir}/vala/vapi/libebook-1.2.vapi
352%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
353%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
354%{_datadir}/vala/vapi/libedataserver-1.2.deps
355%{_datadir}/vala/vapi/libedataserver-1.2.vapi
356
357
358%changelog
359* Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
360- new upstream release
361
362* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.3-1
363- new upstream release
364
365* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
366- new upstream release
367
368* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
369- new upstream release
370
371* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
372- new upstream release
373- add BuildRequires: libicu-devel
374
375* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
376- new upstream release
377
378* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
379- new upstream release
380
381* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
382- new upstream release
383
384* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
385- new upstream release
386
387* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
388- new upstream release
389
390* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
391- new upstream release
392
393* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
394- new upstream release
395- add configure option (--disable-uoa)
396- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
397- create %%{name}-vala subpackage
398
399* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
400- new upstream release
401
402* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
403- new upstream release
404
405* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
406- new upstream release
407
408* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
409- new upstream release
410
411* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
412- new upstream release
413
414* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
415- new upstream release
416
417* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
418- new upstream release
419
420* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
421- new upstream release
422
423* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
424- new upstream release
425- add BuildRequires: dbus-glib-devel
426
427* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
428- new upstream release
429
430* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
431- new upstream release
432
433* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
434- new upstream release
435
436* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
437- new upstream release
438
439* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
440- new upstream release
441- remove Patch101
442
443* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
444- new upstream release
445
446* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
447- new upstream release
448- change BuildRequires: gtk3-devel instead of gtk2-devel
449- BuildRequires: gnome-online-accounts-devel
450- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
451- fix %%files
452
453* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
454- new upstream release
455
456* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
457- rebuild with openssl-1.0.0c
458
459* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
460- new upstream release
461- remove Requires: gnome-vfs2, libglade2, libgnomeui
462- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
463- add BuildRequires: libgdata
464- add Requires: nspr-devel, nss-devel (devel package)
465- drop Patch11
466
467* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
468- rebuild with rpm-4.8.1 for pkg-config file
469
470* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
471- new upstream release
472
473* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
474- new upstream release
475
476* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
477- new upstream release
478- remove BuildRequires: libbonobo-devel
479- remove Requires: libbonobo
480- drop Patch10
481- add configure option (--with-krb5-libs, --with-krb5-includes)
482
483* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
484- rebuilt with db4-4.8
485
486* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
487- new upstream release
488
489* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
490- new upstream release
491
492* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
493- new upstream release
494
495* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
496- new upstream release
497
498* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
499- added Requires: libical-devel >= 0.43 to devel package
500
501* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
502- new upstream release
503- add BR: libgweather-devel >= 2.26.0
504- add BR: libical-devel >= 0.43
505
506* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
507- new upstream release
508- added BuildRequires: sqlite3-devel
509
510* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
511- enabled krb5 support
512
513* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
514- new upstream release
515
516* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
517- new upstream release
518
519* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
520- new upstream release
521
522* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
523- new upstream release
524
525* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
526- rebuilt with db4-4.6.21
527
528* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
529- new upstream release
530
531* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
532- new upstream release
533
534* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
535- new upstream release
536
537* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
538- new upstream release based on Fedora package 2.20.0-3.fc9
539  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
540  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
541  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
542  - Add patch for RH bug #296671 (GC servers may not support NTLM).
543  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
544  - Try removing the ancient "ldap-x86_64-hack" patch.
545  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
546  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
547- split doc subpackage
548
549* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
550- fixed dependancy
551
552* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
553- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
554  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
555  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
556  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
557  - Make the new ESourceComboBox widget work properly (RH bug #234760).
558  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
559  - Link to static evolution-openldap library (RH bug #210126).
560  - Require openssl-devel when statically linking against openldap.
561  - Add -Wdeclaration-after-statement to strict build settings.
562  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
563  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
564  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
565  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
566  - Update to 1.10.0
567  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
568  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
569  - Patch by Kenny Root.
570- rebuilt with nss-devel and nspr-devel
571
572* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
573- rebuilt with new toolchain and db4-4.3.x
574
575* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
576- new upstream release
577
578* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
579- new upstream release
580- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
581
582* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
583- new upstream release
584- rebuilt with openssl instead of mozilla-nss
585
586* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
587- rebuilt with openldap-2.3.24-0vl4
588
589* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
590- new upstream release
591- build with libsoap-2.2.7
592
593* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
594- new upstream release
595
596* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
597- new upstream release
598- added/removed Patches based on Fedora packages
599  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
600  - Updated patch 102 to fix further implicit function declarations
601  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
602  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
603    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
604  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
605  - Removed upstreamed patch:
606    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
607  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
608  - added patch to calendar/libecal/e-cal.c to fix missing declaration
609    of open_calendar
610- rebuilt with mozilla-1.7.12
611
612* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
613- rebuilt with mozilla-1.7.7
614
615* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
616- initial build for Vine Linux based on FC package
617- disable krb5 support
618
619* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
620- 1.2.1
621
622* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
623- Removed explicit run-time spec-file requirement on mozilla.
624  The Mozilla NSS API/ABI stabilised by version 1.7.3
625  The libraries are always located in the libdir
626  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
627  and so they move each time the mozilla version changes.
628  So we no longer have an explicit mozilla run-time requirement in the specfile;
629  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
630  We have an explicit, exact build-time version, so that we can find the headers (without
631  invoking an RPM query from the spec file; to do so is considered bad practice)
632- Introduced mozilla_build_version, to replace mozilla_version
633- Set mozilla_build_version to 1.7.6 to reflect current state of tree
634
635* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
636- Added a patch to deal with glibc defining a macro called "read"
637
638* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
639- 1.2.0
640- Removed patch for GCC 4 as this is now in upstream tarball
641
642* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
643- rebuild to fix library linking silliness
644
645* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
646- disabling gtk-doc on ia64 and s390x
647
648* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
649- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
650
651* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
652- extended patch to deal with camel-groupwise-store-summary.c
653
654* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
655- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
656
657* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
658- 1.1.6
659
660* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
661- rebuild
662
663* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
664- forgot to fix sources
665
666* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
667- 1.1.5
668
669* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
670- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
671
672* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
673- disable gtk-doc generation on ia64 for now
674
675* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
676- Exclude ppc64 due to missing mozilla dependency
677
678* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
679- Update from 1.0.3 to 1.1.4.1
680- Updated eds_major from 1.0 to 1.2; fixed translation search path.
681- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
682- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
683- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
684- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
685- Camel code from evolution is now in evolution-data-server:
686  - Added camel-index-control and camel-lock-helper to packaged files
687  - Added mozilla dependency code from the evolution package
688  - Ditto for LDAP
689  - Ditto for krb5
690  - Ditto for NNTP support handling
691  - Ditto for --enable-file-locking and --enable-dot-locking
692- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
693- Updated libsoup requirement from 2.2.1 to 2.2.2
694- Enabled gtk-doc
695
696* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
697- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
698
699* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
700- update from upstream 1.0.2 to 1.0.3:
701  * Address Book
702    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
703    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
704
705  * Calendar
706    #XB59904 - Speed up calendar queries (Rodrigo)
707    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
708    - fix libical build for automake 1.9 (Rodney)
709    - fix putenv usage for portability (Julio M. Merino Vidal)
710
711  * Updated Translations:
712    - sv (Christian Rose)
713
714- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
715
716* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
717- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
718http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
719(The groupwise part of that patch did not cleanly apply, so I removed it).
720
721* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
722- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
723optimisation patch posted to upstream development mailing list here:
724http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
725
726* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
727- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
728
729* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
730- added workaround for a backend leak that causes the "contacts" calendar
731backend to hold open an EBook for the local contacts (filed upstream at:
732http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
733never lose its last addressbook, and hence never quit.  We workaround this by
734detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
735
736* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
737- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
738
739* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
740- update from 1.0.1 to 1.0.2
741- increased libsoup requirement to 2.2.1 to match configuration script
742
743* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
744- update from 1.0.0 to 1.0.1
745- removed patch that fixed warnings in calendar code (now in upstream tarball)
746
747* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
748- fixed various warnings in the calendar code
749  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
750
751* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
752- update from 0.0.99 to 1.0.0
753- changed path in FTP source location from 0.0 to 1.0
754
755* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
756- update from 0.0.98 to 0.0.99
757- increased libsoup requirement to 2.2.0 to match configuration script
758
759* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
760- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
761
762* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
763- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
764
765* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
766- upgraded to 0.0.97; rewrote the package's description
767
768* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
769- rebuilt
770
771* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
772- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
773
774* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
775- 0.0.96; libsoup required is now 2.1.12
776
777* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
778- rebuilt
779
780* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
781- rebuilt
782
783* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
784- 0.0.95
785
786* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
787- 0.0.94.1
788
789* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
790- rebuilt
791
792* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
793- 0.0.94
794
795* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
796- added ORBit2 requirement
797
798* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
799- rebuild again
800
801* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
802- rebuilt
803
804* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
805- 0.0.93; libsoup required is now 2.1.10
806
807* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
808- Update to 0.0.92; added a define and a requirement on the libsoup version
809
810* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
811- 0.0.90
812
813* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
814- rebuilt
815
816* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
817- 0.0.6
818
819* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
820- better fix by using system libtool
821
822* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
823- add some libdb linkage to make the build on x86_64 happy
824
825* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
826- update to 0.0.5
827
828* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
829- Initial build.
Note: See TracBrowser for help on using the repository browser.