source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 805

Revision 805, 24.0 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file of gnome-2.30

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.24.0
8%define gtk2_version 2.20.0
9%define gtk_doc_version 1.14
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.0
12%define soup_version 2.30.0
13%define libgweather_version 2.30.0
14%define libical_version 0.43
15
16%define eds_base_version 2.30
17%define eds_api_version 1.2
18
19%define use_gnome_keyring 1
20%define support_imap4_provider 0
21
22%define camel_provider_dir %{_libdir}/evolution-data-server-%{eds_api_version}/camel-providers
23%define eds_extensions_dir %{_libdir}/evolution-data-server-%{eds_api_version}/extensions
24
25# Use stricter build settings than required by upstream.
26%define strict_build_settings 1
27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
33Version: 2.30.0
34Release: 1%{?_dist_release}
35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
38Source0: %{name}-%{version}.tar.bz2
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #215702 / GNOME bug #487988
44Patch10: evolution-data-server-1.8.0-fix-ldap-query.patch
45
46# GNOME bug #373146
47Patch11: evolution-data-server-1.10.1-camel-folder-summary-crash.patch
48
49# RH bug #243296
50Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
51
52### Dependencies ###
53
54Requires: GConf2
55Requires: ORBit2 >= %{orbit2_version}
56Requires: gnome-vfs2
57Requires: libglade2
58Requires: libgnomeui
59Requires: libsoup >= %{soup_version}
60
61### Build Dependencies ###
62
63BuildRequires: GConf2-devel
64BuildRequires: ORBit2-devel >= %{orbit2_version}
65BuildRequires: bison
66BuildRequires: db4-devel
67BuildRequires: flex
68BuildRequires: gettext
69BuildRequires: glib2-devel
70BuildRequires: gnome-vfs2-devel
71BuildRequires: gnutls-devel
72BuildRequires: intltool >= %{intltool_version}
73BuildRequires: libglade2-devel
74BuildRequires: libgnome-devel
75BuildRequires: libgnomeui-devel
76BuildRequires: libsoup-devel >= %{soup_version}
77BuildRequires: libtool
78BuildRequires: libgnome-keyring-devel
79BuildRequires: gtk-doc >= 1.14
80BuildRequires: sqlite3-devel
81BuildRequires: libgweather-devel >= %{libgweather_version}
82BuildRequires: libical-devel >= %{libical_version}
83BuildRequires: gperf
84BuildRequires: krb5-devel
85
86%if %{use_nss}
87BuildRequires: nspr-devel
88BuildRequires: nss-devel
89%else
90BuildRequires: openssl-devel
91%endif
92
93%if %{ldap_support}
94%if %{static_ldap}
95BuildRequires: openldap-evolution-devel
96BuildRequires: openssl-devel
97%else
98BuildRequires: openldap-devel >= 2.0.11
99%endif
100%endif
101
102%if %{krb5_support}
103BuildRequires: krb5-devel
104# tweak for krb5 1.2 vs 1.3
105%define krb5dir /usr/kerberos
106#define krb5dir `pwd`/krb5-fakeprefix
107%endif
108
109%description
110The evolution-data-server package provides a unified backend for
111programs that work with contacts, tasks, and calendar information.
112
113It was originally developed for Evolution (hence the name), but
114is now used by other packages.
115
116%package devel
117Summary: Development files for building against evolution-data-server
118Group: Development/Libraries
119Requires: %{name} = %{version}-%{release}
120Requires: libgnome-devel
121Requires: libgweather-devel
122Requires: libsoup-devel
123Requires: libical-devel >= %{libical_version}
124Requires: sqlite3-devel
125
126%description devel
127Development files needed for building things which link against
128evolution-data-server.
129
130%package doc
131Summary: Documentation files for %{name}
132Group: Applications/Documentation
133
134%description doc
135This package contains developer documentation for %{name}.
136
137%prep
138%setup -q
139
140## %patch10 -p1 -b .fix-ldap-query
141%patch11 -p1 -b .camel-folder-summary-crash
142%patch12 -p1 -b .fix-64bit-acinclude
143
144mkdir -p krb5-fakeprefix/include
145mkdir -p krb5-fakeprefix/lib
146mkdir -p krb5-fakeprefix/%{_lib}
147
148%build
149%if %{ldap_support}
150
151%if %{static_ldap}
152%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
153# Set LIBS so that configure will be able to link with static LDAP libraries,
154# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
155if pkg-config libssl ; then
156        export LIBS="-lsasl2 `pkg-config --libs libssl`"
157else
158        export LIBS="-lsasl2 -lssl -lcrypto"
159fi
160%else
161%define ldap_flags --with-openldap=yes
162%endif
163
164%else
165%define ldap_flags --without-openldap
166%endif
167
168%if %{krb5_support}
169%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
170%else
171%define krb5_flags --without-krb5
172%endif
173
174%if %{nntp_support}
175%define nntp_flags --enable-nntp=yes
176%else
177%define nntp_flags --enable-nntp=no
178%endif
179
180%if %{use_nss}
181%define ssl_flags --enable-nss=yes --enable-smime=yes
182%else
183%define ssl_flags --enable-openssl=yes
184%endif
185
186%if %{use_nss}
187if ! pkg-config --exists nss; then
188  echo "Unable to find suitable version of nss to use!"
189  exit 1
190fi
191%endif
192
193%if %{use_gnome_keyring}
194%define keyring_flags --enable-gnome-keyring
195%else
196%define keyring flags --disable-gnome-keyring
197%endif
198
199%if %{support_imap4_provider}
200%define imap4_flags --enable-imap4=yes
201%else
202%define imap4_flags --enable-imap4=no
203%endif
204
205export CPPFLAGS="-I%{_includedir}/et"
206export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
207%if ! %{use_nss}
208if pkg-config openssl ; then
209        CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
210        LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
211fi
212%endif
213
214# Add stricter build settings here as the source code gets cleaned up.
215# We want to make sure things like compiler warnings and avoiding deprecated
216# functions in the GNOME/GTK+ libraries stay fixed.
217#
218# Please file a bug report at bugzilla.gnome.org if these settings break
219# compilation, and encourage the upstream developers to use them.
220
221%if %{strict_build_settings}
222CFLAGS="$CFLAGS \
223        -DG_DISABLE_DEPRECATED=1 \
224        -DPANGO_DISABLE_DEPRECATED=1 \
225        -DGDK_PIXBUF_DISABLE_DEPRECATED=1 \
226        -DGDK_DISABLE_DEPRECATED=1 \
227        -Wdeclaration-after-statement \
228        -Werror-implicit-function-declaration"
229%endif
230
231# Regenerate configure to pick up configure.in and acinclude.m4 changes.
232aclocal -I m4
233autoheader
234automake
235libtoolize
236intltoolize --force
237autoconf
238
239# See Ross Burton's blog entry for why we want --with-libdb.
240# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
241
242%configure \
243        --with-libdb=/usr \
244        --enable-file-locking=fcntl \
245        --enable-dot-locking=no \
246        --enable-gtk-doc \
247        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
248        %keyring_flags
249export tagname=CC
250make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
251
252%install
253rm -rf $RPM_BUILD_ROOT
254export tagname=CC
255make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
256
257# remove libtool archives for importers and the like
258find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
259rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
260rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server-%{eds_api_version}/camel-providers/*.a
261rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server-%{eds_api_version}/extensions/*.a
262
263# give the libraries some executable bits
264find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
265
266%find_lang %{name}-%{eds_base_version}
267
268%clean
269rm -rf $RPM_BUILD_ROOT
270
271%post -p /sbin/ldconfig
272
273%postun -p /sbin/ldconfig
274
275%files -f %{name}-%{eds_base_version}.lang
276%defattr(-,root,root,-)
277%doc README COPYING ChangeLog NEWS AUTHORS
278%{_libdir}/*.so.*
279%{_libexecdir}/e-addressbook-factory
280%{_libexecdir}/e-calendar-factory
281%{_libexecdir}/camel-index-control-%{eds_api_version}
282%{_libexecdir}/camel-lock-helper-%{eds_api_version}
283%{_datadir}/evolution-data-server-%{eds_base_version}
284## %{_datadir}/idl/evolution-data-server-%{eds_api_version}
285%{_datadir}/pixmaps/evolution-data-server
286#{_libdir}/evolution-data-server-%{eds_api_version}
287%{_datadir}/dbus-1/services/*
288
289%dir %{_libdir}/evolution-data-server-%{eds_api_version}
290%dir %{camel_provider_dir}
291%dir %{eds_extensions_dir}
292
293# Camel providers:
294%{camel_provider_dir}/libcamelgroupwise.so
295%{camel_provider_dir}/libcamelgroupwise.urls
296
297%{camel_provider_dir}/libcamelimap.so
298%{camel_provider_dir}/libcamelimap.urls
299
300%if %{support_imap4_provider}
301%{camel_provider_dir}/libcamelimap4.so
302%{camel_provider_dir}/libcamelimap4.urls
303%endif
304
305%{camel_provider_dir}/libcamellocal.so
306%{camel_provider_dir}/libcamellocal.urls
307
308%{camel_provider_dir}/libcamelnntp.so
309%{camel_provider_dir}/libcamelnntp.urls
310
311%{camel_provider_dir}/libcamelpop3.so
312%{camel_provider_dir}/libcamelpop3.urls
313
314%{camel_provider_dir}/libcamelsendmail.so
315%{camel_provider_dir}/libcamelsendmail.urls
316
317%{camel_provider_dir}/libcamelsmtp.so
318%{camel_provider_dir}/libcamelsmtp.urls
319
320%{camel_provider_dir}/libcamelimapx.so
321%{camel_provider_dir}/libcamelimapx.urls
322
323# e-d-s extensions:
324%{eds_extensions_dir}/libebookbackendfile.so
325%{eds_extensions_dir}/libebookbackendgoogle.so
326%{eds_extensions_dir}/libebookbackendgroupwise.so
327%{eds_extensions_dir}/libebookbackendldap.so
328%{eds_extensions_dir}/libebookbackendvcf.so
329%{eds_extensions_dir}/libebookbackendwebdav.so
330%{eds_extensions_dir}/libecalbackendcontacts.so
331%{eds_extensions_dir}/libecalbackendfile.so
332%{eds_extensions_dir}/libecalbackendgroupwise.so
333%{eds_extensions_dir}/libecalbackendhttp.so
334%{eds_extensions_dir}/libecalbackendweather.so
335%{eds_extensions_dir}/libecalbackendcaldav.so
336%{eds_extensions_dir}/libecalbackendgoogle.so
337
338%files devel
339%defattr(-,root,root,-)
340%{_includedir}/evolution-data-server-%{eds_base_version}
341%{_libdir}/*.so
342%{_libdir}/pkgconfig/*.pc
343
344%files doc
345%defattr(-,root,root,-)
346%{_datadir}/gtk-doc/html/camel
347%{_datadir}/gtk-doc/html/libebackend
348%{_datadir}/gtk-doc/html/libebook
349%{_datadir}/gtk-doc/html/libecal
350%{_datadir}/gtk-doc/html/libedata-book
351%{_datadir}/gtk-doc/html/libedata-cal
352%{_datadir}/gtk-doc/html/libedataserver
353%{_datadir}/gtk-doc/html/libedataserverui
354
355%changelog
356* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
357- new upstream release
358- remove BuildRequires: libbonobo-devel
359- remove Requires: libbonobo
360- drop Patch10
361- add configure option (--with-krb5-libs, --with-krb5-includes)
362
363* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
364- rebuilt with db4-4.8
365
366* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
367- new upstream release
368
369* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
370- new upstream release
371
372* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
373- new upstream release
374
375* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
376- new upstream release
377
378* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
379- added Requires: libical-devel >= 0.43 to devel package
380
381* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
382- new upstream release
383- add BR: libgweather-devel >= 2.26.0
384- add BR: libical-devel >= 0.43
385
386* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
387- new upstream release
388- added BuildRequires: sqlite3-devel
389
390* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
391- enabled krb5 support
392
393* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
394- new upstream release
395
396* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
397- new upstream release
398
399* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
400- new upstream release
401
402* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
403- new upstream release
404
405* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
406- rebuilt with db4-4.6.21
407
408* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
409- new upstream release
410
411* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
412- new upstream release
413
414* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
415- new upstream release
416
417* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
418- new upstream release based on Fedora package 2.20.0-3.fc9
419  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
420  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
421  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
422  - Add patch for RH bug #296671 (GC servers may not support NTLM).
423  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
424  - Try removing the ancient "ldap-x86_64-hack" patch.
425  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
426  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
427- split doc subpackage
428
429* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
430- fixed dependancy
431
432* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
433- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
434  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
435  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
436  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
437  - Make the new ESourceComboBox widget work properly (RH bug #234760).
438  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
439  - Link to static evolution-openldap library (RH bug #210126).
440  - Require openssl-devel when statically linking against openldap.
441  - Add -Wdeclaration-after-statement to strict build settings.
442  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
443  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
444  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
445  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
446  - Update to 1.10.0
447  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
448  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
449  - Patch by Kenny Root.
450- rebuilt with nss-devel and nspr-devel
451
452* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
453- rebuilt with new toolchain and db4-4.3.x
454
455* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
456- new upstream release
457
458* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
459- new upstream release
460- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
461
462* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
463- new upstream release
464- rebuilt with openssl instead of mozilla-nss
465
466* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
467- rebuilt with openldap-2.3.24-0vl4
468
469* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
470- new upstream release
471- build with libsoap-2.2.7
472
473* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
474- new upstream release
475
476* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
477- new upstream release
478- added/removed Patches based on Fedora packages
479  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
480  - Updated patch 102 to fix further implicit function declarations
481  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
482  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
483    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
484  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
485  - Removed upstreamed patch:
486    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
487  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
488  - added patch to calendar/libecal/e-cal.c to fix missing declaration
489    of open_calendar
490- rebuilt with mozilla-1.7.12
491
492* Thu May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
493- rebuilt with mozilla-1.7.7
494
495* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
496- initial build for Vine Linux based on FC package
497- disable krb5 support
498
499* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
500- 1.2.1
501
502* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
503- Removed explicit run-time spec-file requirement on mozilla.
504  The Mozilla NSS API/ABI stabilised by version 1.7.3
505  The libraries are always located in the libdir
506  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
507  and so they move each time the mozilla version changes.
508  So we no longer have an explicit mozilla run-time requirement in the specfile;
509  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
510  We have an explicit, exact build-time version, so that we can find the headers (without
511  invoking an RPM query from the spec file; to do so is considered bad practice)
512- Introduced mozilla_build_version, to replace mozilla_version
513- Set mozilla_build_version to 1.7.6 to reflect current state of tree
514
515* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
516- Added a patch to deal with glibc defining a macro called "read"
517
518* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
519- 1.2.0
520- Removed patch for GCC 4 as this is now in upstream tarball
521
522* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
523- rebuild to fix library linking silliness
524
525* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
526- disabling gtk-doc on ia64 and s390x
527
528* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
529- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
530
531* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
532- extended patch to deal with camel-groupwise-store-summary.c
533
534* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
535- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
536
537* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
538- 1.1.6
539
540* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
541- rebuild
542
543* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
544- forgot to fix sources
545
546* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
547- 1.1.5
548
549* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
550- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
551
552* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
553- disable gtk-doc generation on ia64 for now
554
555* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
556- Exclude ppc64 due to missing mozilla dependency
557
558* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
559- Update from 1.0.3 to 1.1.4.1
560- Updated eds_major from 1.0 to 1.2; fixed translation search path.
561- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
562- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
563- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
564- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
565- Camel code from evolution is now in evolution-data-server:
566  - Added camel-index-control and camel-lock-helper to packaged files
567  - Added mozilla dependency code from the evolution package
568  - Ditto for LDAP
569  - Ditto for krb5
570  - Ditto for NNTP support handling
571  - Ditto for --enable-file-locking and --enable-dot-locking
572- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
573- Updated libsoup requirement from 2.2.1 to 2.2.2
574- Enabled gtk-doc
575
576* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
577- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
578
579* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
580- update from upstream 1.0.2 to 1.0.3:
581  * Address Book
582    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
583    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
584
585  * Calendar
586    #XB59904 - Speed up calendar queries (Rodrigo)
587    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
588    - fix libical build for automake 1.9 (Rodney)
589    - fix putenv usage for portability (Julio M. Merino Vidal)
590
591  * Updated Translations:
592    - sv (Christian Rose)
593
594- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
595
596* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
597- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
598http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
599(The groupwise part of that patch did not cleanly apply, so I removed it).
600
601* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
602- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
603optimisation patch posted to upstream development mailing list here:
604http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
605
606* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
607- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
608
609* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
610- added workaround for a backend leak that causes the "contacts" calendar
611backend to hold open an EBook for the local contacts (filed upstream at:
612http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
613never lose its last addressbook, and hence never quit.  We workaround this by
614detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
615
616* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
617- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
618
619* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
620- update from 1.0.1 to 1.0.2
621- increased libsoup requirement to 2.2.1 to match configuration script
622
623* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
624- update from 1.0.0 to 1.0.1
625- removed patch that fixed warnings in calendar code (now in upstream tarball)
626
627* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
628- fixed various warnings in the calendar code
629  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
630
631* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
632- update from 0.0.99 to 1.0.0
633- changed path in FTP source location from 0.0 to 1.0
634
635* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
636- update from 0.0.98 to 0.0.99
637- increased libsoup requirement to 2.2.0 to match configuration script
638
639* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
640- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
641
642* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
643- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
644
645* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
646- upgraded to 0.0.97; rewrote the package's description
647
648* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
649- rebuilt
650
651* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
652- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
653
654* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
655- 0.0.96; libsoup required is now 2.1.12
656
657* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
658- rebuilt
659
660* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
661- rebuilt
662
663* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
664- 0.0.95
665
666* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
667- 0.0.94.1
668
669* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
670- rebuilt
671
672* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
673- 0.0.94
674
675* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
676- added ORBit2 requirement
677
678* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
679- rebuild again
680
681* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
682- rebuilt
683
684* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
685- 0.0.93; libsoup required is now 2.1.10
686
687* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
688- Update to 0.0.92; added a define and a requirement on the libsoup version
689
690* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
691- 0.0.90
692
693* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
694- rebuilt
695
696* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
697- 0.0.6
698
699* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
700- better fix by using system libtool
701
702* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
703- add some libdb linkage to make the build on x86_64 happy
704
705* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
706- update to 0.0.5
707
708* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
709- Initial build.
Note: See TracBrowser for help on using the repository browser.