source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 521

Revision 521, 23.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.20.0
8%define gtk2_version 2.16.0
9%define gtk_doc_version 1.9
10%define intltool_version 0.35.5
11%define libbonobo_version 2.24.1
12%define orbit2_version 2.14.0
13%define soup_version 2.26.0
14%define libgweather_version 2.26.0
15%define libical_version 0.43
16
17%define eds_base_version 2.28
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server-%{eds_api_version}/camel-providers
24%define eds_extensions_dir %{_libdir}/evolution-data-server-%{eds_api_version}/extensions
25
26# Use stricter build settings than required by upstream.
27%define strict_build_settings 1
28
29### Abstract ###
30
31Summary: Backend data server for evolution
32Summary(ja): Evolution バックエンドデータサーバ
33Name: evolution-data-server
34Version: 2.28.1
35Release: 2%{?_dist_release}
36License: LGPL
37Group: System Environment/Libraries
38URL: http://www.gnome.org/projects/evolution/
39Source0: %{name}-%{version}.tar.bz2
40BuildRoot: %{_tmppath}/%{name}-%{version}-root
41
42### Patches ###
43
44# RH bug #215702 / GNOME bug #487988
45Patch10: evolution-data-server-1.8.0-fix-ldap-query.patch
46
47# GNOME bug #373146
48Patch11: evolution-data-server-1.10.1-camel-folder-summary-crash.patch
49
50# RH bug #243296
51Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
52
53### Dependencies ###
54
55Requires: GConf2
56Requires: ORBit2 >= %{orbit2_version}
57Requires: gnome-vfs2
58Requires: libbonobo >= %{libbonobo_version}
59Requires: libglade2
60Requires: libgnomeui
61Requires: libsoup >= %{soup_version}
62
63### Build Dependencies ###
64
65BuildRequires: GConf2-devel
66BuildRequires: ORBit2-devel >= %{orbit2_version}
67BuildRequires: bison
68BuildRequires: db4-devel
69BuildRequires: flex
70BuildRequires: gettext
71BuildRequires: glib2-devel
72BuildRequires: gnome-vfs2-devel
73BuildRequires: gnutls-devel
74BuildRequires: intltool >= %{intltool_version}
75BuildRequires: libbonobo-devel >= %{libbonobo_version}
76BuildRequires: libglade2-devel
77BuildRequires: libgnome-devel
78BuildRequires: libgnomeui-devel
79BuildRequires: libsoup-devel >= %{soup_version}
80BuildRequires: libtool
81BuildRequires: gnome-keyring-devel
82BuildRequires: gtk-doc >= 1.9
83BuildRequires: sqlite3-devel
84BuildRequires: libgweather-devel >= %{libgweather_version}
85BuildRequires: libical-devel >= %{libical_version}
86
87%if %{use_nss}
88BuildRequires: nspr-devel
89BuildRequires: nss-devel
90%else
91BuildRequires: openssl-devel
92%endif
93
94%if %{ldap_support}
95%if %{static_ldap}
96BuildRequires: openldap-evolution-devel
97BuildRequires: openssl-devel
98%else
99BuildRequires: openldap-devel >= 2.0.11
100%endif
101%endif
102
103%if %{krb5_support}
104BuildRequires: krb5-devel
105# tweak for krb5 1.2 vs 1.3
106%define krb5dir /usr/kerberos
107#define krb5dir `pwd`/krb5-fakeprefix
108%endif
109
110%description
111The evolution-data-server package provides a unified backend for
112programs that work with contacts, tasks, and calendar information.
113
114It was originally developed for Evolution (hence the name), but
115is now used by other packages.
116
117%package devel
118Summary: Development files for building against evolution-data-server
119Group: Development/Libraries
120Requires: %{name} = %{version}-%{release}
121Requires: libbonobo-devel
122Requires: libgnome-devel
123Requires: libgweather-devel
124Requires: libsoup-devel
125Requires: libical-devel >= %{libical_version}
126Requires: sqlite3-devel
127
128%description devel
129Development files needed for building things which link against
130evolution-data-server.
131
132%package doc
133Summary: Documentation files for %{name}
134Group: Applications/Documentation
135
136%description doc
137This package contains developer documentation for %{name}.
138
139%prep
140%setup -q
141
142%patch10 -p1 -b .fix-ldap-query
143%patch11 -p1 -b .camel-folder-summary-crash
144%patch12 -p1 -b .fix-64bit-acinclude
145
146mkdir -p krb5-fakeprefix/include
147mkdir -p krb5-fakeprefix/lib
148mkdir -p krb5-fakeprefix/%{_lib}
149
150%build
151%if %{ldap_support}
152
153%if %{static_ldap}
154%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
155# Set LIBS so that configure will be able to link with static LDAP libraries,
156# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
157if pkg-config openssl ; then
158        export LIBS="-lsasl2 `pkg-config --libs openssl`"
159else
160        export LIBS="-lsasl2 -lssl -lcrypto"
161fi
162%else
163%define ldap_flags --with-openldap=yes
164%endif
165
166%else
167%define ldap_flags --without-openldap
168%endif
169
170%if %{krb5_support}
171%define krb5_flags --with-krb5=%{krb5dir}
172%else
173%define krb5_flags --without-krb5
174%endif
175
176%if %{nntp_support}
177%define nntp_flags --enable-nntp=yes
178%else
179%define nntp_flags --enable-nntp=no
180%endif
181
182%if %{use_nss}
183%define ssl_flags --enable-nss=yes --enable-smime=yes
184%else
185%define ssl_flags --enable-openssl=yes
186%endif
187
188%if %{use_nss}
189if ! pkg-config --exists nss; then
190  echo "Unable to find suitable version of nss to use!"
191  exit 1
192fi
193%endif
194
195%if %{use_gnome_keyring}
196%define keyring_flags --enable-gnome-keyring
197%else
198%define keyring flags --disable-gnome-keyring
199%endif
200
201%if %{support_imap4_provider}
202%define imap4_flags --enable-imap4=yes
203%else
204%define imap4_flags --enable-imap4=no
205%endif
206
207export CPPFLAGS="-I%{_includedir}/et"
208export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
209%if ! %{use_nss}
210if pkg-config openssl ; then
211        CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
212        LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
213fi
214%endif
215
216# Add stricter build settings here as the source code gets cleaned up.
217# We want to make sure things like compiler warnings and avoiding deprecated
218# functions in the GNOME/GTK+ libraries stay fixed.
219#
220# Please file a bug report at bugzilla.gnome.org if these settings break
221# compilation, and encourage the upstream developers to use them.
222
223%if %{strict_build_settings}
224CFLAGS="$CFLAGS \
225        -DG_DISABLE_DEPRECATED=1 \
226        -DPANGO_DISABLE_DEPRECATED=1 \
227        -DGDK_PIXBUF_DISABLE_DEPRECATED=1 \
228        -DGDK_DISABLE_DEPRECATED=1 \
229        -Wdeclaration-after-statement \
230        -Werror-implicit-function-declaration"
231%endif
232
233# Regenerate configure to pick up configure.in and acinclude.m4 changes.
234aclocal -I m4
235autoheader
236automake
237libtoolize
238intltoolize --force
239autoconf
240
241# See Ross Burton's blog entry for why we want --with-libdb.
242# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
243
244%configure \
245        --with-libdb=/usr \
246        --enable-file-locking=fcntl \
247        --enable-dot-locking=no \
248        --enable-gtk-doc \
249        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
250        %keyring_flags
251export tagname=CC
252make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
253
254%install
255rm -rf $RPM_BUILD_ROOT
256export tagname=CC
257make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
258
259# remove libtool archives for importers and the like
260find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
261rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
262rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server-%{eds_api_version}/camel-providers/*.a
263rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server-%{eds_api_version}/extensions/*.a
264
265# give the libraries some executable bits
266find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
267
268%find_lang %{name}-%{eds_base_version}
269
270%clean
271rm -rf $RPM_BUILD_ROOT
272
273%post -p /sbin/ldconfig
274
275%postun -p /sbin/ldconfig
276
277%files -f %{name}-%{eds_base_version}.lang
278%defattr(-,root,root,-)
279%doc README COPYING ChangeLog NEWS AUTHORS
280%{_libdir}/bonobo/servers/*
281%{_libdir}/*.so.*
282%{_libexecdir}/evolution-data-server-%{eds_base_version}
283%{_libexecdir}/camel-index-control-%{eds_api_version}
284%{_libexecdir}/camel-lock-helper-%{eds_api_version}
285%{_datadir}/evolution-data-server-%{eds_base_version}
286%{_datadir}/idl/evolution-data-server-%{eds_api_version}
287%{_datadir}/pixmaps/evolution-data-server
288#{_libdir}/evolution-data-server-%{eds_api_version}
289
290%dir %{_libdir}/evolution-data-server-%{eds_api_version}
291%dir %{camel_provider_dir}
292%dir %{eds_extensions_dir}
293
294# Camel providers:
295%{camel_provider_dir}/libcamelgroupwise.so
296%{camel_provider_dir}/libcamelgroupwise.urls
297
298%{camel_provider_dir}/libcamelimap.so
299%{camel_provider_dir}/libcamelimap.urls
300
301%if %{support_imap4_provider}
302%{camel_provider_dir}/libcamelimap4.so
303%{camel_provider_dir}/libcamelimap4.urls
304%endif
305
306%{camel_provider_dir}/libcamellocal.so
307%{camel_provider_dir}/libcamellocal.urls
308
309%{camel_provider_dir}/libcamelnntp.so
310%{camel_provider_dir}/libcamelnntp.urls
311
312%{camel_provider_dir}/libcamelpop3.so
313%{camel_provider_dir}/libcamelpop3.urls
314
315%{camel_provider_dir}/libcamelsendmail.so
316%{camel_provider_dir}/libcamelsendmail.urls
317
318%{camel_provider_dir}/libcamelsmtp.so
319%{camel_provider_dir}/libcamelsmtp.urls
320
321# e-d-s extensions:
322%{eds_extensions_dir}/libebookbackendfile.so
323%{eds_extensions_dir}/libebookbackendgoogle.so
324%{eds_extensions_dir}/libebookbackendgroupwise.so
325%{eds_extensions_dir}/libebookbackendldap.so
326%{eds_extensions_dir}/libebookbackendvcf.so
327%{eds_extensions_dir}/libebookbackendwebdav.so
328%{eds_extensions_dir}/libecalbackendcontacts.so
329%{eds_extensions_dir}/libecalbackendfile.so
330%{eds_extensions_dir}/libecalbackendgroupwise.so
331%{eds_extensions_dir}/libecalbackendhttp.so
332%{eds_extensions_dir}/libecalbackendweather.so
333%{eds_extensions_dir}/libecalbackendcaldav.so
334%{eds_extensions_dir}/libecalbackendgoogle.so
335
336%files devel
337%defattr(-,root,root,-)
338%{_includedir}/evolution-data-server-%{eds_base_version}
339%{_libdir}/*.so
340%{_libdir}/pkgconfig/*.pc
341
342%files doc
343%defattr(-,root,root,-)
344%{_datadir}/gtk-doc/html/camel
345%{_datadir}/gtk-doc/html/libebackend
346%{_datadir}/gtk-doc/html/libebook
347%{_datadir}/gtk-doc/html/libecal
348%{_datadir}/gtk-doc/html/libedata-book
349%{_datadir}/gtk-doc/html/libedata-cal
350%{_datadir}/gtk-doc/html/libedataserver
351%{_datadir}/gtk-doc/html/libedataserverui
352
353%changelog
354* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
355- rebuilt with db4-4.8
356
357* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
358- new upstream release
359
360* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
361- new upstream release
362
363* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
364- new upstream release
365
366* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
367- new upstream release
368
369* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
370- added Requires: libical-devel >= 0.43 to devel package
371
372* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
373- new upstream release
374- add BR: libgweather-devel >= 2.26.0
375- add BR: libical-devel >= 0.43
376
377* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
378- new upstream release
379- added BuildRequires: sqlite3-devel
380
381* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
382- enabled krb5 support
383
384* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
385- new upstream release
386
387* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
388- new upstream release
389
390* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
391- new upstream release
392
393* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
394- new upstream release
395
396* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
397- rebuilt with db4-4.6.21
398
399* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
400- new upstream release
401
402* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
403- new upstream release
404
405* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
406- new upstream release
407
408* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
409- new upstream release based on Fedora package 2.20.0-3.fc9
410  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
411  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
412  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
413  - Add patch for RH bug #296671 (GC servers may not support NTLM).
414  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
415  - Try removing the ancient "ldap-x86_64-hack" patch.
416  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
417  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
418- split doc subpackage
419
420* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
421- fixed dependancy
422
423* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
424- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
425  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
426  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
427  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
428  - Make the new ESourceComboBox widget work properly (RH bug #234760).
429  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
430  - Link to static evolution-openldap library (RH bug #210126).
431  - Require openssl-devel when statically linking against openldap.
432  - Add -Wdeclaration-after-statement to strict build settings.
433  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
434  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
435  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
436  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
437  - Update to 1.10.0
438  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
439  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
440  - Patch by Kenny Root.
441- rebuilt with nss-devel and nspr-devel
442
443* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
444- rebuilt with new toolchain and db4-4.3.x
445
446* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
447- new upstream release
448
449* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
450- new upstream release
451- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
452
453* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
454- new upstream release
455- rebuilt with openssl instead of mozilla-nss
456
457* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
458- rebuilt with openldap-2.3.24-0vl4
459
460* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
461- new upstream release
462- build with libsoap-2.2.7
463
464* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
465- new upstream release
466
467* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
468- new upstream release
469- added/removed Patches based on Fedora packages
470  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
471  - Updated patch 102 to fix further implicit function declarations
472  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
473  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
474    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
475  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
476  - Removed upstreamed patch:
477    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
478  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
479  - added patch to calendar/libecal/e-cal.c to fix missing declaration
480    of open_calendar
481- rebuilt with mozilla-1.7.12
482
483* Thu May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
484- rebuilt with mozilla-1.7.7
485
486* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
487- initial build for Vine Linux based on FC package
488- disable krb5 support
489
490* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
491- 1.2.1
492
493* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
494- Removed explicit run-time spec-file requirement on mozilla.
495  The Mozilla NSS API/ABI stabilised by version 1.7.3
496  The libraries are always located in the libdir
497  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
498  and so they move each time the mozilla version changes.
499  So we no longer have an explicit mozilla run-time requirement in the specfile;
500  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
501  We have an explicit, exact build-time version, so that we can find the headers (without
502  invoking an RPM query from the spec file; to do so is considered bad practice)
503- Introduced mozilla_build_version, to replace mozilla_version
504- Set mozilla_build_version to 1.7.6 to reflect current state of tree
505
506* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
507- Added a patch to deal with glibc defining a macro called "read"
508
509* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
510- 1.2.0
511- Removed patch for GCC 4 as this is now in upstream tarball
512
513* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
514- rebuild to fix library linking silliness
515
516* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
517- disabling gtk-doc on ia64 and s390x
518
519* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
520- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
521
522* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
523- extended patch to deal with camel-groupwise-store-summary.c
524
525* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
526- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
527
528* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
529- 1.1.6
530
531* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
532- rebuild
533
534* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
535- forgot to fix sources
536
537* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
538- 1.1.5
539
540* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
541- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
542
543* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
544- disable gtk-doc generation on ia64 for now
545
546* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
547- Exclude ppc64 due to missing mozilla dependency
548
549* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
550- Update from 1.0.3 to 1.1.4.1
551- Updated eds_major from 1.0 to 1.2; fixed translation search path.
552- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
553- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
554- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
555- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
556- Camel code from evolution is now in evolution-data-server:
557  - Added camel-index-control and camel-lock-helper to packaged files
558  - Added mozilla dependency code from the evolution package
559  - Ditto for LDAP
560  - Ditto for krb5
561  - Ditto for NNTP support handling
562  - Ditto for --enable-file-locking and --enable-dot-locking
563- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
564- Updated libsoup requirement from 2.2.1 to 2.2.2
565- Enabled gtk-doc
566
567* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
568- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
569
570* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
571- update from upstream 1.0.2 to 1.0.3:
572  * Address Book
573    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
574    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
575
576  * Calendar
577    #XB59904 - Speed up calendar queries (Rodrigo)
578    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
579    - fix libical build for automake 1.9 (Rodney)
580    - fix putenv usage for portability (Julio M. Merino Vidal)
581
582  * Updated Translations:
583    - sv (Christian Rose)
584
585- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
586
587* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
588- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
589http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
590(The groupwise part of that patch did not cleanly apply, so I removed it).
591
592* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
593- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
594optimisation patch posted to upstream development mailing list here:
595http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
596
597* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
598- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
599
600* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
601- added workaround for a backend leak that causes the "contacts" calendar
602backend to hold open an EBook for the local contacts (filed upstream at:
603http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
604never lose its last addressbook, and hence never quit.  We workaround this by
605detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
606
607* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
608- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
609
610* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
611- update from 1.0.1 to 1.0.2
612- increased libsoup requirement to 2.2.1 to match configuration script
613
614* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
615- update from 1.0.0 to 1.0.1
616- removed patch that fixed warnings in calendar code (now in upstream tarball)
617
618* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
619- fixed various warnings in the calendar code
620  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
621
622* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
623- update from 0.0.99 to 1.0.0
624- changed path in FTP source location from 0.0 to 1.0
625
626* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
627- update from 0.0.98 to 0.0.99
628- increased libsoup requirement to 2.2.0 to match configuration script
629
630* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
631- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
632
633* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
634- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
635
636* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
637- upgraded to 0.0.97; rewrote the package's description
638
639* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
640- rebuilt
641
642* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
643- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
644
645* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
646- 0.0.96; libsoup required is now 2.1.12
647
648* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
649- rebuilt
650
651* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
652- rebuilt
653
654* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
655- 0.0.95
656
657* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
658- 0.0.94.1
659
660* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
661- rebuilt
662
663* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
664- 0.0.94
665
666* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
667- added ORBit2 requirement
668
669* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
670- rebuild again
671
672* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
673- rebuilt
674
675* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
676- 0.0.93; libsoup required is now 2.1.10
677
678* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
679- Update to 0.0.92; added a define and a requirement on the libsoup version
680
681* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
682- 0.0.90
683
684* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
685- rebuilt
686
687* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
688- 0.0.6
689
690* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
691- better fix by using system libtool
692
693* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
694- add some libdb linkage to make the build on x86_64 happy
695
696* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
697- update to 0.0.5
698
699* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
700- Initial build.
Note: See TracBrowser for help on using the repository browser.