source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 2041

Revision 2041, 24.6 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.26.0
8%define gtk2_version 2.22.0
9%define gtk_doc_version 1.14
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.32.0
13%define libgweather_version 2.30.3
14%define libical_version 0.44
15%define libgdata_version 0.6.5
16
17%define eds_base_version 2.32
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server-%{eds_api_version}/camel-providers
24%define eds_extensions_dir %{_libdir}/evolution-data-server-%{eds_api_version}/extensions
25
26# Use stricter build settings than required by upstream.
27%define strict_build_settings 1
28
29### Abstract ###
30
31Summary: Backend data server for evolution
32Summary(ja): Evolution バックエンドデータサーバ
33Name: evolution-data-server
34Version: 2.32.0
35Release: 1%{?_dist_release}
36License: LGPL
37Group: System Environment/Libraries
38URL: http://www.gnome.org/projects/evolution/
39Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/2.32/%{name}-%{version}.tar.bz2
40BuildRoot: %{_tmppath}/%{name}-%{version}-root
41
42### Patches ###
43
44# RH bug #215702 / GNOME bug #487988
45Patch10: evolution-data-server-1.8.0-fix-ldap-query.patch
46
47# GNOME bug #373146
48Patch11: evolution-data-server-1.10.1-camel-folder-summary-crash.patch
49
50# RH bug #243296
51Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
52
53### Dependencies ###
54
55Requires: GConf2
56Requires: ORBit2 >= %{orbit2_version}
57Requires: libsoup >= %{soup_version}
58
59### Build Dependencies ###
60
61BuildRequires: GConf2-devel
62BuildRequires: ORBit2-devel >= %{orbit2_version}
63BuildRequires: bison
64BuildRequires: db4-devel
65BuildRequires: flex
66BuildRequires: gettext
67BuildRequires: glib2-devel
68BuildRequires: gnutls-devel
69BuildRequires: intltool >= %{intltool_version}
70BuildRequires: libsoup-devel >= %{soup_version}
71BuildRequires: libtool
72BuildRequires: libgnome-keyring-devel
73BuildRequires: gtk-doc >= 1.14
74BuildRequires: sqlite3-devel
75BuildRequires: libgweather-devel >= %{libgweather_version}
76BuildRequires: libical-devel >= %{libical_version}
77BuildRequires: gperf
78BuildRequires: krb5-devel
79BuildRequires: libgdata-devel >= %{libgdata_version}
80
81%if %{use_nss}
82BuildRequires: nspr-devel
83BuildRequires: nss-devel
84%else
85BuildRequires: openssl-devel
86%endif
87
88%if %{ldap_support}
89%if %{static_ldap}
90BuildRequires: openldap-evolution-devel
91BuildRequires: openssl-devel
92%else
93BuildRequires: openldap-devel >= 2.0.11
94%endif
95%endif
96
97%if %{krb5_support}
98BuildRequires: krb5-devel
99# tweak for krb5 1.2 vs 1.3
100%define krb5dir /usr/kerberos
101#define krb5dir `pwd`/krb5-fakeprefix
102%endif
103
104%description
105The evolution-data-server package provides a unified backend for
106programs that work with contacts, tasks, and calendar information.
107
108It was originally developed for Evolution (hence the name), but
109is now used by other packages.
110
111%package devel
112Summary: Development files for building against evolution-data-server
113Group: Development/Libraries
114Requires: %{name} = %{version}-%{release}
115Requires: libgnome-devel
116Requires: libgweather-devel
117Requires: libsoup-devel
118Requires: libical-devel >= %{libical_version}
119Requires: sqlite3-devel
120%if %{use_nss}
121Requires: nspr-devel
122Requires: nss-devel
123%endif
124
125%description devel
126Development files needed for building things which link against
127evolution-data-server.
128
129%package doc
130Summary: Documentation files for %{name}
131Group: Applications/Documentation
132
133%description doc
134This package contains developer documentation for %{name}.
135
136%prep
137%setup -q
138
139## %patch10 -p1 -b .fix-ldap-query
140##%patch11 -p1 -b .camel-folder-summary-crash
141%patch12 -p1 -b .fix-64bit-acinclude
142
143mkdir -p krb5-fakeprefix/include
144mkdir -p krb5-fakeprefix/lib
145mkdir -p krb5-fakeprefix/%{_lib}
146
147%build
148%if %{ldap_support}
149
150%if %{static_ldap}
151%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
152# Set LIBS so that configure will be able to link with static LDAP libraries,
153# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
154if pkg-config libssl ; then
155        export LIBS="-lsasl2 `pkg-config --libs libssl`"
156else
157        export LIBS="-lsasl2 -lssl -lcrypto"
158fi
159%else
160%define ldap_flags --with-openldap=yes
161%endif
162
163%else
164%define ldap_flags --without-openldap
165%endif
166
167%if %{krb5_support}
168%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
169%else
170%define krb5_flags --without-krb5
171%endif
172
173%if %{nntp_support}
174%define nntp_flags --enable-nntp=yes
175%else
176%define nntp_flags --enable-nntp=no
177%endif
178
179%if %{use_nss}
180%define ssl_flags --enable-nss=yes --enable-smime=yes
181%else
182%define ssl_flags --enable-openssl=yes
183%endif
184
185%if %{use_nss}
186if ! pkg-config --exists nss; then
187  echo "Unable to find suitable version of nss to use!"
188  exit 1
189fi
190%endif
191
192%if %{use_gnome_keyring}
193%define keyring_flags --enable-gnome-keyring
194%else
195%define keyring flags --disable-gnome-keyring
196%endif
197
198%if %{support_imap4_provider}
199%define imap4_flags --enable-imap4=yes
200%else
201%define imap4_flags --enable-imap4=no
202%endif
203
204export CPPFLAGS="-I%{_includedir}/et"
205export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
206%if ! %{use_nss}
207if pkg-config openssl ; then
208        CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
209        LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
210fi
211%endif
212
213# Add stricter build settings here as the source code gets cleaned up.
214# We want to make sure things like compiler warnings and avoiding deprecated
215# functions in the GNOME/GTK+ libraries stay fixed.
216#
217# Please file a bug report at bugzilla.gnome.org if these settings break
218# compilation, and encourage the upstream developers to use them.
219
220%if %{strict_build_settings}
221CFLAGS="$CFLAGS \
222        -DG_DISABLE_DEPRECATED=1 \
223        -DPANGO_DISABLE_DEPRECATED=1 \
224        -DGDK_PIXBUF_DISABLE_DEPRECATED=1 \
225        -DGDK_DISABLE_DEPRECATED=1 \
226        -Wdeclaration-after-statement \
227        -Werror-implicit-function-declaration"
228%endif
229
230# Regenerate configure to pick up configure.in and acinclude.m4 changes.
231aclocal -I m4
232autoheader
233automake
234libtoolize
235intltoolize --force
236autoconf
237
238# See Ross Burton's blog entry for why we want --with-libdb.
239# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
240
241%configure \
242        --with-libdb=/usr \
243        --enable-file-locking=fcntl \
244        --enable-dot-locking=no \
245        --enable-gtk-doc \
246        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
247        %keyring_flags
248export tagname=CC
249make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
250
251%install
252rm -rf $RPM_BUILD_ROOT
253export tagname=CC
254make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
255
256# remove libtool archives for importers and the like
257find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
258rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
259rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server-%{eds_api_version}/camel-providers/*.a
260rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server-%{eds_api_version}/extensions/*.a
261
262# give the libraries some executable bits
263find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
264
265%find_lang %{name}-%{eds_base_version}
266
267%clean
268rm -rf $RPM_BUILD_ROOT
269
270%post -p /sbin/ldconfig
271
272%postun -p /sbin/ldconfig
273
274%files -f %{name}-%{eds_base_version}.lang
275%defattr(-,root,root,-)
276%doc README COPYING ChangeLog NEWS AUTHORS
277%{_libdir}/*.so.*
278%{_libexecdir}/e-addressbook-factory
279%{_libexecdir}/e-calendar-factory
280%{_libexecdir}/camel-index-control-%{eds_api_version}
281%{_libexecdir}/camel-lock-helper-%{eds_api_version}
282%{_datadir}/evolution-data-server-%{eds_base_version}
283## %{_datadir}/idl/evolution-data-server-%{eds_api_version}
284%{_datadir}/pixmaps/evolution-data-server
285#{_libdir}/evolution-data-server-%{eds_api_version}
286%{_datadir}/dbus-1/services/*
287
288%dir %{_libdir}/evolution-data-server-%{eds_api_version}
289%dir %{camel_provider_dir}
290%dir %{eds_extensions_dir}
291
292# Camel providers:
293%{camel_provider_dir}/libcamelgroupwise.so
294%{camel_provider_dir}/libcamelgroupwise.urls
295
296%{camel_provider_dir}/libcamelimap.so
297%{camel_provider_dir}/libcamelimap.urls
298
299%if %{support_imap4_provider}
300%{camel_provider_dir}/libcamelimap4.so
301%{camel_provider_dir}/libcamelimap4.urls
302%endif
303
304%{camel_provider_dir}/libcamellocal.so
305%{camel_provider_dir}/libcamellocal.urls
306
307%{camel_provider_dir}/libcamelnntp.so
308%{camel_provider_dir}/libcamelnntp.urls
309
310%{camel_provider_dir}/libcamelpop3.so
311%{camel_provider_dir}/libcamelpop3.urls
312
313%{camel_provider_dir}/libcamelsendmail.so
314%{camel_provider_dir}/libcamelsendmail.urls
315
316%{camel_provider_dir}/libcamelsmtp.so
317%{camel_provider_dir}/libcamelsmtp.urls
318
319%{camel_provider_dir}/libcamelimapx.so
320%{camel_provider_dir}/libcamelimapx.urls
321
322# e-d-s extensions:
323%{eds_extensions_dir}/libebookbackendfile.so
324%{eds_extensions_dir}/libebookbackendgoogle.so
325%{eds_extensions_dir}/libebookbackendgroupwise.so
326%{eds_extensions_dir}/libebookbackendldap.so
327%{eds_extensions_dir}/libebookbackendvcf.so
328%{eds_extensions_dir}/libebookbackendwebdav.so
329%{eds_extensions_dir}/libecalbackendcontacts.so
330%{eds_extensions_dir}/libecalbackendfile.so
331%{eds_extensions_dir}/libecalbackendgroupwise.so
332%{eds_extensions_dir}/libecalbackendhttp.so
333%{eds_extensions_dir}/libecalbackendweather.so
334%{eds_extensions_dir}/libecalbackendcaldav.so
335## %{eds_extensions_dir}/libecalbackendgoogle.so
336
337%files devel
338%defattr(-,root,root,-)
339%{_includedir}/evolution-data-server-%{eds_base_version}
340%{_libdir}/*.so
341%{_libdir}/pkgconfig/*.pc
342
343%files doc
344%defattr(-,root,root,-)
345%{_datadir}/gtk-doc/html/camel
346%{_datadir}/gtk-doc/html/libebackend
347%{_datadir}/gtk-doc/html/libebook
348%{_datadir}/gtk-doc/html/libecal
349%{_datadir}/gtk-doc/html/libedata-book
350%{_datadir}/gtk-doc/html/libedata-cal
351%{_datadir}/gtk-doc/html/libedataserver
352%{_datadir}/gtk-doc/html/libedataserverui
353
354%changelog
355* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
356- new upstream release
357- remove Requires: gnome-vfs2, libglade2, libgnomeui
358- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
359- add BuildRequires: libgdata
360- add Requires: nspr-devel, nss-devel (devel package)
361- drop Patch11
362
363* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
364- rebuild with rpm-4.8.1 for pkg-config file
365
366* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
367- new upstream release
368
369* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
370- new upstream release
371
372* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
373- new upstream release
374- remove BuildRequires: libbonobo-devel
375- remove Requires: libbonobo
376- drop Patch10
377- add configure option (--with-krb5-libs, --with-krb5-includes)
378
379* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
380- rebuilt with db4-4.8
381
382* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
383- new upstream release
384
385* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
386- new upstream release
387
388* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
389- new upstream release
390
391* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
392- new upstream release
393
394* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
395- added Requires: libical-devel >= 0.43 to devel package
396
397* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
398- new upstream release
399- add BR: libgweather-devel >= 2.26.0
400- add BR: libical-devel >= 0.43
401
402* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
403- new upstream release
404- added BuildRequires: sqlite3-devel
405
406* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
407- enabled krb5 support
408
409* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
410- new upstream release
411
412* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
413- new upstream release
414
415* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
416- new upstream release
417
418* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
419- new upstream release
420
421* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
422- rebuilt with db4-4.6.21
423
424* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
425- new upstream release
426
427* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
428- new upstream release
429
430* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
431- new upstream release
432
433* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
434- new upstream release based on Fedora package 2.20.0-3.fc9
435  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
436  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
437  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
438  - Add patch for RH bug #296671 (GC servers may not support NTLM).
439  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
440  - Try removing the ancient "ldap-x86_64-hack" patch.
441  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
442  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
443- split doc subpackage
444
445* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
446- fixed dependancy
447
448* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
449- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
450  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
451  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
452  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
453  - Make the new ESourceComboBox widget work properly (RH bug #234760).
454  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
455  - Link to static evolution-openldap library (RH bug #210126).
456  - Require openssl-devel when statically linking against openldap.
457  - Add -Wdeclaration-after-statement to strict build settings.
458  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
459  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
460  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
461  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
462  - Update to 1.10.0
463  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
464  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
465  - Patch by Kenny Root.
466- rebuilt with nss-devel and nspr-devel
467
468* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
469- rebuilt with new toolchain and db4-4.3.x
470
471* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
472- new upstream release
473
474* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
475- new upstream release
476- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
477
478* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
479- new upstream release
480- rebuilt with openssl instead of mozilla-nss
481
482* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
483- rebuilt with openldap-2.3.24-0vl4
484
485* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
486- new upstream release
487- build with libsoap-2.2.7
488
489* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
490- new upstream release
491
492* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
493- new upstream release
494- added/removed Patches based on Fedora packages
495  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
496  - Updated patch 102 to fix further implicit function declarations
497  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
498  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
499    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
500  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
501  - Removed upstreamed patch:
502    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
503  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
504  - added patch to calendar/libecal/e-cal.c to fix missing declaration
505    of open_calendar
506- rebuilt with mozilla-1.7.12
507
508* Thu May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
509- rebuilt with mozilla-1.7.7
510
511* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
512- initial build for Vine Linux based on FC package
513- disable krb5 support
514
515* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
516- 1.2.1
517
518* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
519- Removed explicit run-time spec-file requirement on mozilla.
520  The Mozilla NSS API/ABI stabilised by version 1.7.3
521  The libraries are always located in the libdir
522  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
523  and so they move each time the mozilla version changes.
524  So we no longer have an explicit mozilla run-time requirement in the specfile;
525  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
526  We have an explicit, exact build-time version, so that we can find the headers (without
527  invoking an RPM query from the spec file; to do so is considered bad practice)
528- Introduced mozilla_build_version, to replace mozilla_version
529- Set mozilla_build_version to 1.7.6 to reflect current state of tree
530
531* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
532- Added a patch to deal with glibc defining a macro called "read"
533
534* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
535- 1.2.0
536- Removed patch for GCC 4 as this is now in upstream tarball
537
538* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
539- rebuild to fix library linking silliness
540
541* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
542- disabling gtk-doc on ia64 and s390x
543
544* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
545- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
546
547* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
548- extended patch to deal with camel-groupwise-store-summary.c
549
550* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
551- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
552
553* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
554- 1.1.6
555
556* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
557- rebuild
558
559* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
560- forgot to fix sources
561
562* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
563- 1.1.5
564
565* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
566- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
567
568* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
569- disable gtk-doc generation on ia64 for now
570
571* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
572- Exclude ppc64 due to missing mozilla dependency
573
574* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
575- Update from 1.0.3 to 1.1.4.1
576- Updated eds_major from 1.0 to 1.2; fixed translation search path.
577- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
578- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
579- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
580- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
581- Camel code from evolution is now in evolution-data-server:
582  - Added camel-index-control and camel-lock-helper to packaged files
583  - Added mozilla dependency code from the evolution package
584  - Ditto for LDAP
585  - Ditto for krb5
586  - Ditto for NNTP support handling
587  - Ditto for --enable-file-locking and --enable-dot-locking
588- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
589- Updated libsoup requirement from 2.2.1 to 2.2.2
590- Enabled gtk-doc
591
592* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
593- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
594
595* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
596- update from upstream 1.0.2 to 1.0.3:
597  * Address Book
598    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
599    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
600
601  * Calendar
602    #XB59904 - Speed up calendar queries (Rodrigo)
603    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
604    - fix libical build for automake 1.9 (Rodney)
605    - fix putenv usage for portability (Julio M. Merino Vidal)
606
607  * Updated Translations:
608    - sv (Christian Rose)
609
610- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
611
612* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
613- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
614http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
615(The groupwise part of that patch did not cleanly apply, so I removed it).
616
617* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
618- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
619optimisation patch posted to upstream development mailing list here:
620http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
621
622* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
623- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
624
625* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
626- added workaround for a backend leak that causes the "contacts" calendar
627backend to hold open an EBook for the local contacts (filed upstream at:
628http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
629never lose its last addressbook, and hence never quit.  We workaround this by
630detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
631
632* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
633- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
634
635* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
636- update from 1.0.1 to 1.0.2
637- increased libsoup requirement to 2.2.1 to match configuration script
638
639* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
640- update from 1.0.0 to 1.0.1
641- removed patch that fixed warnings in calendar code (now in upstream tarball)
642
643* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
644- fixed various warnings in the calendar code
645  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
646
647* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
648- update from 0.0.99 to 1.0.0
649- changed path in FTP source location from 0.0 to 1.0
650
651* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
652- update from 0.0.98 to 0.0.99
653- increased libsoup requirement to 2.2.0 to match configuration script
654
655* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
656- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
657
658* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
659- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
660
661* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
662- upgraded to 0.0.97; rewrote the package's description
663
664* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
665- rebuilt
666
667* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
668- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
669
670* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
671- 0.0.96; libsoup required is now 2.1.12
672
673* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
674- rebuilt
675
676* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
677- rebuilt
678
679* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
680- 0.0.95
681
682* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
683- 0.0.94.1
684
685* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
686- rebuilt
687
688* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
689- 0.0.94
690
691* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
692- added ORBit2 requirement
693
694* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
695- rebuild again
696
697* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
698- rebuilt
699
700* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
701- 0.0.93; libsoup required is now 2.1.10
702
703* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
704- Update to 0.0.92; added a define and a requirement on the libsoup version
705
706* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
707- 0.0.90
708
709* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
710- rebuilt
711
712* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
713- 0.0.6
714
715* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
716- better fix by using system libtool
717
718* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
719- add some libdb linkage to make the build on x86_64 happy
720
721* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
722- update to 0.0.5
723
724* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
725- Initial build.
Note: See TracBrowser for help on using the repository browser.