source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 1883

Revision 1883, 24.3 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.24.0
8%define gtk2_version 2.20.0
9%define gtk_doc_version 1.14
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.0
12%define soup_version 2.30.0
13%define libgweather_version 2.30.0
14%define libical_version 0.43
15
16%define eds_base_version 2.30
17%define eds_api_version 1.2
18
19%define use_gnome_keyring 1
20%define support_imap4_provider 0
21
22%define camel_provider_dir %{_libdir}/evolution-data-server-%{eds_api_version}/camel-providers
23%define eds_extensions_dir %{_libdir}/evolution-data-server-%{eds_api_version}/extensions
24
25# Use stricter build settings than required by upstream.
26%define strict_build_settings 1
27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
33Version: 2.30.2
34Release: 2%{?_dist_release}
35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
38Source0: %{name}-%{version}.tar.bz2
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #215702 / GNOME bug #487988
44Patch10: evolution-data-server-1.8.0-fix-ldap-query.patch
45
46# GNOME bug #373146
47Patch11: evolution-data-server-1.10.1-camel-folder-summary-crash.patch
48
49# RH bug #243296
50Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
51
52### Dependencies ###
53
54Requires: GConf2
55Requires: ORBit2 >= %{orbit2_version}
56Requires: gnome-vfs2
57Requires: libglade2
58Requires: libgnomeui
59Requires: libsoup >= %{soup_version}
60
61### Build Dependencies ###
62
63BuildRequires: GConf2-devel
64BuildRequires: ORBit2-devel >= %{orbit2_version}
65BuildRequires: bison
66BuildRequires: db4-devel
67BuildRequires: flex
68BuildRequires: gettext
69BuildRequires: glib2-devel
70BuildRequires: gnome-vfs2-devel
71BuildRequires: gnutls-devel
72BuildRequires: intltool >= %{intltool_version}
73BuildRequires: libglade2-devel
74BuildRequires: libgnome-devel
75BuildRequires: libgnomeui-devel
76BuildRequires: libsoup-devel >= %{soup_version}
77BuildRequires: libtool
78BuildRequires: libgnome-keyring-devel
79BuildRequires: gtk-doc >= 1.14
80BuildRequires: sqlite3-devel
81BuildRequires: libgweather-devel >= %{libgweather_version}
82BuildRequires: libical-devel >= %{libical_version}
83BuildRequires: gperf
84BuildRequires: krb5-devel
85
86%if %{use_nss}
87BuildRequires: nspr-devel
88BuildRequires: nss-devel
89%else
90BuildRequires: openssl-devel
91%endif
92
93%if %{ldap_support}
94%if %{static_ldap}
95BuildRequires: openldap-evolution-devel
96BuildRequires: openssl-devel
97%else
98BuildRequires: openldap-devel >= 2.0.11
99%endif
100%endif
101
102%if %{krb5_support}
103BuildRequires: krb5-devel
104# tweak for krb5 1.2 vs 1.3
105%define krb5dir /usr/kerberos
106#define krb5dir `pwd`/krb5-fakeprefix
107%endif
108
109%description
110The evolution-data-server package provides a unified backend for
111programs that work with contacts, tasks, and calendar information.
112
113It was originally developed for Evolution (hence the name), but
114is now used by other packages.
115
116%package devel
117Summary: Development files for building against evolution-data-server
118Group: Development/Libraries
119Requires: %{name} = %{version}-%{release}
120Requires: libgnome-devel
121Requires: libgweather-devel
122Requires: libsoup-devel
123Requires: libical-devel >= %{libical_version}
124Requires: sqlite3-devel
125
126%description devel
127Development files needed for building things which link against
128evolution-data-server.
129
130%package doc
131Summary: Documentation files for %{name}
132Group: Applications/Documentation
133
134%description doc
135This package contains developer documentation for %{name}.
136
137%prep
138%setup -q
139
140## %patch10 -p1 -b .fix-ldap-query
141%patch11 -p1 -b .camel-folder-summary-crash
142%patch12 -p1 -b .fix-64bit-acinclude
143
144mkdir -p krb5-fakeprefix/include
145mkdir -p krb5-fakeprefix/lib
146mkdir -p krb5-fakeprefix/%{_lib}
147
148%build
149%if %{ldap_support}
150
151%if %{static_ldap}
152%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
153# Set LIBS so that configure will be able to link with static LDAP libraries,
154# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
155if pkg-config libssl ; then
156        export LIBS="-lsasl2 `pkg-config --libs libssl`"
157else
158        export LIBS="-lsasl2 -lssl -lcrypto"
159fi
160%else
161%define ldap_flags --with-openldap=yes
162%endif
163
164%else
165%define ldap_flags --without-openldap
166%endif
167
168%if %{krb5_support}
169%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
170%else
171%define krb5_flags --without-krb5
172%endif
173
174%if %{nntp_support}
175%define nntp_flags --enable-nntp=yes
176%else
177%define nntp_flags --enable-nntp=no
178%endif
179
180%if %{use_nss}
181%define ssl_flags --enable-nss=yes --enable-smime=yes
182%else
183%define ssl_flags --enable-openssl=yes
184%endif
185
186%if %{use_nss}
187if ! pkg-config --exists nss; then
188  echo "Unable to find suitable version of nss to use!"
189  exit 1
190fi
191%endif
192
193%if %{use_gnome_keyring}
194%define keyring_flags --enable-gnome-keyring
195%else
196%define keyring flags --disable-gnome-keyring
197%endif
198
199%if %{support_imap4_provider}
200%define imap4_flags --enable-imap4=yes
201%else
202%define imap4_flags --enable-imap4=no
203%endif
204
205export CPPFLAGS="-I%{_includedir}/et"
206export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
207%if ! %{use_nss}
208if pkg-config openssl ; then
209        CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
210        LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
211fi
212%endif
213
214# Add stricter build settings here as the source code gets cleaned up.
215# We want to make sure things like compiler warnings and avoiding deprecated
216# functions in the GNOME/GTK+ libraries stay fixed.
217#
218# Please file a bug report at bugzilla.gnome.org if these settings break
219# compilation, and encourage the upstream developers to use them.
220
221%if %{strict_build_settings}
222CFLAGS="$CFLAGS \
223        -DG_DISABLE_DEPRECATED=1 \
224        -DPANGO_DISABLE_DEPRECATED=1 \
225        -DGDK_PIXBUF_DISABLE_DEPRECATED=1 \
226        -DGDK_DISABLE_DEPRECATED=1 \
227        -Wdeclaration-after-statement \
228        -Werror-implicit-function-declaration"
229%endif
230
231# Regenerate configure to pick up configure.in and acinclude.m4 changes.
232aclocal -I m4
233autoheader
234automake
235libtoolize
236intltoolize --force
237autoconf
238
239# See Ross Burton's blog entry for why we want --with-libdb.
240# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
241
242%configure \
243        --with-libdb=/usr \
244        --enable-file-locking=fcntl \
245        --enable-dot-locking=no \
246        --enable-gtk-doc \
247        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
248        %keyring_flags
249export tagname=CC
250make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
251
252%install
253rm -rf $RPM_BUILD_ROOT
254export tagname=CC
255make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
256
257# remove libtool archives for importers and the like
258find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
259rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
260rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server-%{eds_api_version}/camel-providers/*.a
261rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server-%{eds_api_version}/extensions/*.a
262
263# give the libraries some executable bits
264find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
265
266%find_lang %{name}-%{eds_base_version}
267
268%clean
269rm -rf $RPM_BUILD_ROOT
270
271%post -p /sbin/ldconfig
272
273%postun -p /sbin/ldconfig
274
275%files -f %{name}-%{eds_base_version}.lang
276%defattr(-,root,root,-)
277%doc README COPYING ChangeLog NEWS AUTHORS
278%{_libdir}/*.so.*
279%{_libexecdir}/e-addressbook-factory
280%{_libexecdir}/e-calendar-factory
281%{_libexecdir}/camel-index-control-%{eds_api_version}
282%{_libexecdir}/camel-lock-helper-%{eds_api_version}
283%{_datadir}/evolution-data-server-%{eds_base_version}
284## %{_datadir}/idl/evolution-data-server-%{eds_api_version}
285%{_datadir}/pixmaps/evolution-data-server
286#{_libdir}/evolution-data-server-%{eds_api_version}
287%{_datadir}/dbus-1/services/*
288
289%dir %{_libdir}/evolution-data-server-%{eds_api_version}
290%dir %{camel_provider_dir}
291%dir %{eds_extensions_dir}
292
293# Camel providers:
294%{camel_provider_dir}/libcamelgroupwise.so
295%{camel_provider_dir}/libcamelgroupwise.urls
296
297%{camel_provider_dir}/libcamelimap.so
298%{camel_provider_dir}/libcamelimap.urls
299
300%if %{support_imap4_provider}
301%{camel_provider_dir}/libcamelimap4.so
302%{camel_provider_dir}/libcamelimap4.urls
303%endif
304
305%{camel_provider_dir}/libcamellocal.so
306%{camel_provider_dir}/libcamellocal.urls
307
308%{camel_provider_dir}/libcamelnntp.so
309%{camel_provider_dir}/libcamelnntp.urls
310
311%{camel_provider_dir}/libcamelpop3.so
312%{camel_provider_dir}/libcamelpop3.urls
313
314%{camel_provider_dir}/libcamelsendmail.so
315%{camel_provider_dir}/libcamelsendmail.urls
316
317%{camel_provider_dir}/libcamelsmtp.so
318%{camel_provider_dir}/libcamelsmtp.urls
319
320%{camel_provider_dir}/libcamelimapx.so
321%{camel_provider_dir}/libcamelimapx.urls
322
323# e-d-s extensions:
324%{eds_extensions_dir}/libebookbackendfile.so
325%{eds_extensions_dir}/libebookbackendgoogle.so
326%{eds_extensions_dir}/libebookbackendgroupwise.so
327%{eds_extensions_dir}/libebookbackendldap.so
328%{eds_extensions_dir}/libebookbackendvcf.so
329%{eds_extensions_dir}/libebookbackendwebdav.so
330%{eds_extensions_dir}/libecalbackendcontacts.so
331%{eds_extensions_dir}/libecalbackendfile.so
332%{eds_extensions_dir}/libecalbackendgroupwise.so
333%{eds_extensions_dir}/libecalbackendhttp.so
334%{eds_extensions_dir}/libecalbackendweather.so
335%{eds_extensions_dir}/libecalbackendcaldav.so
336%{eds_extensions_dir}/libecalbackendgoogle.so
337
338%files devel
339%defattr(-,root,root,-)
340%{_includedir}/evolution-data-server-%{eds_base_version}
341%{_libdir}/*.so
342%{_libdir}/pkgconfig/*.pc
343
344%files doc
345%defattr(-,root,root,-)
346%{_datadir}/gtk-doc/html/camel
347%{_datadir}/gtk-doc/html/libebackend
348%{_datadir}/gtk-doc/html/libebook
349%{_datadir}/gtk-doc/html/libecal
350%{_datadir}/gtk-doc/html/libedata-book
351%{_datadir}/gtk-doc/html/libedata-cal
352%{_datadir}/gtk-doc/html/libedataserver
353%{_datadir}/gtk-doc/html/libedataserverui
354
355%changelog
356* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
357- rebuild with rpm-4.8.1 for pkg-config file
358
359* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
360- new upstream release
361
362* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
363- new upstream release
364
365* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
366- new upstream release
367- remove BuildRequires: libbonobo-devel
368- remove Requires: libbonobo
369- drop Patch10
370- add configure option (--with-krb5-libs, --with-krb5-includes)
371
372* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
373- rebuilt with db4-4.8
374
375* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
376- new upstream release
377
378* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
379- new upstream release
380
381* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
382- new upstream release
383
384* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
385- new upstream release
386
387* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
388- added Requires: libical-devel >= 0.43 to devel package
389
390* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
391- new upstream release
392- add BR: libgweather-devel >= 2.26.0
393- add BR: libical-devel >= 0.43
394
395* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
396- new upstream release
397- added BuildRequires: sqlite3-devel
398
399* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
400- enabled krb5 support
401
402* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
403- new upstream release
404
405* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
406- new upstream release
407
408* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
409- new upstream release
410
411* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
412- new upstream release
413
414* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
415- rebuilt with db4-4.6.21
416
417* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
418- new upstream release
419
420* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
421- new upstream release
422
423* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
424- new upstream release
425
426* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
427- new upstream release based on Fedora package 2.20.0-3.fc9
428  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
429  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
430  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
431  - Add patch for RH bug #296671 (GC servers may not support NTLM).
432  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
433  - Try removing the ancient "ldap-x86_64-hack" patch.
434  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
435  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
436- split doc subpackage
437
438* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
439- fixed dependancy
440
441* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
442- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
443  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
444  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
445  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
446  - Make the new ESourceComboBox widget work properly (RH bug #234760).
447  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
448  - Link to static evolution-openldap library (RH bug #210126).
449  - Require openssl-devel when statically linking against openldap.
450  - Add -Wdeclaration-after-statement to strict build settings.
451  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
452  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
453  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
454  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
455  - Update to 1.10.0
456  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
457  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
458  - Patch by Kenny Root.
459- rebuilt with nss-devel and nspr-devel
460
461* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
462- rebuilt with new toolchain and db4-4.3.x
463
464* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
465- new upstream release
466
467* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
468- new upstream release
469- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
470
471* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
472- new upstream release
473- rebuilt with openssl instead of mozilla-nss
474
475* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
476- rebuilt with openldap-2.3.24-0vl4
477
478* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
479- new upstream release
480- build with libsoap-2.2.7
481
482* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
483- new upstream release
484
485* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
486- new upstream release
487- added/removed Patches based on Fedora packages
488  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
489  - Updated patch 102 to fix further implicit function declarations
490  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
491  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
492    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
493  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
494  - Removed upstreamed patch:
495    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
496  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
497  - added patch to calendar/libecal/e-cal.c to fix missing declaration
498    of open_calendar
499- rebuilt with mozilla-1.7.12
500
501* Thu May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
502- rebuilt with mozilla-1.7.7
503
504* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
505- initial build for Vine Linux based on FC package
506- disable krb5 support
507
508* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
509- 1.2.1
510
511* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
512- Removed explicit run-time spec-file requirement on mozilla.
513  The Mozilla NSS API/ABI stabilised by version 1.7.3
514  The libraries are always located in the libdir
515  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
516  and so they move each time the mozilla version changes.
517  So we no longer have an explicit mozilla run-time requirement in the specfile;
518  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
519  We have an explicit, exact build-time version, so that we can find the headers (without
520  invoking an RPM query from the spec file; to do so is considered bad practice)
521- Introduced mozilla_build_version, to replace mozilla_version
522- Set mozilla_build_version to 1.7.6 to reflect current state of tree
523
524* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
525- Added a patch to deal with glibc defining a macro called "read"
526
527* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
528- 1.2.0
529- Removed patch for GCC 4 as this is now in upstream tarball
530
531* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
532- rebuild to fix library linking silliness
533
534* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
535- disabling gtk-doc on ia64 and s390x
536
537* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
538- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
539
540* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
541- extended patch to deal with camel-groupwise-store-summary.c
542
543* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
544- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
545
546* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
547- 1.1.6
548
549* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
550- rebuild
551
552* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
553- forgot to fix sources
554
555* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
556- 1.1.5
557
558* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
559- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
560
561* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
562- disable gtk-doc generation on ia64 for now
563
564* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
565- Exclude ppc64 due to missing mozilla dependency
566
567* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
568- Update from 1.0.3 to 1.1.4.1
569- Updated eds_major from 1.0 to 1.2; fixed translation search path.
570- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
571- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
572- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
573- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
574- Camel code from evolution is now in evolution-data-server:
575  - Added camel-index-control and camel-lock-helper to packaged files
576  - Added mozilla dependency code from the evolution package
577  - Ditto for LDAP
578  - Ditto for krb5
579  - Ditto for NNTP support handling
580  - Ditto for --enable-file-locking and --enable-dot-locking
581- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
582- Updated libsoup requirement from 2.2.1 to 2.2.2
583- Enabled gtk-doc
584
585* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
586- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
587
588* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
589- update from upstream 1.0.2 to 1.0.3:
590  * Address Book
591    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
592    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
593
594  * Calendar
595    #XB59904 - Speed up calendar queries (Rodrigo)
596    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
597    - fix libical build for automake 1.9 (Rodney)
598    - fix putenv usage for portability (Julio M. Merino Vidal)
599
600  * Updated Translations:
601    - sv (Christian Rose)
602
603- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
604
605* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
606- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
607http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
608(The groupwise part of that patch did not cleanly apply, so I removed it).
609
610* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
611- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
612optimisation patch posted to upstream development mailing list here:
613http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
614
615* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
616- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
617
618* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
619- added workaround for a backend leak that causes the "contacts" calendar
620backend to hold open an EBook for the local contacts (filed upstream at:
621http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
622never lose its last addressbook, and hence never quit.  We workaround this by
623detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
624
625* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
626- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
627
628* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
629- update from 1.0.1 to 1.0.2
630- increased libsoup requirement to 2.2.1 to match configuration script
631
632* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
633- update from 1.0.0 to 1.0.1
634- removed patch that fixed warnings in calendar code (now in upstream tarball)
635
636* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
637- fixed various warnings in the calendar code
638  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
639
640* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
641- update from 0.0.99 to 1.0.0
642- changed path in FTP source location from 0.0 to 1.0
643
644* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
645- update from 0.0.98 to 0.0.99
646- increased libsoup requirement to 2.2.0 to match configuration script
647
648* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
649- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
650
651* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
652- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
653
654* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
655- upgraded to 0.0.97; rewrote the package's description
656
657* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
658- rebuilt
659
660* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
661- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
662
663* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
664- 0.0.96; libsoup required is now 2.1.12
665
666* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
667- rebuilt
668
669* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
670- rebuilt
671
672* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
673- 0.0.95
674
675* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
676- 0.0.94.1
677
678* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
679- rebuilt
680
681* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
682- 0.0.94
683
684* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
685- added ORBit2 requirement
686
687* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
688- rebuild again
689
690* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
691- rebuilt
692
693* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
694- 0.0.93; libsoup required is now 2.1.10
695
696* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
697- Update to 0.0.92; added a define and a requirement on the libsoup version
698
699* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
700- 0.0.90
701
702* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
703- rebuilt
704
705* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
706- 0.0.6
707
708* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
709- better fix by using system libtool
710
711* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
712- add some libdb linkage to make the build on x86_64 happy
713
714* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
715- update to 0.0.5
716
717* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
718- Initial build.
Note: See TracBrowser for help on using the repository browser.