source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 10716

Revision 10716, 29.8 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME-3.20

RevLine 
[521]1%define use_nss 1
2%define ldap_support 1
[10226]3%define static_ldap 0
[521]4%define krb5_support 1
5%define nntp_support 1
6
[6890]7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
[4850]9%define gtk_doc_version 1.18
[521]10%define intltool_version 0.35.5
[2041]11%define orbit2_version 2.14.19
[4850]12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
[9376]14%define libical_version 0.43
[4850]15%define libgdata_version 0.10.1
[521]16
[10716]17%define eds_base_version 3.20
[521]18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
[4616]23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
[6890]26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
[521]27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
[10716]33Version: 3.20.4
34Release: 1%{?_dist_release}
[521]35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
[10716]38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.20/%{name}-%{version}.tar.xz
[521]39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
[6890]48#Requires: ORBit2 >= %{orbit2_version}
[521]49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
[6890]53#BuildRequires: ORBit2-devel >= %{orbit2_version}
[521]54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
[4616]59BuildRequires: gtk3-devel
[10716]60BuildRequires: WebKit3-gtk-devel
61BuildRequires: json-glib-devel
[6011]62BuildRequires: dbus-glib-devel
[521]63BuildRequires: gnutls-devel
64BuildRequires: intltool >= %{intltool_version}
65BuildRequires: libsoup-devel >= %{soup_version}
66BuildRequires: libtool
[805]67BuildRequires: libgnome-keyring-devel
[521]68BuildRequires: sqlite3-devel
69BuildRequires: libgweather-devel >= %{libgweather_version}
70BuildRequires: libical-devel >= %{libical_version}
[805]71BuildRequires: gperf
[4616]72BuildRequires: krb5-devel
[2041]73BuildRequires: libgdata-devel >= %{libgdata_version}
[4616]74BuildRequires: gnome-online-accounts-devel
75BuildRequires: liboauth-devel
[7633]76BuildRequires: libsecret-devel
[8353]77BuildRequires: libicu-devel
[7633]78BuildRequires: gnome-common
[521]79
[7633]80BuildRequires: vala
81BuildRequires: vala-tools
82
[521]83%if %{use_nss}
84BuildRequires: nspr-devel
85BuildRequires: nss-devel
86%else
87BuildRequires: openssl-devel
88%endif
89
90%if %{ldap_support}
91%if %{static_ldap}
92BuildRequires: openldap-evolution-devel
93BuildRequires: openssl-devel
94%else
95BuildRequires: openldap-devel >= 2.0.11
96%endif
97%endif
98
99%if %{krb5_support}
100BuildRequires: krb5-devel
101# tweak for krb5 1.2 vs 1.3
102%define krb5dir /usr/kerberos
103#define krb5dir `pwd`/krb5-fakeprefix
104%endif
105
[4616]106Vendor: Project Vine
107Distribution: Vine Linux
108
[9791]109
[521]110%description
111The evolution-data-server package provides a unified backend for
112programs that work with contacts, tasks, and calendar information.
113
114It was originally developed for Evolution (hence the name), but
115is now used by other packages.
116
[7633]117
[521]118%package devel
119Summary: Development files for building against evolution-data-server
120Group: Development/Libraries
121Requires: %{name} = %{version}-%{release}
[6890]122Requires: pkgconfig
[521]123Requires: sqlite3-devel
[6890]124Requires: libgnome-keyring-devel
[521]125
126%description devel
127Development files needed for building things which link against
128evolution-data-server.
129
130
[7633]131%package        vala
132Summary:        Vala bindings for %{name}
133Summary(ja):    %{name} の Vala バインディング
134Group:          Development/Libraries
135Requires:       %{name} = %{version}-%{release}
136Requires:       vala
137
138%description    vala
139Vala bindings for %{name}.
140
141
[521]142%prep
143%setup -q
144
145%patch12 -p1 -b .fix-64bit-acinclude
146
147mkdir -p krb5-fakeprefix/include
148mkdir -p krb5-fakeprefix/lib
149mkdir -p krb5-fakeprefix/%{_lib}
150
151%build
152%if %{ldap_support}
153
154%if %{static_ldap}
155%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
156# Set LIBS so that configure will be able to link with static LDAP libraries,
157# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
[805]158if pkg-config libssl ; then
159        export LIBS="-lsasl2 `pkg-config --libs libssl`"
[521]160else
161        export LIBS="-lsasl2 -lssl -lcrypto"
162fi
163%else
164%define ldap_flags --with-openldap=yes
165%endif
166
167%else
168%define ldap_flags --without-openldap
169%endif
170
171%if %{krb5_support}
[805]172%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
[521]173%else
174%define krb5_flags --without-krb5
175%endif
176
177%if %{nntp_support}
178%define nntp_flags --enable-nntp=yes
179%else
180%define nntp_flags --enable-nntp=no
181%endif
182
183%if %{use_nss}
184%define ssl_flags --enable-nss=yes --enable-smime=yes
185%else
186%define ssl_flags --enable-openssl=yes
187%endif
188
189%if %{use_nss}
190if ! pkg-config --exists nss; then
191  echo "Unable to find suitable version of nss to use!"
192  exit 1
193fi
194%endif
195
196%if %{use_gnome_keyring}
197%define keyring_flags --enable-gnome-keyring
198%else
199%define keyring flags --disable-gnome-keyring
200%endif
201
202%if %{support_imap4_provider}
203%define imap4_flags --enable-imap4=yes
204%else
205%define imap4_flags --enable-imap4=no
206%endif
207
208export CPPFLAGS="-I%{_includedir}/et"
209export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
210
211# Regenerate configure to pick up configure.in and acinclude.m4 changes.
[7938]212autoreconf -if
[521]213
214# See Ross Burton's blog entry for why we want --with-libdb.
215# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
216
217%configure \
218        --with-libdb=/usr \
[7633]219        --disable-uoa \
[521]220        --enable-file-locking=fcntl \
221        --enable-dot-locking=no \
[9569]222        --disable-gtk-doc \
[7633]223        --enable-introspection=yes \
224        --enable-vala-bindings \
[521]225        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
226        %keyring_flags
227export tagname=CC
[9569]228make %{?_smp_mflags}
[521]229
230%install
231rm -rf $RPM_BUILD_ROOT
232export tagname=CC
[9569]233make DESTDIR=$RPM_BUILD_ROOT install
[521]234
235# remove libtool archives for importers and the like
236find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
[6890]237find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
[521]238
239# give the libraries some executable bits
240find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
241
[10716]242# remove unused files
243rm -rf $RPM_BUILD_ROOT%{_prefix}/lib/systemd
244
[521]245%find_lang %{name}-%{eds_base_version}
246
247%clean
248rm -rf $RPM_BUILD_ROOT
249
250%post -p /sbin/ldconfig
251
[6011]252%postun
253/sbin/ldconfig
254if [ $1 -eq 0 ]; then
255  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
256fi
[521]257
[6011]258%posttrans
259glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
260
261
[521]262%files -f %{name}-%{eds_base_version}.lang
263%defattr(-,root,root,-)
264%doc README COPYING ChangeLog NEWS AUTHORS
265%{_libdir}/*.so.*
[9475]266%{_libdir}/evolution-data-server/credential-modules/module-credentials-goa.so
267%{_libdir}/evolution-data-server/libedbus-private.so
[4616]268%{_libdir}/girepository-1.0/*.typelib
[6011]269%{_libexecdir}/evolution-addressbook-factory
[9475]270%{_libexecdir}/evolution-addressbook-factory-subprocess
[6011]271%{_libexecdir}/evolution-calendar-factory
[9475]272%{_libexecdir}/evolution-calendar-factory-subprocess
[8011]273%{_libexecdir}/evolution-scan-gconf-tree-xml
[6890]274%{_libexecdir}/evolution-source-registry
[7633]275%{_libexecdir}/evolution-user-prompter
[521]276%{_libexecdir}/camel-index-control-%{eds_api_version}
277%{_libexecdir}/camel-lock-helper-%{eds_api_version}
[6890]278%{_datadir}/GConf/gsettings/evolution-data-server.convert
[6011]279%{_datadir}/dbus-1/services/*
[7633]280%{_datadir}/%{name}/evolutionperson.schema
[9475]281%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.gschema.xml
[6011]282%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
283%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
[6890]284%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
285%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
286%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
[521]287%{_datadir}/pixmaps/evolution-data-server
288
[4616]289%dir %{_libdir}/evolution-data-server
[521]290%dir %{camel_provider_dir}
[4616]291%dir %{ebook_backends_dir}
292%dir %{ecal_backends_dir}
[6890]293%dir %{registry_modules_dir}
[521]294
[4616]295%{camel_provider_dir}/libcamelimapx.so
296%{camel_provider_dir}/libcamelimapx.urls
[521]297
298%{camel_provider_dir}/libcamellocal.so
299%{camel_provider_dir}/libcamellocal.urls
300
301%{camel_provider_dir}/libcamelnntp.so
302%{camel_provider_dir}/libcamelnntp.urls
303
304%{camel_provider_dir}/libcamelpop3.so
305%{camel_provider_dir}/libcamelpop3.urls
306
307%{camel_provider_dir}/libcamelsendmail.so
308%{camel_provider_dir}/libcamelsendmail.urls
309
310%{camel_provider_dir}/libcamelsmtp.so
311%{camel_provider_dir}/libcamelsmtp.urls
312
313# e-d-s extensions:
[4616]314%{ebook_backends_dir}/libebookbackendfile.so
315%{ebook_backends_dir}/libebookbackendgoogle.so
316%{ebook_backends_dir}/libebookbackendldap.so
317%{ebook_backends_dir}/libebookbackendwebdav.so
[521]318
[4616]319%{ecal_backends_dir}/libecalbackendcaldav.so
320%{ecal_backends_dir}/libecalbackendcontacts.so
321%{ecal_backends_dir}/libecalbackendfile.so
[9073]322%{ecal_backends_dir}/libecalbackendgtasks.so
[4616]323%{ecal_backends_dir}/libecalbackendhttp.so
324%{ecal_backends_dir}/libecalbackendweather.so
325
[6890]326%{registry_modules_dir}/module-cache-reaper.so
327%{registry_modules_dir}/module-google-backend.so
[7633]328%{registry_modules_dir}/module-gnome-online-accounts.so
[7938]329%{registry_modules_dir}/module-outlook-backend.so
[7633]330%{registry_modules_dir}/module-owncloud-backend.so
[8353]331%{registry_modules_dir}/module-secret-monitor.so
[7633]332%{registry_modules_dir}/module-trust-prompt.so
[6890]333%{registry_modules_dir}/module-yahoo-backend.so
334
[521]335%files devel
336%defattr(-,root,root,-)
[7633]337%{_includedir}/%{name}
[521]338%{_libdir}/*.so
339%{_libdir}/pkgconfig/*.pc
[4616]340%{_datadir}/gir-1.0/*.gir
[521]341
[7633]342%files vala
343%defattr(-,root,root,-)
344%{_datadir}/vala/vapi/libebook-1.2.deps
345%{_datadir}/vala/vapi/libebook-1.2.vapi
346%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
347%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
348%{_datadir}/vala/vapi/libedataserver-1.2.deps
349%{_datadir}/vala/vapi/libedataserver-1.2.vapi
[10716]350%{_datadir}/vala/vapi/camel-1.2.deps
351%{_datadir}/vala/vapi/camel-1.2.vapi
[7633]352
353
[521]354%changelog
[10716]355* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.4-1
356- new upstream release
357- add BuildRequires: WebKit3-gtk-devel, json-glib-devel
358
[10437]359* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.5-2
360- rebuild with gcc-5.4.0
361
[10226]362* Wed May 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.5-1
363- new upstream release
364
[9988]365* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.4-1
366- new upstream release
367
[9876]368* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
369- new upstream release
370
[9804]371* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
372- new upstream release
373
[9791]374* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
375- new upstream release
376
[9724]377* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.5-1
378- new upstream release
379
[9672]380* Mon Jul 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
381- new upstream release
382
[9590]383* Wed Jun 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
384- new upstream release
385- remove %%{name}-doc subpackage
386
[9569]387* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
388- new upstream release
389
[9520]390* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
391- new upstream release
392
[9475]393* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
394- new upstream release
395
[9376]396* Mon Feb 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.12.11-2
397- rebuilt with libical 1.0.1
398
[9371]399* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.11-1
400- new upstream release
401
[9313]402* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.10-1
403- new upstream release
404
[9178]405* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.9-1
406- new upstream release
407
[9102]408* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.8-1
409- new upstream release
410
[9073]411* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.7-1
412- new upstream release
413
[8949]414* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-1
415- new upstream release
416
[8912]417* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.5-1
418- new upstream release
419
[8836]420* Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
421- new upstream release
422
[8545]423* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.3-1
424- new upstream release
425
[8447]426* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
427- new upstream release
428
[8369]429* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
430- new upstream release
431
[8353]432* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
433- new upstream release
434- add BuildRequires: libicu-devel
435
[8060]436* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
437- new upstream release
438
[8011]439* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
440- new upstream release
441
[7938]442* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
443- new upstream release
444
[7756]445* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
446- new upstream release
447
[7712]448* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
449- new upstream release
450
[7681]451* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
452- new upstream release
453
[7633]454* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
455- new upstream release
456- add configure option (--disable-uoa)
457- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
458- create %%{name}-vala subpackage
459
[7538]460* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
461- new upstream release
462
[7474]463* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
464- new upstream release
465
[7119]466* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
467- new upstream release
468
[6933]469* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
470- new upstream release
471
[6890]472* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
473- new upstream release
474
[6739]475* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
476- new upstream release
477
[6401]478* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
479- new upstream release
480
[6201]481* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
482- new upstream release
483
[6078]484* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
[6011]485- new upstream release
486- add BuildRequires: dbus-glib-devel
487
[5402]488* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
489- new upstream release
490
[5168]491* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
492- new upstream release
493
[5038]494* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
495- new upstream release
496
[4850]497* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
498- new upstream release
499
[4812]500* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
501- new upstream release
502- remove Patch101
503
[4704]504* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
505- new upstream release
506
[4616]507* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
[3801]508- new upstream release
[4616]509- change BuildRequires: gtk3-devel instead of gtk2-devel
510- BuildRequires: gnome-online-accounts-devel
511- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
512- fix %%files
[3801]513
[2661]514* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
515- new upstream release
516
[2483]517* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
518- rebuild with openssl-1.0.0c
[2219]519
[2041]520* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
521- new upstream release
522- remove Requires: gnome-vfs2, libglade2, libgnomeui
523- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
524- add BuildRequires: libgdata
525- add Requires: nspr-devel, nss-devel (devel package)
526- drop Patch11
527
[1883]528* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
529- rebuild with rpm-4.8.1 for pkg-config file
530
[1231]531* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
532- new upstream release
533
[926]534* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
535- new upstream release
536
[805]537* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
538- new upstream release
539- remove BuildRequires: libbonobo-devel
540- remove Requires: libbonobo
541- drop Patch10
542- add configure option (--with-krb5-libs, --with-krb5-includes)
543
[521]544* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
545- rebuilt with db4-4.8
546
547* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
548- new upstream release
549
550* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
551- new upstream release
552
553* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
554- new upstream release
555
556* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
557- new upstream release
558
559* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
560- added Requires: libical-devel >= 0.43 to devel package
561
562* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
563- new upstream release
564- add BR: libgweather-devel >= 2.26.0
565- add BR: libical-devel >= 0.43
566
567* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
568- new upstream release
569- added BuildRequires: sqlite3-devel
570
571* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
572- enabled krb5 support
573
574* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
575- new upstream release
576
577* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
578- new upstream release
579
580* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
581- new upstream release
582
583* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
584- new upstream release
585
586* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
587- rebuilt with db4-4.6.21
588
589* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
590- new upstream release
591
592* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
593- new upstream release
594
595* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
596- new upstream release
597
598* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
599- new upstream release based on Fedora package 2.20.0-3.fc9
600  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
601  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
602  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
603  - Add patch for RH bug #296671 (GC servers may not support NTLM).
604  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
605  - Try removing the ancient "ldap-x86_64-hack" patch.
606  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
607  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
608- split doc subpackage
609
610* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
611- fixed dependancy
612
613* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
614- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
615  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
616  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
617  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
618  - Make the new ESourceComboBox widget work properly (RH bug #234760).
619  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
620  - Link to static evolution-openldap library (RH bug #210126).
621  - Require openssl-devel when statically linking against openldap.
622  - Add -Wdeclaration-after-statement to strict build settings.
623  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
624  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
625  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
626  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
627  - Update to 1.10.0
628  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
629  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
630  - Patch by Kenny Root.
631- rebuilt with nss-devel and nspr-devel
632
633* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
634- rebuilt with new toolchain and db4-4.3.x
635
636* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
637- new upstream release
638
639* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
640- new upstream release
641- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
642
643* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
644- new upstream release
645- rebuilt with openssl instead of mozilla-nss
646
647* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
648- rebuilt with openldap-2.3.24-0vl4
649
650* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
651- new upstream release
652- build with libsoap-2.2.7
653
654* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
655- new upstream release
656
657* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
658- new upstream release
659- added/removed Patches based on Fedora packages
660  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
661  - Updated patch 102 to fix further implicit function declarations
662  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
663  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
664    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
665  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
666  - Removed upstreamed patch:
667    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
668  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
669  - added patch to calendar/libecal/e-cal.c to fix missing declaration
670    of open_calendar
671- rebuilt with mozilla-1.7.12
672
[7633]673* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
[521]674- rebuilt with mozilla-1.7.7
675
676* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
677- initial build for Vine Linux based on FC package
678- disable krb5 support
679
680* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
681- 1.2.1
682
683* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
684- Removed explicit run-time spec-file requirement on mozilla.
685  The Mozilla NSS API/ABI stabilised by version 1.7.3
686  The libraries are always located in the libdir
687  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
688  and so they move each time the mozilla version changes.
689  So we no longer have an explicit mozilla run-time requirement in the specfile;
690  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
691  We have an explicit, exact build-time version, so that we can find the headers (without
692  invoking an RPM query from the spec file; to do so is considered bad practice)
693- Introduced mozilla_build_version, to replace mozilla_version
694- Set mozilla_build_version to 1.7.6 to reflect current state of tree
695
696* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
697- Added a patch to deal with glibc defining a macro called "read"
698
699* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
700- 1.2.0
701- Removed patch for GCC 4 as this is now in upstream tarball
702
703* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
704- rebuild to fix library linking silliness
705
706* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
707- disabling gtk-doc on ia64 and s390x
708
709* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
710- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
711
712* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
713- extended patch to deal with camel-groupwise-store-summary.c
714
715* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
716- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
717
718* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
719- 1.1.6
720
721* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
722- rebuild
723
724* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
725- forgot to fix sources
726
727* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
728- 1.1.5
729
730* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
731- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
732
733* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
734- disable gtk-doc generation on ia64 for now
735
736* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
737- Exclude ppc64 due to missing mozilla dependency
738
739* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
740- Update from 1.0.3 to 1.1.4.1
741- Updated eds_major from 1.0 to 1.2; fixed translation search path.
742- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
743- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
744- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
745- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
746- Camel code from evolution is now in evolution-data-server:
747  - Added camel-index-control and camel-lock-helper to packaged files
748  - Added mozilla dependency code from the evolution package
749  - Ditto for LDAP
750  - Ditto for krb5
751  - Ditto for NNTP support handling
752  - Ditto for --enable-file-locking and --enable-dot-locking
753- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
754- Updated libsoup requirement from 2.2.1 to 2.2.2
755- Enabled gtk-doc
756
757* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
758- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
759
760* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
761- update from upstream 1.0.2 to 1.0.3:
762  * Address Book
763    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
764    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
765
766  * Calendar
767    #XB59904 - Speed up calendar queries (Rodrigo)
768    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
769    - fix libical build for automake 1.9 (Rodney)
770    - fix putenv usage for portability (Julio M. Merino Vidal)
771
772  * Updated Translations:
773    - sv (Christian Rose)
774
775- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
776
777* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
778- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
779http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
780(The groupwise part of that patch did not cleanly apply, so I removed it).
781
782* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
783- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
784optimisation patch posted to upstream development mailing list here:
785http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
786
787* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
788- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
789
790* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
791- added workaround for a backend leak that causes the "contacts" calendar
792backend to hold open an EBook for the local contacts (filed upstream at:
793http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
794never lose its last addressbook, and hence never quit.  We workaround this by
795detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
796
797* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
798- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
799
800* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
801- update from 1.0.1 to 1.0.2
802- increased libsoup requirement to 2.2.1 to match configuration script
803
804* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
805- update from 1.0.0 to 1.0.1
806- removed patch that fixed warnings in calendar code (now in upstream tarball)
807
808* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
809- fixed various warnings in the calendar code
810  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
811
812* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
813- update from 0.0.99 to 1.0.0
814- changed path in FTP source location from 0.0 to 1.0
815
816* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
817- update from 0.0.98 to 0.0.99
818- increased libsoup requirement to 2.2.0 to match configuration script
819
820* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
821- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
822
823* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
824- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
825
826* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
827- upgraded to 0.0.97; rewrote the package's description
828
829* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
830- rebuilt
831
832* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
833- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
834
835* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
836- 0.0.96; libsoup required is now 2.1.12
837
838* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
839- rebuilt
840
841* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
842- rebuilt
843
844* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
845- 0.0.95
846
847* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
848- 0.0.94.1
849
850* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
851- rebuilt
852
853* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
854- 0.0.94
855
856* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
857- added ORBit2 requirement
858
859* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
860- rebuild again
861
862* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
863- rebuilt
864
865* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
866- 0.0.93; libsoup required is now 2.1.10
867
868* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
869- Update to 0.0.92; added a define and a requirement on the libsoup version
870
871* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
872- 0.0.90
873
874* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
875- rebuilt
876
877* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
878- 0.0.6
879
880* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
881- better fix by using system libtool
882
883* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
884- add some libdb linkage to make the build on x86_64 happy
885
886* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
887- update to 0.0.5
888
889* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
890- Initial build.
Note: See TracBrowser for help on using the repository browser.