source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 10437

Revision 10437, 29.4 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 0
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.43
15%define libgdata_version 0.10.1
16
17%define eds_base_version 3.18
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
33Version: 3.18.5
34Release: 2%{?_dist_release}
35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.18/%{name}-%{version}.tar.xz
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
48#Requires: ORBit2 >= %{orbit2_version}
49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
53#BuildRequires: ORBit2-devel >= %{orbit2_version}
54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
59BuildRequires: gtk3-devel
60BuildRequires: dbus-glib-devel
61BuildRequires: gnutls-devel
62BuildRequires: intltool >= %{intltool_version}
63BuildRequires: libsoup-devel >= %{soup_version}
64BuildRequires: libtool
65BuildRequires: libgnome-keyring-devel
66BuildRequires: sqlite3-devel
67BuildRequires: libgweather-devel >= %{libgweather_version}
68BuildRequires: libical-devel >= %{libical_version}
69BuildRequires: gperf
70BuildRequires: krb5-devel
71BuildRequires: libgdata-devel >= %{libgdata_version}
72BuildRequires: gnome-online-accounts-devel
73BuildRequires: liboauth-devel
74BuildRequires: libsecret-devel
75BuildRequires: libicu-devel
76BuildRequires: gnome-common
77
78BuildRequires: vala
79BuildRequires: vala-tools
80
81%if %{use_nss}
82BuildRequires: nspr-devel
83BuildRequires: nss-devel
84%else
85BuildRequires: openssl-devel
86%endif
87
88%if %{ldap_support}
89%if %{static_ldap}
90BuildRequires: openldap-evolution-devel
91BuildRequires: openssl-devel
92%else
93BuildRequires: openldap-devel >= 2.0.11
94%endif
95%endif
96
97%if %{krb5_support}
98BuildRequires: krb5-devel
99# tweak for krb5 1.2 vs 1.3
100%define krb5dir /usr/kerberos
101#define krb5dir `pwd`/krb5-fakeprefix
102%endif
103
104Vendor: Project Vine
105Distribution: Vine Linux
106
107
108%description
109The evolution-data-server package provides a unified backend for
110programs that work with contacts, tasks, and calendar information.
111
112It was originally developed for Evolution (hence the name), but
113is now used by other packages.
114
115
116%package devel
117Summary: Development files for building against evolution-data-server
118Group: Development/Libraries
119Requires: %{name} = %{version}-%{release}
120Requires: pkgconfig
121Requires: sqlite3-devel
122Requires: libgnome-keyring-devel
123
124%description devel
125Development files needed for building things which link against
126evolution-data-server.
127
128
129%package        vala
130Summary:        Vala bindings for %{name}
131Summary(ja):    %{name} の Vala バインディング
132Group:          Development/Libraries
133Requires:       %{name} = %{version}-%{release}
134Requires:       vala
135
136%description    vala
137Vala bindings for %{name}.
138
139
140%prep
141%setup -q
142
143%patch12 -p1 -b .fix-64bit-acinclude
144
145mkdir -p krb5-fakeprefix/include
146mkdir -p krb5-fakeprefix/lib
147mkdir -p krb5-fakeprefix/%{_lib}
148
149%build
150%if %{ldap_support}
151
152%if %{static_ldap}
153%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
154# Set LIBS so that configure will be able to link with static LDAP libraries,
155# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
156if pkg-config libssl ; then
157        export LIBS="-lsasl2 `pkg-config --libs libssl`"
158else
159        export LIBS="-lsasl2 -lssl -lcrypto"
160fi
161%else
162%define ldap_flags --with-openldap=yes
163%endif
164
165%else
166%define ldap_flags --without-openldap
167%endif
168
169%if %{krb5_support}
170%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
171%else
172%define krb5_flags --without-krb5
173%endif
174
175%if %{nntp_support}
176%define nntp_flags --enable-nntp=yes
177%else
178%define nntp_flags --enable-nntp=no
179%endif
180
181%if %{use_nss}
182%define ssl_flags --enable-nss=yes --enable-smime=yes
183%else
184%define ssl_flags --enable-openssl=yes
185%endif
186
187%if %{use_nss}
188if ! pkg-config --exists nss; then
189  echo "Unable to find suitable version of nss to use!"
190  exit 1
191fi
192%endif
193
194%if %{use_gnome_keyring}
195%define keyring_flags --enable-gnome-keyring
196%else
197%define keyring flags --disable-gnome-keyring
198%endif
199
200%if %{support_imap4_provider}
201%define imap4_flags --enable-imap4=yes
202%else
203%define imap4_flags --enable-imap4=no
204%endif
205
206export CPPFLAGS="-I%{_includedir}/et"
207export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
208
209# Regenerate configure to pick up configure.in and acinclude.m4 changes.
210autoreconf -if
211
212# See Ross Burton's blog entry for why we want --with-libdb.
213# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
214
215%configure \
216        --with-libdb=/usr \
217        --disable-uoa \
218        --enable-file-locking=fcntl \
219        --enable-dot-locking=no \
220        --disable-gtk-doc \
221        --enable-introspection=yes \
222        --enable-vala-bindings \
223        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
224        %keyring_flags
225export tagname=CC
226make %{?_smp_mflags}
227
228%install
229rm -rf $RPM_BUILD_ROOT
230export tagname=CC
231make DESTDIR=$RPM_BUILD_ROOT install
232
233# remove libtool archives for importers and the like
234find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
235find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
236
237# give the libraries some executable bits
238find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
239
240%find_lang %{name}-%{eds_base_version}
241
242%clean
243rm -rf $RPM_BUILD_ROOT
244
245%post -p /sbin/ldconfig
246
247%postun
248/sbin/ldconfig
249if [ $1 -eq 0 ]; then
250  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
251fi
252
253%posttrans
254glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
255
256
257%files -f %{name}-%{eds_base_version}.lang
258%defattr(-,root,root,-)
259%doc README COPYING ChangeLog NEWS AUTHORS
260%{_libdir}/*.so.*
261%{_libdir}/evolution-data-server/credential-modules/module-credentials-goa.so
262%{_libdir}/evolution-data-server/libedbus-private.so
263%{_libdir}/girepository-1.0/*.typelib
264%{_libexecdir}/evolution-addressbook-factory
265%{_libexecdir}/evolution-addressbook-factory-subprocess
266%{_libexecdir}/evolution-calendar-factory
267%{_libexecdir}/evolution-calendar-factory-subprocess
268%{_libexecdir}/evolution-scan-gconf-tree-xml
269%{_libexecdir}/evolution-source-registry
270%{_libexecdir}/evolution-user-prompter
271%{_libexecdir}/camel-index-control-%{eds_api_version}
272%{_libexecdir}/camel-lock-helper-%{eds_api_version}
273%{_datadir}/GConf/gsettings/evolution-data-server.convert
274%{_datadir}/dbus-1/services/*
275%{_datadir}/%{name}/evolutionperson.schema
276%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.gschema.xml
277%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
278%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
279%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
280%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
281%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
282%{_datadir}/pixmaps/evolution-data-server
283
284%dir %{_libdir}/evolution-data-server
285%dir %{camel_provider_dir}
286%dir %{ebook_backends_dir}
287%dir %{ecal_backends_dir}
288%dir %{registry_modules_dir}
289
290%{camel_provider_dir}/libcamelimapx.so
291%{camel_provider_dir}/libcamelimapx.urls
292
293%{camel_provider_dir}/libcamellocal.so
294%{camel_provider_dir}/libcamellocal.urls
295
296%{camel_provider_dir}/libcamelnntp.so
297%{camel_provider_dir}/libcamelnntp.urls
298
299%{camel_provider_dir}/libcamelpop3.so
300%{camel_provider_dir}/libcamelpop3.urls
301
302%{camel_provider_dir}/libcamelsendmail.so
303%{camel_provider_dir}/libcamelsendmail.urls
304
305%{camel_provider_dir}/libcamelsmtp.so
306%{camel_provider_dir}/libcamelsmtp.urls
307
308# e-d-s extensions:
309%{ebook_backends_dir}/libebookbackendfile.so
310%{ebook_backends_dir}/libebookbackendgoogle.so
311%{ebook_backends_dir}/libebookbackendldap.so
312%{ebook_backends_dir}/libebookbackendwebdav.so
313
314%{ecal_backends_dir}/libecalbackendcaldav.so
315%{ecal_backends_dir}/libecalbackendcontacts.so
316%{ecal_backends_dir}/libecalbackendfile.so
317%{ecal_backends_dir}/libecalbackendgtasks.so
318%{ecal_backends_dir}/libecalbackendhttp.so
319%{ecal_backends_dir}/libecalbackendweather.so
320
321%{registry_modules_dir}/module-cache-reaper.so
322%{registry_modules_dir}/module-google-backend.so
323%{registry_modules_dir}/module-gnome-online-accounts.so
324%{registry_modules_dir}/module-outlook-backend.so
325%{registry_modules_dir}/module-owncloud-backend.so
326%{registry_modules_dir}/module-secret-monitor.so
327%{registry_modules_dir}/module-trust-prompt.so
328%{registry_modules_dir}/module-yahoo-backend.so
329
330%files devel
331%defattr(-,root,root,-)
332%{_includedir}/%{name}
333%{_libdir}/*.so
334%{_libdir}/pkgconfig/*.pc
335%{_datadir}/gir-1.0/*.gir
336
337%files vala
338%defattr(-,root,root,-)
339%{_datadir}/vala/vapi/libebook-1.2.deps
340%{_datadir}/vala/vapi/libebook-1.2.vapi
341%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
342%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
343%{_datadir}/vala/vapi/libedataserver-1.2.deps
344%{_datadir}/vala/vapi/libedataserver-1.2.vapi
345
346
347%changelog
348* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.5-2
349- rebuild with gcc-5.4.0
350
351* Wed May 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.5-1
352- new upstream release
353
354* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.4-1
355- new upstream release
356
357* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
358- new upstream release
359
360* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
361- new upstream release
362
363* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
364- new upstream release
365
366* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.5-1
367- new upstream release
368
369* Mon Jul 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
370- new upstream release
371
372* Wed Jun 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
373- new upstream release
374- remove %%{name}-doc subpackage
375
376* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
377- new upstream release
378
379* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
380- new upstream release
381
382* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
383- new upstream release
384
385* Mon Feb 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.12.11-2
386- rebuilt with libical 1.0.1
387
388* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.11-1
389- new upstream release
390
391* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.10-1
392- new upstream release
393
394* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.9-1
395- new upstream release
396
397* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.8-1
398- new upstream release
399
400* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.7-1
401- new upstream release
402
403* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-1
404- new upstream release
405
406* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.5-1
407- new upstream release
408
409* Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
410- new upstream release
411
412* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.3-1
413- new upstream release
414
415* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
416- new upstream release
417
418* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
419- new upstream release
420
421* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
422- new upstream release
423- add BuildRequires: libicu-devel
424
425* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
426- new upstream release
427
428* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
429- new upstream release
430
431* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
432- new upstream release
433
434* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
435- new upstream release
436
437* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
438- new upstream release
439
440* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
441- new upstream release
442
443* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
444- new upstream release
445- add configure option (--disable-uoa)
446- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
447- create %%{name}-vala subpackage
448
449* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
450- new upstream release
451
452* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
453- new upstream release
454
455* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
456- new upstream release
457
458* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
459- new upstream release
460
461* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
462- new upstream release
463
464* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
465- new upstream release
466
467* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
468- new upstream release
469
470* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
471- new upstream release
472
473* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
474- new upstream release
475- add BuildRequires: dbus-glib-devel
476
477* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
478- new upstream release
479
480* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
481- new upstream release
482
483* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
484- new upstream release
485
486* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
487- new upstream release
488
489* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
490- new upstream release
491- remove Patch101
492
493* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
494- new upstream release
495
496* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
497- new upstream release
498- change BuildRequires: gtk3-devel instead of gtk2-devel
499- BuildRequires: gnome-online-accounts-devel
500- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
501- fix %%files
502
503* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
504- new upstream release
505
506* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
507- rebuild with openssl-1.0.0c
508
509* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
510- new upstream release
511- remove Requires: gnome-vfs2, libglade2, libgnomeui
512- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
513- add BuildRequires: libgdata
514- add Requires: nspr-devel, nss-devel (devel package)
515- drop Patch11
516
517* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
518- rebuild with rpm-4.8.1 for pkg-config file
519
520* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
521- new upstream release
522
523* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
524- new upstream release
525
526* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
527- new upstream release
528- remove BuildRequires: libbonobo-devel
529- remove Requires: libbonobo
530- drop Patch10
531- add configure option (--with-krb5-libs, --with-krb5-includes)
532
533* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
534- rebuilt with db4-4.8
535
536* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
537- new upstream release
538
539* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
540- new upstream release
541
542* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
543- new upstream release
544
545* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
546- new upstream release
547
548* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
549- added Requires: libical-devel >= 0.43 to devel package
550
551* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
552- new upstream release
553- add BR: libgweather-devel >= 2.26.0
554- add BR: libical-devel >= 0.43
555
556* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
557- new upstream release
558- added BuildRequires: sqlite3-devel
559
560* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
561- enabled krb5 support
562
563* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
564- new upstream release
565
566* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
567- new upstream release
568
569* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
570- new upstream release
571
572* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
573- new upstream release
574
575* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
576- rebuilt with db4-4.6.21
577
578* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
579- new upstream release
580
581* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
582- new upstream release
583
584* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
585- new upstream release
586
587* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
588- new upstream release based on Fedora package 2.20.0-3.fc9
589  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
590  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
591  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
592  - Add patch for RH bug #296671 (GC servers may not support NTLM).
593  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
594  - Try removing the ancient "ldap-x86_64-hack" patch.
595  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
596  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
597- split doc subpackage
598
599* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
600- fixed dependancy
601
602* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
603- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
604  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
605  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
606  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
607  - Make the new ESourceComboBox widget work properly (RH bug #234760).
608  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
609  - Link to static evolution-openldap library (RH bug #210126).
610  - Require openssl-devel when statically linking against openldap.
611  - Add -Wdeclaration-after-statement to strict build settings.
612  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
613  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
614  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
615  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
616  - Update to 1.10.0
617  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
618  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
619  - Patch by Kenny Root.
620- rebuilt with nss-devel and nspr-devel
621
622* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
623- rebuilt with new toolchain and db4-4.3.x
624
625* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
626- new upstream release
627
628* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
629- new upstream release
630- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
631
632* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
633- new upstream release
634- rebuilt with openssl instead of mozilla-nss
635
636* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
637- rebuilt with openldap-2.3.24-0vl4
638
639* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
640- new upstream release
641- build with libsoap-2.2.7
642
643* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
644- new upstream release
645
646* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
647- new upstream release
648- added/removed Patches based on Fedora packages
649  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
650  - Updated patch 102 to fix further implicit function declarations
651  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
652  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
653    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
654  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
655  - Removed upstreamed patch:
656    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
657  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
658  - added patch to calendar/libecal/e-cal.c to fix missing declaration
659    of open_calendar
660- rebuilt with mozilla-1.7.12
661
662* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
663- rebuilt with mozilla-1.7.7
664
665* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
666- initial build for Vine Linux based on FC package
667- disable krb5 support
668
669* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
670- 1.2.1
671
672* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
673- Removed explicit run-time spec-file requirement on mozilla.
674  The Mozilla NSS API/ABI stabilised by version 1.7.3
675  The libraries are always located in the libdir
676  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
677  and so they move each time the mozilla version changes.
678  So we no longer have an explicit mozilla run-time requirement in the specfile;
679  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
680  We have an explicit, exact build-time version, so that we can find the headers (without
681  invoking an RPM query from the spec file; to do so is considered bad practice)
682- Introduced mozilla_build_version, to replace mozilla_version
683- Set mozilla_build_version to 1.7.6 to reflect current state of tree
684
685* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
686- Added a patch to deal with glibc defining a macro called "read"
687
688* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
689- 1.2.0
690- Removed patch for GCC 4 as this is now in upstream tarball
691
692* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
693- rebuild to fix library linking silliness
694
695* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
696- disabling gtk-doc on ia64 and s390x
697
698* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
699- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
700
701* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
702- extended patch to deal with camel-groupwise-store-summary.c
703
704* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
705- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
706
707* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
708- 1.1.6
709
710* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
711- rebuild
712
713* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
714- forgot to fix sources
715
716* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
717- 1.1.5
718
719* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
720- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
721
722* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
723- disable gtk-doc generation on ia64 for now
724
725* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
726- Exclude ppc64 due to missing mozilla dependency
727
728* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
729- Update from 1.0.3 to 1.1.4.1
730- Updated eds_major from 1.0 to 1.2; fixed translation search path.
731- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
732- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
733- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
734- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
735- Camel code from evolution is now in evolution-data-server:
736  - Added camel-index-control and camel-lock-helper to packaged files
737  - Added mozilla dependency code from the evolution package
738  - Ditto for LDAP
739  - Ditto for krb5
740  - Ditto for NNTP support handling
741  - Ditto for --enable-file-locking and --enable-dot-locking
742- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
743- Updated libsoup requirement from 2.2.1 to 2.2.2
744- Enabled gtk-doc
745
746* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
747- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
748
749* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
750- update from upstream 1.0.2 to 1.0.3:
751  * Address Book
752    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
753    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
754
755  * Calendar
756    #XB59904 - Speed up calendar queries (Rodrigo)
757    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
758    - fix libical build for automake 1.9 (Rodney)
759    - fix putenv usage for portability (Julio M. Merino Vidal)
760
761  * Updated Translations:
762    - sv (Christian Rose)
763
764- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
765
766* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
767- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
768http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
769(The groupwise part of that patch did not cleanly apply, so I removed it).
770
771* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
772- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
773optimisation patch posted to upstream development mailing list here:
774http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
775
776* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
777- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
778
779* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
780- added workaround for a backend leak that causes the "contacts" calendar
781backend to hold open an EBook for the local contacts (filed upstream at:
782http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
783never lose its last addressbook, and hence never quit.  We workaround this by
784detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
785
786* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
787- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
788
789* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
790- update from 1.0.1 to 1.0.2
791- increased libsoup requirement to 2.2.1 to match configuration script
792
793* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
794- update from 1.0.0 to 1.0.1
795- removed patch that fixed warnings in calendar code (now in upstream tarball)
796
797* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
798- fixed various warnings in the calendar code
799  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
800
801* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
802- update from 0.0.99 to 1.0.0
803- changed path in FTP source location from 0.0 to 1.0
804
805* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
806- update from 0.0.98 to 0.0.99
807- increased libsoup requirement to 2.2.0 to match configuration script
808
809* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
810- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
811
812* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
813- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
814
815* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
816- upgraded to 0.0.97; rewrote the package's description
817
818* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
819- rebuilt
820
821* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
822- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
823
824* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
825- 0.0.96; libsoup required is now 2.1.12
826
827* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
828- rebuilt
829
830* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
831- rebuilt
832
833* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
834- 0.0.95
835
836* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
837- 0.0.94.1
838
839* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
840- rebuilt
841
842* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
843- 0.0.94
844
845* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
846- added ORBit2 requirement
847
848* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
849- rebuild again
850
851* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
852- rebuilt
853
854* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
855- 0.0.93; libsoup required is now 2.1.10
856
857* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
858- Update to 0.0.92; added a define and a requirement on the libsoup version
859
860* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
861- 0.0.90
862
863* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
864- rebuilt
865
866* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
867- 0.0.6
868
869* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
870- better fix by using system libtool
871
872* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
873- add some libdb linkage to make the build on x86_64 happy
874
875* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
876- update to 0.0.5
877
878* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
879- Initial build.
Note: See TracBrowser for help on using the repository browser.