source: projects/specs/trunk/e/espeak/espeak-vl.spec @ 568

Revision 568, 9.6 KB checked in by inagaki, 14 years ago (diff)

NEW: dotconf, espeak, nas, portautio, speech-dispatcher

Line 
1Name:           espeak
2Version:        1.43
3Release:        3%{?_dist_release}
4Summary:        Software speech synthesizer (text-to-speech)
5
6Group:          Applications/Multimedia
7License:        GPLv3+
8URL:            http://espeak.sourceforge.net
9Source0:        http://kent.dl.sourceforge.net/sourceforge/espeak/espeak-%{version}-source.zip
10Source1:        espeak.1
11Patch0:         espeak-1.23-makefile_nostaticlibs.patch
12Patch1:         espeak-1.40.02-gcc_no_libstdc++.patch
13Patch2:         espeak-1.42.04-runtime-detection.patch
14Patch3:         espeak-1.43-ftbs_ld_libm.patch
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires:  portaudio-devel
18BuildRequires:  pulseaudio-libs-devel
19BuildRequires:  gcc-c++
20
21
22%description
23eSpeak is a software speech synthesizer for English and other languages.
24
25eSpeak produces good quality English speech. It uses a different synthesis
26method from other open source TTS engines, and sounds quite different.
27It's perhaps not as natural or "smooth", but some people may find the
28articulation clearer and easier to listen to for long periods. eSpeak supports
29several languages, however in most cases these are initial drafts and need more
30work to improve them.
31
32It can run as a command line program to speak text from a file or from stdin.
33
34
35%package devel
36Summary: Development files for espeak
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39
40
41%description devel
42Development files for eSpeak, a software speech synthesizer.
43
44
45%prep
46%setup -q -n espeak-%{version}-source
47%patch0 -p1 -b .nostaticlibs
48%patch1 -p1 -b .gcc_no_libstdc++
49%patch2 -p1 -b .runtime-detection
50%patch3 -p1 -b .ftbs_ld_libm
51
52# Fix file permissions
53find . -type f -exec chmod 0644 {} ";"
54# Prepare documentation
55rm -rf docs/images/.svn
56mv docs html
57sed -i 's/\r//' License.txt
58# Compile against portaudio v19 (see ReadMe)
59cp -f src/portaudio19.h src/portaudio.h
60# Don't use the included binary voice dictionaries; we compile these from source
61rm -f espeak-data/*_dict
62
63
64%build
65# Compile espeak
66cd src
67make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
68
69# Compile the TTS voice dictionaries
70export ESPEAK_DATA_PATH=$RPM_BUILD_DIR/espeak-%{version}-source
71cd ../dictsource
72for voice in $(../src/speak --voices | awk '{print $2}{print $5}' | egrep -v Language\|File\|/ | uniq); do \
73    ../src/speak --compile=$voice; \
74done
75
76
77%install
78rm -rf $RPM_BUILD_ROOT
79cd $RPM_BUILD_DIR/espeak-%{version}-source/src
80make install DESTDIR=$RPM_BUILD_ROOT BINDIR=%{_bindir} INCDIR=%{_includedir}/espeak LIBDIR=%{_libdir}
81# Install manpage
82mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
83cp -pf %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1/
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88
89%post -p /sbin/ldconfig
90
91
92%postun -p /sbin/ldconfig
93
94
95%files
96%defattr(-,root,root,-)
97%doc $RPM_BUILD_DIR/espeak-%{version}-source/ReadMe $RPM_BUILD_DIR/espeak-%{version}-source/ChangeLog $RPM_BUILD_DIR/espeak-%{version}-source/License.txt $RPM_BUILD_DIR/espeak-%{version}-source/html/
98%{_mandir}/man1/espeak.1.gz
99%{_bindir}/espeak
100%{_datadir}/espeak-data
101%{_libdir}/libespeak.so.*
102
103
104%files devel
105%defattr(-,root,root)
106%{_libdir}/*.so
107%{_includedir}/espeak
108
109
110%changelog
111* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.43-3
112- Added patch declaring explicit libm linking dependency (RHBZ #565186)
113
114* Thu Feb 18 2010 Francois Aucamp <faucamp@fedoraproject.org> - 1.43-2
115- Added patch declaring explicit libm linking dependency (RHBZ #565186)
116
117* Sat Feb 13 2010 Francois Aucamp <faucamp@fedoraproject.org> - 1.43-1
118- Update to version 1.43
119- Added patch for runtime detection of pulseaudio, contributed by Kevin Kofler (RHBZ #512190)
120
121* Thu Dec 17 2009 Francois Aucamp <faucamp@fedoraproject.org> - 1.42.04-1
122- Update to version 1.42.04
123- Revert: build against PortAudio instead of native PulseAudio (RHBZ #512190, #532674)
124
125* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.40.02-3
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
127
128* Tue Jun 30 2009 Francois Aucamp <faucamp@fedoraproject.org> - 1.40.02-2
129- Compile against pulseaudio instead of portaudio (RHBZ #481651)
130
131* Mon Jun 22 2009 Francois Aucamp <faucamp@fedoraproject.org> - 1.40.02-1
132- Update to version 1.40.02
133- Added patch to compile with GCC and not to link to libstdc++ (not needed)
134- Added manpage (thanks goes to Luke Yelavich from Ubuntu for writing it)
135
136* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.39-2
137- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
138
139* Tue Oct 21 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.39-1
140- Update to version 1.39
141
142* Tue Feb 26 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.31-5
143- Export ESPEAK_DATA_PATH in %%build to allow proper compilation of voice dictionaries
144
145* Tue Jan 29 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.31-4
146- Removed libjack patches as they are unnecessary
147
148* Tue Jan 29 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.31-3
149- Added "makefile_libjack" patch to link to libjack
150- Added BuildRequires: jack-audio-connection-kit-devel
151
152* Fri Jan 25 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.31-2
153- Removed espeakedit (and associated patches and BuildRequires) from package
154  until all phoneme table compilation functions can be moved into espeak (or a
155  separate commandline app without wxGTK dependencies)
156- Voices are still compiled from source, but using pre-compiled phoneme table
157  from upstream until the above issue is resolved
158
159* Thu Jan 24 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.31-1
160- Update to version 1.31
161- Compile phoneme tables and voice dictionaries from source instead of
162  packaging pre-compiled binary data
163- Added espeakedit as Source1
164- Added BuildRequires: wxGTK-devel for espeakedit
165- Added "makefile_rpmoptflags_wxversion" espeakedit patch to enable
166  RPM_OPT_FLAGS and set the correct wxWidgets version
167- Added "espeak_data_path" espeakedit patch to be able to set control the
168  source directory that espeakedit's compiler uses
169
170* Tue Jan 15 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.30-1
171- Update to version 1.30
172- Removed local "synthdata_strlen" patch (included upstream)
173
174* Mon Aug 20 2007 Francois Aucamp <faucamp@csir.co.za> - 1.28-1
175- Update to version 1.28
176- Added "synthdata_strlen" patch to fix memory allocation issue on x86_64 (RHBZ #252712)
177- Modified %%prep to build against portaudio v19 for F8 and later
178- Upstream license changed from GPLv2+ to GPLv3+
179
180* Tue Jun 19 2007 Francois Aucamp <faucamp@csir.co.za> - 1.26-1
181- Update to version 1.26
182- Modified %%prep to build against portaudio v19
183
184* Tue Jun 05 2007 Francois Aucamp <faucamp@csir.co.za> - 1.25-1
185- Update to version 1.25
186
187* Tue May 08 2007 Francois Aucamp <faucamp@csir.co.za> - 1.24-1
188- Update to version 1.24
189
190* Tue Apr 24 2007 Francois Aucamp <faucamp@csir.co.za> - 1.23-1
191- Update to version 1.23
192- Added "makefile_nostaticlibs" patch so static libraries aren't installed
193
194* Thu Feb 08 2007 Francois Aucamp <faucamp@csir.co.za> - 1.20-1
195- Update to version 1.20
196- Solves stack smash bug (RHBZ #227316)
197
198* Fri Jan 26 2007 Francois Aucamp <faucamp@csir.co.za> - 1.19-1
199- Update to version 1.19
200- Removed "espeak-1.18-makefile_lpthread" patch as it has been included upstream
201- Removed "espeak-1.18-makefile_smp" patch as it has been included upstream
202- Removed "espeak-1.18-ptr_64bit" patch as it has been solved upstream
203- Fixed espeak-data file permissions
204
205* Tue Jan 16 2007 Francois Aucamp <faucamp@csir.co.za> - 1.18-2
206- Created "espeak-1.18-ptr_64bit" patch to allow compilation on x86_64 (fixes 64-bit pointer issues)
207- Created "espeak-1.18-makefile_smp" patch to allow parallel make ("_smp_mflags")
208- Renamed "makefile_lpthread" patch to "espeak-1.18-makefile_lpthread"
209
210* Mon Jan 15 2007 Francois Aucamp <faucamp@csir.co.za> - 1.18-1
211- Update to version 1.18
212- Dropped statically-linked "speak" executable (replaced by dynamically-linked "espeak" executable)
213- Removed the "espeak program name" patch as it has been included upstream
214- Removed "espeak program name" patch backup file cleanup from %%install
215- Minor modification to "makefile lpthread" patch to account for new lib/executable
216- Removed "BIN_NAME" variable from make in %%build (implemented upstream)
217
218* Mon Nov 20 2006 Francois Aucamp <faucamp@csir.co.za> - 1.17-1
219- Update to version 1.17
220- Removed "makefile install target" patch as it has been included upstream
221- Removed "AMD64 sizeof(char *)" patch as it has been included upstream
222- Minor modification to "espeak program name" patch to allow patching current version
223
224* Tue Nov 07 2006 Francois Aucamp <faucamp@csir.co.za> - 1.16-4
225- Modified patch steps to create backups with different suffixes
226- Renamed patch file extensions to .patch
227- Added step in %%install to remove patch backup files in documentation
228
229* Sat Nov 04 2006 Francois Aucamp <faucamp@csir.co.za> - 1.16-3
230- Fixed source file permissions for -debuginfo package in %%prep
231- Added RPM_OPT_FLAGS to "make" command in %%build; removed RPM_OPT_FLAGS makefile patch
232- Modified makefile install target patch to include general support for setting compiler optimization flags via CXXFLAGS
233- Removed creation of .orig backup files during patching
234- Modified patch files to have different suffixes
235
236* Thu Nov 02 2006 Francois Aucamp <faucamp@csir.co.za> - 1.16-2
237- Added "install" target to makefile (makefile_install_target.patch)
238- Added patch to fix AMD64 sizeof(char *) assumption bug (upstream request ID 1588938)
239- Changed "portaudio" BuildRequires to "portaudio-devel"
240- Added patch to makefile to allow RPM_OPT_FLAGS
241- Added patch to replace all references to "speak" binary with "espeak"
242- Moved header files to /usr/include/espeak
243- Added rmdir command to "install" to remove empty soundicons directory
244
245* Wed Oct 04 2006 Francois Aucamp <faucamp@csir.co.za> - 1.16-1
246- Initial RPM build
Note: See TracBrowser for help on using the repository browser.