source: projects/specs/trunk/e/espeak/espeak-vl.spec @ 10759

Revision 10759, 10.3 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name:           espeak
2Summary:        Software speech synthesizer (text-to-speech)
3Version:        1.48.04
4Release:        2%{?_dist_release}
5
6Group:          Applications/Multimedia
7License:        GPLv3+
8URL:            http://espeak.sourceforge.net
9
10Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}-source.zip
11# Upstream ticket: https://sourceforge.net/p/espeak/patches/10/
12Source1:        espeak.1
13Patch0:         espeak-1.47-makefile-nostaticlibs.patch
14Patch1:         espeak-1.47-ftbs-ld-libm.patch
15# Upstream ticket: https://sourceforge.net/p/espeak/patches/10/
16Patch2:         espeak-1.48-help-fix.patch
17# Upstream ticket: https://sourceforge.net/p/espeak/bugs/105/
18Patch3:         espeak-1.47-wav-close.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  portaudio-devel
22BuildRequires:  pulseaudio-libs-devel
23BuildRequires:  gcc-c++
24
25
26%description
27eSpeak is a software speech synthesizer for English and other languages.
28
29eSpeak produces good quality English speech. It uses a different synthesis
30method from other open source TTS engines, and sounds quite different.
31It's perhaps not as natural or "smooth", but some people may find the
32articulation clearer and easier to listen to for long periods. eSpeak supports
33several languages, however in most cases these are initial drafts and need more
34work to improve them.
35
36It can run as a command line program to speak text from a file or from stdin.
37#'
38
39%package devel
40Summary: Development files for %{name}
41Summary(ja): %{name} の開発用ファイル
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44
45%description devel
46Development files for eSpeak, a software speech synthesizer.
47
48
49%prep
50%setup -q -n espeak-%{version}-source
51%patch0 -p1 -b .nostaticlibs
52%patch1 -p1 -b .ftbs-ld-libm
53%patch2 -p1 -b .help-fix
54%patch3 -p1 -b .wav-close
55
56# Fix file permissions
57find . -type f -exec chmod 0644 {} ";"
58# Prepare documentation
59rm -rf docs/images/.svn
60mv docs html
61sed -i 's/\r//' License.txt
62# Compile against portaudio v19 (see ReadMe)
63cp -f src/portaudio19.h src/portaudio.h
64# Don't use the included binary voice dictionaries; we compile these from source
65rm -f espeak-data/*_dict
66
67
68%build
69# Compile espeak
70cd src
71make %{?_smp_mflags} CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS" AUDIO=pulseaudio
72
73# Compile the TTS voice dictionaries
74export ESPEAK_DATA_PATH=$RPM_BUILD_DIR/espeak-%{version}-source
75cd ../dictsource
76# Strange sed regex to parse ambiguous output from 'speak --voices', filled upstream BZ 3608811
77for voice in $(../src/speak --voices | \
78LANG=C sed -n '/Age\/Gender/ ! s/ *[0-9]\+ *\([^ ]\+\) *M\? *[^ ]\+ *\(\((\|[A-Z]\)[^ ]\+\)\? *\([^ ]\+\).*/\1 \4/ p' | \
79sort | uniq); do \
80    ../src/speak --compile=$voice; \
81done
82
83
84%install
85rm -rf $RPM_BUILD_ROOT
86cd $RPM_BUILD_DIR/espeak-%{version}-source/src
87make install DESTDIR=$RPM_BUILD_ROOT BINDIR=%{_bindir} INCDIR=%{_includedir}/espeak LIBDIR=%{_libdir}
88# Install manpage
89mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
90cp -pf %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1/
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95
96%post -p /sbin/ldconfig
97
98%postun -p /sbin/ldconfig
99
100
101%files
102%defattr(-,root,root,-)
103%doc $RPM_BUILD_DIR/espeak-%{version}-source/ReadMe $RPM_BUILD_DIR/espeak-%{version}-source/ChangeLog.txt $RPM_BUILD_DIR/espeak-%{version}-source/License.txt $RPM_BUILD_DIR/espeak-%{version}-source/html/
104%{_mandir}/man1/espeak.1.gz
105%{_bindir}/espeak
106%{_datadir}/espeak-data
107%{_libdir}/libespeak.so.*
108
109%files devel
110%defattr(-,root,root)
111%{_libdir}/*.so
112%{_includedir}/espeak
113
114
115%changelog
116* Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> - 1.48.04-2
117- rebuild with gcc-5.4.0
118
119* Mon Dec 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.48.04-1
120- updated to 1.48.04
121- replaced Patch0, 1, 2 and 3 based FC
122
123* Sun May 27 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.43-4
124- rebuilt with rpm-4.8.1-3
125
126* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.43-3
127- Initial build for Vine Linux
128
129* Thu Feb 18 2010 Francois Aucamp <faucamp@fedoraproject.org> - 1.43-2
130- Added patch declaring explicit libm linking dependency (RHBZ #565186)
131
132* Sat Feb 13 2010 Francois Aucamp <faucamp@fedoraproject.org> - 1.43-1
133- Update to version 1.43
134- Added patch for runtime detection of pulseaudio, contributed by Kevin Kofler (RHBZ #512190)
135
136* Thu Dec 17 2009 Francois Aucamp <faucamp@fedoraproject.org> - 1.42.04-1
137- Update to version 1.42.04
138- Revert: build against PortAudio instead of native PulseAudio (RHBZ #512190, #532674)
139
140* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.40.02-3
141- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
142
143* Tue Jun 30 2009 Francois Aucamp <faucamp@fedoraproject.org> - 1.40.02-2
144- Compile against pulseaudio instead of portaudio (RHBZ #481651)
145
146* Mon Jun 22 2009 Francois Aucamp <faucamp@fedoraproject.org> - 1.40.02-1
147- Update to version 1.40.02
148- Added patch to compile with GCC and not to link to libstdc++ (not needed)
149- Added manpage (thanks goes to Luke Yelavich from Ubuntu for writing it)
150
151* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.39-2
152- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
153
154* Tue Oct 21 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.39-1
155- Update to version 1.39
156
157* Tue Feb 26 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.31-5
158- Export ESPEAK_DATA_PATH in %%build to allow proper compilation of voice dictionaries
159
160* Tue Jan 29 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.31-4
161- Removed libjack patches as they are unnecessary
162
163* Tue Jan 29 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.31-3
164- Added "makefile_libjack" patch to link to libjack
165- Added BuildRequires: jack-audio-connection-kit-devel
166
167* Fri Jan 25 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.31-2
168- Removed espeakedit (and associated patches and BuildRequires) from package
169  until all phoneme table compilation functions can be moved into espeak (or a
170  separate commandline app without wxGTK dependencies)
171- Voices are still compiled from source, but using pre-compiled phoneme table
172  from upstream until the above issue is resolved
173
174* Thu Jan 24 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.31-1
175- Update to version 1.31
176- Compile phoneme tables and voice dictionaries from source instead of
177  packaging pre-compiled binary data
178- Added espeakedit as Source1
179- Added BuildRequires: wxGTK-devel for espeakedit
180- Added "makefile_rpmoptflags_wxversion" espeakedit patch to enable
181  RPM_OPT_FLAGS and set the correct wxWidgets version
182- Added "espeak_data_path" espeakedit patch to be able to set control the
183  source directory that espeakedit's compiler uses
184
185* Tue Jan 15 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.30-1
186- Update to version 1.30
187- Removed local "synthdata_strlen" patch (included upstream)
188
189* Mon Aug 20 2007 Francois Aucamp <faucamp@csir.co.za> - 1.28-1
190- Update to version 1.28
191- Added "synthdata_strlen" patch to fix memory allocation issue on x86_64 (RHBZ #252712)
192- Modified %%prep to build against portaudio v19 for F8 and later
193- Upstream license changed from GPLv2+ to GPLv3+
194
195* Tue Jun 19 2007 Francois Aucamp <faucamp@csir.co.za> - 1.26-1
196- Update to version 1.26
197- Modified %%prep to build against portaudio v19
198
199* Tue Jun 05 2007 Francois Aucamp <faucamp@csir.co.za> - 1.25-1
200- Update to version 1.25
201
202* Tue May 08 2007 Francois Aucamp <faucamp@csir.co.za> - 1.24-1
203- Update to version 1.24
204
205* Tue Apr 24 2007 Francois Aucamp <faucamp@csir.co.za> - 1.23-1
206- Update to version 1.23
207- Added "makefile_nostaticlibs" patch so static libraries aren't installed
208
209* Thu Feb 08 2007 Francois Aucamp <faucamp@csir.co.za> - 1.20-1
210- Update to version 1.20
211- Solves stack smash bug (RHBZ #227316)
212
213* Fri Jan 26 2007 Francois Aucamp <faucamp@csir.co.za> - 1.19-1
214- Update to version 1.19
215- Removed "espeak-1.18-makefile_lpthread" patch as it has been included upstream
216- Removed "espeak-1.18-makefile_smp" patch as it has been included upstream
217- Removed "espeak-1.18-ptr_64bit" patch as it has been solved upstream
218- Fixed espeak-data file permissions
219
220* Tue Jan 16 2007 Francois Aucamp <faucamp@csir.co.za> - 1.18-2
221- Created "espeak-1.18-ptr_64bit" patch to allow compilation on x86_64 (fixes 64-bit pointer issues)
222- Created "espeak-1.18-makefile_smp" patch to allow parallel make ("_smp_mflags")
223- Renamed "makefile_lpthread" patch to "espeak-1.18-makefile_lpthread"
224
225* Mon Jan 15 2007 Francois Aucamp <faucamp@csir.co.za> - 1.18-1
226- Update to version 1.18
227- Dropped statically-linked "speak" executable (replaced by dynamically-linked "espeak" executable)
228- Removed the "espeak program name" patch as it has been included upstream
229- Removed "espeak program name" patch backup file cleanup from %%install
230- Minor modification to "makefile lpthread" patch to account for new lib/executable
231- Removed "BIN_NAME" variable from make in %%build (implemented upstream)
232
233* Mon Nov 20 2006 Francois Aucamp <faucamp@csir.co.za> - 1.17-1
234- Update to version 1.17
235- Removed "makefile install target" patch as it has been included upstream
236- Removed "AMD64 sizeof(char *)" patch as it has been included upstream
237- Minor modification to "espeak program name" patch to allow patching current version
238
239* Tue Nov 07 2006 Francois Aucamp <faucamp@csir.co.za> - 1.16-4
240- Modified patch steps to create backups with different suffixes
241- Renamed patch file extensions to .patch
242- Added step in %%install to remove patch backup files in documentation
243
244* Sat Nov 04 2006 Francois Aucamp <faucamp@csir.co.za> - 1.16-3
245- Fixed source file permissions for -debuginfo package in %%prep
246- Added RPM_OPT_FLAGS to "make" command in %%build; removed RPM_OPT_FLAGS makefile patch
247- Modified makefile install target patch to include general support for setting compiler optimization flags via CXXFLAGS
248- Removed creation of .orig backup files during patching
249- Modified patch files to have different suffixes
250
251* Thu Nov 02 2006 Francois Aucamp <faucamp@csir.co.za> - 1.16-2
252- Added "install" target to makefile (makefile_install_target.patch)
253- Added patch to fix AMD64 sizeof(char *) assumption bug (upstream request ID 1588938)
254- Changed "portaudio" BuildRequires to "portaudio-devel"
255- Added patch to makefile to allow RPM_OPT_FLAGS
256- Added patch to replace all references to "speak" binary with "espeak"
257- Moved header files to /usr/include/espeak
258- Added rmdir command to "install" to remove empty soundicons directory
259
260* Wed Oct 04 2006 Francois Aucamp <faucamp@csir.co.za> - 1.16-1
261- Initial RPM build
Note: See TracBrowser for help on using the repository browser.