source: projects/specs/trunk/e/eruby/eruby-vl.spec @ 7021

Revision 7021, 5.2 KB checked in by daisuke, 12 years ago (diff)

eruby:

  • build with ruby-1.9.3
  • add patches from FreeBSD/fedora to build with ruby-1.9
Line 
1Summary:       An interpreter of embedded Ruby language
2Summary(ja):   テキスト埋め込みの Ruby 言語インタプリタ
3Name:          eruby
4Version:       1.0.5
5Release:       3%{?_dist_release}
6# eruby is GPLv2+
7# liberuby is LGPLv2+
8License:       GPLv2+ and LGPLv2+
9Group:         Development/Languages
10Source0:       http://www.modruby.net/archive/%{name}-%{version}.tar.gz
11Patch0:        patch-aa-git
12Patch1:        eruby-fix-build.patch
13Patch2:        eruby-1.0.5-ruby19.patch
14URL:           http://www.modruby.net/
15Prefix:        /usr
16BuildRoot:     %{_tmppath}/%{name}-%{version}-root
17BuildRequires: ruby, ruby-devel >= 1.9
18
19
20%description
21eRuby interprets a Ruby code embedded text file. For example, eRuby
22enables you to embed a Ruby code to a HTML file.
23
24%description -l ja
25eRubyはRubyのコードが埋めこまれたテキストファイルを解釈実行します.た
26とえば,eRubyを使えば,HTMLにRubyのコードをHTMLファイルに埋めこむこと
27ができます.
28
29
30%package -n liberuby
31Summary:     Library for eruby
32Summary(ja): eruby 用ライブラリ
33Group:       System Environment/Libraries
34Requires:    libruby >= 1.8.0
35
36%description -n liberuby
37This package includes library for eruby.
38
39%description -n liberuby -l ja
40eruby に必要なライブラリです。
41
42
43%package -n liberuby-devel
44Summary:     A eRuby development environment.
45Summary(ja): eRuby 開発環境
46Group:       Development/Libraries
47Requires:    liberuby = %{version}
48Obsoletes:   eruby-devel
49
50%description -n liberuby-devel
51Header files and libraries for an application embedded ERuby.
52
53%description -n liberuby-devel -l ja
54ERubyを組み込んだアプリケーションを作るために必要となるへッダファイルや
55ライブラリです.
56
57
58%prep
59%setup -q
60%patch0 -p1 -b .git
61%patch1 -p1 -b .0-build
62%patch2 -p1 -b .ruby19
63
64%build
65ruby configure.rb --enable-shared
66make
67cd ..
68
69
70%install
71rm -rf %{buildroot}
72mkdir -p %{buildroot}%{_bindir}
73mkdir -p %{buildroot}%{_libdir}
74mkdir -p %{buildroot}%{_mandir}/man1
75mkdir -p %{buildroot}%{_includedir}
76mkdir -p %{buildroot}%{ruby_vendorarchdir}
77
78# installing binaries ...
79make install DESTDIR=$RPM_BUILD_ROOT
80
81# remove the unnecessary files
82rm %{buildroot}%{_libdir}/*.a
83
84# change permissions
85find %{buildroot}%{_libdir} -name '*.so*' | xargs chmod 0755
86
87# workaround for not working site-install properly
88mv $RPM_BUILD_ROOT%{ruby_libarchdir}/eruby.so $RPM_BUILD_ROOT%{ruby_vendorarchdir}/
89
90%clean
91rm -rf %{buildroot}
92
93
94%post -p /sbin/ldconfig -n liberuby
95
96
97%postun -p /sbin/ldconfig -n liberuby
98
99
100%files -n eruby
101%defattr(-, root, root)
102%{rbindir}/%{name}
103%{_mandir}/man1/%{name}.1*
104%doc COPYING GPL LGPL
105%doc README* ChangeLog examples
106
107
108%files -n liberuby
109%defattr(-, root, root)
110%{_libdir}/lib%{name}.so.*
111%{ruby_vendorarchdir}/%{name}*
112
113
114%files -n liberuby-devel
115%defattr(-, root, root)
116%{_libdir}/lib%{name}.so
117%{_includedir}/%{name}*.h
118
119
120%changelog
121* Fri Oct 26 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-3
122- rebuild with ruby-1.9.3
123- add patches from FreeBSD/fedora
124
125* Thu Mar 22 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.5-2
126- rebuild; spec revamp; remove *.a file
127
128* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.5-1vl5
129- applied new versioning policy, spec in utf-8
130
131* Mon Sep 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl3
132- changed liberuby Group to System Environment/Libraries
133- changed liberuby-devel Group to Development/Libraries
134
135* Sat Jul 29 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-0vl2
136- s/Copyright/License/
137- added "libdir=${RPM_BUILD_ROOT}%{_libdir}" to make install option
138
139* Tue Dec 30 2003 akira yamada <akira@vinelinux.org> 1.0.5-0vl1
140- new upstream version.
141
142* Mon Oct 06 2003 akira yamada <akira@vinelinux.org> 1.0.4-0vl1
143- new upstream version.
144- build with ruby-1.8.0.
145
146* Mon Jul 21 2003 IWAI Masaharu <iwai@alib.jp> 1.0.3-0vl1
147- new upstream version.
148
149* Thu May 30 2002 akira yamada <akira@vinelinux.org> 0.9.8-0vl2
150- updated URL of upstream sources.
151
152* Thu May 30 2002 akira yamada <akira@vinelinux.org> 0.9.8-0vl1
153- new upstream version.
154
155* Wed Aug 08 2001 akira yamada <akira@vinelinux.org> 0.9.7-0vl1
156- new upstream version.
157
158* Wed Aug 08 2001 akira yamada <akira@vinelinux.org>
159- 0.9.6-0vl1
160- new upstream version 0.9.6.
161
162* Thu Jul 26 2001 akira yamada <akira@vinelinux.org>
163- rebuild with ruby-devel-1.6.4-0vl3.
164
165* Mon Jun 25 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
166- 0.9.5-0vl2
167- added "Obsoletes: eruby-devel" for liberuby-devel
168
169* Thu Jun 21 2001 akira yamada <akira@vinelinux.org>
170- Updated to upstream version 0.9.5.
171- eruby -> eruby + liberuby
172- eruby-devel -> liberuby-devel
173
174* Mon Jun 07 2001 akira yamada <akira@vinelinux.org>
175- Updated to upstream version 0.9.4.
176
177* Mon Jun 04 2001 akira yamada <akira@vinelinux.org>
178- Updated to upstream version 0.9.3.
179
180* Thu Oct 19 2000 akira yamada <akira@vinelinux.org>
181- Updated to upstream version 0.1.2.
182
183* Thu Sep 27 2000 akira yamada <akira@vinelinux.org>
184- Updated to upstream version 0.1.1
185- New binary package: eruby-devel
186- Removed eruby.c.O_EXCL.patch (fixed at 0.1.1)
187
188* Tue Aug 29 2000 akira yamada <akira@vinelinux.org>
189- Updated to upstream  version 0.0.9
190- Added eruby.c.O_EXCL.patch
191
192* Tue Jun 22 2000 akira yamada <akira@redhat.com>
193- Initial packaging.
Note: See TracBrowser for help on using the repository browser.