source: projects/specs/trunk/e/eruby/eruby-vl.spec @ 5944

Revision 5944, 4.9 KB checked in by shaolin, 12 years ago (diff)
  • eruby: rebuild; spec revamp; remove *.a file
Line 
1Summary:       An interpreter of embedded Ruby language
2Summary(ja):   テキスト埋め込みの Ruby 言語インタプリタ
3Name:          eruby
4Version:       1.0.5
5Release:       2%{?_dist_release}
6# eruby is GPLv2+
7# liberuby is LGPLv2+
8License:       GPLv2+ and LGPLv2+
9Group:         Development/Languages
10Source0:       http://www.modruby.net/archive/%{name}-%{version}.tar.gz
11Patch0:        eruby-fix-build.patch
12URL:           http://www.modruby.net/
13Prefix:        /usr
14BuildRoot:     %{_tmppath}/%{name}-%{version}-root
15BuildRequires: ruby, ruby-devel >= 1.8.0
16Requires:      libruby >= 1.8.0, liberuby = %{version}
17
18
19%description
20eRuby interprets a Ruby code embedded text file. For example, eRuby
21enables you to embed a Ruby code to a HTML file.
22
23%description -l ja
24eRubyはRubyのコードが埋めこまれたテキストファイルを解釈実行します.た
25とえば,eRubyを使えば,HTMLにRubyのコードをHTMLファイルに埋めこむこと
26ができます.
27
28
29%package -n liberuby
30Summary:     Library for eruby
31Summary(ja): eruby 用ライブラリ
32Group:       System Environment/Libraries
33Requires:    libruby >= 1.8.0
34
35%description -n liberuby
36This package includes library for eruby.
37
38%description -n liberuby -l ja
39eruby に必要なライブラリです。
40
41
42%package -n liberuby-devel
43Summary:     A eRuby development environment.
44Summary(ja): eRuby 開発環境
45Group:       Development/Libraries
46Requires:    liberuby = %{version}
47Obsoletes:   eruby-devel
48
49%description -n liberuby-devel
50Header files and libraries for an application embedded ERuby.
51
52%description -n liberuby-devel -l ja
53ERubyを組み込んだアプリケーションを作るために必要となるへッダファイルや
54ライブラリです.
55
56
57%prep
58%setup -q
59%patch0 -p1 -b .0-build
60
61%build
62ruby configure.rb --enable-shared
63make
64cd ..
65
66
67%install
68rm -rf %{buildroot}
69mkdir -p %{buildroot}%{_bindir}
70mkdir -p %{buildroot}%{_libdir}
71mkdir -p %{buildroot}%{_mandir}/man1
72mkdir -p %{buildroot}%{_includedir}
73
74# installing binaries ...
75make install prefix=%{buildroot}%{prefix} \
76             libdir=%{buildroot}%{_libdir} \
77             mandir=%{buildroot}%{_mandir}
78
79# remove the unnecessary files
80rm %{buildroot}%{_libdir}/*.a
81
82# change permissions
83find %{buildroot}%{_libdir} -name '*.so*' | xargs chmod 0755
84
85%clean
86rm -rf %{buildroot}
87
88
89%post -p /sbin/ldconfig -n liberuby
90
91
92%postun -p /sbin/ldconfig -n liberuby
93
94
95%files -n eruby
96%defattr(-, root, root)
97%{rbindir}/%{name}
98%{_mandir}/man1/%{name}.1*
99%doc COPYING GPL LGPL
100%doc README* ChangeLog examples
101
102
103%files -n liberuby
104%defattr(-, root, root)
105%{_libdir}/lib%{name}.so.*
106%{rarchdir}/%{name}*
107
108
109%files -n liberuby-devel
110%defattr(-, root, root)
111%{_libdir}/lib%{name}.so
112%{_includedir}/%{name}*.h
113
114
115%changelog
116* Thu Mar 22 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.5-2
117- rebuild; spec revamp; remove *.a file
118
119* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.5-1vl5
120- applied new versioning policy, spec in utf-8
121
122* Mon Sep 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl3
123- changed liberuby Group to System Environment/Libraries
124- changed liberuby-devel Group to Development/Libraries
125
126* Sat Jul 29 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-0vl2
127- s/Copyright/License/
128- added "libdir=${RPM_BUILD_ROOT}%{_libdir}" to make install option
129
130* Tue Dec 30 2003 akira yamada <akira@vinelinux.org> 1.0.5-0vl1
131- new upstream version.
132
133* Mon Oct 06 2003 akira yamada <akira@vinelinux.org> 1.0.4-0vl1
134- new upstream version.
135- build with ruby-1.8.0.
136
137* Mon Jul 21 2003 IWAI Masaharu <iwai@alib.jp> 1.0.3-0vl1
138- new upstream version.
139
140* Thu May 30 2002 akira yamada <akira@vinelinux.org> 0.9.8-0vl2
141- updated URL of upstream sources.
142
143* Thu May 30 2002 akira yamada <akira@vinelinux.org> 0.9.8-0vl1
144- new upstream version.
145
146* Wed Aug 08 2001 akira yamada <akira@vinelinux.org> 0.9.7-0vl1
147- new upstream version.
148
149* Wed Aug 08 2001 akira yamada <akira@vinelinux.org>
150- 0.9.6-0vl1
151- new upstream version 0.9.6.
152
153* Thu Jul 26 2001 akira yamada <akira@vinelinux.org>
154- rebuild with ruby-devel-1.6.4-0vl3.
155
156* Mon Jun 25 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
157- 0.9.5-0vl2
158- added "Obsoletes: eruby-devel" for liberuby-devel
159
160* Thu Jun 21 2001 akira yamada <akira@vinelinux.org>
161- Updated to upstream version 0.9.5.
162- eruby -> eruby + liberuby
163- eruby-devel -> liberuby-devel
164
165* Mon Jun 07 2001 akira yamada <akira@vinelinux.org>
166- Updated to upstream version 0.9.4.
167
168* Mon Jun 04 2001 akira yamada <akira@vinelinux.org>
169- Updated to upstream version 0.9.3.
170
171* Thu Oct 19 2000 akira yamada <akira@vinelinux.org>
172- Updated to upstream version 0.1.2.
173
174* Thu Sep 27 2000 akira yamada <akira@vinelinux.org>
175- Updated to upstream version 0.1.1
176- New binary package: eruby-devel
177- Removed eruby.c.O_EXCL.patch (fixed at 0.1.1)
178
179* Tue Aug 29 2000 akira yamada <akira@vinelinux.org>
180- Updated to upstream  version 0.0.9
181- Added eruby.c.O_EXCL.patch
182
183* Tue Jun 22 2000 akira yamada <akira@redhat.com>
184- Initial packaging.
Note: See TracBrowser for help on using the repository browser.