source: projects/specs/trunk/e/epiphany/epiphany-vl.spec @ 871

Revision 871, 10.4 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file for gnome-2.30

Line 
1# gecko backend was removed 2.27.0
2%define with_gecko 0
3%define with_webkit 1
4
5%define gecko_version 1.9.1
6%define webkit_version 1.1.15
7
8ExclusiveArch: %ix86 ppc x86_64 alpha
9
10Summary: GNOME web browser based on Gecko/WebKit
11Summary(ja): Gecko/WebKit レンダリングエンジンベースの GNOME ウェブブラウザ
12Name: epiphany
13Version: 2.30.0
14Release: 1%{?_dist_release}
15License: GPL
16Group: Applications/Internet
17URL: http://www.gnome.org/projects/epiphany/
18
19Source0: http://ftp.gnome.org/pub/GNOME/sources/epiphany/2.28/%{name}-%{version}.tar.bz2
20Patch1: epiphany-2.26.2-gecko191.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24Requires: gnome-icon-theme >= 2.30.0
25%if %{with_gecko}
26Requires: gecko-libs
27%endif
28Requires(post,pre,preun): GConf2
29Requires(post,postun): scrollkeeper, shared-mime-info
30
31%if %{with_gecko}
32BuildRequires: gecko-devel-unstable >= %{gecko_version}
33%endif
34%if %{with_webkit}
35BuildRequires: WebKit-gtk-devel >= %{webkit_version}
36%endif
37BuildRequires: glib2-devel >= 2.24.0
38BuildRequires: gtk2-devel >= 2.20.0
39BuildRequires: libxml2-devel >= 2.6.12
40BuildRequires: libxslt-devel >= 1.1.7
41BuildRequires: libnotify-devel >= 0.4.0
42BuildRequires: dbus-glib-devel >= 0.35
43BuildRequires: libsoup-devel >= 2.30.0
44BuildRequires: gnome-desktop-devel >= 2.30.0
45BuildRequires: GConf2-devel
46BuildRequires: nss-devel
47BuildRequires: avahi-gobject-devel >= 0.6.22
48BuildRequires: NetworkManager-devel
49BuildRequires: iso-codes
50BuildRequires: intltool >= 0.40
51BuildRequires: libICE-devel
52BuildRequires: libSM-devel
53BuildRequires: libgnome-keyring-devel
54BuildRequires: gobject-introspection-devel
55BuildRequires: gir-repository-devel
56BuildRequires: gnome-doc-utils
57
58%description
59epiphany is a simple GNOME web browser based on the Mozilla rendering
60engine
61
62%description -l ja
63epiphany は Mozilla レンダリングエンジンベースのシンプルな GNOME
64ウェブブラウザです。
65
66%prep
67%setup -q
68
69#patch1 -p1
70
71%build
72MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')
73export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
74
75%configure \
76%if %{with_gecko}
77  --with-gecko=libxul-embedding \
78%endif
79%if %{with_webkit}
80  --with-engine=webkit \
81%endif
82  --enable-zeroconf \
83  --enable-network-manager \
84  --disable-scrollkeeper \
85  --without-ca-file
86
87%__make %{?_smp_mflags}
88
89%install
90rm -rf $RPM_BUILD_ROOT
91export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
92make install DESTDIR=$RPM_BUILD_ROOT
93unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
94
95%find_lang %{name} --with-gnome
96
97rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
98rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/*/plugins/*.la
99
100rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
101
102%pre
103if [ "$1" -gt 1 ]; then
104  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
105  SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
106  for S in $SCHEMAS; do
107    gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
108  done
109fi
110
111%post
112touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
113export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
114SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
115for S in $SCHEMAS; do
116  gconftool-2 --makefile-install-rule /etc/gconf/schemas/$S > /dev/null
117done
118
119%preun
120if [ "$1" -eq 0 ]; then
121  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
122  SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
123  for S in $SCHEMAS; do
124    gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
125  done
126fi
127
128%postun
129if [ $1 -eq 0 ] ; then
130    touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
131    gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
132    update-desktop-database %{_datadir}/applications >& /dev/null ||:
133    scrollkeeper-update >& /dev/null ||:
134fi
135
136%posttrans
137gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
138update-desktop-database %{_datadir}/applications >& /dev/null ||:
139scrollkeeper-update >& /dev/null ||:
140
141
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145%files -f %{name}.lang
146%defattr(-,root,root,-)
147%doc AUTHORS ChangeLog* COPYING* NEWS README
148%{_sysconfdir}/gconf/schemas/epiphany*.schemas
149%{_bindir}/epiphany
150%{_includedir}/epiphany/*
151%{_libdir}/pkgconfig/epiphany*.pc
152%{_libdir}/girepository-1.0/Epiphany-2.29.typelib
153%if %{with_gecko}
154%{_libdir}/epiphany
155%endif
156%{_datadir}/gir-1.0/Epiphany-2.29.gir
157#{_datadir}/pygtk/*/defs/*
158%{_datadir}/applications/*.desktop
159%{_datadir}/epiphany
160%{_datadir}/gtk-doc/html/*
161%{_datadir}/icons/*
162%{_datadir}/aclocal/*
163%{_datadir}/dbus-1/services/*
164%{_mandir}/man1/epiphany.1*
165
166%changelog
167* Sat Apr 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
168- new upstream release
169- add BuildRequires: gobject-introspection-devel, gir-repository-devel
170- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
171- add configure option (--without-ca-file)
172- remove unrecognized configure option (--with-engine)
173
174* Sat Jan 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
175- new upstream release
176- added BR: libICE-devel, libSM-devel and gnome-keyring-devel
177
178* Sat Nov 07 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
179- new upstream release
180
181* Mon Jul 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
182- run gtk-update-icon-cache in %%post/postun script.
183
184* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
185- new upstream release
186
187* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
188- rebuild with gecko-1.9.1
189
190* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
191- new upstream release
192
193* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
194- new upstream release
195- build with xulrunner-1.9.0.7
196
197* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
198- new upstream release
199
200* Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
201- build with gecko-1.9.0.3 instead of WebKit.
202  - WebKit port is unstable yet.
203- enable zeroconf, NetworkManager support
204
205* Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
206- new upstream release
207
208* Thu Jul 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1.1-2vl5
209- build with WebKit instead of gecko.
210
211* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
212- new upstream release
213- added %%pre and %%preun section
214
215* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
216- new upstream release
217- rebuilt with firefox-2.0.0.6-0vl3
218
219* Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.2-0vl2
220- add BuildRequires: gnome-python
221
222* Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
223- new upstream release
224- rebuilt with new toolchain and firefox-2.0.0.4-0vl6
225
226* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
227- new upstream release
228
229* Tue Nov 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.3-0vl1
230- source update
231- add Patch0 to build with firefox 2.0 <BTS:VineLinux:342>
232- add BuildRequires: pygtk2-devel
233
234* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2.1-0vl1
235- new upstream release
236
237* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
238- rebuild with firefox-1.5.0.2-0vl4
239
240* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
241- new upstream release
242- build with firefox-1.5.0.2
243
244* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
245- new upstream release
246
247* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
248- new upstream release
249- build with firefox-1.5.0.1
250
251* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
252- new upstream release
253- build with mozilla-1.7.12
254
255* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl2
256- rebuild with mozilla-1.7.8
257
258* Sun Apr 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl1
259- new upstream release
260
261* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-0vl1
262- new upstream release
263- build with mozilla-1.7.7
264
265* Fri Apr  1 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl2
266- rebuild with mozilla-1.7.6
267
268* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
269- new upstream release
270
271* Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl1
272- new upstream release
273- build with mozilla-1.7.5
274
275* Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
276- new upstream release
277
278* Tue Nov 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-0vl1
279- new upstream release
280
281* Mon Sep 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl2
282- rebuild with mozilla-1.7.3
283
284* Wed Aug 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
285- new upstream release
286- build with mozilla-1.7.2
287- add Patch10 to build with gnome-2.4
288
289* Wed Jan 21 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.7-0vl1
290- new upstream version
291        -- dropped patch10
292- changed URL
293
294* Fri Jan  9 2004 Tomoya TAKA <taka@vinelinux.org> 1.0.6-0vl3
295- add alpha into ExclusiveArch
296
297* Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-0vl2
298- rebuild with mozilla-1.5.1
299
300* Sat Dec  6 2003 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.0.6-0vl1
301- new upstream release
302
303* Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
304- new upstream release
305
306* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl2
307- fixed missing locale files
308
309* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
310- new upstream release
311
312* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
313- new upstream release
314
315* Sun Jul 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
316- new upstream release
317
318* Sun Jul 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-0vl1
319- new upstream release
320- build with mozilla 1.4
321
322* Sat Jun 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
323- new upstream release
324
325* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl1
326- build for Vine Linux
327
328* Mon Jun  2 2003 Elliot Lee <sopwith@redhat.com> 0.6.1-2
329- Rebuild to fix broken mozilla dep, patch for mozilla 1.4
330
331* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 0.6.1-1
332- 0.6.1
333
334* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-4
335- add patch to fix gint/gpointer conversion bugs for 64bit arches
336
337* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-3
338- only build on arches mozilla is built on
339
340* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-2
341- rebuild against new mozilla, make mozilla requires dynamic
342
343* Sun May  4 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-1
344- update to 0.6.0
345- fix tyop in %%postun
346
347* Wed Apr 16 2003 Bill Nottingham <notting@redhat.com> 0.5.0-3
348- make it build with mozilla-1.4 (shouldn't affect moz-1.2/moz-1.3 builds)
349
350* Mon Apr 14 2003 Jeremy Katz <katzj@redhat.com> 0.5.0-2
351- add some buildrequires, prereq GConf2
352- disable building nautilus view
353
354* Sun Apr 13 2003 Jeremy Katz <katzj@redhat.com>
355- Initial build.
356
357
Note: See TracBrowser for help on using the repository browser.