source: projects/specs/trunk/e/epiphany/epiphany-vl.spec @ 521

Revision 521, 9.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# gecko backend was removed 2.27.0
2%define with_gecko 0
3%define with_webkit 1
4
5%define gecko_version 1.9.1
6%define webkit_version 1.1.15
7
8ExclusiveArch: i386 ppc x86_64 alpha
9
10Summary: GNOME web browser based on Gecko/WebKit
11Summary(ja): Gecko/WebKit レンダリングエンジンベースの GNOME ウェブブラウザ
12Name: epiphany
13Version: 2.28.2
14Release: 1%{?_dist_release}
15License: GPL
16Group: Applications/Internet
17URL: http://www.gnome.org/projects/epiphany/
18
19Source0: http://ftp.gnome.org/pub/GNOME/sources/epiphany/2.28/%{name}-%{version}.tar.bz2
20Patch1: epiphany-2.26.2-gecko191.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24Requires: gnome-icon-theme >= 2.24.0
25%if %{with_gecko}
26Requires: gecko-libs
27%endif
28Requires(post,pre,preun): GConf2
29Requires(post,postun): scrollkeeper, shared-mime-info
30
31%if %{with_gecko}
32BuildRequires: gecko-devel-unstable >= %{gecko_version}
33%endif
34%if %{with_webkit}
35BuildRequires: WebKit-gtk-devel >= %{webkit_version}
36%endif
37BuildRequires: glib2-devel >= 2.20.0
38BuildRequires: gtk2-devel >= 2.16.0
39BuildRequires: libxml2-devel >= 2.6.12
40BuildRequires: libxslt-devel >= 1.1.7
41BuildRequires: libnotify-devel >= 0.4.0
42BuildRequires: dbus-glib-devel >= 0.35
43BuildRequires: libsoup-devel >= 2.28.0
44BuildRequires: gnome-desktop-devel >= 2.26.0
45BuildRequires: GConf2-devel
46BuildRequires: nss-devel
47BuildRequires: avahi-gobject-devel >= 0.6.22
48BuildRequires: NetworkManager-devel
49BuildRequires: iso-codes
50BuildRequires: intltool >= 0.40
51BuildRequires: libICE-devel
52BuildRequires: libSM-devel
53BuildRequires: gnome-keyring-devel
54
55%description
56epiphany is a simple GNOME web browser based on the Mozilla rendering
57engine
58
59%description -l ja
60epiphany は Mozilla レンダリングエンジンベースのシンプルな GNOME
61ウェブブラウザです。
62
63%prep
64%setup -q
65
66#patch1 -p1
67
68%build
69MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')
70export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
71
72%configure \
73%if %{with_gecko}
74  --with-engine=mozilla \
75  --with-gecko=libxul-embedding \
76%endif
77%if %{with_webkit}
78  --with-engine=webkit \
79%endif
80  --enable-zeroconf \
81  --enable-network-manager \
82  --disable-scrollkeeper
83
84%__make %{?_smp_mflags}
85
86%install
87rm -rf $RPM_BUILD_ROOT
88export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
89make install DESTDIR=$RPM_BUILD_ROOT
90unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
91
92%find_lang %{name} --with-gnome
93
94rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
95rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/*/plugins/*.la
96
97rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
98
99%pre
100if [ "$1" -gt 1 ]; then
101  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102  SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
103  for S in $SCHEMAS; do
104    gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
105  done
106fi
107
108%post
109touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
110export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
111SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
112for S in $SCHEMAS; do
113  gconftool-2 --makefile-install-rule /etc/gconf/schemas/$S > /dev/null
114done
115
116%preun
117if [ "$1" -eq 0 ]; then
118  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
119  SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
120  for S in $SCHEMAS; do
121    gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
122  done
123fi
124
125%postun
126if [ $1 -eq 0 ] ; then
127    touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
128    gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
129    update-desktop-database %{_datadir}/applications >& /dev/null ||:
130    scrollkeeper-update >& /dev/null ||:
131fi
132
133%posttrans
134gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
135update-desktop-database %{_datadir}/applications >& /dev/null ||:
136scrollkeeper-update >& /dev/null ||:
137
138
139%clean
140rm -rf $RPM_BUILD_ROOT
141
142%files -f %{name}.lang
143%defattr(-,root,root,-)
144%doc AUTHORS ChangeLog* COPYING* NEWS README
145%{_sysconfdir}/gconf/schemas/epiphany*.schemas
146%{_bindir}/epiphany
147%{_includedir}/epiphany/*
148%{_libdir}/pkgconfig/epiphany*.pc
149%if %{with_gecko}
150%{_libdir}/epiphany
151%endif
152#{_datadir}/pygtk/*/defs/*
153%{_datadir}/applications/*.desktop
154%{_datadir}/epiphany
155%{_datadir}/gtk-doc/html/*
156%{_datadir}/icons/*
157%{_datadir}/aclocal/*
158%{_datadir}/dbus-1/services/*
159%{_mandir}/man1/epiphany.1*
160
161%changelog
162* Sat Jan 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
163- new upstream release
164- added BR: libICE-devel, libSM-devel and gnome-keyring-devel
165
166* Sat Nov 07 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
167- new upstream release
168
169* Mon Jul 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
170- run gtk-update-icon-cache in %%post/postun script.
171
172* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
173- new upstream release
174
175* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
176- rebuild with gecko-1.9.1
177
178* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
179- new upstream release
180
181* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
182- new upstream release
183- build with xulrunner-1.9.0.7
184
185* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
186- new upstream release
187
188* Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
189- build with gecko-1.9.0.3 instead of WebKit.
190  - WebKit port is unstable yet.
191- enable zeroconf, NetworkManager support
192
193* Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
194- new upstream release
195
196* Thu Jul 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1.1-2vl5
197- build with WebKit instead of gecko.
198
199* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
200- new upstream release
201- added %%pre and %%preun section
202
203* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
204- new upstream release
205- rebuilt with firefox-2.0.0.6-0vl3
206
207* Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.2-0vl2
208- add BuildRequires: gnome-python
209
210* Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
211- new upstream release
212- rebuilt with new toolchain and firefox-2.0.0.4-0vl6
213
214* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
215- new upstream release
216
217* Tue Nov 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.3-0vl1
218- source update
219- add Patch0 to build with firefox 2.0 <BTS:VineLinux:342>
220- add BuildRequires: pygtk2-devel
221
222* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2.1-0vl1
223- new upstream release
224
225* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
226- rebuild with firefox-1.5.0.2-0vl4
227
228* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
229- new upstream release
230- build with firefox-1.5.0.2
231
232* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
233- new upstream release
234
235* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
236- new upstream release
237- build with firefox-1.5.0.1
238
239* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
240- new upstream release
241- build with mozilla-1.7.12
242
243* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl2
244- rebuild with mozilla-1.7.8
245
246* Sun Apr 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl1
247- new upstream release
248
249* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-0vl1
250- new upstream release
251- build with mozilla-1.7.7
252
253* Fri Apr  1 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl2
254- rebuild with mozilla-1.7.6
255
256* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
257- new upstream release
258
259* Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl1
260- new upstream release
261- build with mozilla-1.7.5
262
263* Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
264- new upstream release
265
266* Tue Nov 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-0vl1
267- new upstream release
268
269* Mon Sep 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl2
270- rebuild with mozilla-1.7.3
271
272* Wed Aug 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
273- new upstream release
274- build with mozilla-1.7.2
275- add Patch10 to build with gnome-2.4
276
277* Wed Jan 21 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.7-0vl1
278- new upstream version
279        -- dropped patch10
280- changed URL
281
282* Fri Jan  9 2004 Tomoya TAKA <taka@vinelinux.org> 1.0.6-0vl3
283- add alpha into ExclusiveArch
284
285* Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-0vl2
286- rebuild with mozilla-1.5.1
287
288* Sat Dec  6 2003 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.0.6-0vl1
289- new upstream release
290
291* Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
292- new upstream release
293
294* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl2
295- fixed missing locale files
296
297* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
298- new upstream release
299
300* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
301- new upstream release
302
303* Sun Jul 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
304- new upstream release
305
306* Sun Jul 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-0vl1
307- new upstream release
308- build with mozilla 1.4
309
310* Sat Jun 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
311- new upstream release
312
313* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl1
314- build for Vine Linux
315
316* Mon Jun  2 2003 Elliot Lee <sopwith@redhat.com> 0.6.1-2
317- Rebuild to fix broken mozilla dep, patch for mozilla 1.4
318
319* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 0.6.1-1
320- 0.6.1
321
322* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-4
323- add patch to fix gint/gpointer conversion bugs for 64bit arches
324
325* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-3
326- only build on arches mozilla is built on
327
328* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-2
329- rebuild against new mozilla, make mozilla requires dynamic
330
331* Sun May  4 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-1
332- update to 0.6.0
333- fix tyop in %%postun
334
335* Wed Apr 16 2003 Bill Nottingham <notting@redhat.com> 0.5.0-3
336- make it build with mozilla-1.4 (shouldn't affect moz-1.2/moz-1.3 builds)
337
338* Mon Apr 14 2003 Jeremy Katz <katzj@redhat.com> 0.5.0-2
339- add some buildrequires, prereq GConf2
340- disable building nautilus view
341
342* Sun Apr 13 2003 Jeremy Katz <katzj@redhat.com>
343- Initial build.
344
345
Note: See TracBrowser for help on using the repository browser.