source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 5168

Revision 5168, 16.5 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define major_ver 3.2
2%define minor_ver 2
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk3_min_version        3.2.0
10%global glib2_min_version       2.30.0
11%global tp_mc_min_version       5.6.0
12%global tp_glib_min_version     0.16.0
13%global tp_logger_min_version   0.2.10
14%global aspell_version          0.50
15%global libcanberra_version     0.25
16%global gnome_keyring_version   3.2
17%global libnotify_version       0.7.4
18%global folks_version           0.6.2
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  GConf2-devel
42BuildRequires:  gettext
43BuildRequires:  glib2-devel >= %{glib2_min_version}
44BuildRequires:  gnome-doc-utils >= 0.17.3
45BuildRequires:  gnome-panel
46BuildRequires:  gtk3-devel >= %{gtk3_min_version}
47BuildRequires:  intltool
48BuildRequires:  libxml2-devel
49BuildRequires:  perl(XML::Parser)
50BuildRequires:  pygtk2-devel
51BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
52BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
53BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
54BuildRequires:  farsight2-devel
55BuildRequires:  telepathy-farsight-devel
56BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
57BuildRequires:  libgnome-keyring-devel >= %{gnome_keyring_version}
58BuildRequires:  unique3-devel
59BuildRequires:  libnotify-devel >= %{libnotify_version}
60BuildRequires:  folks-devel >= %{folks_version}
61BuildRequires:  gnome-keyring-devel >= %{gnome_keyring_version}
62BuildRequires:  openssl-devel
63BuildRequires:  NetworkManager-glib-devel
64BuildRequires:  WebKit3-gtk-devel
65BuildRequires:  geoclue-devel
66BuildRequires:  enchant-devel
67BuildRequires:  libICE-devel
68BuildRequires:  cheese-devel
69BuildRequires:  pulseaudio-libs-devel
70BuildRequires:  gnome-online-accounts-devel
71BuildRequires:  libgudev1-devel
72BuildRequires:  libchamplain-gtk-devel
73BuildRequires:  gsettings-desktop-schemas
74
75Requires:       telepathy-filesystem
76## Empathy is useless without a proper Telepathy connection manager installed.
77## We hardcode dependencies on Salut and Gabble to support XMPP on a default
78## install, in both the link-local and Jabber/GoogleTalk incarnations.
79## (RHBZ: 308871 and 334221)
80## TODO: Perhaps we can configure these to be installed "on demand" with
81##       PackageKit and friends?
82Requires:       telepathy-gabble
83Requires:       telepathy-salut
84## Also hardcode Haze dependency since Empathy is the default IM client in F10+
85## and I'd hate for people to simply disregard it for lack of the "out of the
86## box" protocol support that Pidgin has. (RHBZ: 458935)
87BuildRequires:  telepathy-haze
88# Require this for VOIP support
89Requires:       telepathy-stream-engine
90Requires:       telepathy-mission-control >= %{tp_mc_min_version}
91
92
93Requires(post): GConf2
94Requires(post): scrollkeeper
95
96Requires(postun):       scrollkeeper
97
98## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
99Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
100Provides:       telepathy-haze-mission-control = 0.2.0-3
101## upstream 2.29.1 removed shared libraries: #599086
102Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
103## upstream 2.29.1 removed python bindings' #599039
104Obsoletes: empathy-python < 2.29.1
105
106Vendor: Project Vine
107Distribution: Vine Linux
108
109%description
110Empathy provides a powerful multiple protocol instant messaging
111client using the Telepathy framework.
112
113
114%package -n     nautilus-sendto-empathy
115License:        GPLv2+
116Summary:        Nautilus-sendto plugin for empathy
117Summary(ja):    empathy 用 nautilus-sendto プラグイン
118Group:          User Interface/Desktop
119
120Requires:       %{name} = %{version}-%{release}
121Requires:       nautilus-sendto
122BuildRequires:  nautilus-sendto-devel
123
124%description -n nautilus-sendto-empathy
125This package contains nautilus-sendto plugin for the Empathy IM application.
126
127
128%prep
129%setup -q
130
131
132%build
133## GCC complains about some unused functions, so we forcibly show those as
134## simple warnings instead of build-halting errors.
135%configure --disable-static
136
137## RPATHs are yucky.
138sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
139sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
140
141##make %{?_smp_mflags}
142## don't use _smp_mflags at empathy-2.18.1
143make
144
145install -m 0644 %{SOURCE1} ./README.ConnectionManagers
146
147
148%install
149rm -rf $RPM_BUILD_ROOT
150make install DESTDIR=$RPM_BUILD_ROOT
151find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
152
153%find_lang %{name}
154
155desktop-file-install --vendor "" --delete-original      \
156        --dir %{buildroot}%{_datadir}/applications      \
157        %{buildroot}%{_datadir}/applications/%{name}.desktop
158
159
160%clean
161rm -rf %{buildroot}
162
163
164%post
165scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
166touch --no-create %{_datadir}/icons/hicolor ||:
167%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
168
169%postun
170scrollkeeper-update -q || :
171touch --no-create %{_datadir}/icons/hicolor || :
172if [ -x %{_bindir}/gtk-update-icon-cache ]; then
173        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
174        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
175fi
176
177%posttrans
178gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
179glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
180
181
182%files -f %{name}.lang
183%defattr(-,root,root,-)
184%doc AUTHORS COPYING README README.ConnectionManagers NEWS
185%{_bindir}/empathy
186%{_bindir}/empathy-accounts
187%{_bindir}/empathy-debugger
188%{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
189%{_libexecdir}/empathy-auth-client
190%{_libexecdir}/empathy-av
191%{_libexecdir}/empathy-chat
192%{_datadir}/dbus-1/services/*
193%{_datadir}/empathy
194%{_datadir}/glib-2.0/schemas/*.xml
195%{_datadir}/GConf/gsettings/*
196%{_datadir}/applications/*.desktop
197%{_datadir}/gnome/help/%{name}/
198#{_datadir}/omf/%{name}/
199%{_datadir}/icons/hicolor/*/apps/%{name}*
200#{_datadir}/mission-control/profiles/*.profile
201%{_datadir}/telepathy/clients/*.client
202%{_mandir}/man1/empathy*.1*
203
204%files -n nautilus-sendto-empathy
205%defattr(-,root,root,-)
206%{_libdir}/nautilus-sendto/plugins/libnstempathy.so
207
208
209%changelog
210* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
211- new upstream release
212
213* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1.1-1
214- new upstream release
215
216* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
217- new upstream release
218- add BuildRequires: libgudev1-devel, gnome-online-accounts-devel
219
220* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
221- new upstream release
222
223* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
224- new upstream release
225
226* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
227- new upstream release
228
229* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
230- new upstream release
231
232* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
233- new upstream release
234
235* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
236- new upstream release
237- add BuildRequires: pulseaudio-libs-devel
238
239* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
240- new upstream release
241- change BuildRequires: gtk3-devel instead of gtk2-devel
242- change BuildRequires: unique3-devel instead of unique-devel
243- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
244- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
245- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
246
247* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
248- new upstream release
249- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
250                     geoclue-devel, enchant-devel
251- add Requires: telepathy-mission-control
252- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
253
254* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
255- new upstream release
256- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
257- fix %files
258- fix %post, %postun
259- drop %pre, %preun
260
261* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
262- rebuild with evolution-data-server-2.30.2
263- add nautilus-sendto-empathy package
264  - add configure option (--enable-nautilus-sendto=yes)
265  - add BuildRequires: nautilus-sendto-devel
266
267* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
268- add Obsoletes: empathy-python < 2.29.1
269
270* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
271- new upstream release
272- add new files: %%{_bindir}/empathy-{accounts,debugger}
273- drop -libs, -devel, -python sub packages: upstream removed
274  - Obsoletes: empathy-{libs,devel} < 2.29.1
275  - drop BuildRequires: python-devel
276- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
277- drop applet files in %%files: upstream removed the panel applets
278  - update %%post, %pre and %%preun
279- update BuildRequires version for glib2 and tp_glib
280- defined major_ver, minor_ver and rel
281- fix BuildRequires for gnome-keyring
282
283* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
284- new upstream release
285- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
286
287* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
288- rebuilt with python-2.6.4
289
290* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
291- unuse %%{?_smp_mflags} option to make
292
293* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
294- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
295
296* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
297- new upstream release
298
299* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
300- new upstream release
301
302* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
303- initial build for Vine Linux
304
305* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
306- Update to 2.23.92
307
308* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
309- Update to 2.23.91
310
311* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
312- Now that Empathy will be the default IM client in F10+, hardcode a dependency
313  on telepathy-haze to keep the same protocol functionality across upgrades,
314  for a much improved "out of the box" experience.
315- Reference: bug 458935.
316
317* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
318- Update to new upstream release (2.23.90)
319
320* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
321- Apply patch from Colin Walters to automagically update profile namings for
322  the switch to using Empathy's provided profiles.
323- Drop the upgrade script (no longer needed since it's automatically done).
324  - upgrade-haze-profiles.sh
325
326* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
327- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
328  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
329  horribly stale...). This makes for better automagic functionality (if Haze is
330  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
331  + upgrade-haze-profiles.sh
332
333* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
334- Update to new upstream release (2.23.6)
335- Use the in-tarball libtool scripts instead of the system copy to workaround
336  'make install' errors.
337
338* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
339- Update to 0.23.4.
340- Update source url.
341
342* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
343- Update to 0.23.3.
344- Remove reference to stream-engine in connections managers readme.
345
346* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
347- Update to 0.23.2.
348- Add man pages.
349- Use enchant-devel, instead of aspell-devel.
350
351* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
352- Rebuild for new e-d-s.
353
354* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
355- Drop multiple copies of COPYING file.
356- Drop BR on gnome-vfs2-devel.
357- Require telepathy-stream-engine for VOIP support.
358- Add BR on iso-codes-devel, so spell-checking is enabled.
359
360* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
361- Update to new upstream release (0.23.1)
362- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
363
364* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
365- Update to new upstream release (0.22.1)
366
367* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
368- Update to new upstream release (0.22.0)
369
370* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
371- Update to new upstream release (0.21.91)
372
373* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
374- Update to new upstream release (0.21.90)
375
376* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
377- Autorebuild for GCC 4.3
378
379* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
380- Update to new upstream release (0.21.4)
381
382* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
383- Update to new upstream release (0.21.2)
384- Drop backported drag-and-drop patch (fixed upstream):
385    - svn380-fix-contact-DnD.patch
386- Update README.ConnectionManagers: Include Haze package note, remove Galago
387  note (a feed-only connection manager isn't useful for instant messaging),
388  and fix some wording.
389
390* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
391- Backport upstream patch to fixes crashes when using drag-and-drop of a
392  contact from the buddy list to the current conversation window to initiate a
393  conversation:
394    + svn380-fix-contact-DnD.patch
395- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
396  dragged a contact ...)
397
398* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
399- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
400  is essentially useless due to the need to install an external connection
401  manager. Also, add a README.ConnectionManagers to the installed
402  documentation which lists other possibilities.
403- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
404  and bug 334221 (Default empathy install is useless).
405
406* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
407- Enable VoIP support for those brave enough to test/break/debug it (F9+
408  only). Though it is functional, it is still deemed rather unstable by
409  upstream. Use it at your own risk. :)
410
411* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
412- Disable VoIP support at this time, since it is deemed unstable by upstream
413  for now. (Thanks to Brian Pepple for the notice.)
414 
415* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
416- Update to new upstream release (0.14).
417
418* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
419- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
420  and python bindings.
421- Split shared libraries into a libs subpackage for easier handling
422  in multi-lib environments.
423
424* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
425- Add ldconfig invocations to %%post and %%postun scriptlets.
426
427* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
428- Update to new upstream release (0.12).
429- Build against new mission-control stack.
430- Update License tag (GPLv2+).
431- Alphabetize BuildRequires list (aesthetic-only change).
432
433* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
434- Rebuild for selinux ppc32 issue.
435
436* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
437- Update to new upstream release (0.11)
438
439* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
440- bump to 0.8
441- Now with aspell support (deat to teh speeling mistaks)
442
443* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
444- bump to 0.7
445
446* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
447- Add telepathy-filesystem to Requires
448- Move .desktop from autostart to applications
449- Nasty hackery to make empathy launch from the menu
450
451* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
452- Add gettext to BuildRequires
453
454* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
455- Bump to 0.6
456
457* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
458- Let Empathy own the directory and not just the files in it
459
460* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
461- Initial package
Note: See TracBrowser for help on using the repository browser.