source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 5094

Revision 5094, 16.4 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%define major_ver 3.2
2%define minor_ver 1.1
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk3_min_version        3.2.0
10%global glib2_min_version       2.30.0
11%global tp_mc_min_version       5.6.0
12%global tp_glib_min_version     0.16.0
13%global tp_logger_min_version   0.2.10
14%global aspell_version          0.50
15%global libcanberra_version     0.25
16%global gnome_keyring_version   3.2
17%global libnotify_version       0.7.4
18%global folks_version           0.6.2
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  GConf2-devel
42BuildRequires:  gettext
43BuildRequires:  glib2-devel >= %{glib2_min_version}
44BuildRequires:  gnome-doc-utils >= 0.17.3
45BuildRequires:  gnome-panel
46BuildRequires:  gtk3-devel >= %{gtk3_min_version}
47BuildRequires:  intltool
48BuildRequires:  libxml2-devel
49BuildRequires:  perl(XML::Parser)
50BuildRequires:  pygtk2-devel
51BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
52BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
53BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
54BuildRequires:  farsight2-devel
55BuildRequires:  telepathy-farsight-devel
56BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
57BuildRequires:  libgnome-keyring-devel >= %{gnome_keyring_version}
58BuildRequires:  unique3-devel
59BuildRequires:  libnotify-devel >= %{libnotify_version}
60BuildRequires:  folks-devel >= %{folks_version}
61BuildRequires:  gnome-keyring-devel >= %{gnome_keyring_version}
62BuildRequires:  openssl-devel
63BuildRequires:  NetworkManager-glib-devel
64BuildRequires:  WebKit3-gtk-devel
65BuildRequires:  geoclue-devel
66BuildRequires:  enchant-devel
67BuildRequires:  libICE-devel
68BuildRequires:  cheese-devel
69BuildRequires:  pulseaudio-libs-devel
70BuildRequires:  gnome-online-accounts-devel
71BuildRequires:  libgudev1-devel
72BuildRequires:  libchamplain-gtk-devel
73BuildRequires:  gsettings-desktop-schemas
74
75Requires:       telepathy-filesystem
76## Empathy is useless without a proper Telepathy connection manager installed.
77## We hardcode dependencies on Salut and Gabble to support XMPP on a default
78## install, in both the link-local and Jabber/GoogleTalk incarnations.
79## (RHBZ: 308871 and 334221)
80## TODO: Perhaps we can configure these to be installed "on demand" with
81##       PackageKit and friends?
82Requires:       telepathy-gabble
83Requires:       telepathy-salut
84## Also hardcode Haze dependency since Empathy is the default IM client in F10+
85## and I'd hate for people to simply disregard it for lack of the "out of the
86## box" protocol support that Pidgin has. (RHBZ: 458935)
87BuildRequires:  telepathy-haze
88# Require this for VOIP support
89Requires:       telepathy-stream-engine
90Requires:       telepathy-mission-control >= %{tp_mc_min_version}
91
92
93Requires(post): GConf2
94Requires(post): scrollkeeper
95
96Requires(postun):       scrollkeeper
97
98## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
99Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
100Provides:       telepathy-haze-mission-control = 0.2.0-3
101## upstream 2.29.1 removed shared libraries: #599086
102Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
103## upstream 2.29.1 removed python bindings' #599039
104Obsoletes: empathy-python < 2.29.1
105
106Vendor: Project Vine
107Distribution: Vine Linux
108
109%description
110Empathy provides a powerful multiple protocol instant messaging
111client using the Telepathy framework.
112
113
114%package -n     nautilus-sendto-empathy
115License:        GPLv2+
116Summary:        Nautilus-sendto plugin for empathy
117Summary(ja):    empathy 用 nautilus-sendto プラグイン
118Group:          User Interface/Desktop
119
120Requires:       %{name} = %{version}-%{release}
121Requires:       nautilus-sendto
122BuildRequires:  nautilus-sendto-devel
123
124%description -n nautilus-sendto-empathy
125This package contains nautilus-sendto plugin for the Empathy IM application.
126
127
128%prep
129%setup -q
130
131
132%build
133## GCC complains about some unused functions, so we forcibly show those as
134## simple warnings instead of build-halting errors.
135%configure --disable-static
136
137## RPATHs are yucky.
138sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
139sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
140
141##make %{?_smp_mflags}
142## don't use _smp_mflags at empathy-2.18.1
143make
144
145install -m 0644 %{SOURCE1} ./README.ConnectionManagers
146
147
148%install
149rm -rf $RPM_BUILD_ROOT
150make install DESTDIR=$RPM_BUILD_ROOT
151find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
152
153%find_lang %{name}
154
155desktop-file-install --vendor "" --delete-original      \
156        --dir %{buildroot}%{_datadir}/applications      \
157        %{buildroot}%{_datadir}/applications/%{name}.desktop
158
159
160%clean
161rm -rf %{buildroot}
162
163
164%post
165scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
166touch --no-create %{_datadir}/icons/hicolor ||:
167%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
168
169%postun
170scrollkeeper-update -q || :
171touch --no-create %{_datadir}/icons/hicolor || :
172if [ -x %{_bindir}/gtk-update-icon-cache ]; then
173        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
174        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
175fi
176
177%posttrans
178gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
179glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
180
181
182%files -f %{name}.lang
183%defattr(-,root,root,-)
184%doc AUTHORS COPYING README README.ConnectionManagers NEWS
185%{_bindir}/empathy
186%{_bindir}/empathy-accounts
187%{_bindir}/empathy-debugger
188%{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
189%{_libexecdir}/empathy-auth-client
190%{_libexecdir}/empathy-av
191%{_libexecdir}/empathy-chat
192%{_datadir}/dbus-1/services/*
193%{_datadir}/empathy
194%{_datadir}/glib-2.0/schemas/*.xml
195%{_datadir}/GConf/gsettings/*
196%{_datadir}/applications/*.desktop
197%{_datadir}/gnome/help/%{name}/
198#{_datadir}/omf/%{name}/
199%{_datadir}/icons/hicolor/*/apps/%{name}*
200#{_datadir}/mission-control/profiles/*.profile
201%{_datadir}/telepathy/clients/*.client
202%{_mandir}/man1/empathy*.1*
203
204%files -n nautilus-sendto-empathy
205%defattr(-,root,root,-)
206%{_libdir}/nautilus-sendto/plugins/libnstempathy.so
207
208
209%changelog
210* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1.1-1
211- new upstream release
212
213* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
214- new upstream release
215- add BuildRequires: libgudev1-devel, gnome-online-accounts-devel
216
217* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
218- new upstream release
219
220* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
221- new upstream release
222
223* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
224- new upstream release
225
226* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
227- new upstream release
228
229* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
230- new upstream release
231
232* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
233- new upstream release
234- add BuildRequires: pulseaudio-libs-devel
235
236* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
237- new upstream release
238- change BuildRequires: gtk3-devel instead of gtk2-devel
239- change BuildRequires: unique3-devel instead of unique-devel
240- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
241- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
242- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
243
244* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
245- new upstream release
246- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
247                     geoclue-devel, enchant-devel
248- add Requires: telepathy-mission-control
249- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
250
251* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
252- new upstream release
253- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
254- fix %files
255- fix %post, %postun
256- drop %pre, %preun
257
258* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
259- rebuild with evolution-data-server-2.30.2
260- add nautilus-sendto-empathy package
261  - add configure option (--enable-nautilus-sendto=yes)
262  - add BuildRequires: nautilus-sendto-devel
263
264* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
265- add Obsoletes: empathy-python < 2.29.1
266
267* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
268- new upstream release
269- add new files: %%{_bindir}/empathy-{accounts,debugger}
270- drop -libs, -devel, -python sub packages: upstream removed
271  - Obsoletes: empathy-{libs,devel} < 2.29.1
272  - drop BuildRequires: python-devel
273- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
274- drop applet files in %%files: upstream removed the panel applets
275  - update %%post, %pre and %%preun
276- update BuildRequires version for glib2 and tp_glib
277- defined major_ver, minor_ver and rel
278- fix BuildRequires for gnome-keyring
279
280* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
281- new upstream release
282- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
283
284* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
285- rebuilt with python-2.6.4
286
287* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
288- unuse %%{?_smp_mflags} option to make
289
290* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
291- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
292
293* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
294- new upstream release
295
296* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
297- new upstream release
298
299* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
300- initial build for Vine Linux
301
302* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
303- Update to 2.23.92
304
305* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
306- Update to 2.23.91
307
308* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
309- Now that Empathy will be the default IM client in F10+, hardcode a dependency
310  on telepathy-haze to keep the same protocol functionality across upgrades,
311  for a much improved "out of the box" experience.
312- Reference: bug 458935.
313
314* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
315- Update to new upstream release (2.23.90)
316
317* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
318- Apply patch from Colin Walters to automagically update profile namings for
319  the switch to using Empathy's provided profiles.
320- Drop the upgrade script (no longer needed since it's automatically done).
321  - upgrade-haze-profiles.sh
322
323* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
324- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
325  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
326  horribly stale...). This makes for better automagic functionality (if Haze is
327  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
328  + upgrade-haze-profiles.sh
329
330* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
331- Update to new upstream release (2.23.6)
332- Use the in-tarball libtool scripts instead of the system copy to workaround
333  'make install' errors.
334
335* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
336- Update to 0.23.4.
337- Update source url.
338
339* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
340- Update to 0.23.3.
341- Remove reference to stream-engine in connections managers readme.
342
343* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
344- Update to 0.23.2.
345- Add man pages.
346- Use enchant-devel, instead of aspell-devel.
347
348* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
349- Rebuild for new e-d-s.
350
351* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
352- Drop multiple copies of COPYING file.
353- Drop BR on gnome-vfs2-devel.
354- Require telepathy-stream-engine for VOIP support.
355- Add BR on iso-codes-devel, so spell-checking is enabled.
356
357* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
358- Update to new upstream release (0.23.1)
359- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
360
361* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
362- Update to new upstream release (0.22.1)
363
364* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
365- Update to new upstream release (0.22.0)
366
367* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
368- Update to new upstream release (0.21.91)
369
370* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
371- Update to new upstream release (0.21.90)
372
373* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
374- Autorebuild for GCC 4.3
375
376* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
377- Update to new upstream release (0.21.4)
378
379* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
380- Update to new upstream release (0.21.2)
381- Drop backported drag-and-drop patch (fixed upstream):
382    - svn380-fix-contact-DnD.patch
383- Update README.ConnectionManagers: Include Haze package note, remove Galago
384  note (a feed-only connection manager isn't useful for instant messaging),
385  and fix some wording.
386
387* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
388- Backport upstream patch to fixes crashes when using drag-and-drop of a
389  contact from the buddy list to the current conversation window to initiate a
390  conversation:
391    + svn380-fix-contact-DnD.patch
392- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
393  dragged a contact ...)
394
395* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
396- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
397  is essentially useless due to the need to install an external connection
398  manager. Also, add a README.ConnectionManagers to the installed
399  documentation which lists other possibilities.
400- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
401  and bug 334221 (Default empathy install is useless).
402
403* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
404- Enable VoIP support for those brave enough to test/break/debug it (F9+
405  only). Though it is functional, it is still deemed rather unstable by
406  upstream. Use it at your own risk. :)
407
408* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
409- Disable VoIP support at this time, since it is deemed unstable by upstream
410  for now. (Thanks to Brian Pepple for the notice.)
411 
412* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
413- Update to new upstream release (0.14).
414
415* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
416- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
417  and python bindings.
418- Split shared libraries into a libs subpackage for easier handling
419  in multi-lib environments.
420
421* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
422- Add ldconfig invocations to %%post and %%postun scriptlets.
423
424* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
425- Update to new upstream release (0.12).
426- Build against new mission-control stack.
427- Update License tag (GPLv2+).
428- Alphabetize BuildRequires list (aesthetic-only change).
429
430* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
431- Rebuild for selinux ppc32 issue.
432
433* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
434- Update to new upstream release (0.11)
435
436* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
437- bump to 0.8
438- Now with aspell support (deat to teh speeling mistaks)
439
440* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
441- bump to 0.7
442
443* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
444- Add telepathy-filesystem to Requires
445- Move .desktop from autostart to applications
446- Nasty hackery to make empathy launch from the menu
447
448* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
449- Add gettext to BuildRequires
450
451* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
452- Bump to 0.6
453
454* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
455- Let Empathy own the directory and not just the files in it
456
457* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
458- Initial package
Note: See TracBrowser for help on using the repository browser.