source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 4850

Revision 4850, 16.1 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2.0

Line 
1%define major_ver 3.2
2%define minor_ver 0
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk3_min_version        3.2.0
10%global glib2_min_version       2.30.0
11%global tp_mc_min_version       5.6.0
12%global tp_glib_min_version     0.13.0
13%global tp_logger_min_version   0.1.5
14#global enchant_version         1.4.0
15%global aspell_version          0.50
16%global libcanberra_version     0.4
17%global gnome_keyring_version   3.2
18%global libnotify_version       0.7.4
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  GConf2-devel
42BuildRequires:  gettext
43BuildRequires:  glib2-devel >= %{glib2_min_version}
44BuildRequires:  gnome-doc-utils >= 0.17.3
45BuildRequires:  gnome-panel
46BuildRequires:  gtk3-devel >= %{gtk3_min_version}
47BuildRequires:  intltool
48BuildRequires:  libxml2-devel
49BuildRequires:  perl(XML::Parser)
50BuildRequires:  pygtk2-devel
51BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
52BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
53BuildRequires:  farsight2-devel
54BuildRequires:  telepathy-farsight-devel
55BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
56BuildRequires:  libgnome-keyring-devel >= %{gnome_keyring_version}
57BuildRequires:  unique3-devel
58BuildRequires:  libnotify-devel >= %{libnotify_version}
59BuildRequires:  libtelepathy-devel
60BuildRequires:  libgnomecanvas-devel
61BuildRequires:  libbonoboui-devel
62BuildRequires:  folks-devel
63BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
64BuildRequires:  gnome-keyring-devel >= %{gnome_keyring_version}
65BuildRequires:  openssl-devel
66BuildRequires:  NetworkManager-glib-devel
67BuildRequires:  WebKit3-gtk-devel
68BuildRequires:  geoclue-devel
69BuildRequires:  enchant-devel
70BuildRequires:  libICE-devel
71BuildRequires:  cheese-devel
72BuildRequires:  libchamplain-gtk-devel
73BuildRequires:  pulseaudio-libs-devel
74BuildRequires:  gsettings-desktop-schemas
75
76Requires:       telepathy-filesystem
77## Empathy is useless without a proper Telepathy connection manager installed.
78## We hardcode dependencies on Salut and Gabble to support XMPP on a default
79## install, in both the link-local and Jabber/GoogleTalk incarnations.
80## (RHBZ: 308871 and 334221)
81## TODO: Perhaps we can configure these to be installed "on demand" with
82##       PackageKit and friends?
83Requires:       telepathy-gabble
84Requires:       telepathy-salut
85## Also hardcode Haze dependency since Empathy is the default IM client in F10+
86## and I'd hate for people to simply disregard it for lack of the "out of the
87## box" protocol support that Pidgin has. (RHBZ: 458935)
88BuildRequires:  telepathy-haze
89# Require this for VOIP support
90Requires:       telepathy-stream-engine
91Requires:       telepathy-mission-control >= %{tp_mc_min_version}
92
93
94Requires(post): GConf2
95Requires(post): scrollkeeper
96
97Requires(postun):       scrollkeeper
98
99## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
100Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
101Provides:       telepathy-haze-mission-control = 0.2.0-3
102## upstream 2.29.1 removed shared libraries: #599086
103Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
104## upstream 2.29.1 removed python bindings' #599039
105Obsoletes: empathy-python < 2.29.1
106
107Vendor: Project Vine
108Distribution: Vine Linux
109
110%description
111Empathy provides a powerful multiple protocol instant messaging
112client using the Telepathy framework.
113
114
115%package -n     nautilus-sendto-empathy
116License:        GPLv2+
117Summary:        Nautilus-sendto plugin for empathy
118Summary(ja):    empathy 用 nautilus-sendto プラグイン
119Group:          User Interface/Desktop
120
121Requires:       %{name} = %{version}-%{release}
122Requires:       nautilus-sendto
123BuildRequires:  nautilus-sendto-devel
124
125%description -n nautilus-sendto-empathy
126This package contains nautilus-sendto plugin for the Empathy IM application.
127
128
129%prep
130%setup -q
131
132
133%build
134## GCC complains about some unused functions, so we forcibly show those as
135## simple warnings instead of build-halting errors.
136%configure --disable-static
137
138## RPATHs are yucky.
139sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
140sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
141
142##make %{?_smp_mflags}
143## don't use _smp_mflags at empathy-2.18.1
144make
145
146install -m 0644 %{SOURCE1} ./README.ConnectionManagers
147
148
149%install
150rm -rf $RPM_BUILD_ROOT
151make install DESTDIR=$RPM_BUILD_ROOT
152find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
153
154%find_lang %{name}
155
156desktop-file-install --vendor "" --delete-original      \
157        --dir %{buildroot}%{_datadir}/applications      \
158        %{buildroot}%{_datadir}/applications/%{name}.desktop
159
160
161%clean
162rm -rf %{buildroot}
163
164
165%post
166scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
167touch --no-create %{_datadir}/icons/hicolor ||:
168%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
169
170%postun
171scrollkeeper-update -q || :
172touch --no-create %{_datadir}/icons/hicolor || :
173if [ -x %{_bindir}/gtk-update-icon-cache ]; then
174        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
175        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
176fi
177
178%posttrans
179gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
180glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
181
182
183%files -f %{name}.lang
184%defattr(-,root,root,-)
185%doc AUTHORS COPYING README README.ConnectionManagers NEWS
186%{_bindir}/empathy
187%{_bindir}/empathy-accounts
188%{_bindir}/empathy-debugger
189%{_libexecdir}/empathy-auth-client
190%{_libexecdir}/empathy-av
191%{_libexecdir}/empathy-chat
192%{_datadir}/dbus-1/services/*
193%{_datadir}/empathy
194%{_datadir}/glib-2.0/schemas/*.xml
195%{_datadir}/GConf/gsettings/*
196%{_datadir}/applications/*.desktop
197%{_datadir}/gnome/help/%{name}/
198#{_datadir}/omf/%{name}/
199%{_datadir}/icons/hicolor/*/apps/%{name}*
200#{_datadir}/mission-control/profiles/*.profile
201%{_datadir}/telepathy/clients/*.client
202%{_mandir}/man1/empathy*.1*
203
204%files -n nautilus-sendto-empathy
205%defattr(-,root,root,-)
206%{_libdir}/nautilus-sendto/plugins/libnstempathy.so
207
208
209%changelog
210* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
211- new upstream release
212
213* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
214- new upstream release
215
216* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
217- new upstream release
218
219* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
220- new upstream release
221
222* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
223- new upstream release
224- add BuildRequires: pulseaudio-libs-devel
225
226* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
227- new upstream release
228- change BuildRequires: gtk3-devel instead of gtk2-devel
229- change BuildRequires: unique3-devel instead of unique-devel
230- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
231- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
232- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
233
234* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
235- new upstream release
236- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
237                     geoclue-devel, enchant-devel
238- add Requires: telepathy-mission-control
239- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
240
241* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
242- new upstream release
243- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
244- fix %files
245- fix %post, %postun
246- drop %pre, %preun
247
248* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
249- rebuild with evolution-data-server-2.30.2
250- add nautilus-sendto-empathy package
251  - add configure option (--enable-nautilus-sendto=yes)
252  - add BuildRequires: nautilus-sendto-devel
253
254* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
255- add Obsoletes: empathy-python < 2.29.1
256
257* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
258- new upstream release
259- add new files: %%{_bindir}/empathy-{accounts,debugger}
260- drop -libs, -devel, -python sub packages: upstream removed
261  - Obsoletes: empathy-{libs,devel} < 2.29.1
262  - drop BuildRequires: python-devel
263- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
264- drop applet files in %%files: upstream removed the panel applets
265  - update %%post, %pre and %%preun
266- update BuildRequires version for glib2 and tp_glib
267- defined major_ver, minor_ver and rel
268- fix BuildRequires for gnome-keyring
269
270* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
271- new upstream release
272- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
273
274* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
275- rebuilt with python-2.6.4
276
277* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
278- unuse %%{?_smp_mflags} option to make
279
280* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
281- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
282
283* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
284- new upstream release
285
286* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
287- new upstream release
288
289* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
290- initial build for Vine Linux
291
292* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
293- Update to 2.23.92
294
295* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
296- Update to 2.23.91
297
298* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
299- Now that Empathy will be the default IM client in F10+, hardcode a dependency
300  on telepathy-haze to keep the same protocol functionality across upgrades,
301  for a much improved "out of the box" experience.
302- Reference: bug 458935.
303
304* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
305- Update to new upstream release (2.23.90)
306
307* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
308- Apply patch from Colin Walters to automagically update profile namings for
309  the switch to using Empathy's provided profiles.
310- Drop the upgrade script (no longer needed since it's automatically done).
311  - upgrade-haze-profiles.sh
312
313* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
314- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
315  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
316  horribly stale...). This makes for better automagic functionality (if Haze is
317  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
318  + upgrade-haze-profiles.sh
319
320* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
321- Update to new upstream release (2.23.6)
322- Use the in-tarball libtool scripts instead of the system copy to workaround
323  'make install' errors.
324
325* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
326- Update to 0.23.4.
327- Update source url.
328
329* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
330- Update to 0.23.3.
331- Remove reference to stream-engine in connections managers readme.
332
333* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
334- Update to 0.23.2.
335- Add man pages.
336- Use enchant-devel, instead of aspell-devel.
337
338* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
339- Rebuild for new e-d-s.
340
341* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
342- Drop multiple copies of COPYING file.
343- Drop BR on gnome-vfs2-devel.
344- Require telepathy-stream-engine for VOIP support.
345- Add BR on iso-codes-devel, so spell-checking is enabled.
346
347* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
348- Update to new upstream release (0.23.1)
349- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
350
351* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
352- Update to new upstream release (0.22.1)
353
354* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
355- Update to new upstream release (0.22.0)
356
357* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
358- Update to new upstream release (0.21.91)
359
360* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
361- Update to new upstream release (0.21.90)
362
363* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
364- Autorebuild for GCC 4.3
365
366* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
367- Update to new upstream release (0.21.4)
368
369* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
370- Update to new upstream release (0.21.2)
371- Drop backported drag-and-drop patch (fixed upstream):
372    - svn380-fix-contact-DnD.patch
373- Update README.ConnectionManagers: Include Haze package note, remove Galago
374  note (a feed-only connection manager isn't useful for instant messaging),
375  and fix some wording.
376
377* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
378- Backport upstream patch to fixes crashes when using drag-and-drop of a
379  contact from the buddy list to the current conversation window to initiate a
380  conversation:
381    + svn380-fix-contact-DnD.patch
382- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
383  dragged a contact ...)
384
385* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
386- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
387  is essentially useless due to the need to install an external connection
388  manager. Also, add a README.ConnectionManagers to the installed
389  documentation which lists other possibilities.
390- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
391  and bug 334221 (Default empathy install is useless).
392
393* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
394- Enable VoIP support for those brave enough to test/break/debug it (F9+
395  only). Though it is functional, it is still deemed rather unstable by
396  upstream. Use it at your own risk. :)
397
398* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
399- Disable VoIP support at this time, since it is deemed unstable by upstream
400  for now. (Thanks to Brian Pepple for the notice.)
401 
402* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
403- Update to new upstream release (0.14).
404
405* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
406- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
407  and python bindings.
408- Split shared libraries into a libs subpackage for easier handling
409  in multi-lib environments.
410
411* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
412- Add ldconfig invocations to %%post and %%postun scriptlets.
413
414* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
415- Update to new upstream release (0.12).
416- Build against new mission-control stack.
417- Update License tag (GPLv2+).
418- Alphabetize BuildRequires list (aesthetic-only change).
419
420* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
421- Rebuild for selinux ppc32 issue.
422
423* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
424- Update to new upstream release (0.11)
425
426* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
427- bump to 0.8
428- Now with aspell support (deat to teh speeling mistaks)
429
430* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
431- bump to 0.7
432
433* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
434- Add telepathy-filesystem to Requires
435- Move .desktop from autostart to applications
436- Nasty hackery to make empathy launch from the menu
437
438* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
439- Add gettext to BuildRequires
440
441* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
442- Bump to 0.6
443
444* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
445- Let Empathy own the directory and not just the files in it
446
447* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
448- Initial package
Note: See TracBrowser for help on using the repository browser.