source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 5007

Revision 5007, 16.1 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%define major_ver 3.2
2%define minor_ver 0.1
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk3_min_version        3.2.0
10%global glib2_min_version       2.30.0
11%global tp_mc_min_version       5.6.0
12%global tp_glib_min_version     0.13.0
13%global tp_logger_min_version   0.1.5
14#global enchant_version         1.4.0
15%global aspell_version          0.50
16%global libcanberra_version     0.4
17%global gnome_keyring_version   3.2
18%global libnotify_version       0.7.4
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  GConf2-devel
42BuildRequires:  gettext
43BuildRequires:  glib2-devel >= %{glib2_min_version}
44BuildRequires:  gnome-doc-utils >= 0.17.3
45BuildRequires:  gnome-panel
46BuildRequires:  gtk3-devel >= %{gtk3_min_version}
47BuildRequires:  intltool
48BuildRequires:  libxml2-devel
49BuildRequires:  perl(XML::Parser)
50BuildRequires:  pygtk2-devel
51BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
52BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
53BuildRequires:  farsight2-devel
54BuildRequires:  telepathy-farsight-devel
55BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
56BuildRequires:  libgnome-keyring-devel >= %{gnome_keyring_version}
57BuildRequires:  unique3-devel
58BuildRequires:  libnotify-devel >= %{libnotify_version}
59BuildRequires:  libtelepathy-devel
60BuildRequires:  libgnomecanvas-devel
61BuildRequires:  libbonoboui-devel
62BuildRequires:  folks-devel
63BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
64BuildRequires:  gnome-keyring-devel >= %{gnome_keyring_version}
65BuildRequires:  openssl-devel
66BuildRequires:  NetworkManager-glib-devel
67BuildRequires:  WebKit3-gtk-devel
68BuildRequires:  geoclue-devel
69BuildRequires:  enchant-devel
70BuildRequires:  libICE-devel
71BuildRequires:  cheese-devel
72BuildRequires:  libchamplain-gtk-devel
73BuildRequires:  pulseaudio-libs-devel
74BuildRequires:  gsettings-desktop-schemas
75
76Requires:       telepathy-filesystem
77## Empathy is useless without a proper Telepathy connection manager installed.
78## We hardcode dependencies on Salut and Gabble to support XMPP on a default
79## install, in both the link-local and Jabber/GoogleTalk incarnations.
80## (RHBZ: 308871 and 334221)
81## TODO: Perhaps we can configure these to be installed "on demand" with
82##       PackageKit and friends?
83Requires:       telepathy-gabble
84Requires:       telepathy-salut
85## Also hardcode Haze dependency since Empathy is the default IM client in F10+
86## and I'd hate for people to simply disregard it for lack of the "out of the
87## box" protocol support that Pidgin has. (RHBZ: 458935)
88BuildRequires:  telepathy-haze
89# Require this for VOIP support
90Requires:       telepathy-stream-engine
91Requires:       telepathy-mission-control >= %{tp_mc_min_version}
92
93
94Requires(post): GConf2
95Requires(post): scrollkeeper
96
97Requires(postun):       scrollkeeper
98
99## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
100Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
101Provides:       telepathy-haze-mission-control = 0.2.0-3
102## upstream 2.29.1 removed shared libraries: #599086
103Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
104## upstream 2.29.1 removed python bindings' #599039
105Obsoletes: empathy-python < 2.29.1
106
107Vendor: Project Vine
108Distribution: Vine Linux
109
110%description
111Empathy provides a powerful multiple protocol instant messaging
112client using the Telepathy framework.
113
114
115%package -n     nautilus-sendto-empathy
116License:        GPLv2+
117Summary:        Nautilus-sendto plugin for empathy
118Summary(ja):    empathy 用 nautilus-sendto プラグイン
119Group:          User Interface/Desktop
120
121Requires:       %{name} = %{version}-%{release}
122Requires:       nautilus-sendto
123BuildRequires:  nautilus-sendto-devel
124
125%description -n nautilus-sendto-empathy
126This package contains nautilus-sendto plugin for the Empathy IM application.
127
128
129%prep
130%setup -q
131
132
133%build
134## GCC complains about some unused functions, so we forcibly show those as
135## simple warnings instead of build-halting errors.
136%configure --disable-static
137
138## RPATHs are yucky.
139sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
140sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
141
142##make %{?_smp_mflags}
143## don't use _smp_mflags at empathy-2.18.1
144make
145
146install -m 0644 %{SOURCE1} ./README.ConnectionManagers
147
148
149%install
150rm -rf $RPM_BUILD_ROOT
151make install DESTDIR=$RPM_BUILD_ROOT
152find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
153
154%find_lang %{name}
155
156desktop-file-install --vendor "" --delete-original      \
157        --dir %{buildroot}%{_datadir}/applications      \
158        %{buildroot}%{_datadir}/applications/%{name}.desktop
159
160
161%clean
162rm -rf %{buildroot}
163
164
165%post
166scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
167touch --no-create %{_datadir}/icons/hicolor ||:
168%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
169
170%postun
171scrollkeeper-update -q || :
172touch --no-create %{_datadir}/icons/hicolor || :
173if [ -x %{_bindir}/gtk-update-icon-cache ]; then
174        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
175        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
176fi
177
178%posttrans
179gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
180glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
181
182
183%files -f %{name}.lang
184%defattr(-,root,root,-)
185%doc AUTHORS COPYING README README.ConnectionManagers NEWS
186%{_bindir}/empathy
187%{_bindir}/empathy-accounts
188%{_bindir}/empathy-debugger
189%{_libexecdir}/empathy-auth-client
190%{_libexecdir}/empathy-av
191%{_libexecdir}/empathy-chat
192%{_datadir}/dbus-1/services/*
193%{_datadir}/empathy
194%{_datadir}/glib-2.0/schemas/*.xml
195%{_datadir}/GConf/gsettings/*
196%{_datadir}/applications/*.desktop
197%{_datadir}/gnome/help/%{name}/
198#{_datadir}/omf/%{name}/
199%{_datadir}/icons/hicolor/*/apps/%{name}*
200#{_datadir}/mission-control/profiles/*.profile
201%{_datadir}/telepathy/clients/*.client
202%{_mandir}/man1/empathy*.1*
203
204%files -n nautilus-sendto-empathy
205%defattr(-,root,root,-)
206%{_libdir}/nautilus-sendto/plugins/libnstempathy.so
207
208
209%changelog
210* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
211- new upstream release
212
213* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
214- new upstream release
215
216* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
217- new upstream release
218
219* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
220- new upstream release
221
222* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
223- new upstream release
224
225* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
226- new upstream release
227- add BuildRequires: pulseaudio-libs-devel
228
229* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
230- new upstream release
231- change BuildRequires: gtk3-devel instead of gtk2-devel
232- change BuildRequires: unique3-devel instead of unique-devel
233- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
234- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
235- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
236
237* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
238- new upstream release
239- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
240                     geoclue-devel, enchant-devel
241- add Requires: telepathy-mission-control
242- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
243
244* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
245- new upstream release
246- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
247- fix %files
248- fix %post, %postun
249- drop %pre, %preun
250
251* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
252- rebuild with evolution-data-server-2.30.2
253- add nautilus-sendto-empathy package
254  - add configure option (--enable-nautilus-sendto=yes)
255  - add BuildRequires: nautilus-sendto-devel
256
257* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
258- add Obsoletes: empathy-python < 2.29.1
259
260* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
261- new upstream release
262- add new files: %%{_bindir}/empathy-{accounts,debugger}
263- drop -libs, -devel, -python sub packages: upstream removed
264  - Obsoletes: empathy-{libs,devel} < 2.29.1
265  - drop BuildRequires: python-devel
266- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
267- drop applet files in %%files: upstream removed the panel applets
268  - update %%post, %pre and %%preun
269- update BuildRequires version for glib2 and tp_glib
270- defined major_ver, minor_ver and rel
271- fix BuildRequires for gnome-keyring
272
273* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
274- new upstream release
275- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
276
277* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
278- rebuilt with python-2.6.4
279
280* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
281- unuse %%{?_smp_mflags} option to make
282
283* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
284- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
285
286* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
287- new upstream release
288
289* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
290- new upstream release
291
292* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
293- initial build for Vine Linux
294
295* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
296- Update to 2.23.92
297
298* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
299- Update to 2.23.91
300
301* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
302- Now that Empathy will be the default IM client in F10+, hardcode a dependency
303  on telepathy-haze to keep the same protocol functionality across upgrades,
304  for a much improved "out of the box" experience.
305- Reference: bug 458935.
306
307* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
308- Update to new upstream release (2.23.90)
309
310* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
311- Apply patch from Colin Walters to automagically update profile namings for
312  the switch to using Empathy's provided profiles.
313- Drop the upgrade script (no longer needed since it's automatically done).
314  - upgrade-haze-profiles.sh
315
316* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
317- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
318  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
319  horribly stale...). This makes for better automagic functionality (if Haze is
320  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
321  + upgrade-haze-profiles.sh
322
323* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
324- Update to new upstream release (2.23.6)
325- Use the in-tarball libtool scripts instead of the system copy to workaround
326  'make install' errors.
327
328* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
329- Update to 0.23.4.
330- Update source url.
331
332* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
333- Update to 0.23.3.
334- Remove reference to stream-engine in connections managers readme.
335
336* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
337- Update to 0.23.2.
338- Add man pages.
339- Use enchant-devel, instead of aspell-devel.
340
341* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
342- Rebuild for new e-d-s.
343
344* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
345- Drop multiple copies of COPYING file.
346- Drop BR on gnome-vfs2-devel.
347- Require telepathy-stream-engine for VOIP support.
348- Add BR on iso-codes-devel, so spell-checking is enabled.
349
350* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
351- Update to new upstream release (0.23.1)
352- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
353
354* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
355- Update to new upstream release (0.22.1)
356
357* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
358- Update to new upstream release (0.22.0)
359
360* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
361- Update to new upstream release (0.21.91)
362
363* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
364- Update to new upstream release (0.21.90)
365
366* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
367- Autorebuild for GCC 4.3
368
369* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
370- Update to new upstream release (0.21.4)
371
372* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
373- Update to new upstream release (0.21.2)
374- Drop backported drag-and-drop patch (fixed upstream):
375    - svn380-fix-contact-DnD.patch
376- Update README.ConnectionManagers: Include Haze package note, remove Galago
377  note (a feed-only connection manager isn't useful for instant messaging),
378  and fix some wording.
379
380* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
381- Backport upstream patch to fixes crashes when using drag-and-drop of a
382  contact from the buddy list to the current conversation window to initiate a
383  conversation:
384    + svn380-fix-contact-DnD.patch
385- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
386  dragged a contact ...)
387
388* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
389- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
390  is essentially useless due to the need to install an external connection
391  manager. Also, add a README.ConnectionManagers to the installed
392  documentation which lists other possibilities.
393- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
394  and bug 334221 (Default empathy install is useless).
395
396* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
397- Enable VoIP support for those brave enough to test/break/debug it (F9+
398  only). Though it is functional, it is still deemed rather unstable by
399  upstream. Use it at your own risk. :)
400
401* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
402- Disable VoIP support at this time, since it is deemed unstable by upstream
403  for now. (Thanks to Brian Pepple for the notice.)
404 
405* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
406- Update to new upstream release (0.14).
407
408* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
409- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
410  and python bindings.
411- Split shared libraries into a libs subpackage for easier handling
412  in multi-lib environments.
413
414* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
415- Add ldconfig invocations to %%post and %%postun scriptlets.
416
417* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
418- Update to new upstream release (0.12).
419- Build against new mission-control stack.
420- Update License tag (GPLv2+).
421- Alphabetize BuildRequires list (aesthetic-only change).
422
423* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
424- Rebuild for selinux ppc32 issue.
425
426* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
427- Update to new upstream release (0.11)
428
429* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
430- bump to 0.8
431- Now with aspell support (deat to teh speeling mistaks)
432
433* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
434- bump to 0.7
435
436* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
437- Add telepathy-filesystem to Requires
438- Move .desktop from autostart to applications
439- Nasty hackery to make empathy launch from the menu
440
441* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
442- Add gettext to BuildRequires
443
444* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
445- Bump to 0.6
446
447* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
448- Let Empathy own the directory and not just the files in it
449
450* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
451- Initial package
Note: See TracBrowser for help on using the repository browser.