source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 4650

Revision 4650, 15.8 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.1.5

Line 
1%define major_ver 3.1
2%define minor_ver 5
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk3_min_version        3.0.0
10%global glib2_min_version       2.28.0
11%global tp_mc_min_version       5.6.0
12%global tp_glib_min_version     0.13.0
13%global tp_logger_min_version   0.1.5
14#global enchant_version         1.4.0
15%global aspell_version          0.50
16%global libcanberra_version     0.4
17%global gnome_keyring_version   2.32
18%global libnotify_version       0.4.4
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  GConf2-devel
42BuildRequires:  gettext
43BuildRequires:  glib2-devel >= %{glib2_min_version}
44BuildRequires:  gnome-doc-utils >= 0.17.3
45BuildRequires:  gnome-panel
46BuildRequires:  gtk3-devel >= %{gtk3_min_version}
47BuildRequires:  intltool
48BuildRequires:  libxml2-devel
49BuildRequires:  perl(XML::Parser)
50BuildRequires:  pygtk2-devel
51BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
52BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
53BuildRequires:  farsight2-devel
54BuildRequires:  telepathy-farsight-devel
55BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
56BuildRequires:  libgnome-keyring-devel >= %{gnome_keyring_version}
57BuildRequires:  unique3-devel
58BuildRequires:  libnotify-devel >= %{libnotify_version}
59BuildRequires:  libtelepathy-devel
60BuildRequires:  libgnomecanvas-devel
61BuildRequires:  libbonoboui-devel
62BuildRequires:  folks-devel
63BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
64BuildRequires:  gnome-keyring-devel >= %{gnome_keyring_version}
65BuildRequires:  openssl-devel
66BuildRequires:  NetworkManager-glib-devel
67BuildRequires:  WebKit3-gtk-devel
68BuildRequires:  geoclue-devel
69BuildRequires:  enchant-devel
70BuildRequires:  libICE-devel
71BuildRequires:  cheese-devel
72BuildRequires:  libchamplain-gtk-devel
73BuildRequires:  pulseaudio-libs-devel
74BuildRequires:  gsettings-desktop-schemas
75
76Requires:       telepathy-filesystem
77## Empathy is useless without a proper Telepathy connection manager installed.
78## We hardcode dependencies on Salut and Gabble to support XMPP on a default
79## install, in both the link-local and Jabber/GoogleTalk incarnations.
80## (RHBZ: 308871 and 334221)
81## TODO: Perhaps we can configure these to be installed "on demand" with
82##       PackageKit and friends?
83Requires:       telepathy-gabble
84Requires:       telepathy-salut
85## Also hardcode Haze dependency since Empathy is the default IM client in F10+
86## and I'd hate for people to simply disregard it for lack of the "out of the
87## box" protocol support that Pidgin has. (RHBZ: 458935)
88BuildRequires:  telepathy-haze
89# Require this for VOIP support
90Requires:       telepathy-stream-engine
91Requires:       telepathy-mission-control >= %{tp_mc_min_version}
92
93
94Requires(post): GConf2
95Requires(post): scrollkeeper
96
97Requires(postun):       scrollkeeper
98
99## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
100Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
101Provides:       telepathy-haze-mission-control = 0.2.0-3
102## upstream 2.29.1 removed shared libraries: #599086
103Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
104## upstream 2.29.1 removed python bindings' #599039
105Obsoletes: empathy-python < 2.29.1
106
107Vendor: Project Vine
108Distribution: Vine Linux
109
110%description
111Empathy provides a powerful multiple protocol instant messaging
112client using the Telepathy framework.
113
114
115%package -n     nautilus-sendto-empathy
116License:        GPLv2+
117Summary:        Nautilus-sendto plugin for empathy
118Summary(ja):    empathy 用 nautilus-sendto プラグイン
119Group:          User Interface/Desktop
120
121Requires:       %{name} = %{version}-%{release}
122Requires:       nautilus-sendto
123BuildRequires:  nautilus-sendto-devel
124
125%description -n nautilus-sendto-empathy
126This package contains nautilus-sendto plugin for the Empathy IM application.
127
128
129%prep
130%setup -q
131
132
133%build
134## GCC complains about some unused functions, so we forcibly show those as
135## simple warnings instead of build-halting errors.
136%configure \
137        --with-compile-warnings=yes \
138        --disable-static \
139        --enable-nautilus-sendto=yes \
140         --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
141## RPATHs are yucky.
142sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
143sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
144
145##make %{?_smp_mflags}
146## don't use _smp_mflags at empathy-2.18.1
147make
148
149install -m 0644 %{SOURCE1} ./README.ConnectionManagers
150
151
152%install
153rm -rf $RPM_BUILD_ROOT
154make install DESTDIR=$RPM_BUILD_ROOT
155find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
156
157%find_lang %{name}
158
159desktop-file-install --vendor "" --delete-original      \
160        --dir %{buildroot}%{_datadir}/applications      \
161        %{buildroot}%{_datadir}/applications/%{name}.desktop
162
163
164%clean
165rm -rf %{buildroot}
166
167
168%post
169scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
170touch --no-create %{_datadir}/icons/hicolor ||:
171%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
172
173%postun
174scrollkeeper-update -q || :
175touch --no-create %{_datadir}/icons/hicolor || :
176if [ -x %{_bindir}/gtk-update-icon-cache ]; then
177        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
178        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
179fi
180
181%posttrans
182gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
183glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
184
185
186%files -f %{name}.lang
187%defattr(-,root,root,-)
188%doc AUTHORS COPYING README README.ConnectionManagers NEWS
189%{_bindir}/empathy
190%{_bindir}/empathy-accounts
191%{_bindir}/empathy-debugger
192%{_libexecdir}/empathy-auth-client
193%{_libexecdir}/empathy-av
194%{_libexecdir}/empathy-chat
195%{_datadir}/dbus-1/services/*
196%{_datadir}/empathy
197%{_datadir}/glib-2.0/schemas/*.xml
198%{_datadir}/GConf/gsettings/*
199%{_datadir}/applications/*.desktop
200%{_datadir}/gnome/help/%{name}/
201#{_datadir}/omf/%{name}/
202%{_datadir}/icons/hicolor/*/apps/%{name}*
203#{_datadir}/mission-control/profiles/*.profile
204%{_datadir}/telepathy/clients/*.client
205%{_mandir}/man1/empathy*.1*
206
207%files -n nautilus-sendto-empathy
208%defattr(-,root,root,-)
209%{_libdir}/nautilus-sendto/plugins/libnstempathy.so
210
211
212%changelog
213* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
214- new upstream release
215- add BuildRequires: pulseaudio-libs-devel
216
217* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
218- new upstream release
219- change BuildRequires: gtk3-devel instead of gtk2-devel
220- change BuildRequires: unique3-devel instead of unique-devel
221- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
222- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
223- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
224
225* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
226- new upstream release
227- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
228                     geoclue-devel, enchant-devel
229- add Requires: telepathy-mission-control
230- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
231
232* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
233- new upstream release
234- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
235- fix %files
236- fix %post, %postun
237- drop %pre, %preun
238
239* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
240- rebuild with evolution-data-server-2.30.2
241- add nautilus-sendto-empathy package
242  - add configure option (--enable-nautilus-sendto=yes)
243  - add BuildRequires: nautilus-sendto-devel
244
245* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
246- add Obsoletes: empathy-python < 2.29.1
247
248* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
249- new upstream release
250- add new files: %%{_bindir}/empathy-{accounts,debugger}
251- drop -libs, -devel, -python sub packages: upstream removed
252  - Obsoletes: empathy-{libs,devel} < 2.29.1
253  - drop BuildRequires: python-devel
254- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
255- drop applet files in %%files: upstream removed the panel applets
256  - update %%post, %pre and %%preun
257- update BuildRequires version for glib2 and tp_glib
258- defined major_ver, minor_ver and rel
259- fix BuildRequires for gnome-keyring
260
261* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
262- new upstream release
263- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
264
265* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
266- rebuilt with python-2.6.4
267
268* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
269- unuse %%{?_smp_mflags} option to make
270
271* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
272- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
273
274* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
275- new upstream release
276
277* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
278- new upstream release
279
280* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
281- initial build for Vine Linux
282
283* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
284- Update to 2.23.92
285
286* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
287- Update to 2.23.91
288
289* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
290- Now that Empathy will be the default IM client in F10+, hardcode a dependency
291  on telepathy-haze to keep the same protocol functionality across upgrades,
292  for a much improved "out of the box" experience.
293- Reference: bug 458935.
294
295* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
296- Update to new upstream release (2.23.90)
297
298* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
299- Apply patch from Colin Walters to automagically update profile namings for
300  the switch to using Empathy's provided profiles.
301- Drop the upgrade script (no longer needed since it's automatically done).
302  - upgrade-haze-profiles.sh
303
304* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
305- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
306  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
307  horribly stale...). This makes for better automagic functionality (if Haze is
308  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
309  + upgrade-haze-profiles.sh
310
311* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
312- Update to new upstream release (2.23.6)
313- Use the in-tarball libtool scripts instead of the system copy to workaround
314  'make install' errors.
315
316* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
317- Update to 0.23.4.
318- Update source url.
319
320* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
321- Update to 0.23.3.
322- Remove reference to stream-engine in connections managers readme.
323
324* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
325- Update to 0.23.2.
326- Add man pages.
327- Use enchant-devel, instead of aspell-devel.
328
329* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
330- Rebuild for new e-d-s.
331
332* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
333- Drop multiple copies of COPYING file.
334- Drop BR on gnome-vfs2-devel.
335- Require telepathy-stream-engine for VOIP support.
336- Add BR on iso-codes-devel, so spell-checking is enabled.
337
338* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
339- Update to new upstream release (0.23.1)
340- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
341
342* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
343- Update to new upstream release (0.22.1)
344
345* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
346- Update to new upstream release (0.22.0)
347
348* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
349- Update to new upstream release (0.21.91)
350
351* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
352- Update to new upstream release (0.21.90)
353
354* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
355- Autorebuild for GCC 4.3
356
357* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
358- Update to new upstream release (0.21.4)
359
360* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
361- Update to new upstream release (0.21.2)
362- Drop backported drag-and-drop patch (fixed upstream):
363    - svn380-fix-contact-DnD.patch
364- Update README.ConnectionManagers: Include Haze package note, remove Galago
365  note (a feed-only connection manager isn't useful for instant messaging),
366  and fix some wording.
367
368* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
369- Backport upstream patch to fixes crashes when using drag-and-drop of a
370  contact from the buddy list to the current conversation window to initiate a
371  conversation:
372    + svn380-fix-contact-DnD.patch
373- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
374  dragged a contact ...)
375
376* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
377- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
378  is essentially useless due to the need to install an external connection
379  manager. Also, add a README.ConnectionManagers to the installed
380  documentation which lists other possibilities.
381- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
382  and bug 334221 (Default empathy install is useless).
383
384* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
385- Enable VoIP support for those brave enough to test/break/debug it (F9+
386  only). Though it is functional, it is still deemed rather unstable by
387  upstream. Use it at your own risk. :)
388
389* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
390- Disable VoIP support at this time, since it is deemed unstable by upstream
391  for now. (Thanks to Brian Pepple for the notice.)
392 
393* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
394- Update to new upstream release (0.14).
395
396* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
397- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
398  and python bindings.
399- Split shared libraries into a libs subpackage for easier handling
400  in multi-lib environments.
401
402* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
403- Add ldconfig invocations to %%post and %%postun scriptlets.
404
405* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
406- Update to new upstream release (0.12).
407- Build against new mission-control stack.
408- Update License tag (GPLv2+).
409- Alphabetize BuildRequires list (aesthetic-only change).
410
411* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
412- Rebuild for selinux ppc32 issue.
413
414* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
415- Update to new upstream release (0.11)
416
417* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
418- bump to 0.8
419- Now with aspell support (deat to teh speeling mistaks)
420
421* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
422- bump to 0.7
423
424* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
425- Add telepathy-filesystem to Requires
426- Move .desktop from autostart to applications
427- Nasty hackery to make empathy launch from the menu
428
429* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
430- Add gettext to BuildRequires
431
432* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
433- Bump to 0.6
434
435* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
436- Let Empathy own the directory and not just the files in it
437
438* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
439- Initial package
Note: See TracBrowser for help on using the repository browser.