source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 4616

Revision 4616, 15.7 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define major_ver 3.1
2%define minor_ver 4
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk3_min_version        3.0.0
10%global glib2_min_version       2.28.0
11%global tp_mc_min_version       5.6.0
12%global tp_glib_min_version     0.13.0
13%global tp_logger_min_version   0.1.5
14#global enchant_version         1.4.0
15%global aspell_version          0.50
16%global libcanberra_version     0.4
17%global gnome_keyring_version   2.32
18%global libnotify_version       0.4.4
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  GConf2-devel
42BuildRequires:  gettext
43BuildRequires:  glib2-devel >= %{glib2_min_version}
44BuildRequires:  gnome-doc-utils >= 0.17.3
45BuildRequires:  gnome-panel
46BuildRequires:  gtk3-devel >= %{gtk3_min_version}
47BuildRequires:  intltool
48BuildRequires:  libxml2-devel
49BuildRequires:  perl(XML::Parser)
50BuildRequires:  pygtk2-devel
51BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
52BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
53BuildRequires:  farsight2-devel
54BuildRequires:  telepathy-farsight-devel
55BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
56BuildRequires:  libgnome-keyring-devel >= %{gnome_keyring_version}
57BuildRequires:  unique3-devel
58BuildRequires:  libnotify-devel >= %{libnotify_version}
59BuildRequires:  libtelepathy-devel
60BuildRequires:  libgnomecanvas-devel
61BuildRequires:  libbonoboui-devel
62BuildRequires:  folks-devel
63BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
64BuildRequires:  gnome-keyring-devel >= %{gnome_keyring_version}
65BuildRequires:  openssl-devel
66BuildRequires:  NetworkManager-glib-devel
67BuildRequires:  WebKit3-gtk-devel
68BuildRequires:  geoclue-devel
69BuildRequires:  enchant-devel
70BuildRequires:  gsettings-desktop-schemas
71BuildRequires:  libICE-devel
72BuildRequires:  cheese-devel
73BuildRequires:  libchamplain-gtk-devel
74
75Requires:       telepathy-filesystem
76## Empathy is useless without a proper Telepathy connection manager installed.
77## We hardcode dependencies on Salut and Gabble to support XMPP on a default
78## install, in both the link-local and Jabber/GoogleTalk incarnations.
79## (RHBZ: 308871 and 334221)
80## TODO: Perhaps we can configure these to be installed "on demand" with
81##       PackageKit and friends?
82Requires:       telepathy-gabble
83Requires:       telepathy-salut
84## Also hardcode Haze dependency since Empathy is the default IM client in F10+
85## and I'd hate for people to simply disregard it for lack of the "out of the
86## box" protocol support that Pidgin has. (RHBZ: 458935)
87BuildRequires:  telepathy-haze
88# Require this for VOIP support
89Requires:       telepathy-stream-engine
90Requires:       telepathy-mission-control >= %{tp_mc_min_version}
91
92
93Requires(post): GConf2
94Requires(post): scrollkeeper
95
96Requires(postun):       scrollkeeper
97
98## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
99Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
100Provides:       telepathy-haze-mission-control = 0.2.0-3
101## upstream 2.29.1 removed shared libraries: #599086
102Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
103## upstream 2.29.1 removed python bindings' #599039
104Obsoletes: empathy-python < 2.29.1
105
106Vendor: Project Vine
107Distribution: Vine Linux
108
109%description
110Empathy provides a powerful multiple protocol instant messaging
111client using the Telepathy framework.
112
113
114%package -n     nautilus-sendto-empathy
115License:        GPLv2+
116Summary:        Nautilus-sendto plugin for empathy
117Summary(ja):    empathy 用 nautilus-sendto プラグイン
118Group:          User Interface/Desktop
119
120Requires:       %{name} = %{version}-%{release}
121Requires:       nautilus-sendto
122BuildRequires:  nautilus-sendto-devel
123
124%description -n nautilus-sendto-empathy
125This package contains nautilus-sendto plugin for the Empathy IM application.
126
127
128%prep
129%setup -q
130
131
132%build
133## GCC complains about some unused functions, so we forcibly show those as
134## simple warnings instead of build-halting errors.
135%configure \
136        --with-compile-warnings=yes \
137        --disable-static \
138        --enable-nautilus-sendto=yes \
139         --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
140## RPATHs are yucky.
141sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
142sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
143
144##make %{?_smp_mflags}
145## don't use _smp_mflags at empathy-2.18.1
146make
147
148install -m 0644 %{SOURCE1} ./README.ConnectionManagers
149
150
151%install
152rm -rf $RPM_BUILD_ROOT
153make install DESTDIR=$RPM_BUILD_ROOT
154find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
155
156%find_lang %{name}
157
158desktop-file-install --vendor "" --delete-original      \
159        --dir %{buildroot}%{_datadir}/applications      \
160        %{buildroot}%{_datadir}/applications/%{name}.desktop
161
162
163%clean
164rm -rf %{buildroot}
165
166
167%post
168scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
169touch --no-create %{_datadir}/icons/hicolor ||:
170%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
171
172%postun
173scrollkeeper-update -q || :
174touch --no-create %{_datadir}/icons/hicolor || :
175if [ -x %{_bindir}/gtk-update-icon-cache ]; then
176        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
177        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
178fi
179
180%posttrans
181gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
182glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
183
184
185%files -f %{name}.lang
186%defattr(-,root,root,-)
187%doc AUTHORS COPYING README README.ConnectionManagers NEWS
188%{_bindir}/empathy
189%{_bindir}/empathy-accounts
190%{_bindir}/empathy-debugger
191%{_libexecdir}/empathy-auth-client
192%{_libexecdir}/empathy-av
193%{_libexecdir}/empathy-chat
194%{_datadir}/dbus-1/services/*
195%{_datadir}/empathy
196%{_datadir}/glib-2.0/schemas/*.xml
197%{_datadir}/GConf/gsettings/*
198%{_datadir}/applications/*.desktop
199%{_datadir}/gnome/help/%{name}/
200#{_datadir}/omf/%{name}/
201%{_datadir}/icons/hicolor/*/apps/%{name}*
202#{_datadir}/mission-control/profiles/*.profile
203%{_datadir}/telepathy/clients/*.client
204%{_mandir}/man1/empathy*.1*
205
206%files -n nautilus-sendto-empathy
207%defattr(-,root,root,-)
208%{_libdir}/nautilus-sendto/plugins/libnstempathy.so
209
210
211%changelog
212* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
213- new upstream release
214- change BuildRequires: gtk3-devel instead of gtk2-devel
215- change BuildRequires: unique3-devel instead of unique-devel
216- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
217- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
218- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
219
220* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
221- new upstream release
222- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
223                     geoclue-devel, enchant-devel
224- add Requires: telepathy-mission-control
225- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
226
227* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
228- new upstream release
229- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
230- fix %files
231- fix %post, %postun
232- drop %pre, %preun
233
234* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
235- rebuild with evolution-data-server-2.30.2
236- add nautilus-sendto-empathy package
237  - add configure option (--enable-nautilus-sendto=yes)
238  - add BuildRequires: nautilus-sendto-devel
239
240* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
241- add Obsoletes: empathy-python < 2.29.1
242
243* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
244- new upstream release
245- add new files: %%{_bindir}/empathy-{accounts,debugger}
246- drop -libs, -devel, -python sub packages: upstream removed
247  - Obsoletes: empathy-{libs,devel} < 2.29.1
248  - drop BuildRequires: python-devel
249- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
250- drop applet files in %%files: upstream removed the panel applets
251  - update %%post, %pre and %%preun
252- update BuildRequires version for glib2 and tp_glib
253- defined major_ver, minor_ver and rel
254- fix BuildRequires for gnome-keyring
255
256* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
257- new upstream release
258- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
259
260* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
261- rebuilt with python-2.6.4
262
263* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
264- unuse %%{?_smp_mflags} option to make
265
266* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
267- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
268
269* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
270- new upstream release
271
272* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
273- new upstream release
274
275* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
276- initial build for Vine Linux
277
278* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
279- Update to 2.23.92
280
281* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
282- Update to 2.23.91
283
284* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
285- Now that Empathy will be the default IM client in F10+, hardcode a dependency
286  on telepathy-haze to keep the same protocol functionality across upgrades,
287  for a much improved "out of the box" experience.
288- Reference: bug 458935.
289
290* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
291- Update to new upstream release (2.23.90)
292
293* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
294- Apply patch from Colin Walters to automagically update profile namings for
295  the switch to using Empathy's provided profiles.
296- Drop the upgrade script (no longer needed since it's automatically done).
297  - upgrade-haze-profiles.sh
298
299* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
300- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
301  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
302  horribly stale...). This makes for better automagic functionality (if Haze is
303  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
304  + upgrade-haze-profiles.sh
305
306* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
307- Update to new upstream release (2.23.6)
308- Use the in-tarball libtool scripts instead of the system copy to workaround
309  'make install' errors.
310
311* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
312- Update to 0.23.4.
313- Update source url.
314
315* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
316- Update to 0.23.3.
317- Remove reference to stream-engine in connections managers readme.
318
319* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
320- Update to 0.23.2.
321- Add man pages.
322- Use enchant-devel, instead of aspell-devel.
323
324* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
325- Rebuild for new e-d-s.
326
327* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
328- Drop multiple copies of COPYING file.
329- Drop BR on gnome-vfs2-devel.
330- Require telepathy-stream-engine for VOIP support.
331- Add BR on iso-codes-devel, so spell-checking is enabled.
332
333* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
334- Update to new upstream release (0.23.1)
335- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
336
337* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
338- Update to new upstream release (0.22.1)
339
340* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
341- Update to new upstream release (0.22.0)
342
343* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
344- Update to new upstream release (0.21.91)
345
346* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
347- Update to new upstream release (0.21.90)
348
349* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
350- Autorebuild for GCC 4.3
351
352* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
353- Update to new upstream release (0.21.4)
354
355* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
356- Update to new upstream release (0.21.2)
357- Drop backported drag-and-drop patch (fixed upstream):
358    - svn380-fix-contact-DnD.patch
359- Update README.ConnectionManagers: Include Haze package note, remove Galago
360  note (a feed-only connection manager isn't useful for instant messaging),
361  and fix some wording.
362
363* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
364- Backport upstream patch to fixes crashes when using drag-and-drop of a
365  contact from the buddy list to the current conversation window to initiate a
366  conversation:
367    + svn380-fix-contact-DnD.patch
368- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
369  dragged a contact ...)
370
371* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
372- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
373  is essentially useless due to the need to install an external connection
374  manager. Also, add a README.ConnectionManagers to the installed
375  documentation which lists other possibilities.
376- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
377  and bug 334221 (Default empathy install is useless).
378
379* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
380- Enable VoIP support for those brave enough to test/break/debug it (F9+
381  only). Though it is functional, it is still deemed rather unstable by
382  upstream. Use it at your own risk. :)
383
384* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
385- Disable VoIP support at this time, since it is deemed unstable by upstream
386  for now. (Thanks to Brian Pepple for the notice.)
387 
388* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
389- Update to new upstream release (0.14).
390
391* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
392- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
393  and python bindings.
394- Split shared libraries into a libs subpackage for easier handling
395  in multi-lib environments.
396
397* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
398- Add ldconfig invocations to %%post and %%postun scriptlets.
399
400* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
401- Update to new upstream release (0.12).
402- Build against new mission-control stack.
403- Update License tag (GPLv2+).
404- Alphabetize BuildRequires list (aesthetic-only change).
405
406* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
407- Rebuild for selinux ppc32 issue.
408
409* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
410- Update to new upstream release (0.11)
411
412* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
413- bump to 0.8
414- Now with aspell support (deat to teh speeling mistaks)
415
416* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
417- bump to 0.7
418
419* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
420- Add telepathy-filesystem to Requires
421- Move .desktop from autostart to applications
422- Nasty hackery to make empathy launch from the menu
423
424* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
425- Add gettext to BuildRequires
426
427* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
428- Bump to 0.6
429
430* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
431- Let Empathy own the directory and not just the files in it
432
433* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
434- Initial package
Note: See TracBrowser for help on using the repository browser.