source: projects/specs/trunk/e/emacs/emacs24-vl.spec @ 9014

Revision 9014, 29.4 KB checked in by munepi, 10 years ago (diff)

new upstream release

Line 
1%define emacsversion 24.4
2#% define gitdate 20110817
3%define emacsrelease 1%{?gitdate:.%gitdate}%{?_dist_release}
4%define vine_default_major_version %(echo %_dist_release|%__sed s/vl//)
5
6%define _noVersionedDependencies 1
7%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
8
9%define infodir %{_infodir}/emacs-%{emacsversion}
10
11%define menutreeelversion 0.97
12
13Summary:      GNU Emacs editor
14Summary(ja):  GNU Emacs エディタ
15Name:         emacs
16#Name:         emacs24
17#Provides:     emacs-snapshot
18Version:      %{emacsversion}
19Release:      %{emacsrelease}
20Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}.tar.xz
21#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}%{?gitdate:.git%gitdate}.tar.xz
22#Source0:      ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}.tar.xz
23#Source1:      emacs-snapshot.sh
24
25Source10:     site-start.el.emacs24
26
27## local settings for local system
28Source20:     emacs24-local.el
29
30# desktop file
31Source50:     emacs24.desktop.in
32
33## Enable Japanese Menu
34## http://www11.atwiki.jp/s-irie/pages/13.html
35# Source100:    menu-tree-el-%{menutreeelversion}.tar.gz
36# Source101:    menu-tree-init.el.emacs24
37Source102:    coding-system-init.el.emacs24
38
39## default settings for Vine Linux
40Source150:    vine-default-base.el
41
42## Vine Patch(es)
43Patch11:      emacs-24.3.90-locallisppath.patch
44#Patch20:      emacs-23.1.90-fixed-resolution.patch
45Patch30:      emacs-24.0.90-libs-termcap.patch
46
47# patches from Fedora
48# rhbz#713600
49Patch107: emacs-spellchecker.patch
50
51# security patches (from Debian)
52
53#Patch1001:    emacs-21.1-bzip2.patch.bz2
54
55License:      GPLv3+
56Group:        Applications/Editors/Emacs
57
58Distribution: Vine Linux
59Vendor:       Project Vine
60Packager:     munepi, daisuke
61
62BuildRoot:    %{_tmppath}/%{name}-%{version}-root
63# Requires:     tamago >= 4.0.6
64Obsoletes:    mule-base, mule-canna, mule-wnn6, mule, emacs-beta
65Obsoletes:    emacs21 <= 21.2-0vl7
66Obsoletes:    emacs22 <= 22.1
67Obsoletes:    emacs23 <= 23.1
68Obsoletes:    emacs24 <= 24.1
69#Provides:     emacs24 = %{version}
70Provides:     emacsen = 0.1
71#% prereq_ge    emacsen-common
72Requires(post):    emacsen-common
73Requires(postun):    emacsen-common
74
75BuildRequires: autoconf
76BuildRequires: xz
77BuildRequires: atk-devel
78BuildRequires: dbus-devel GConf2-devel
79BuildRequires: alsa-lib-devel
80BuildRequires: gnutls-devel
81#if %{?_dist_release} >= "vl7"
82#BuildRequires: gtk3-devel
83#else
84BuildRequires: gtk2-devel
85#endif
86BuildRequires: cairo-devel
87BuildRequires: freetype2-devel, fontconfig-devel
88BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
89BuildRequires: librsvg2-devel, libotf-devel
90BuildRequires: ImageMagick-devel
91BuildRequires: libxml2-devel > 2.6.17
92BuildRequires: m17n-lib-devel
93BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
94BuildRequires: libSM-devel, libXt-devel, libXpm-devel, ncurses-devel
95BuildRequires: xorg-x11-proto-devel, zlib-devel
96BuildRequires: texinfo
97BuildRequires: nkf
98
99%description
100GNU Emacs is the extensible, customizable, self-documenting real-time
101display editor.
102
103%description -l ja
104GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
105
106
107%prep
108
109%setup -q -n emacs-%{version}
110
111%patch11 -p1
112#%patch20 -p1
113#%patch30 -p1
114
115%patch107 -p1 -b .spellchecker
116
117#%patch1001 -p1
118
119
120# Avoid trademark issues
121grep -v "tetris.elc" lisp/Makefile.in > lisp/Makefile.in.new \
122   && %__mv lisp/Makefile.in.new lisp/Makefile.in || exit 1
123%__rm -f lisp/play/tetris.el lisp/play/tetris.elc || exit 1
124
125#autoconf
126autoreconf -i -I m4
127
128%build
129export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
130#to find installinfo
131export PATH="$PATH:/sbin:/usr/sbin"
132
133%configure --with-pop --with-sound \
134    --libexecdir=%{_libdir} --infodir=%{infodir} \
135    --disable-rename \
136    --with-x-toolkit=gtk \
137    --with-freetype --with-xft \
138    --enable-font-backend \
139    --without-gpm \
140    --with-libotf \
141    --with-m17n-flt \
142    --with-dbus --with-gconf \
143    ;
144#    --with-x-toolkit=gtk3 \
145
146%__make bootstrap
147%__make %{?_smp_mflags}
148
149
150%install
151[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
152
153%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
154        infodir=${RPM_BUILD_ROOT}%{infodir}
155
156## This is a duplicate of the file in FLAVOR/site-lisp
157%__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
158
159# (cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
160# (cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
161
162%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
163%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
164# %__tar zxvf %{SOURCE100}
165# %__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
166# nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
167
168## vine default
169%__cp -a %{SOURCE150} \
170    $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
171
172# The elisp reference manual
173#bzcat %{SOURCE13} | tar xf -
174#pushd elisp-manual-21-2.8
175#install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
176#popd
177
178# some modifications of installed files
179
180#rm -f $RPM_BUILD_ROOT%{infodir}/dir
181#gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
182
183%__install -m 644 %{SOURCE10} \
184        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
185%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
186          -e 's/VINE_DEFAULT_MAJOR_VERSION/%{vine_default_major_version}/g' \
187        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
188
189## create site-start.d directory
190%__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
191
192# install coding-system init.el
193# %__install -m644 %{SOURCE101} \
194#     $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
195# %__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
196#     ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
197%__install -m644 %{SOURCE102} \
198    $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el
199%__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el \
200    ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60coding-system-init.el
201
202## install system-wide configure file
203%__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
204%__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
205%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
206    ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
207
208## Python mode, php mode and rpm-spec mode
209
210## make file list
211strip $RPM_BUILD_ROOT%{_bindir}/* || :
212
213# install desktop file
214%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
215%__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
216    $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
217[ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
218    %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
219
220# install icons
221%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
222%__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
223
224## remove man files
225%__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
226
227## Remove ctags
228#rm -f $RPM_BUILD_ROOT/usr/bin/ctags
229#rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
230#rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
231
232DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
233     ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
234BIN=${RPM_BUILD_ROOT}%{_bindir}
235LIB=${RPM_BUILD_ROOT}%{_libdir}
236EL="*.el"
237
238## prepare file list for emacs
239echo "/usr/bin/ctags
240/usr/bin/ebrowse
241/usr/bin/etags
242/usr/bin/rcs-checkin
243/usr/bin/emacs
244/usr/bin/emacsclient
245/usr/bin/grep-changelog
246/usr/share/icons/hicolor/scalable/apps/emacs.svg
247/usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg" |
248    %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
249    awk '{system($_)}'
250
251find $DIR $BIN $LIB -type d |
252  %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
253
254find $DIR $BIN $LIB -type f -o -type l |
255  %__sed -e "
256    s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
257    s#^${RPM_BUILD_ROOT}##
258  " >> rpm-files
259
260
261%clean
262[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
263
264
265%define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
266
267
268%pre
269
270if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
271    %__rm -f %{_datadir}/emacs-%{version}/site-lisp
272fi
273
274if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
275    find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
276        xargs %__rm -rf
277fi
278
279
280%post
281touch --no-create %{_datadir}/icons/hicolor
282if [ -x %{_bindir}/gtk-update-icon-cache ]; then
283   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
284fi
285%{_bindir}/update-desktop-database %{_datadir}/applications &>/dev/null ||:
286
287if [ "$1" = 1 ]; then
288
289%_addflavorslist emacs-%{version}
290
291export PRIORITY=50
292
293%_installemacs emacs-%{version}
294
295unset PRIORITY
296fi
297
298if [ "$1" = 2 ]; then
299
300#  export PRIORITY=50
301 
302#  %_installemacs emacs-%{version}
303 
304#  unset PRIORITY
305   
306  echo emacs-%{version} >  /var/lib/emacsen-common/doinstaflavor-emacs
307   
308fi
309
310
311%postun
312%{_bindir}/update-desktop-database %{_datadir}/applications &>/dev/null ||:
313touch --no-create %{_datadir}/icons/hicolor
314if [ -x %{_bindir}/gtk-update-icon-cache ]; then
315  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
316fi
317
318if [ $1 = 1 ]; then
319# run upgrade install time
320
321# old version uninstall
322
323%_removeflavorslist emacs-%{version}
324
325%_removeemacs emacs-%{version}
326
327#new version install
328if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
329
330NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
331
332%_addflavorslist $NEWFLAVOR
333
334export PRIORITY=50
335
336%_installemacs $NEWFLAVOR
337
338unset PRIORITY
339
340%__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
341
342fi
343
344fi
345
346
347%preun
348if [ $1 = 0 ]; then
349
350%_removeflavorslist emacs-%{version}
351
352%_removeemacs emacs-%{version}
353
354fi
355
356
357%triggerpostun -- emacs23 < %{version}-%{release}
358
359%_addflavorslist emacs-%{version}
360
361export PRIORITY=50
362
363%_installemacs emacs-%{version}
364
365unset PRIORITY
366
367
368%files -f rpm-files
369%defattr(-,root,root)
370%doc INSTALL README BUGS ChangeLog COPYING
371#%doc INSTALL.BZR
372%dir %{_sysconfdir}/emacs-%{version}
373%dir %{_sysconfdir}/emacs-%{version}/site-start.d
374%{_sysconfdir}/emacs-%{version}/site-start.d/*.el
375%config(noreplace) %{_sysconfdir}/emacs/emacs24-local.el
376%{_infodir}/*
377# %{_mandir}/*/*
378%{_datadir}/applications/emacs24.desktop
379%{_datadir}/icons/hicolor/*
380# %{_datadir}/emacs-%{version}/site-lisp
381%dir %{_localstatedir}/games/emacs
382%{_localstatedir}/games/emacs/*
383
384
385%changelog
386* Thu Oct 23 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.4-1
387- new upstream release
388
389* Fri Aug 15 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.93-1
390- updated to 24.3.93
391
392* Sun Jul  6 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.92-1
393- updated to 24.3.92
394
395* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.3.91-2
396- rebuild with ImageMagick-6.8.9.5
397
398* Mon May 12 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.91-1
399- updated to 24.3.91
400
401* Sun Apr 27 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.90-1
402- updated to 24.3.90
403
404* Tue Feb 25 2014 NAKAMURA Kenta <kenta@vinelinux.org> 24.3-5
405- rebuilt with gnutls-3.2
406
407* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-4
408- rebuilt
409
410* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.3-3
411- rebuild with ImageMagick-6.8.6.8
412
413* Sat May 11 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-2
414- dropped some obsolete patches
415- disable menu-tree-el
416  - added coding-system-init.el instead of menu-tree-init.el
417
418* Sat Mar 30 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-1
419- new upstream release
420
421* Thu Feb  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.93-1
422- updated to 24.2.93 (24.3 pretest)
423
424* Mon Jan 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.92-1
425- updated to 24.2.92 (24.3 pretest)
426
427* Sun Nov 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.90-1
428- updated to 24.2.90 (24.3 pretest)
429
430* Mon Aug 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2-1
431- new upstream release
432
433* Sun Jun 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.1-1
434- new upstream release
435
436* Sat May 19 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.97-1
437- updated to 24.0.97 (24.1 pretest)
438
439* Sun Apr 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.96-1
440- updated to 24.0.96 (24.1 pretest)
441
442* Mon Apr  2 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.95-1
443- updated to 24.0.95 (24.1 pretest)
444
445* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.0.94-2
446- rebuild with ImageMagick-6.7.5.10
447
448* Mon Feb 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.94-1
449- updated to 24.0.94 (24.1 pretest)
450
451* Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-2
452- use gtk as X toolkit (for vl6)
453
454* Mon Jan 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-1
455- updated to 24.0.93 (24.1 pretest)
456
457* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.92-1
458- updated to 24.0.92 (24.1 pretest)
459
460* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.91-1
461- updated to 24.0.91 (24.1 pretest)
462
463* Thu Oct  6 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-2
464- set --with-x-toolkit=gtk3 (%%configure)
465  - added BuildRequires: gtk3-devel
466
467* Mon Sep 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-1
468- updated to 24.0.90 (24.1 pretest)
469- applied emacs-24.0.90-libs-termcap.patch
470
471* Sat Jul 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-10.20110817
472- emacs24 24.0.50 (20110817) snapshot
473- added BuildRequires: ImageMagick-devel, libSM-devel, libxml2-devel > 2.6.17
474
475* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-9.20110604
476- emacs24 24.0.50 (20110604) snapshot
477
478* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-8.20110413
479- emacs24 24.0.50 (20110413) snapshot
480
481* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-7.20110318
482- updated site-start.el
483  - defined vine-default-major-version, vine-default-minor-version,
484    vine-default-version
485  - set "ibus-el" to emacs-ime as default
486  - added ", modified for Vine Linux" to the end of emacs-build-system
487  - set "Vine _at_mark_ vinelinux.org" to report-emacs-bug-address
488
489* Sun Apr 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-6.20110318
490- fixed site-start.el
491  - do not use the macro loop (contained in the common lisp)
492
493* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-5.20110318
494- emacs24 24.0.50 (20110318) snapshot
495
496* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-4.20110222
497- emacs24 24.0.50 (20110222) snapshot
498- updated site-start.el
499  - defined the function drop-vine-default-from-load-path (regex)
500
501* Sat Jan 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-3.20110128
502- emacs24 24.0.50 (20110128) snapshot
503
504* Sun Jan 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-2.20110101
505- emacs24 24.0.50 (20110101) snapshot
506
507* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-1.20101203
508- emacs24 24.0.50 (20101203) snapshot
509- applied new vine-default system
510  - updated site-start.el
511  - updated vine-default-{base,faces}.el
512  - dropped showvdefaultemacs
513    - merged to emacsen-common package as show-vine-default.sh
514  - renamed local wide configration file to emacs24-local.el
515- updated menu-tree.el to version 0.97
516- added Provides: emacs-snapshot
517
518* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
519- updated vine-default-base.el
520  - changed the variable next-line-add-newlines to nil (default)
521
522* Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
523- updated menu-tree.el to version 0.96
524
525* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
526- applied some patches from Fedora
527  - Fixed handling of dual spacing fonts rhbz#599437
528  - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
529    under certain circumstances
530  - Added a patch fixing m17n and libotf version checking (m17ncheck)
531- updated menu-tree.el to version 0.95
532- merged emacs23-vl.spec of Vine Linux 5.1
533#* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
534#- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
535#
536#* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
537#- added Requires(post): emacsen-common, Requires(postun): emacsen-common
538#
539#* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
540#- dropped BuildRequires: m17n-lib-devel
541#- added --without-m17n-flt in %%configure
542
543* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
544- new upstream release
545- updated menu-tree.el to version 0.94
546- updated menu-tree-init.el.emacs23
547  - used prefer-coding-system
548
549* Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
550- updated to 23.1.96 (23.2 pretest)
551
552* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
553- removed /usr/share/emacs/site-lisp/subdirs.el
554
555* Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
556- updated to 23.1.95 (23.2 pretest)
557- added BuildRequires:
558  - atk-devel
559  - dbus-devel
560  - GConf2-devel
561  - alsa-lib-devel
562- added some configure options:
563  --with-libotf --with-m17n-flt --with-dbus --with-gconf
564
565* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
566- updated to 23.1.94
567
568* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
569- updated to 23.1.93 alpha
570
571* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
572- added Requires(post): emacsen-common, Requires(postun): emacsen-common
573
574* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
575- update to 23.1.92 alpha
576
577* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
578- added BuildRequires:
579  - librsvg2-devel
580  - m17n-lib-devel
581  - libotf-devel
582
583* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
584- changed License to GPLv3+
585- renamed emacs23.desktop to emacs23.desktop.in
586- updated vine-default-base.el (See [vine-users:079919])
587- fixed in upstream CVS (from Fedora)
588  - fix #543046 - Using scroll bar in emacs highlights/selects text
589  - fix #542657 - emacs does not display indic text
590  - Fixed rhbz#545398 - ETags messes up filenames
591
592* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
593- rebuilt to add signature
594
595* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
596- added BuildRequires: nkf
597- updated menu-tree-init.el.emacs23
598  - fixed menu-tree encoding <BTS:VineLinux:766>
599- set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
600
601* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
602- replaced BR: libungif-devel with BR: giflib-devel
603
604* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
605- new upstream release
606
607* Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
608- updated vine-default-faces.el to sync with emacs22
609
610* Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
611- update to 23.0.96 (20090714) snapshot
612- update vine-default-faces.el
613  - use bash to call gconftool-2
614
615* Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
616- update vine-default-faces.el
617  - added \'font in default-frame-alist
618    (if \'font is already in default-frame-alist, overwrited it)
619
620* Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
621- update vine-default-faces.el:
622  - use set-frame-font
623    bacause set-default-font function is obsolete since Emacs 23.1
624    (See M-x describe-function RET set-default-font)
625
626* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
627- update vine-default-faces.el:
628  - set desktop-gnome-interface-monospace-font-name
629    from /desktop/gnome/interface/monospace_font_name
630  - automatically set set-default-font
631    with desktop-gnome-interface-monospace-font-name
632
633* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
634- update to emacs-23.0.94 (20090527) snapshot
635- add --without-gpm to configure
636
637* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
638- defined show-vine-default function in site-start.el
639  - added showvdefaultemacs script
640
641* Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
642- set PRIORITY=40
643
644* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
645- changed menu-tree-init.el from hard copy to symbolic link
646  on /etc/emacs-23.0.92/site-start.d
647- added %%{_mandir}/*/* in %%files section
648
649* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
650- updated menu-tree.el to v0.93
651
652* Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
653- returned alternatives priority to 30
654  (emacs: 30, emacs22: 30)
655
656* Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
657- installed system-wide configure file in /etc/emacs
658- updated vine-default-base.el
659- changed alternatives priority from 30 to 50
660  (emacs: 50, emacs22: 30)
661
662* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
663- update to emacs 23.0.92 (20090422) snapshot
664- add %%triggerpostun to fix alternatives
665
666* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
667- renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
668- updated default settings for Vine Linux
669  - dropped vine-default-mouse.el, vine-default-misc.el
670
671* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
672- enable default settings for Vine Linux
673  - added site-start.el.emacs23
674  - updated site-start.el
675  - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
676    vine-default-misc.el
677
678* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
679- emacs23 23.0.91 snapshot
680
681* Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
682- drop patch10
683- s/emacsrelese/emacsrelease/
684
685* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
686- emacs23 23.0.60 snapshot
687
688* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
689- new upstream release
690
691* Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
692- import security fixes from Debian
693  CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
694  CVE-2008-1694: fix insecure temporary file creation in vcdiff script
695                 leading to possible symlink attacks
696
697* Wed Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
698- update menu-tree.el
699- add 60menu-tree-init.el to sed coding-system and load menu-tree
700- build with xorg-x11-7.3
701  - update BuildRequires
702
703* Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
704- new upstream release
705
706* Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
707- add Patch10000 to fix local variable processing security bypass
708  vulnerability.
709  - http://www.frsirt.com/english/advisories/2007/3715
710  - http://bugs.debian.org/449008
711
712* Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
713- new upstream release
714- rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
715- drop emcws support
716
717* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
718- rebuilt with new toolchain
719
720* Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
721- changed Group:
722
723* Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
724- update to CVS-20060403
725- update emacs22.desktop
726
727* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
728- fix site-start.el
729
730* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
731- update to CVS-20050927
732
733* Thu Sep  8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
734- initial build for Vine Linux based on emacs package.
735  - emacs-22.0.50 on CVS-20050907
736
737* Sat Sep  3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
738- create site-start.d directory on %install
739
740* Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
741- included leim-21.4
742- update emcws-21.3-20031213.gz
743
744* Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
745- update
746
747* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
748- rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
749
750* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
751- add Patch20 to fix display resolutions. (set to 96dpi)
752  (do not compute dynamically from display's size)
753
754* Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
755- rebuilt with new toolchain environment
756
757* Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
758- use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
759
760* Wed May  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
761- add BuildPrereq: libpng >= 1.2.5
762
763* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
764- fixed %%pre script
765
766* Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
767- new upstream release
768- remove patch14 whick included in upstream
769
770* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
771- add patch14 to fix frame title text encoding.
772  - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
773
774* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
775- autoconf-2.13, not autoconf in %%setup section
776- BuildPreReq: autoconf213
777
778* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
779- modifiy rpm scripts.
780
781* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
782- rename to emacs
783- obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
784
785* Sun Dec  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
786- enable menubar fontset patch (Patch103)
787
788* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
789- add requires/buildprereq tags.
790
791* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
792- add emcws-20021014
793
794* Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
795- removed *-mode
796
797* Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
798- python-mode was made pending
799- some additional *.el files was moved from "emacs/site-lisp" to
800  "emacs-(version)/site-lisp"
801
802* Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
803- added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
804
805* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
806- update.
807- Package Name emacs-beta -> emacs21
808- Add Patch100,101,102, Source100(default = Disable)
809- (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
810- --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
811
812* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
813- site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
814
815* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
816- move /tmp -> /var/lib/emacsen-common (IP(package)C file)
817
818* Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
819- replace patch10 with patch11, posted to gnu.emacs.bug
820  Message-Id: <jebsiza3db.fsf@sykes.suse.de>
821  (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
822
823* Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
824- fixed build to fail in alpha( only apply patch0 to ppc)
825
826* Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
827- added Patch10 (thanks Kitame-san)
828
829* Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
830- update to 21.1
831
832* Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
833- support  shared installing otheremacsen.
834
835* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
836- update 21.0.104
837
838* Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
839- support emacsen-common
840
841* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
842- 21.0.103-0vl1
843- updated to 21.0.103
844- revamped and cleaned up spec file :-)
845- Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
846
847* Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
848- fixed .spec bugs( _libdir)
849
850* Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
851- updated to 21.0.95
852
853* Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
854- fixed emacs-beta.spec
855
856* Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
857- 21.0.93 test packaging.
858
859* Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
860- added linespace-patch
861
862* Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
863- updated to emacs 20.7
864
865* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
866- updated to emacs 20.6
867
868* Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
869- [emacs-20.5a-2]
870- Modified reference of Emacs Info
871
872* Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
873- [emacs-20.5a-2]
874- added ppc patch
875
876* Fri Jan  7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
877- [emacs-20.5a-1]
878- change version from 20.5 to 20.5a
879- added Mule-4.1 patch
880
881* Fri Jan  7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
882- [emacs-20.5-1]
883- add desktop-link files for desktop menu.
884
885* Fri Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
886- [emacs-20.4-16]
887- replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
888
889* Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
890- added documents
891- strip bins
892
893* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
894- [emacs-20.4-14]
895- Change Group to Applications/Editors/Emacs
896
897* Sat Nov  6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
898- [emacs-20.4-13]
899- included Y2K savvy timezone.{el,elc},
900  modified by Mr. Youichi Teranishi <teranishi@gohome.org>
901
902* Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
903- [emacs-20.4-12]
904- Modified info-dir.
905- Removed -c option from %setup.
906
907* Mon Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
908- fixed XIM support patch
909* Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
910- fixed postinst bug and fontset patch
911* Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
912- first build
Note: See TracBrowser for help on using the repository browser.