source: projects/specs/trunk/e/emacs/emacs24-vl.spec @ 8904

Revision 8904, 29.3 KB checked in by munepi, 10 years ago (diff)

updated to 24.3.93

Line 
1%define emacsversion 24.3.93
2#% define gitdate 20110817
3%define emacsrelease 1%{?gitdate:.%gitdate}%{?_dist_release}
4%define vine_default_major_version %(echo %_dist_release|%__sed s/vl//)
5
6%define _noVersionedDependencies 1
7%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
8
9%define infodir %{_infodir}/emacs-%{emacsversion}
10
11%define menutreeelversion 0.97
12
13Summary:      GNU Emacs editor
14Summary(ja):  GNU Emacs エディタ
15Name:         emacs
16#Name:         emacs24
17#Provides:     emacs-snapshot
18Version:      %{emacsversion}
19Release:      %{emacsrelease}
20#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}.tar.xz
21#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}%{?gitdate:.git%gitdate}.tar.xz
22Source0:      ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}.tar.xz
23Source1:      emacs-snapshot.sh
24
25Source10:     site-start.el.emacs24
26
27## local settings for local system
28Source20:     emacs24-local.el
29
30# desktop file
31Source50:     emacs24.desktop.in
32
33## Enable Japanese Menu
34## http://www11.atwiki.jp/s-irie/pages/13.html
35# Source100:    menu-tree-el-%{menutreeelversion}.tar.gz
36# Source101:    menu-tree-init.el.emacs24
37Source102:    coding-system-init.el.emacs24
38
39## default settings for Vine Linux
40Source150:    vine-default-base.el
41
42## Vine Patch(es)
43Patch11:      emacs-24.3.90-locallisppath.patch
44#Patch20:      emacs-23.1.90-fixed-resolution.patch
45Patch30:      emacs-24.0.90-libs-termcap.patch
46
47# patches from Fedora
48# rhbz#713600
49Patch107: emacs-spellchecker.patch
50
51# security patches (from Debian)
52
53#Patch1001:    emacs-21.1-bzip2.patch.bz2
54
55License:      GPLv3+
56Group:        Applications/Editors/Emacs
57
58Distribution: Vine Linux
59Vendor:       Project Vine
60Packager:     munepi, daisuke
61
62BuildRoot:    %{_tmppath}/%{name}-%{version}-root
63# Requires:     tamago >= 4.0.6
64Obsoletes:    mule-base, mule-canna, mule-wnn6, mule, emacs-beta
65Obsoletes:    emacs21 <= 21.2-0vl7
66Obsoletes:    emacs22 <= 22.1
67Obsoletes:    emacs23 <= 23.1
68Obsoletes:    emacs24 <= 24.1
69#Provides:     emacs24 = %{version}
70Provides:     emacsen = 0.1
71#% prereq_ge    emacsen-common
72Requires(post):    emacsen-common
73Requires(postun):    emacsen-common
74
75BuildRequires: autoconf
76BuildRequires: xz
77BuildRequires: atk-devel
78BuildRequires: dbus-devel GConf2-devel
79BuildRequires: alsa-lib-devel
80BuildRequires: gnutls-devel
81#if %{?_dist_release} >= "vl7"
82#BuildRequires: gtk3-devel
83#else
84BuildRequires: gtk2-devel
85#endif
86BuildRequires: cairo-devel
87BuildRequires: freetype2-devel, fontconfig-devel
88BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
89BuildRequires: librsvg2-devel, libotf-devel
90BuildRequires: ImageMagick-devel
91BuildRequires: libxml2-devel > 2.6.17
92BuildRequires: m17n-lib-devel
93BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
94BuildRequires: libSM-devel, libXt-devel, libXpm-devel, ncurses-devel
95BuildRequires: xorg-x11-proto-devel, zlib-devel
96BuildRequires: texinfo
97BuildRequires: nkf
98
99%description
100GNU Emacs is the extensible, customizable, self-documenting real-time
101display editor.
102
103%description -l ja
104GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
105
106
107%prep
108
109%setup -q -n emacs-%{version}
110
111%patch11 -p1
112#%patch20 -p1
113#%patch30 -p1
114
115%patch107 -p1 -b .spellchecker
116
117#%patch1001 -p1
118
119
120# Avoid trademark issues
121grep -v "tetris.elc" lisp/Makefile.in > lisp/Makefile.in.new \
122   && %__mv lisp/Makefile.in.new lisp/Makefile.in || exit 1
123%__rm -f lisp/play/tetris.el lisp/play/tetris.elc || exit 1
124
125#autoconf
126autoreconf -i -I m4
127
128%build
129export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
130#to find installinfo
131export PATH="$PATH:/sbin:/usr/sbin"
132
133%configure --with-pop --with-sound \
134    --libexecdir=%{_libdir} --infodir=%{infodir} \
135    --disable-rename \
136    --with-x-toolkit=gtk \
137    --with-freetype --with-xft \
138    --enable-font-backend \
139    --without-gpm \
140    --with-libotf \
141    --with-m17n-flt \
142    --with-dbus --with-gconf \
143    ;
144#    --with-x-toolkit=gtk3 \
145
146%__make bootstrap
147%__make %{?_smp_mflags}
148
149
150%install
151[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
152
153%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
154        infodir=${RPM_BUILD_ROOT}%{infodir}
155
156## This is a duplicate of the file in FLAVOR/site-lisp
157%__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
158
159# (cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
160# (cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
161
162%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
163%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
164# %__tar zxvf %{SOURCE100}
165# %__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
166# nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
167
168## vine default
169%__cp -a %{SOURCE150} \
170    $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
171
172# The elisp reference manual
173#bzcat %{SOURCE13} | tar xf -
174#pushd elisp-manual-21-2.8
175#install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
176#popd
177
178# some modifications of installed files
179
180#rm -f $RPM_BUILD_ROOT%{infodir}/dir
181#gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
182
183%__install -m 644 %{SOURCE10} \
184        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
185%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
186          -e 's/VINE_DEFAULT_MAJOR_VERSION/%{vine_default_major_version}/g' \
187        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
188
189## create site-start.d directory
190%__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
191
192# install coding-system init.el
193# %__install -m644 %{SOURCE101} \
194#     $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
195# %__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
196#     ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
197%__install -m644 %{SOURCE102} \
198    $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el
199%__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el \
200    ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60coding-system-init.el
201
202## install system-wide configure file
203%__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
204%__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
205%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
206    ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
207
208## Python mode, php mode and rpm-spec mode
209
210## make file list
211strip $RPM_BUILD_ROOT%{_bindir}/* || :
212
213# install desktop file
214%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
215%__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
216    $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
217[ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
218    %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
219
220# install icons
221%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
222%__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
223
224## remove man files
225%__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
226
227## Remove ctags
228#rm -f $RPM_BUILD_ROOT/usr/bin/ctags
229#rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
230#rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
231
232DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
233     ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
234BIN=${RPM_BUILD_ROOT}%{_bindir}
235LIB=${RPM_BUILD_ROOT}%{_libdir}
236EL="*.el"
237
238## prepare file list for emacs
239echo "/usr/bin/ctags
240/usr/bin/ebrowse
241/usr/bin/etags
242/usr/bin/rcs-checkin
243/usr/bin/emacs
244/usr/bin/emacsclient
245/usr/bin/grep-changelog
246/usr/share/icons/hicolor/scalable/apps/emacs.svg
247/usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg" |
248    %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
249    awk '{system($_)}'
250
251find $DIR $BIN $LIB -type d |
252  %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
253
254find $DIR $BIN $LIB -type f -o -type l |
255  %__sed -e "
256    s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
257    s#^${RPM_BUILD_ROOT}##
258  " >> rpm-files
259
260
261%clean
262[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
263
264
265%define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
266
267
268%pre
269
270if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
271    %__rm -f %{_datadir}/emacs-%{version}/site-lisp
272fi
273
274if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
275    find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
276        xargs %__rm -rf
277fi
278
279
280%post
281touch --no-create %{_datadir}/icons/hicolor
282if [ -x %{_bindir}/gtk-update-icon-cache ]; then
283   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
284fi
285%{_bindir}/update-desktop-database %{_datadir}/applications &>/dev/null ||:
286
287if [ "$1" = 1 ]; then
288
289%_addflavorslist emacs-%{version}
290
291export PRIORITY=50
292
293%_installemacs emacs-%{version}
294
295unset PRIORITY
296fi
297
298if [ "$1" = 2 ]; then
299
300#  export PRIORITY=50
301 
302#  %_installemacs emacs-%{version}
303 
304#  unset PRIORITY
305   
306  echo emacs-%{version} >  /var/lib/emacsen-common/doinstaflavor-emacs
307   
308fi
309
310
311%postun
312%{_bindir}/update-desktop-database %{_datadir}/applications &>/dev/null ||:
313touch --no-create %{_datadir}/icons/hicolor
314if [ -x %{_bindir}/gtk-update-icon-cache ]; then
315  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
316fi
317
318if [ $1 = 1 ]; then
319# run upgrade install time
320
321# old version uninstall
322
323%_removeflavorslist emacs-%{version}
324
325%_removeemacs emacs-%{version}
326
327#new version install
328if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
329
330NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
331
332%_addflavorslist $NEWFLAVOR
333
334export PRIORITY=50
335
336%_installemacs $NEWFLAVOR
337
338unset PRIORITY
339
340%__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
341
342fi
343
344fi
345
346
347%preun
348if [ $1 = 0 ]; then
349
350%_removeflavorslist emacs-%{version}
351
352%_removeemacs emacs-%{version}
353
354fi
355
356
357%triggerpostun -- emacs23 < %{version}-%{release}
358
359%_addflavorslist emacs-%{version}
360
361export PRIORITY=50
362
363%_installemacs emacs-%{version}
364
365unset PRIORITY
366
367
368%files -f rpm-files
369%defattr(-,root,root)
370%doc INSTALL README BUGS ChangeLog COPYING
371#%doc INSTALL.BZR
372%dir %{_sysconfdir}/emacs-%{version}
373%dir %{_sysconfdir}/emacs-%{version}/site-start.d
374%{_sysconfdir}/emacs-%{version}/site-start.d/*.el
375%config(noreplace) %{_sysconfdir}/emacs/emacs24-local.el
376%{_infodir}/*
377# %{_mandir}/*/*
378%{_datadir}/applications/emacs24.desktop
379%{_datadir}/icons/hicolor/*
380# %{_datadir}/emacs-%{version}/site-lisp
381%dir %{_localstatedir}/games/emacs
382%{_localstatedir}/games/emacs/*
383
384
385%changelog
386* Fri Aug 15 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.93-1
387- updated to 24.3.93
388
389* Sun Jul  6 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.92-1
390- updated to 24.3.92
391
392* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.3.91-2
393- rebuild with ImageMagick-6.8.9.5
394
395* Mon May 12 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.91-1
396- updated to 24.3.91
397
398* Sun Apr 27 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.90-1
399- updated to 24.3.90
400
401* Tue Feb 25 2014 NAKAMURA Kenta <kenta@vinelinux.org> 24.3-5
402- rebuilt with gnutls-3.2
403
404* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-4
405- rebuilt
406
407* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.3-3
408- rebuild with ImageMagick-6.8.6.8
409
410* Sat May 11 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-2
411- dropped some obsolete patches
412- disable menu-tree-el
413  - added coding-system-init.el instead of menu-tree-init.el
414
415* Sat Mar 30 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-1
416- new upstream release
417
418* Thu Feb  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.93-1
419- updated to 24.2.93 (24.3 pretest)
420
421* Mon Jan 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.92-1
422- updated to 24.2.92 (24.3 pretest)
423
424* Sun Nov 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.90-1
425- updated to 24.2.90 (24.3 pretest)
426
427* Mon Aug 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2-1
428- new upstream release
429
430* Sun Jun 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.1-1
431- new upstream release
432
433* Sat May 19 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.97-1
434- updated to 24.0.97 (24.1 pretest)
435
436* Sun Apr 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.96-1
437- updated to 24.0.96 (24.1 pretest)
438
439* Mon Apr  2 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.95-1
440- updated to 24.0.95 (24.1 pretest)
441
442* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.0.94-2
443- rebuild with ImageMagick-6.7.5.10
444
445* Mon Feb 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.94-1
446- updated to 24.0.94 (24.1 pretest)
447
448* Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-2
449- use gtk as X toolkit (for vl6)
450
451* Mon Jan 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-1
452- updated to 24.0.93 (24.1 pretest)
453
454* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.92-1
455- updated to 24.0.92 (24.1 pretest)
456
457* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.91-1
458- updated to 24.0.91 (24.1 pretest)
459
460* Thu Oct  6 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-2
461- set --with-x-toolkit=gtk3 (%%configure)
462  - added BuildRequires: gtk3-devel
463
464* Mon Sep 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-1
465- updated to 24.0.90 (24.1 pretest)
466- applied emacs-24.0.90-libs-termcap.patch
467
468* Sat Jul 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-10.20110817
469- emacs24 24.0.50 (20110817) snapshot
470- added BuildRequires: ImageMagick-devel, libSM-devel, libxml2-devel > 2.6.17
471
472* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-9.20110604
473- emacs24 24.0.50 (20110604) snapshot
474
475* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-8.20110413
476- emacs24 24.0.50 (20110413) snapshot
477
478* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-7.20110318
479- updated site-start.el
480  - defined vine-default-major-version, vine-default-minor-version,
481    vine-default-version
482  - set "ibus-el" to emacs-ime as default
483  - added ", modified for Vine Linux" to the end of emacs-build-system
484  - set "Vine _at_mark_ vinelinux.org" to report-emacs-bug-address
485
486* Sun Apr 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-6.20110318
487- fixed site-start.el
488  - do not use the macro loop (contained in the common lisp)
489
490* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-5.20110318
491- emacs24 24.0.50 (20110318) snapshot
492
493* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-4.20110222
494- emacs24 24.0.50 (20110222) snapshot
495- updated site-start.el
496  - defined the function drop-vine-default-from-load-path (regex)
497
498* Sat Jan 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-3.20110128
499- emacs24 24.0.50 (20110128) snapshot
500
501* Sun Jan 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-2.20110101
502- emacs24 24.0.50 (20110101) snapshot
503
504* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-1.20101203
505- emacs24 24.0.50 (20101203) snapshot
506- applied new vine-default system
507  - updated site-start.el
508  - updated vine-default-{base,faces}.el
509  - dropped showvdefaultemacs
510    - merged to emacsen-common package as show-vine-default.sh
511  - renamed local wide configration file to emacs24-local.el
512- updated menu-tree.el to version 0.97
513- added Provides: emacs-snapshot
514
515* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
516- updated vine-default-base.el
517  - changed the variable next-line-add-newlines to nil (default)
518
519* Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
520- updated menu-tree.el to version 0.96
521
522* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
523- applied some patches from Fedora
524  - Fixed handling of dual spacing fonts rhbz#599437
525  - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
526    under certain circumstances
527  - Added a patch fixing m17n and libotf version checking (m17ncheck)
528- updated menu-tree.el to version 0.95
529- merged emacs23-vl.spec of Vine Linux 5.1
530#* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
531#- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
532#
533#* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
534#- added Requires(post): emacsen-common, Requires(postun): emacsen-common
535#
536#* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
537#- dropped BuildRequires: m17n-lib-devel
538#- added --without-m17n-flt in %%configure
539
540* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
541- new upstream release
542- updated menu-tree.el to version 0.94
543- updated menu-tree-init.el.emacs23
544  - used prefer-coding-system
545
546* Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
547- updated to 23.1.96 (23.2 pretest)
548
549* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
550- removed /usr/share/emacs/site-lisp/subdirs.el
551
552* Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
553- updated to 23.1.95 (23.2 pretest)
554- added BuildRequires:
555  - atk-devel
556  - dbus-devel
557  - GConf2-devel
558  - alsa-lib-devel
559- added some configure options:
560  --with-libotf --with-m17n-flt --with-dbus --with-gconf
561
562* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
563- updated to 23.1.94
564
565* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
566- updated to 23.1.93 alpha
567
568* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
569- added Requires(post): emacsen-common, Requires(postun): emacsen-common
570
571* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
572- update to 23.1.92 alpha
573
574* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
575- added BuildRequires:
576  - librsvg2-devel
577  - m17n-lib-devel
578  - libotf-devel
579
580* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
581- changed License to GPLv3+
582- renamed emacs23.desktop to emacs23.desktop.in
583- updated vine-default-base.el (See [vine-users:079919])
584- fixed in upstream CVS (from Fedora)
585  - fix #543046 - Using scroll bar in emacs highlights/selects text
586  - fix #542657 - emacs does not display indic text
587  - Fixed rhbz#545398 - ETags messes up filenames
588
589* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
590- rebuilt to add signature
591
592* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
593- added BuildRequires: nkf
594- updated menu-tree-init.el.emacs23
595  - fixed menu-tree encoding <BTS:VineLinux:766>
596- set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
597
598* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
599- replaced BR: libungif-devel with BR: giflib-devel
600
601* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
602- new upstream release
603
604* Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
605- updated vine-default-faces.el to sync with emacs22
606
607* Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
608- update to 23.0.96 (20090714) snapshot
609- update vine-default-faces.el
610  - use bash to call gconftool-2
611
612* Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
613- update vine-default-faces.el
614  - added \'font in default-frame-alist
615    (if \'font is already in default-frame-alist, overwrited it)
616
617* Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
618- update vine-default-faces.el:
619  - use set-frame-font
620    bacause set-default-font function is obsolete since Emacs 23.1
621    (See M-x describe-function RET set-default-font)
622
623* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
624- update vine-default-faces.el:
625  - set desktop-gnome-interface-monospace-font-name
626    from /desktop/gnome/interface/monospace_font_name
627  - automatically set set-default-font
628    with desktop-gnome-interface-monospace-font-name
629
630* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
631- update to emacs-23.0.94 (20090527) snapshot
632- add --without-gpm to configure
633
634* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
635- defined show-vine-default function in site-start.el
636  - added showvdefaultemacs script
637
638* Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
639- set PRIORITY=40
640
641* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
642- changed menu-tree-init.el from hard copy to symbolic link
643  on /etc/emacs-23.0.92/site-start.d
644- added %%{_mandir}/*/* in %%files section
645
646* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
647- updated menu-tree.el to v0.93
648
649* Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
650- returned alternatives priority to 30
651  (emacs: 30, emacs22: 30)
652
653* Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
654- installed system-wide configure file in /etc/emacs
655- updated vine-default-base.el
656- changed alternatives priority from 30 to 50
657  (emacs: 50, emacs22: 30)
658
659* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
660- update to emacs 23.0.92 (20090422) snapshot
661- add %%triggerpostun to fix alternatives
662
663* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
664- renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
665- updated default settings for Vine Linux
666  - dropped vine-default-mouse.el, vine-default-misc.el
667
668* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
669- enable default settings for Vine Linux
670  - added site-start.el.emacs23
671  - updated site-start.el
672  - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
673    vine-default-misc.el
674
675* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
676- emacs23 23.0.91 snapshot
677
678* Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
679- drop patch10
680- s/emacsrelese/emacsrelease/
681
682* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
683- emacs23 23.0.60 snapshot
684
685* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
686- new upstream release
687
688* Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
689- import security fixes from Debian
690  CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
691  CVE-2008-1694: fix insecure temporary file creation in vcdiff script
692                 leading to possible symlink attacks
693
694* Wed Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
695- update menu-tree.el
696- add 60menu-tree-init.el to sed coding-system and load menu-tree
697- build with xorg-x11-7.3
698  - update BuildRequires
699
700* Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
701- new upstream release
702
703* Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
704- add Patch10000 to fix local variable processing security bypass
705  vulnerability.
706  - http://www.frsirt.com/english/advisories/2007/3715
707  - http://bugs.debian.org/449008
708
709* Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
710- new upstream release
711- rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
712- drop emcws support
713
714* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
715- rebuilt with new toolchain
716
717* Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
718- changed Group:
719
720* Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
721- update to CVS-20060403
722- update emacs22.desktop
723
724* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
725- fix site-start.el
726
727* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
728- update to CVS-20050927
729
730* Thu Sep  8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
731- initial build for Vine Linux based on emacs package.
732  - emacs-22.0.50 on CVS-20050907
733
734* Sat Sep  3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
735- create site-start.d directory on %install
736
737* Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
738- included leim-21.4
739- update emcws-21.3-20031213.gz
740
741* Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
742- update
743
744* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
745- rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
746
747* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
748- add Patch20 to fix display resolutions. (set to 96dpi)
749  (do not compute dynamically from display's size)
750
751* Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
752- rebuilt with new toolchain environment
753
754* Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
755- use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
756
757* Wed May  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
758- add BuildPrereq: libpng >= 1.2.5
759
760* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
761- fixed %%pre script
762
763* Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
764- new upstream release
765- remove patch14 whick included in upstream
766
767* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
768- add patch14 to fix frame title text encoding.
769  - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
770
771* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
772- autoconf-2.13, not autoconf in %%setup section
773- BuildPreReq: autoconf213
774
775* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
776- modifiy rpm scripts.
777
778* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
779- rename to emacs
780- obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
781
782* Sun Dec  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
783- enable menubar fontset patch (Patch103)
784
785* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
786- add requires/buildprereq tags.
787
788* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
789- add emcws-20021014
790
791* Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
792- removed *-mode
793
794* Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
795- python-mode was made pending
796- some additional *.el files was moved from "emacs/site-lisp" to
797  "emacs-(version)/site-lisp"
798
799* Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
800- added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
801
802* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
803- update.
804- Package Name emacs-beta -> emacs21
805- Add Patch100,101,102, Source100(default = Disable)
806- (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
807- --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
808
809* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
810- site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
811
812* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
813- move /tmp -> /var/lib/emacsen-common (IP(package)C file)
814
815* Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
816- replace patch10 with patch11, posted to gnu.emacs.bug
817  Message-Id: <jebsiza3db.fsf@sykes.suse.de>
818  (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
819
820* Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
821- fixed build to fail in alpha( only apply patch0 to ppc)
822
823* Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
824- added Patch10 (thanks Kitame-san)
825
826* Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
827- update to 21.1
828
829* Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
830- support  shared installing otheremacsen.
831
832* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
833- update 21.0.104
834
835* Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
836- support emacsen-common
837
838* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
839- 21.0.103-0vl1
840- updated to 21.0.103
841- revamped and cleaned up spec file :-)
842- Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
843
844* Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
845- fixed .spec bugs( _libdir)
846
847* Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
848- updated to 21.0.95
849
850* Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
851- fixed emacs-beta.spec
852
853* Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
854- 21.0.93 test packaging.
855
856* Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
857- added linespace-patch
858
859* Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
860- updated to emacs 20.7
861
862* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
863- updated to emacs 20.6
864
865* Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
866- [emacs-20.5a-2]
867- Modified reference of Emacs Info
868
869* Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
870- [emacs-20.5a-2]
871- added ppc patch
872
873* Fri Jan  7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
874- [emacs-20.5a-1]
875- change version from 20.5 to 20.5a
876- added Mule-4.1 patch
877
878* Fri Jan  7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
879- [emacs-20.5-1]
880- add desktop-link files for desktop menu.
881
882* Fri Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
883- [emacs-20.4-16]
884- replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
885
886* Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
887- added documents
888- strip bins
889
890* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
891- [emacs-20.4-14]
892- Change Group to Applications/Editors/Emacs
893
894* Sat Nov  6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
895- [emacs-20.4-13]
896- included Y2K savvy timezone.{el,elc},
897  modified by Mr. Youichi Teranishi <teranishi@gohome.org>
898
899* Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
900- [emacs-20.4-12]
901- Modified info-dir.
902- Removed -c option from %setup.
903
904* Mon Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
905- fixed XIM support patch
906* Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
907- fixed postinst bug and fontset patch
908* Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
909- first build
Note: See TracBrowser for help on using the repository browser.