source: projects/specs/trunk/e/elogind/elogind-vl.spec @ 12012

Revision 12012, 4.8 KB checked in by tomop, 5 years ago (diff)

elogind-239.3-3

Line 
1%define pkg_version 239.3
2%define pkg_release 3%{?_dist_release}
3
4%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
5
6Name:         elogind
7Summary:      The systemd project's "logind", extracted to a standalone package
8Summary(ja):  systemdプロジェクトのlogindを単独で動作するようにしたソフトウェア
9Version:      %{pkg_version}
10Release:      %{pkg_release}
11License:      GPL2/LGPL2.1
12Group:        System Environment/Base
13URL:          https://wiki.gentoo.org/wiki/Elogind
14Vendor:       Project Vine
15Distribution: Vine Linux
16Packager:     tomop
17
18Source0:     https://github.com/elogind/elogind/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
19
20# derives from
21# https://github.com/systemd/systemd/commit/2675747f3cdd6f1e6236bbb2f79abfa53fb307f1
22Patch0:      pam_elogind-reduce-log.patch
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25
26Requires: util-linux
27Requires: polkit
28Requires: dbus
29Requires: elogind-libs = %{version}-%{release}
30
31BuildRequires: meson
32BuildRequires: ninja
33BuildRequires: gperf
34BuildRequires: libacl-devel
35BuildRequires: libblkid-devel
36BuildRequires: libcap-devel
37BuildRequires: libmount-devel
38BuildRequires: eudev-libudev-devel
39BuildRequires: pam-devel
40BuildRequires: pkgconfig
41BuildRequires: python3-devel
42BuildRequires: libxslt
43BuildRequires: docbook-style-xsl
44
45%description
46elogind is the systemd project's logind, extracted to a standalone package. It's designed for users who prefer a non-systemd init system, but still want to use popular software such as KDE/Wayland or GNOME that otherwise hard-depends on systemd.
47
48%description -l ja
49 eloginは、systemdプロジェクトのlogindを単体で抽出したものです。これは
50systemdを利用していないシステム上で、KDE、Wayland、GNOMEのようにsystemd
51に強く依存しているソフトウェアを使用したいユーザのために設計されています。
52
53%package libs
54Summary:     shared libraries for elogind
55Summary(ja): eloginのための共有ライブラリファイル
56Group:       System Environment/Libraries
57
58%description libs
59 This package contains shared libraries for elogind
60
61%description libs -l ja
62 このパッケージにはeloginを用いた開発のための共有ライブラリファイル
63が含まれています。
64
65%package devel
66Summary:     headers and libraries for elogind
67Summary(ja): eloginを用いた開発のためのヘッダ・ライブラリファイル
68Group:       Development/Libraries
69Requires:    elogind-libs = %{version}-%{release}
70
71%description devel
72 This package contains headers and libraries for elogind
73
74%description devel -l ja
75 このパッケージにはeloginを用いた開発のためのヘッダ・ライブラリファイル
76が含まれています。
77
78%package -n compat32-elogind-libs
79Summary:     shared libraries for elogind
80Summary(ja): eloginのための共有ライブラリファイル
81Group:       System Environment/Libraries
82
83%description -n compat32-elogind-libs
84 This package contains shared libraries for elogind
85
86%description -n compat32-elogind-libs -l ja
87 このパッケージにはeloginを用いた開発のための共有ライブラリファイル
88が含まれています。
89
90
91%prep
92%autosetup -p1
93
94
95%build
96export LANG=ja_JP.UTF-8
97%meson
98%meson_build
99
100%install
101export LANG=ja_JP.UTF-8
102%{__rm} -rf %{buildroot}
103%meson_install
104
105
106rm -f %{buildroot}/%{_lib}/libelogind.so
107ln -s ../../%{_lib}/libelogind.so.0 %{buildroot}%{_libdir}/libelogind.so
108perl -pi -e 's|^libdir=.*$|libdir=%{_libdir}|' %{buildroot}%{_libdir}/pkgconfig/libelogind.pc
109
110rm -rf %{buildroot}%{_datadir}/factory
111
112%find_lang %{name}
113
114%check
115export LANG=ja_JP.UTF-8
116%meson_test
117
118%clean
119%{__rm} -rf %{buildroot}
120
121
122%post
123/sbin/ldconfig
124
125%postun
126/sbin/ldconfig
127
128%files -f %{name}.lang
129%defattr(-,root,root)
130%license LICENSE*
131%doc NEWS README
132%config(noreplace) %{_sysconfdir}/elogind/logind.conf
133%config(noreplace) %{_sysconfdir}/pam.d/elogind-user
134/bin/*
135%{_bindir}/*
136/lib/elogind
137/lib/udev/rules.d/*
138/%{_lib}/security/*
139%{_datadir}/dbus-1/system-services/*
140%{_datadir}/dbus-1/system.d/*
141%{_datadir}/polkit-1/actions/*
142%dir %{_datadir}/zsh
143%{_datadir}/zsh/site-functions/*
144%dir %{_datadir}/bash-completion
145%dir %{_datadir}/bash-completion/completions
146%{_datadir}/bash-completion/completions/*
147%{_mandir}/man1/*
148%{_mandir}/man5/*
149%{_mandir}/man7/*
150%{_mandir}/man8/*
151
152%files libs
153/%{_lib}/*.so.*
154
155%files devel
156%defattr(-,root,root)
157%{_libdir}/libelogind.so
158%{_includedir}/elogind
159%{_libdir}/pkgconfig/libelogind.pc
160%{_mandir}/man3/*
161
162%if %{build_compat32}
163%files -n compat32-elogind-libs
164/%{_lib}/*.so.*
165%endif
166
167
168%changelog
169* Sun Jan 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-3
170- added compat32-elogind-libs.
171
172* Wed Jan 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-2
173- separated libs.
174- built manuals.
175
176* Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-1
177- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.