source: projects/specs/trunk/e/elogind/elogind-vl.spec @ 12005

Revision 12005, 4.1 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define pkg_version 239.3
2%define pkg_release 2%{?_dist_release}
3
4Name:         elogind
5Summary:      The systemd project's "logind", extracted to a standalone package
6Summary(ja):  systemdプロジェクトのlogindを単独で動作するようにしたソフトウェア
7Version:      %{pkg_version}
8Release:      %{pkg_release}
9License:      GPL2/LGPL2.1
10Group:        System Environment/Base
11URL:          https://wiki.gentoo.org/wiki/Elogind
12Vendor:       Project Vine
13Distribution: Vine Linux
14Packager:     tomop
15
16Source0:     https://github.com/elogind/elogind/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
17
18# derives from
19# https://github.com/systemd/systemd/commit/2675747f3cdd6f1e6236bbb2f79abfa53fb307f1
20Patch0:      pam_elogind-reduce-log.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24Requires: util-linux
25Requires: polkit
26Requires: dbus
27Requires: elogind-libs = %{version}-%{release}
28
29BuildRequires: meson
30BuildRequires: ninja
31BuildRequires: gperf
32BuildRequires: libacl-devel
33BuildRequires: libblkid-devel
34BuildRequires: libcap-devel
35BuildRequires: libmount-devel
36BuildRequires: eudev-libudev-devel
37BuildRequires: pam-devel
38BuildRequires: pkgconfig
39BuildRequires: python3-devel
40BuildRequires: libxslt
41BuildRequires: docbook-style-xsl
42
43%description
44elogind is the systemd project's logind, extracted to a standalone package. It's designed for users who prefer a non-systemd init system, but still want to use popular software such as KDE/Wayland or GNOME that otherwise hard-depends on systemd.
45
46%description -l ja
47 eloginは、systemdプロジェクトのlogindを単体で抽出したものです。これは
48systemdを利用していないシステム上で、KDE、Wayland、GNOMEのようにsystemd
49に強く依存しているソフトウェアを使用したいユーザのために設計されています。
50
51%package libs
52Summary:     shared libraries for elogind
53Summary(ja): eloginのための共有ライブラリファイル
54Group:       Development/Libraries
55
56%description libs
57 This package contains shared libraries for elogind
58
59%description libs -l ja
60 このパッケージにはeloginを用いた開発のための共有ライブラリファイル
61が含まれています。
62
63%package devel
64Summary:     headers and libraries for elogind
65Summary(ja): eloginを用いた開発のためのヘッダ・ライブラリファイル
66Group:       Development/Libraries
67Requires:    elogind-libs = %{version}-%{release}
68
69%description devel
70 This package contains headers and libraries for elogind
71
72%description devel -l ja
73 このパッケージにはeloginを用いた開発のためのヘッダ・ライブラリファイル
74が含まれています。
75
76%prep
77%autosetup -p1
78
79
80%build
81export LANG=ja_JP.UTF-8
82%meson
83%meson_build
84
85%install
86export LANG=ja_JP.UTF-8
87%{__rm} -rf %{buildroot}
88%meson_install
89
90
91rm -f %{buildroot}/%{_lib}/libelogind.so
92ln -s ../../%{_lib}/libelogind.so.0 %{buildroot}%{_libdir}/libelogind.so
93perl -pi -e 's|^libdir=.*$|libdir=%{_libdir}|' %{buildroot}%{_libdir}/pkgconfig/libelogind.pc
94
95rm -rf %{buildroot}%{_datadir}/factory
96
97%find_lang %{name}
98
99%check
100export LANG=ja_JP.UTF-8
101%meson_test
102
103%clean
104%{__rm} -rf %{buildroot}
105
106
107%post
108/sbin/ldconfig
109
110%postun
111/sbin/ldconfig
112
113%files -f %{name}.lang
114%defattr(-,root,root)
115%license LICENSE*
116%doc NEWS README
117%config(noreplace) %{_sysconfdir}/elogind/logind.conf
118%config(noreplace) %{_sysconfdir}/pam.d/elogind-user
119/bin/*
120%{_bindir}/*
121/lib/elogind
122/lib/udev/rules.d/*
123/%{_lib}/security/*
124%{_datadir}/dbus-1/system-services/*
125%{_datadir}/dbus-1/system.d/*
126%{_datadir}/polkit-1/actions/*
127%dir %{_datadir}/zsh
128%{_datadir}/zsh/site-functions/*
129%dir %{_datadir}/bash-completion
130%dir %{_datadir}/bash-completion/completions
131%{_datadir}/bash-completion/completions/*
132%{_mandir}/man1/*
133%{_mandir}/man5/*
134%{_mandir}/man7/*
135%{_mandir}/man8/*
136
137%files libs
138/%{_lib}/*.so.*
139
140%files devel
141%defattr(-,root,root)
142%{_libdir}/libelogind.so
143%{_includedir}/elogind
144%{_libdir}/pkgconfig/libelogind.pc
145%{_mandir}/man3/*
146
147%changelog
148* Wed Jan 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-2
149- separated libs.
150- built manuals.
151
152* Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-1
153- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.