source: projects/specs/trunk/e/elfutils/elfutils-vl.spec @ 11177

Revision 11177, 26.6 KB checked in by tomop, 7 years ago (diff)

elfutils-0.170-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define eu_version 0.170
4%define eu_release 1
5
6%global nocheck true
7
8Summary: A collection of utilities and DSOs to handle compiled objects
9Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
10Name: elfutils
11Version: %{eu_version}
12Release: %{eu_release}%{?_dist_release}
13
14License: GPLv3+ and (GPLv2+ or LGPLv3+)
15Group: Development/Tools
16URL: https://sourceware.org/elfutils/
17
18Source: https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
19
20Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
21Requires: elfutils-libs-%{_arch} = %{version}-%{release}
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
24BuildRequires: bison >= 1.875
25BuildRequires: flex >= 2.5.4a
26BuildRequires: bzip2
27BuildRequires: bzip2-devel
28BuildRequires: zlib-devel
29BuildRequires: xz-devel
30BuildRequires: gettext
31BuildRequires: m4
32BuildRequires: gcc >= 3.4
33# Need <byteswap.h> that gives unsigned bswap_16 etc.
34BuildRequires: glibc-headers >= 2.3.4-11
35
36%define _gnu %{nil}
37%define _program_prefix eu-
38
39%description
40Elfutils is a collection of utilities, including ld (a linker),
41nm (for listing symbols from object files), size (for listing the
42section sizes of an object or archive file), strip (for discarding
43symbols), readelf (to see the raw ELF file structures), and elflint
44(to check for well-formed ELF files).
45
46
47%package libs
48Summary: Libraries to handle compiled objects
49Summary(ja): コンパイル済オブジェクトを扱うためのライブラリ
50License: GPLv2+ or LGPLv3+
51Group: System Environment/Libraries
52Provides: elfutils-libs-%{_arch} = %{version}-%{release}
53Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
54Conflicts: elfutils < %{version}-%{release}
55Conflicts: elfutils > %{version}-%{release}
56Conflicts: elfutils-devel < %{version}-%{release}
57Conflicts: elfutils-devel > %{version}-%{release}
58
59%description libs
60The elfutils-libs package contains libraries which implement DWARF, ELF,
61and machine-specific ELF handling.  These libraries are used by the programs
62in the elfutils package.  The elfutils-devel package enables building
63other programs using these libraries.
64
65
66%package devel
67Summary: Development libraries to handle compiled objects
68Summary(ja): コンパイル済オブジェクトを扱うための開発用ライブラリ
69License: GPLv2+ or LGPLv3+
70Group: Development/Libraries
71Provides: elfutils-devel-%{_arch} = %{version}-%{release}
72Requires: elfutils-libs-%{_arch} = %{version}-%{release}
73Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
74Conflicts: elfutils-libelf-devel < %{version}-%{release}
75Conflicts: elfutils-libelf-devel > %{version}-%{release}
76
77%description devel
78The elfutils-devel package contains the libraries to create
79applications for handling compiled objects.  libebl provides some
80higher-level ELF access functionality.  libdw provides access to
81the DWARF debugging information.  libasm provides a programmable
82assembler interface.
83
84
85%package devel-static
86Summary: Static archives to handle compiled objects
87Summary(ja): コンパイル済オブジェクトを扱うための静的ライブラリ
88License: GPLv2+ or LGPLv3+
89Group: Development/Libraries
90Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
91Requires: elfutils-devel-%{_arch} = %{version}-%{release}
92Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
93Conflicts: elfutils-libelf-devel < %{version}-%{release}
94Conflicts: elfutils-libelf-devel > %{version}-%{release}
95
96%description devel-static
97The elfutils-devel-static package contains the static archives
98with the code to handle compiled objects.
99
100
101%package libelf
102Summary: Library to read and write ELF files
103Summary(ja): ELF ファイルを読み書きするためのライブラリ
104License: GPLv2+ or LGPLv3+
105Group: System Environment/Libraries
106Provides: libelf = %{version}-%{release}
107Obsoletes: libelf <= 0.8.2-2
108Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
109Conflicts: elfutils < %{version}-%{release}
110Conflicts: elfutils > %{version}-%{release}
111Conflicts: elfutils-libs < %{version}-%{release}
112Conflicts: elfutils-libs > %{version}-%{release}
113Conflicts: elfutils-libelf-devel < %{version}-%{release}
114Conflicts: elfutils-libelf-devel > %{version}-%{release}
115
116%description libelf
117The elfutils-libelf package provides a DSO which allows reading and
118writing ELF files on a high level.  Third party programs depend on
119this package to read internals of ELF files.  The programs of the
120elfutils package use it also to generate new ELF files.
121
122
123%package libelf-devel
124Summary: Development support for libelf
125Summary(ja): libelf の開発用ライブラリ
126License: GPLv2+ or LGPLv3+
127Group: Development/Libraries
128Provides: libelf-devel = %{version}-%{release}
129Obsoletes: libelf-devel <= 0.8.2-2
130Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
131Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
132Conflicts: libelf-devel < %{version}-%{release}
133
134%description libelf-devel
135The elfutils-libelf-devel package contains the libraries to create
136applications for handling compiled objects.  libelf allows you to
137access the internals of the ELF object file format, so you can see the
138different sections of an ELF file.
139
140
141%package libelf-devel-static
142Summary: Static archive of libelf
143Summary(ja): libelf の静的ライブラリ
144License: GPLv2+ or LGPLv3+
145Group: Development/Libraries
146Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
147Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
148
149%description libelf-devel-static
150The elfutils-libelf-static package contains the static archive
151for libelf.
152
153
154# compat32
155%package -n compat32-%{name}-libelf
156Summary: Library to read and write ELF files
157Summary(ja): ELF ファイルを読み書きするためのライブラリ
158License: GPLv2+ or LGPLv3+
159Group: System Environment/Libraries
160Provides: compat32-libelf = %{version}-%{release}
161
162%description -n compat32-%{name}-libelf
163The elfutils-libelf package provides a DSO which allows reading and
164writing ELF files on a high level.  Third party programs depend on
165this package to read internals of ELF files.  The programs of the
166elfutils package use it also to generate new ELF files.
167
168%prep
169%setup -q
170
171find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
172
173
174%build
175# Remove -Wall from default flags.  The makefiles enable enough warnings
176# themselves, and they use -Werror.  Appending -Wall defeats the cases where
177# the makefiles disable some specific warnings for specific code.
178# But add -Wformat explicitly for use with -Werror=format-security which
179# doesn't work without -Wformat (enabled by -Wall).
180RPM_OPT_FLAGS="${RPM_OPT_FLAGS/-Wall/}"
181RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -Wformat"
182
183%configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
184make -s %{?_smp_mflags}
185
186
187%install
188rm -rf ${RPM_BUILD_ROOT}
189make -s install DESTDIR=${RPM_BUILD_ROOT}
190
191chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
192chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
193
194%find_lang %{name}
195
196# XXX Nuke unpackaged files
197{ cd ${RPM_BUILD_ROOT}
198  rm -f .%{_bindir}/eu-ld
199}
200
201
202
203%check
204make -s %{?_smp_mflags} check || (cat tests/test-suite.log; %{nocheck})
205
206
207%clean
208rm -rf ${RPM_BUILD_ROOT}
209
210
211%post libs -p /sbin/ldconfig
212
213%postun libs -p /sbin/ldconfig
214
215%post libelf -p /sbin/ldconfig
216
217%postun libelf -p /sbin/ldconfig
218
219%post -n compat32-%{name}-libelf -p /sbin/ldconfig
220
221%postun -n compat32-%{name}-libelf -p /sbin/ldconfig
222
223
224%files -f %{name}.lang
225%defattr(-,root,root)
226%doc README TODO
227%{_bindir}/eu-addr2line
228%{_bindir}/eu-ar
229%{_bindir}/eu-elfcmp
230%{_bindir}/eu-elflint
231%{_bindir}/eu-findtextrel
232%{_bindir}/eu-nm
233%{_bindir}/eu-objdump
234%{_bindir}/eu-ranlib
235%{_bindir}/eu-readelf
236%{_bindir}/eu-size
237%{_bindir}/eu-stack
238%{_bindir}/eu-strings
239%{_bindir}/eu-strip
240#%{_bindir}/eu-ld
241%{_bindir}/eu-unstrip
242%{_bindir}/eu-make-debug-archive
243%{_bindir}/eu-elfcompress
244
245%files libs
246%defattr(-,root,root)
247%{_libdir}/libasm-%{version}.so
248%{_libdir}/libasm.so.*
249%{_libdir}/libdw-%{version}.so
250%{_libdir}/libdw.so.*
251%dir %{_libdir}/elfutils
252%{_libdir}/elfutils/lib*.so
253
254
255%files devel
256%defattr(-,root,root)
257%{_includedir}/dwarf.h
258%dir %{_includedir}/elfutils
259%{_includedir}/elfutils/elf-knowledge.h
260%{_includedir}/elfutils/known-dwarf.h
261%{_includedir}/elfutils/libasm.h
262%{_includedir}/elfutils/libebl.h
263%{_includedir}/elfutils/libdw.h
264%{_includedir}/elfutils/libdwelf.h
265%{_includedir}/elfutils/libdwfl.h
266%{_includedir}/elfutils/version.h
267%{_libdir}/libebl.a
268%{_libdir}/libasm.so
269%{_libdir}/libdw.so
270%{_libdir}/pkgconfig/libdw.pc
271
272
273%files devel-static
274%defattr(-,root,root)
275%{_libdir}/libasm.a
276%{_libdir}/libdw.a
277
278
279%files libelf
280%defattr(-,root,root)
281%{_libdir}/libelf-%{version}.so
282%{_libdir}/libelf.so.*
283
284
285%files libelf-devel
286%defattr(-,root,root)
287%{_includedir}/libelf.h
288%{_includedir}/gelf.h
289%{_includedir}/nlist.h
290%{_libdir}/libelf.so
291%{_libdir}/pkgconfig/libelf.pc
292
293
294%files libelf-devel-static
295%defattr(-,root,root)
296%{_libdir}/libelf.a
297
298%if %{build_compat32}
299%files -n compat32-%{name}-libelf
300%defattr(-,root,root)
301%{_libdir}/libelf-%{version}.so
302%{_libdir}/libelf.so.*
303%endif
304
305
306%changelog
307* Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.170-1
308- updated to 0.170.
309- dropped all patches.
310
311* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-3
312- rebuild with gcc-5.4.0
313
314* Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-2
315- create compat32-elfutils-libelf subpackage
316
317* Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.161-1
318- update to 0.161
319- added Japanese summary
320
321* Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
322- update to 0.157
323
324* Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
325- add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
326
327* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
328- update to 0.152
329
330* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
331- elfutils-libs: changed Group to System Environment/Libraries
332- elfutils-libelf: changed Group to System Environment/Libraries
333- elfutils-devel: changed Group to Development/Libraries
334- elfutils-devel-static: changed Group to Development/Libraries
335- elfutils-libelf-devel: changed Group to Development/Libraries
336- elfutils-libelf-devel-static: changed Group to Development/Libraries
337
338* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
339- merged with Fedora 9 0.135-1
340
341  - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
342  - applied new versioning policy
343  - added elfutils-0.131-readelf_c.patch
344
345  - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
346  - new upstream release
347  - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
348    - remove Obsoletes: libelf, libelf-devel from elfutils
349    - add Obsoletes: libelf to elfutils-libelf
350    - add Obsoletes: libelf-devel to elfutils-libelf-devel
351
352* Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
353- Update to 0.135
354  - libdwfl: bug fixes
355  - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
356
357* Wed Apr  9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
358- Update to 0.134
359  - elflint: backend improvements for sparc, alpha (#204170)
360  - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
361- Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
362
363* Sun Mar  2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
364- Update to 0.133
365  - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
366  - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
367  - libdwfl: bug fixes and optimization in relocation handling
368  - elfcmp: bug fix for non-allocated section handling
369  - ld: implement newer features of binutils linker.
370- Install eu-objdump and libasm, now has limited disassembler support.
371
372* Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
373- Update to 0.132
374  - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
375  - eu-readelf: Fix handling of ET_REL files in archives.
376  - libcpu: Implement x86 and x86-64 disassembler.
377  - libasm: Add interface for disassembler.
378  - all programs: add debugging of branch prediction.
379  - libelf: new function elf_scnshndx.
380
381* Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
382- Update to 0.131
383  - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
384           bug fixes for oddly-formatted DWARF
385  - libdwfl: bug fixes in offline archive support, symbol table handling;
386             apply partial relocations for dwfl_module_address_section on ET_REL
387  - libebl: powerpc backend support for Altivec registers
388
389* Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
390- Fix ET_REL support.
391- Fix odd indentation in eu-readelf -x output.
392
393* Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
394- Update to 0.130
395  - eu-readelf -p option can take an argument like -x for one section
396  - eu-readelf --archive-index (or -c)
397  - eu-readelf -n improved output for core dumps
398  - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
399  - eu-elflint: ditto
400  - eu-elflint: stricter checks on debug sections
401  - eu-unstrip: new options, --list (or -n), --relocate (or -R)
402  - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
403            new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
404  - libebl: backend improvements (#324031)
405  - libdwfl: build_id support, new functions for it
406  - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
407  - libdwfl offline archive support, new script eu-make-debug-archive
408
409* Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
410- Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
411
412* Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
413- Update to 0.129
414  - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
415  - addr2line: new option --symbols (or -S)
416  - libdw: dwarf_getscopes fixes (#230235)
417  - libdwfl: dwfl_module_addrsym fixes (#249490)
418
419* Fri Jun  8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
420- Update to 0.128
421  - new program: unstrip
422  - elfcmp: new option --hash-inexact
423- Replace Conflicts: with Provides/Requires using -arch
424
425* Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
426- Update to 0.127
427  - libdw: new function dwarf_getsrcdirs
428  - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
429             dwfl_module_address_section
430
431* Mon Feb  5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
432- Update to 0.126
433  - New program eu-ar.
434  - libdw: fix missing dwarf_getelf (#227206)
435  - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
436- Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
437
438* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
439- Fix overeager warn_unused_result build failures.
440
441* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
442- Update to 0.125
443  - elflint: Compare DT_GNU_HASH tests.
444  - move archives into -static RPMs
445  - libelf, elflint: better support for core file handling
446  - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
447- Resolves: RHBZ #220817, RHBZ #213792
448
449* Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
450- eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
451- Update to 0.124
452  - libebl: fix ia64 reloc support (#206981)
453  - libebl: sparc backend support for return value location
454  - libebl, libdwfl: backend register name support extended with more info
455  - libelf, libdw: bug fixes for unaligned accesses on machines that care
456  - readelf, elflint: trivial bugs fixed
457
458* Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
459- Update to 0.123
460  - libebl: Backend build fixes, thanks to Stepan Kasal.
461  - libebl: ia64 backend support for register names, return value location
462  - libdwfl: Handle truncated linux kernel module section names.
463  - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
464  - elflint: Fix checks to permit --hash-style=gnu format.
465
466* Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
467- Fix warnings in elflint compilation.
468
469* Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
470- Update to 0.122
471  - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
472  - libebl: add function to test for relative relocation
473  - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
474  - elflint, readelf: add support for DT_GNU_HASH
475  - libelf: add elf_gnu_hash
476  - elflint, readelf: add support for 64-bit SysV-style hash tables
477  - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
478
479* Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
480- Update to 0.121
481  - libelf: bug fixes for rewriting existing files when using mmap (#187618).
482  - make all installed headers usable in C++ code (#193153).
483  - eu-readelf: better output format.
484  - eu-elflint: fix tests of dynamic section content.
485  - libdw, libdwfl: handle files without aranges info.
486
487* Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
488- rebuild to pick up -devel deps
489
490* Tue Apr  4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
491- Update to 0.120
492  - License changed to GPL, with some exceptions for using
493    the libelf, libebl, libdw, and libdwfl library interfaces.
494    Red Hat elfutils is an included package of the Open Invention Network.
495  - dwarf.h updated for DWARF 3.0 final specification.
496  - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
497  - libdwfl: New function dwfl_version; fixes for offline.
498
499* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
500- bump again for double-long bug on ppc(64)
501
502* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
503- rebuilt for new gcc4.1 snapshot and glibc changes
504
505* Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
506- update to 0.119
507
508* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
509- rebuilt
510
511* Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
512- update to 0.118
513  - elflint: more tests.
514  - libdwfl: New function dwfl_module_register_names.
515  - libebl: New backend hook for register names.
516- Make sure -fexceptions is always in CFLAGS.
517
518* Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
519- update to 0.117
520  - libdwfl: New function dwfl_module_return_value_location (#166118)
521  - libebl: Backend improvements for several CPUs
522
523* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
524- update to 0.116
525  - libdw fixes, API changes and additions
526  - libdwfl fixes (#169672)
527  - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
528
529* Fri Sep  9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
530- Update requires/conflicts for better biarch update behavior.
531
532* Mon Sep  5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
533- update to 0.115
534  - New program eu-strings.
535  - libdw: New function dwarf_getscopes_die.
536  - libelf: speed-ups of non-mmap reading.
537  - Implement --enable-gcov option for configure.
538
539* Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
540- update to 0.114
541  - new program eu-ranlib
542  - libdw: new calls for inlines
543  - libdwfl: new calls for offline modules
544
545* Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
546- update to 0.113
547  - elflint: relax a bit.  Allow version definitions for defined symbols
548    against DSO versions also for symbols in nobits sections.
549    Allow .rodata section to have STRINGS and MERGE flag set.
550  - strip: add some more compatibility with binutils.
551  - libdwfl: bug fixes.
552- Separate libdw et al into elfutils-libs subpackage.
553
554* Sat Aug  6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
555- update to 0.112
556  - elfcmp: some more relaxation.
557  - elflint: many more tests, especially regarding to symbol versioning.
558  - libelf: Add elfXX_offscn and gelf_offscn.
559  - libasm: asm_begin interface changes.
560  - libebl: Add three new interfaces to directly access machine, class,
561    and data encoding information.
562
563* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
564- update portability patch
565
566* Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
567- update to 0.111
568  - libdwfl library now merged into libdw
569
570* Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
571- update to 0.110
572
573* Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
574- update to 0.109
575  - verify that libebl modules are from the same build
576  - new eu-elflint checks on copy relocations
577  - new program eu-elfcmp
578  - new experimental libdwfl library
579
580* Thu Jun  9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
581- robustification of eu-strip and eu-readelf
582
583* Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
584- more robustification
585
586* Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
587- robustification
588
589* Mon May  9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
590- update to 0.108
591  - merge strip fixes
592  - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
593  - update elf.h from glibc
594
595* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
596- fix strip -f byte-swapping bug
597
598* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
599- update to 0.107
600  - readelf: improve DWARF output format
601  - elflint: -d option to support checking separate debuginfo files
602  - strip: fix ET_REL debuginfo files (#156341)
603
604* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
605- fix some bugs in new code, reenable make check
606
607* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
608- disable make check for most arches, for now
609
610* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
611- update to 0.106
612
613* Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
614- update to 0.104
615
616* Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
617- update to 0.103
618
619* Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
620- update to 0.101.
621- use %%configure macro to get CFLAGS etc. right
622
623* Sat Feb  5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
624- upgrade to 0.99.
625
626* Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
627- upgrade to 0.97.
628
629* Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
630- upgrade to 0.96.
631
632* Mon Jul  5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
633- rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
634  warning
635
636* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
637- rebuilt
638
639* Fri Apr  2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
640- upgrade to 0.95.
641
642* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
643- rebuilt
644
645* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
646- rebuilt
647
648* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
649- upgrade to 0.94
650
651* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
652- upgrade to 0.93
653
654* Thu Jan  8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
655- full version
656- macroized spec file for GPL or OSL builds
657- include only libelf under GPL plus wrapper scripts
658
659* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
660- macroized spec file for GPL or OSL builds
661
662* Wed Jan  7 2004 Ulrich Drepper <drepper@redhat.com>
663- split elfutils-devel into two packages.
664
665* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
666- include only libelf under GPL plus wrapper scripts
667
668* Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
669- readelf, not readline, in %%description (#111214).
670
671* Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
672- update to 0.89 (fix eu-strip)
673
674* Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
675- update to 0.86 (fix eu-strip on s390x/alpha)
676- libebl is an archive now; remove references to DSO
677
678* Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
679- upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
680
681* Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
682- upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
683
684* Wed Jul  9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
685- upgrade to 0.82 (strip tests fixed on big-endian).
686
687* Tue Jul  8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
688- upgrade to 0.81 (strip excludes unused symtable entries, test borked).
689
690* Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
691- upgrade to 0.80 (debugedit changes for kernel in progress).
692
693* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
694- rebuilt
695
696* Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
697- upgrade to 0.79 (correct formats for size_t, more of libdw "works").
698
699* Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
700- upgrade to 0.78 (libdwarf bugfix, libdw additions).
701
702* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
703- debuginfo rebuild
704
705* Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
706- use the correct way of identifying the section via the sh_info link.
707
708* Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
709- update to 0.75 (eu-strip -g fix)
710
711* Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
712- update to 0.74 (fix for writing with some non-dirty sections)
713
714* Thu Feb  6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
715- another -0.73 update (with sparc fixes).
716- do "make check" in %%check, not %%install, section.
717
718* Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
719- update to 0.73 (with s390 fixes).
720
721* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
722- rebuilt
723
724* Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
725- fix arguments to gelf_getsymshndx and elf_getshstrndx
726- fix other warnings
727- reenable checks on s390x
728
729* Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
730- temporarily disable checks on s390x, until someone has
731  time to look at it
732
733* Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
734- update to 0.72
735
736* Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
737- update to 0.71
738
739* Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
740- update to 0.69.
741- add "make check" and segfault avoidance patch.
742- elfutils-libelf needs to run ldconfig.
743
744* Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
745- update to 0.68.
746
747* Fri Dec  6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
748- update to 0.67.
749
750* Tue Dec  3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
751- update to 0.65.
752
753* Mon Dec  2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
754- update to 0.64.
755
756* Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
757- split packages further into elfutils-libelf
758
759* Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
760- update to 0.63.
761
762* Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
763- Adjust for dropping libtool
764
765* Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
766- update to 0.59
767
768* Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
769- update to 0.56
770
771* Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
772- update to 0.54
773
774* Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
775- update to 0.53
776- drop x86_64 hack, ICE fixed in gcc-3.2-11.
777
778* Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
779- get beehive to punch a rhpkg generated package.
780
781* Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
782- build in 8.0.1.
783- x86_64: avoid gcc-3.2 ICE on x86_64 for now.
784
785* Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
786- Add libelf-devel to conflicts for elfutils-devel
787
788* Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
789- Split into runtime and devel package
790
791* Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
792- integrate into official sources
793
794* Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
795- Swaddle.
Note: See TracBrowser for help on using the repository browser.