source: projects/specs/trunk/e/ekiga/ekiga-vl.spec @ 631

Revision 631, 7.3 KB checked in by Takemikaduchi, 14 years ago (diff)

takemikaduchi fix and add spec file

Line 
1Summary: A Gnome based SIP/H323 teleconferencing application
2Summary(ja): GNOME ベースの SIP/H323 遠隔会議アプリケーション
3Name: ekiga
4Version: 3.2.6
5Release: 1%{?_dist_release}
6URL: http://www.ekiga.org/
7Source0: http://www.ekiga.org/ekiga-%{version}.tar.bz2
8License: GPL
9Group: Applications/Communications
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: gtk2-devel >= 2.14.0
13BuildRequires: GConf2-devel >= 2.24.0
14BuildRequires: libgnomeui-devel >= 2.24.0
15BuildRequires: libgnome-devel >= 2.24.0
16BuildRequires: avahi-devel >= 0.6.23
17BuildRequires: avahi-glib-devel >= 0.6.23
18BuildRequires: openldap-devel
19BuildRequires: ptlib-devel >= 2.6.2
20BuildRequires: opal-devel >= 3.6.2
21BuildRequires: libxml2-devel >= 2.6.0
22BuildRequires: SDL-devel
23BuildRequires: intltool >= 0.22
24BuildRequires: pkgconfig
25BuildRequires: scrollkeeper
26BuildRequires: alsa-lib-devel
27BuildRequires: gettext
28BuildRequires: evolution-data-server-devel
29BuildRequires: gnome-doc-utils >= 0.3.2
30BuildRequires: desktop-file-utils
31BuildRequires: dbus-devel
32BuildRequires: dbus-glib-devel
33BuildRequires: libsigc++-devel
34BuildRequires: libXv-devel
35
36Requires(post): GConf2, scrollkeeper
37Requires(postun): scrollkeeper
38
39Obsoletes: gnomemeeting
40
41%description
42Ekiga is a tool to communicate with video and audio over the internet.
43It uses the standard SIP and H323 protocols.
44
45%prep
46%setup -q
47
48%build
49CXXFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED=1 -fPIC"
50%configure --disable-scrollkeeper --disable-schemas-install
51make %{?_smp_mflags}
52
53%install
54rm -rf $RPM_BUILD_ROOT
55export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
56make install DESTDIR=$RPM_BUILD_ROOT
57unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
58
59rm -rf $RPM_BUILD_ROOT/var/scrollkeeper
60
61desktop-file-install \
62    --vendor gnome \
63    --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
64    --delete-original \
65    --copy-generic-name-to-name \
66    $RPM_BUILD_ROOT%{_datadir}/applications/ekiga.desktop
67
68%find_lang %{name} --with-gnome
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%post
74export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
75gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/ekiga.schemas > /dev/null 2>&1
76gconftool-2 --shutdown
77(yes | ekiga-config-tool --install-schemas) > /dev/null 2>&1 ||:
78update-desktop-database %{_datadir}/applications >& /dev/null ||:
79scrollkeeper-update -q > /dev/null ||:
80touch --no-create %{_datadir}/icons/hicolor
81if [ -x /usr/bin/gtk-update-icon-cache ]; then
82  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
83fi
84 
85%pre
86if [ "$1" -gt 1 ]; then
87  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
88  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ekiga.schemas > /dev/null 2>&1
89fi
90
91%preun
92if [ "$1" -eq 0 ]; then
93  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
94  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ekiga.schemas > /dev/null 2>&1
95fi
96
97%postun
98update-desktop-database %{_datadir}/applications >& /dev/null ||:
99scrollkeeper-update -q > /dev/null ||:
100touch --no-create %{_datadir}/icons/hicolor
101if [ -x /usr/bin/gtk-update-icon-cache ]; then
102  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
103fi
104
105%files -f ekiga.lang
106%defattr(-,root,root)
107%doc AUTHORS COPYING ChangeLog NEWS README
108%{_sysconfdir}/gconf/schemas/ekiga.schemas
109%{_bindir}/ekiga
110%{_bindir}/ekiga-config-tool
111%{_bindir}/ekiga-helper
112%{_datadir}/applications/gnome-ekiga.desktop
113%{_datadir}/dbus-1/services/*
114%{_datadir}/pixmaps/*
115%{_datadir}/man/*/*
116%{_datadir}/sounds/ekiga
117%{_datadir}/icons/hicolor/*/apps/*
118
119%changelog
120* Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.6-1
121- new upstream release
122- add BuildRequires: libXv-devel
123
124* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
125- new upstream release
126
127* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.1-1
128- new upstream release
129
130* Sat Apr  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.2-1
131- new upstream release
132
133* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-1
134- new upstream release
135
136* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
137- new upstream release
138
139* Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.11-2vl5
140- built with gnome-2.24
141
142* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.11-1vl5
143- applied new versioning policy
144
145* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.11-0vl1
146- new upstream release
147
148* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl5
149- rebuilt with evolution-data-server-devel 1.10.1
150
151* Tue May 22 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl4
152- add BuildRequires: dbus-glib-devel
153
154* Sat May 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.9-0vl3
155- rebuilt with new toolchain
156
157* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.9-0vl2
158- rebuilt with dbus 1.0.2
159
160* Sat Apr 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.9-0vl1
161- new upstream release
162
163* Sat Feb 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.5-0vl1
164- new upstream release
165
166* Sun Feb  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.4-1vl1
167- initial built for Vine Linux
168
169* Mon Jan 22 2007 Daniel Veillard <veillard@redhat.com> - 2.0.4-1
170- Upgrade to ekiga-2.0.4
171
172* Thu Nov  2 2006 Daniel Veillard <veillard@redhat.com> - 2.0.3-3
173- Resolves: rhbz#201535
174- fixes build-requires for opal-devel and pwlib-devel
175
176* Sat Oct 28 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.3-2
177- Rebuild against evolution-data-server 1.9
178
179* Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.3-1
180- Update to 2.0.3
181
182* Sat Sep 30 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.2-7
183- Make the status icon work in transparent panels
184
185* Thu Aug 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.2-6
186- Fix translator credits (197871)
187
188* Mon Aug  7 2006 Matthew Barnes <mbarnes@redhat.com> - 2.0.2-5
189- Rebuild against evolution-data-server-1.7.91
190
191* Sat Aug  5 2006 Caolan McNamara <caolanm@redhat.com> - 2.0.2-4
192- rebuild against new e-d-s
193
194* Tue Aug  1 2006 Daniel Veillard <veillard@redhat.com> - 2.0.2-3
195- rebuilt for #200960
196
197* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.2-1.1
198- rebuild
199
200* Wed May 31 2006 Daniel Veillard <veillard@redhat.com> - 2.0.2-1
201- new release of ekiga 2.0.2
202- activating Zeroconf support though avahi
203
204* Mon May 22 2006 Jesse Keating <jkeating@redhat.com> - 2.0.1-3
205- Fix BuildRequires and Requires(post), Requires(postun)
206
207* Wed Mar 15 2006 Daniel Veillard <veillard@redhat.com> - 2.0.1-2
208- run 'ekiga-config-tool --install-schemas' in %post, c.f. #178929
209
210* Tue Mar 14 2006 Daniel Veillard <veillard@redhat.com> - 2.0.1-1
211- last minute bug rerelease 2.0.1
212
213* Mon Mar 13 2006 Daniel Veillard <veillard@redhat.com> - 2.0.0-1
214- final release of 2.0.0
215
216* Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 1.99.1-2
217- Buildrequires: gnome-doc-utils
218
219* Mon Feb 13 2006 Daniel Veillard <veillard@redhat.com> - 1.99.1-1
220- new beta release issued
221
222* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.99.0-3.2
223- bump again for double-long bug on ppc(64)
224
225* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.99.0-3.1
226- rebuilt for new gcc4.1 snapshot and glibc changes
227
228* Sat Jan 28 2006 Daniel Veillard <veillard@redhat.com> - 1.99.0-3
229- Rebuilt following a libedataserver revision
230
231* Fri Jan 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.99.0-2
232- Use the upstream .desktop file
233
234* Tue Jan 24 2006 Daniel Veillard <veillard@redhat.com> - 1.99.0-1
235- initial version based on the 1.99.0 beta and gnomemeeting spec file.
Note: See TracBrowser for help on using the repository browser.