source: projects/specs/trunk/e/ekiga/ekiga-vl.spec @ 521

Revision 521, 7.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A Gnome based SIP/H323 teleconferencing application
2Summary(ja): GNOME ベースの SIP/H323 遠隔会議アプリケーション
3Name: ekiga
4Version: 3.2.4
5Release: 1%{?_dist_release}
6URL: http://www.ekiga.org/
7Source0: http://www.ekiga.org/ekiga-%{version}.tar.bz2
8License: GPL
9Group: Applications/Communications
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: gtk2-devel >= 2.14.0
13BuildRequires: GConf2-devel >= 2.24.0
14BuildRequires: libgnomeui-devel >= 2.24.0
15BuildRequires: libgnome-devel >= 2.24.0
16BuildRequires: avahi-devel >= 0.6.23
17BuildRequires: avahi-glib-devel >= 0.6.23
18BuildRequires: openldap-devel
19BuildRequires: ptlib-devel >= 2.6.2
20BuildRequires: opal-devel >= 3.6.2
21BuildRequires: libxml2-devel >= 2.6.0
22BuildRequires: SDL-devel
23BuildRequires: intltool >= 0.22
24BuildRequires: pkgconfig
25BuildRequires: scrollkeeper
26BuildRequires: alsa-lib-devel
27BuildRequires: gettext
28BuildRequires: evolution-data-server-devel
29BuildRequires: gnome-doc-utils >= 0.3.2
30BuildRequires: desktop-file-utils
31BuildRequires: dbus-devel
32BuildRequires: dbus-glib-devel
33BuildRequires: libsigc++-devel
34
35Requires(post): GConf2, scrollkeeper
36Requires(postun): scrollkeeper
37
38Obsoletes: gnomemeeting
39
40%description
41Ekiga is a tool to communicate with video and audio over the internet.
42It uses the standard SIP and H323 protocols.
43
44%prep
45%setup -q
46
47%build
48CXXFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED=1 -fPIC"
49%configure --disable-scrollkeeper --disable-schemas-install
50make %{?_smp_mflags}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
55make install DESTDIR=$RPM_BUILD_ROOT
56unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
57
58rm -rf $RPM_BUILD_ROOT/var/scrollkeeper
59
60desktop-file-install \
61    --vendor gnome \
62    --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
63    --delete-original \
64    --copy-generic-name-to-name \
65    $RPM_BUILD_ROOT%{_datadir}/applications/ekiga.desktop
66
67%find_lang %{name} --with-gnome
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%post
73export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
74gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/ekiga.schemas > /dev/null 2>&1
75gconftool-2 --shutdown
76(yes | ekiga-config-tool --install-schemas) > /dev/null 2>&1 ||:
77update-desktop-database %{_datadir}/applications >& /dev/null ||:
78scrollkeeper-update -q > /dev/null ||:
79touch --no-create %{_datadir}/icons/hicolor
80if [ -x /usr/bin/gtk-update-icon-cache ]; then
81  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
82fi
83 
84%pre
85if [ "$1" -gt 1 ]; then
86  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
87  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ekiga.schemas > /dev/null 2>&1
88fi
89
90%preun
91if [ "$1" -eq 0 ]; then
92  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
93  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ekiga.schemas > /dev/null 2>&1
94fi
95
96%postun
97update-desktop-database %{_datadir}/applications >& /dev/null ||:
98scrollkeeper-update -q > /dev/null ||:
99touch --no-create %{_datadir}/icons/hicolor
100if [ -x /usr/bin/gtk-update-icon-cache ]; then
101  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
102fi
103
104%files -f ekiga.lang
105%defattr(-,root,root)
106%doc AUTHORS COPYING ChangeLog NEWS README
107%{_sysconfdir}/gconf/schemas/ekiga.schemas
108%{_bindir}/ekiga
109%{_bindir}/ekiga-config-tool
110%{_bindir}/ekiga-helper
111%{_datadir}/applications/gnome-ekiga.desktop
112%{_datadir}/dbus-1/services/*
113%{_datadir}/pixmaps/*
114%{_datadir}/man/*/*
115%{_datadir}/sounds/ekiga
116%{_datadir}/icons/hicolor/*/apps/*
117
118%changelog
119* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
120- new upstream release
121
122* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.1-1
123- new upstream release
124
125* Sat Apr  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.2-1
126- new upstream release
127
128* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-1
129- new upstream release
130
131* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
132- new upstream release
133
134* Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.11-2vl5
135- built with gnome-2.24
136
137* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.11-1vl5
138- applied new versioning policy
139
140* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.11-0vl1
141- new upstream release
142
143* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl5
144- rebuilt with evolution-data-server-devel 1.10.1
145
146* Tue May 22 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl4
147- add BuildRequires: dbus-glib-devel
148
149* Sat May 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.9-0vl3
150- rebuilt with new toolchain
151
152* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.9-0vl2
153- rebuilt with dbus 1.0.2
154
155* Sat Apr 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.9-0vl1
156- new upstream release
157
158* Sat Feb 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.5-0vl1
159- new upstream release
160
161* Sun Feb  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.4-1vl1
162- initial built for Vine Linux
163
164* Mon Jan 22 2007 Daniel Veillard <veillard@redhat.com> - 2.0.4-1
165- Upgrade to ekiga-2.0.4
166
167* Thu Nov  2 2006 Daniel Veillard <veillard@redhat.com> - 2.0.3-3
168- Resolves: rhbz#201535
169- fixes build-requires for opal-devel and pwlib-devel
170
171* Sat Oct 28 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.3-2
172- Rebuild against evolution-data-server 1.9
173
174* Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.3-1
175- Update to 2.0.3
176
177* Sat Sep 30 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.2-7
178- Make the status icon work in transparent panels
179
180* Thu Aug 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.2-6
181- Fix translator credits (197871)
182
183* Mon Aug  7 2006 Matthew Barnes <mbarnes@redhat.com> - 2.0.2-5
184- Rebuild against evolution-data-server-1.7.91
185
186* Sat Aug  5 2006 Caolan McNamara <caolanm@redhat.com> - 2.0.2-4
187- rebuild against new e-d-s
188
189* Tue Aug  1 2006 Daniel Veillard <veillard@redhat.com> - 2.0.2-3
190- rebuilt for #200960
191
192* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.2-1.1
193- rebuild
194
195* Wed May 31 2006 Daniel Veillard <veillard@redhat.com> - 2.0.2-1
196- new release of ekiga 2.0.2
197- activating Zeroconf support though avahi
198
199* Mon May 22 2006 Jesse Keating <jkeating@redhat.com> - 2.0.1-3
200- Fix BuildRequires and Requires(post), Requires(postun)
201
202* Wed Mar 15 2006 Daniel Veillard <veillard@redhat.com> - 2.0.1-2
203- run 'ekiga-config-tool --install-schemas' in %post, c.f. #178929
204
205* Tue Mar 14 2006 Daniel Veillard <veillard@redhat.com> - 2.0.1-1
206- last minute bug rerelease 2.0.1
207
208* Mon Mar 13 2006 Daniel Veillard <veillard@redhat.com> - 2.0.0-1
209- final release of 2.0.0
210
211* Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 1.99.1-2
212- Buildrequires: gnome-doc-utils
213
214* Mon Feb 13 2006 Daniel Veillard <veillard@redhat.com> - 1.99.1-1
215- new beta release issued
216
217* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.99.0-3.2
218- bump again for double-long bug on ppc(64)
219
220* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.99.0-3.1
221- rebuilt for new gcc4.1 snapshot and glibc changes
222
223* Sat Jan 28 2006 Daniel Veillard <veillard@redhat.com> - 1.99.0-3
224- Rebuilt following a libedataserver revision
225
226* Fri Jan 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.99.0-2
227- Use the upstream .desktop file
228
229* Tue Jan 24 2006 Daniel Veillard <veillard@redhat.com> - 1.99.0-1
230- initial version based on the 1.99.0 beta and gnomemeeting spec file.
Note: See TracBrowser for help on using the repository browser.