source: projects/specs/trunk/e/eigen3/eigen3-vl.spec @ 9372

Revision 9372, 6.4 KB checked in by inagaki, 9 years ago (diff)

2015-02-22 Ryoichi INAGAKI <ryo1@…>

  • eigen3: NEW
  • gphoto2, suiteparse: updated


Line 
1# The (empty) main package is arch, to have the package built and tests run
2# on all arches, but the actual result package is the noarch -devel subpackge.
3# Debuginfo packages are disabled to prevent rpmbuild from generating an empty
4# debuginfo package for the empty main package.
5%global debug_package %{nil}
6
7%global commit 10219c95fe65
8
9Name:           eigen3
10Version:        3.2.4
11Release:        2%{?_dist_release}
12Summary:        A lightweight C++ template library for vector and matrix math
13Summary(ja):    ベクトル及び行列演算のための軽量 C++ テンプレートライブラリ
14
15Group:          Development/Libraries
16License:        MPLv2.0 and LGPLv2+ and BSD
17URL:            http://eigen.tuxfamily.org/index.php?title=Main_Page
18# Source file is at: http://bitbucket.org/eigen/eigen/get/3.1.3.tar.bz2
19# Renamed source file so it's not just a version number
20Source0:        eigen-%{version}.tar.bz2
21
22# Fix build with recent suitesparse versions
23Patch0:         eigen-3.2.3_suitesparse.patch
24
25# Vine Patch
26Patch700:       eigen-3.2.4_BVHsegfault.patch
27
28#BuildRequires:  atlas-devel
29BuildRequires:  fftw3-devel
30BuildRequires:  glew-devel
31BuildRequires:  gmp-devel
32BuildRequires:  gsl-devel
33BuildRequires:  mpfr-devel
34#BuildRequires:  sparsehash-devel
35BuildRequires:  suitesparse-devel
36BuildRequires:  gcc-gfortran
37#BuildRequires:  SuperLU-devel
38BuildRequires:  qt4-devel
39
40BuildRequires:  cmake
41BuildRequires:  doxygen
42BuildRequires:  graphviz
43BuildRequires:  texlive-collection-latex
44#BuildRequires:  tex(latex)
45
46%description
47%{summary}.
48
49%package devel
50Summary:        A lightweight C++ template library for vector and matrix math
51Summary(ja):    ベクトル及び行列演算のための軽量 C++ テンプレートライブラリ
52Group:          Development/Libraries
53BuildArch:      noarch
54# -devel subpkg only atm, compat with other distros
55Provides:       %{name} = %{version}-%{release}
56# not *strictly* a -static pkg, but the results are the same
57Provides:       %{name}-static = %{version}-%{release}
58
59%description devel
60%{summary}.
61
62%package doc
63Summary:        Developer documentation for Eigen
64Summary(ja):    Eigen の開発用ドキュメント
65Group:          Documentation
66BuildArch:      noarch
67Requires:       %{name}-devel = %{version}-%{release}
68
69%description doc
70Developer documentation for Eigen.
71
72%prep
73%setup -q -n eigen-eigen-%{commit}
74%patch0 -p1
75
76%patch700 -p1
77
78%build
79mkdir %{_target_platform}
80pushd %{_target_platform}
81#cmake .. -DBLAS_LIBRARIES="cblas" -DSUPERLU_INCLUDES=%{_includedir}/SuperLU
82%cmake .. -DBLAS_LIBRARIES="cblas"
83popd
84make -C %{_target_platform} %{?_smp_mflags}
85make doc -C %{_target_platform} %{?_smp_mflags}
86
87rm -f %{_target_platform}/doc/html/installdox
88rm -f %{_target_platform}/doc/html/unsupported/installdox
89
90%install
91rm -rf %{buildroot}
92%make_install -C %{_target_platform}
93
94%check
95# Run tests but make failures non-fatal. Note that upstream doesn't expect the
96# tests to pass consistently since they're seeded randomly.
97make -C %{_target_platform} %{?_smp_mflags} buildtests
98make -C %{_target_platform} %{?_smp_mflags} test ARGS="-V" || exit 0
99
100%clean
101rm -rf %{buildroot}
102
103%files devel
104%doc COPYING.README COPYING.BSD COPYING.MPL2 COPYING.LGPL
105%{_includedir}/eigen3
106%{_datadir}/pkgconfig/*
107
108%files doc
109%doc %{_target_platform}/doc/html
110
111%changelog
112* Tue Feb 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 3.2.4-2
113- Initial build for Vine Linux
114
115* Thu Jan 22 2015 Sandro Mani <manisandro@gmail.com> - 3.2.4-1
116- Update to release 3.2.4
117
118* Mon Jan 05 2015 Rich Mattes <richmattes@gmail.com> - 3.2.3-2
119- Backport upstream Rotation2D fix
120
121* Thu Dec 18 2014 Sandro Mani <manisandro@gmail.com> - 3.2.3-1
122- Update to release 3.2.3
123- Drop upstreamed eigen3-ppc64.patch
124
125* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-2
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
127
128* Mon Aug 04 2014 Sandro Mani <manisandro@gmail.com> - 3.2.2-1
129- Update to release 3.2.2
130
131* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-5
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
133
134* Tue Mar 11 2014 Orion Poplawski <orion@cora.nwra.com> - 3.2.1-4
135- Add ppc64 support
136
137* Thu Feb 27 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-3
138- Make doc package noarch
139
140* Thu Feb 27 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-2
141- Split off doc to a separate package
142
143* Wed Feb 26 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-1
144- Udpate to release 3.2.1
145
146* Sun Aug 11 2013 Sandro Mani <manisandro@gmail.com> - 3.2-3
147- Build and run tests
148- Drop -DBLAS_LIBRARIES_DIR, not used
149- Add some BR to enable tests of corresponding backends
150- spec cleanup
151
152* Wed Jul 24 2013 Sandro Mani <manisandro@gmail.com> - 3.2-1
153- Update to release 3.2
154
155* Sat Jun 29 2013 Rich Mattes <richmattes@gmail.com> - 3.1.3-2
156- Add upstream patch to fix malloc/free bugs (rhbz#978971)
157
158* Fri Apr 19 2013 Sandro Mani <manisandro@gmail.com> - 3.1.3-1
159- Update to release 3.1.3
160- Add patch for unused typedefs warning with gcc4.8
161
162* Tue Mar 05 2013 Rich Mattes <richmattes@gmail.com> - 3.1.2-1
163- Update to release 3.1.2
164
165* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.6-2
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
167
168* Sat Jul 28 2012 Tim Niemueller <tim@niemueller.de> - 3.0.6-1
169- Update to release 3.0.6 (fixes GCC 4.7 warnings)
170
171* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.5-2
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
173
174* Sun Mar 11 2012 Rich Mattes <richmattes@gmail.com> - 3.0.5-1
175- Update to release 3.0.5
176
177* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.4-2
178- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
179
180* Sun Dec 18 2011 Rich Mattes <richmattes@gmail.com> - 3.0.4-1
181- Update to release 3.0.4
182
183* Tue Nov 15 2011 Rich Mattes <richmattes@gmail.com> - 3.0.3-1
184- Update to release 3.0.3
185
186* Sun Apr 17 2011 Rich Mattes <richmattes@gmail.com> - 3.0.0-2
187- Patched sources to fix build failure
188- Removed fixes made upstream
189- Added project name to source tarball filename
190
191* Sat Mar 26 2011 Rich Mattes <richmattes@gmail.com> - 3.0.0-1
192- Update to release 3.0.0
193
194* Tue Jan 25 2011 Rich Mattes <richmattes@gmail.com> - 3.0-0.2.beta2
195- Change blas-devel buildrequirement to atlas-devel
196- Don't make the built-in experimental blas library
197
198* Mon Jan 24 2011 Rich Mattes <richmattes@gmail.com> - 3.0-0.1.beta2
199- Initial package
Note: See TracBrowser for help on using the repository browser.