source: projects/specs/trunk/e/eigen3/eigen3-vl.spec @ 12418

Revision 12418, 6.3 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

eigen3-3.3.7-1

opencv-4.3.0-1

tbb-2020.2-1

Line 
1%bcond_with test
2
3# The (empty) main package is arch, to have the package built and tests run
4# on all arches, but the actual result package is the noarch -devel subpackge.
5# Debuginfo packages are disabled to prevent rpmbuild from generating an empty
6# debuginfo package for the empty main package.
7%global debug_package %{nil}
8
9%global commit 323c052e1731
10
11Name:           eigen3
12Version:        3.3.7
13Release:        1%{?_dist_release}
14Summary:        A lightweight C++ template library for vector and matrix math
15Summary(ja):    ベクトル及び行列演算のための軽量 C++ テンプレートライブラリ
16Group:          Development/Libraries
17Vendor:         Project Vine
18Distribution:   Vine Linux
19
20License:        MPLv2.0 and LGPLv2+ and BSD
21URL:            http://eigen.tuxfamily.org/index.php?title=Main_Page
22Source0:        http://bitbucket.org/eigen/eigen/get/%{version}.tar.bz2#/eigen-%{version}.tar.bz2
23
24# Install FindEigen3.cmake
25# Adapted from Debian eigen3 package
26Patch0:         01_install_FindEigen3.patch
27
28# Fix pkg-config file
29Patch1:         eigen_pkgconfig.patch
30# Fix the include paths in the new Eigen3Config.cmake file
31Patch2:         eigen3-3.3.1-fixcmake.patch
32
33#BuildRequires:  atlas-devel
34BuildRequires:  fftw3-devel
35BuildRequires:  glew-devel
36BuildRequires:  gmp-devel
37BuildRequires:  gsl-devel
38BuildRequires:  mpfr-devel
39#BuildRequires:  sparsehash-devel
40BuildRequires:  suitesparse-devel
41BuildRequires:  gcc-gfortran
42#BuildRequires:  SuperLU-devel
43BuildRequires:  qt4-devel
44
45BuildRequires:  cmake
46BuildRequires:  doxygen
47BuildRequires:  graphviz
48
49%description
50%{summary}.
51
52%package devel
53Summary:        A lightweight C++ template library for vector and matrix math
54Summary(ja):    ベクトル及び行列演算のための軽量 C++ テンプレートライブラリ
55Group:          Development/Libraries
56BuildArch:      noarch
57# -devel subpkg only atm, compat with other distros
58Provides:       %{name} = %{version}-%{release}
59# not *strictly* a -static pkg, but the results are the same
60Provides:       %{name}-static = %{version}-%{release}
61
62%description devel
63%{summary}.
64
65
66%prep
67%autosetup -p1 -n eigen-eigen-%{commit}
68
69
70%build
71mkdir %{_target_platform}
72pushd %{_target_platform}
73#cmake .. -DBLAS_LIBRARIES="cblas" -DSUPERLU_INCLUDES=%{_includedir}/SuperLU
74%cmake -DINCLUDE_INSTALL_DIR=%{_includedir}/eigen3 \
75       -DBLAS_LIBRARIES="cblas" \
76       ..
77popd
78make -C %{_target_platform} %{?_smp_mflags}
79
80rm -f %{_target_platform}/doc/html/installdox
81rm -f %{_target_platform}/doc/html/unsupported/installdox
82
83
84%install
85rm -rf %{buildroot}
86%make_install -C %{_target_platform}
87
88
89%if %{with test}
90%check
91# Run tests but make failures non-fatal. Note that upstream doesn't expect the
92# tests to pass consistently since they're seeded randomly.
93make -C %{_target_platform} %{?_smp_mflags} buildtests
94make -C %{_target_platform} %{?_smp_mflags} test ARGS="-V" || exit 0
95%endif
96
97
98%clean
99rm -rf %{buildroot}
100
101
102%files devel
103%license COPYING.README COPYING.BSD COPYING.MPL2 COPYING.LGPL
104%{_includedir}/eigen3
105%{_datadir}/%{name}
106%{_datadir}/pkgconfig/*
107%{_datadir}/cmake/Modules/*.cmake
108
109
110%changelog
111* Tue Jun 30 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.3.7-1
112- new upstream release.
113
114* Tue Feb 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 3.2.4-2
115- Initial build for Vine Linux
116
117* Thu Jan 22 2015 Sandro Mani <manisandro@gmail.com> - 3.2.4-1
118- Update to release 3.2.4
119
120* Mon Jan 05 2015 Rich Mattes <richmattes@gmail.com> - 3.2.3-2
121- Backport upstream Rotation2D fix
122
123* Thu Dec 18 2014 Sandro Mani <manisandro@gmail.com> - 3.2.3-1
124- Update to release 3.2.3
125- Drop upstreamed eigen3-ppc64.patch
126
127* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-2
128- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
129
130* Mon Aug 04 2014 Sandro Mani <manisandro@gmail.com> - 3.2.2-1
131- Update to release 3.2.2
132
133* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-5
134- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
135
136* Tue Mar 11 2014 Orion Poplawski <orion@cora.nwra.com> - 3.2.1-4
137- Add ppc64 support
138
139* Thu Feb 27 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-3
140- Make doc package noarch
141
142* Thu Feb 27 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-2
143- Split off doc to a separate package
144
145* Wed Feb 26 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-1
146- Udpate to release 3.2.1
147
148* Sun Aug 11 2013 Sandro Mani <manisandro@gmail.com> - 3.2-3
149- Build and run tests
150- Drop -DBLAS_LIBRARIES_DIR, not used
151- Add some BR to enable tests of corresponding backends
152- spec cleanup
153
154* Wed Jul 24 2013 Sandro Mani <manisandro@gmail.com> - 3.2-1
155- Update to release 3.2
156
157* Sat Jun 29 2013 Rich Mattes <richmattes@gmail.com> - 3.1.3-2
158- Add upstream patch to fix malloc/free bugs (rhbz#978971)
159
160* Fri Apr 19 2013 Sandro Mani <manisandro@gmail.com> - 3.1.3-1
161- Update to release 3.1.3
162- Add patch for unused typedefs warning with gcc4.8
163
164* Tue Mar 05 2013 Rich Mattes <richmattes@gmail.com> - 3.1.2-1
165- Update to release 3.1.2
166
167* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.6-2
168- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
169
170* Sat Jul 28 2012 Tim Niemueller <tim@niemueller.de> - 3.0.6-1
171- Update to release 3.0.6 (fixes GCC 4.7 warnings)
172
173* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.5-2
174- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
175
176* Sun Mar 11 2012 Rich Mattes <richmattes@gmail.com> - 3.0.5-1
177- Update to release 3.0.5
178
179* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.4-2
180- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
181
182* Sun Dec 18 2011 Rich Mattes <richmattes@gmail.com> - 3.0.4-1
183- Update to release 3.0.4
184
185* Tue Nov 15 2011 Rich Mattes <richmattes@gmail.com> - 3.0.3-1
186- Update to release 3.0.3
187
188* Sun Apr 17 2011 Rich Mattes <richmattes@gmail.com> - 3.0.0-2
189- Patched sources to fix build failure
190- Removed fixes made upstream
191- Added project name to source tarball filename
192
193* Sat Mar 26 2011 Rich Mattes <richmattes@gmail.com> - 3.0.0-1
194- Update to release 3.0.0
195
196* Tue Jan 25 2011 Rich Mattes <richmattes@gmail.com> - 3.0-0.2.beta2
197- Change blas-devel buildrequirement to atlas-devel
198- Don't make the built-in experimental blas library
199
200* Mon Jan 24 2011 Rich Mattes <richmattes@gmail.com> - 3.0-0.1.beta2
201- Initial package
Note: See TracBrowser for help on using the repository browser.