source: projects/specs/trunk/e/e2fsprogs/e2fsprogs-vl.spec @ 7178

Revision 7178, 16.7 KB checked in by daisuke, 11 years ago (diff)

e2fsprogs: update to 1.42.6

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _root_sbindir   /sbin
3%define _root_libdir    /%{_lib}
4
5Summary:     Utilities for managing ext2/3/4 filesystem.
6Summary(ja): ext2/3/4 ファイルシステム操作ユーティリティ
7Name:        e2fsprogs
8Version:     1.42.6
9Release:     1%{?_dist_release}
10License:     GPL
11Group:       System Environment/Base
12Url:         http://e2fsprogs.sourceforge.net/
13Source0:     ftp://download.sourceforge.net/pub/sourceforge/%{name}/%{name}-%{version}.tar.gz
14Source1:     ext2_types-wrapper.h
15
16Patch2:      e2fsprogs-1.40.4-sb_feature_check_ignore.patch
17
18BuildRoot:   %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires: gettext, texinfo
21BuildRequires: pkgconfig, device-mapper-devel, gawk
22BuildRequires: libblkid-devel
23BuildRequires: libuuid-devel
24
25Requires(post): /sbin/install-info
26Requires(postun): /sbin/install-info
27Requires(post): chkconfig
28Requires(pre): shadow-utils
29
30%description
31The e2fsprogs package contains a number of utilities for creating,
32checking, modifying, and correcting any inconsistencies in ext2/3/4
33filesystems. E2fsprogs contains e2fsck (used to repair filesystem
34inconsistencies after an unclean shutdown), mke2fs (used to
35initialize a partition to contain an empty ext2/3/4 filesystem),
36debugfs (used to examine the internal structure of a filesystem, to
37manually repair a corrupted filesystem, or to create test cases for
38e2fsck), tune2fs (used to modify filesystem parameters), and most of
39the other core ext2fs filesystem utilities.
40
41You should install the e2fsprogs package if you need to manage the
42performance of an ext2/3/4 filesystem.
43
44%description -l ja
45e2fsprogs パッケージには,ファイルシステムの作成/チェック/変更/修正など,
46ext2/3/4 ファイルシステムに対する様々な操作を行うユーティリティが収めら
47れています.e2fsck(正しくアンマウントされずにシャットダウンされた等して
48破損したファイルシステムの不整合を修正する),mke2fs (パーティションを初
49期化してまっさらの ext2 ファイルシステムを作成する),debugfs(ファイルシ
50ステムの内部構造を直接参照して破損したファイルシステムを手で直したり
51e2fsck のテストケースを作りだしたりするのに使う),tune2fs(ファイルシス
52テムのパラメータを修正するのに使う)等,その他 ext2 ファイルシステム用基
53本ユーティリティが収められています.
54
55ext2/3/4 ファイルシステムのパフォーマンスをきちんと把握しておく為にも
56e2fsprogs パッケージを是非インストールしておきましょう.
57
58
59%package devel
60Summary:     Ext2/3/4 filesystem-specific static libraries and headers.
61Summary(ja): ext2/3/4 ファイルシステム特有のライブラリとヘッダ
62Group:       Development/Libraries
63Requires:    e2fsprogs = %{version}
64Requires(post): install-info
65
66
67%description devel
68E2fsprogs-devel contains the libraries and header files needed to
69develop ext2/3/4 filesystem-specific programs.
70
71%description devel -l ja
72e2fsprogs-devel には ext2/3/4 ファイルシステム固有のプログラムを開発する
73のに必要なライブラリとヘッダファイルが収められています.
74
75
76
77## to build compat32 for x86_64 architecture support
78%package -n compat32-%{name}
79Summary:     Utilities for managing ext2/3/4 filesystem.
80Group:       System Environment/Base
81%description -n compat32-%{name}
82The e2fsprogs package contains a number of utilities for creating,
83checking, modifying, and correcting any inconsistencies in ext2/3/4
84filesystems. E2fsprogs contains e2fsck (used to repair filesystem
85inconsistencies after an unclean shutdown), mke2fs (used to initialize
86a partition to contain an empty ext2 filesystem), debugfs (used to
87examine the internal structure of a filesystem, to manually repair
88a corrupted filesystem, or to create test cases for e2fsck),
89tune2fs (used to modify filesystem parameters), and most of the
90other core ext2fs filesystem utilities.
91
92You should install the e2fsprogs package if you need to manage the
93performance of an ext2/3/4 filesystem.
94
95%package -n compat32-%{name}-devel
96Summary:     Ext2/3/4 filesystem-specific static libraries and headers.
97Group:       Development/Libraries
98Requires:    compat32-%{name} = %{version}
99%description -n compat32-%{name}-devel
100E2fsprogs-devel contains the libraries and header files needed to
101develop second extended (ext2) filesystem-specific programs.
102
103You should install e2fsprogs-devel if you want to develop ext2
104filesystem-specific programs. If you install e2fsprogs-devel, you'll
105also want to install e2fsprogs.
106
107
108%prep
109%setup -q -n e2fsprogs-%{version}
110
111# ignore some flag differences on primary/backup sb feature checks
112# mildly unsafe but 'til I get something better, avoid full fsck
113# after an selinux install...
114%patch2 -p1 -b .featurecheck
115
116%build
117%configure --enable-elf-shlibs --enable-nls --disable-uuidd --disable-fsck \
118           --disable-e2initrd-helper --disable-libblkid --disable-libuuid
119make %{?_smp_mflags}
120
121
122%install
123rm -rf $RPM_BUILD_ROOT
124export PATH=/sbin:$PATH
125
126make install install-libs DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" \
127        root_sbindir=%{_root_sbindir} root_libdir=%{_root_libdir}
128
129chmod 644 $RPM_BUILD_ROOT%{_libdir}/*.a
130
131%ifarch %{multilib_arches}
132mv -f %{buildroot}%{_includedir}/ext2fs/ext2_types.h \
133      %{buildroot}%{_includedir}/ext2fs/ext2_types-%{_arch}.h
134install -p -m 644 %{SOURCE1} %{buildroot}%{_includedir}/ext2fs/ext2_types.h
135%endif
136
137%find_lang %{name}
138
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%post -p /sbin/ldconfig
144%postun -p /sbin/ldconfig
145
146%post devel
147/sbin/install-info %{_infodir}/libext2fs.info.gz %{_infodir}/dir || :
148
149%preun devel
150if [ $1 = 0 ]; then
151   /sbin/install-info --delete %{_infodir}/libext2fs.info.gz %{_infodir}/dir || :
152fi
153exit 0
154
155%post -n compat32-%{name} -p /sbin/ldconfig
156%postun -n compat32-%{name} -p /sbin/ldconfig
157
158
159%files -f %{name}.lang
160%defattr(-,root,root)
161%doc README RELEASE-NOTES
162%config(noreplace) %{_sysconfdir}/mke2fs.conf
163%{_root_sbindir}/badblocks
164%{_root_sbindir}/debugfs
165%{_root_sbindir}/dumpe2fs
166%{_root_sbindir}/e2fsck
167%{_root_sbindir}/e2image
168%{_root_sbindir}/e2label
169%{_root_sbindir}/e2undo
170%{_root_sbindir}/fsck.ext2
171%{_root_sbindir}/fsck.ext3
172%{_root_sbindir}/fsck.ext4
173%{_root_sbindir}/fsck.ext4dev
174%{_root_sbindir}/logsave
175%{_root_sbindir}/mke2fs
176%{_root_sbindir}/mkfs.ext2
177%{_root_sbindir}/mkfs.ext3
178%{_root_sbindir}/mkfs.ext4
179%{_root_sbindir}/mkfs.ext4dev
180%{_root_sbindir}/resize2fs
181%{_root_sbindir}/tune2fs
182%{_sbindir}/filefrag
183%{_sbindir}/e2freefrag
184%{_sbindir}/e4defrag
185%{_sbindir}/mklost+found
186
187%{_root_libdir}/libcom_err.so.*
188%{_root_libdir}/libe2p.so.*
189%{_root_libdir}/libext2fs.so.*
190%{_root_libdir}/libss.so.*
191
192%{_bindir}/chattr
193%{_bindir}/lsattr
194
195%{_mandir}/man1/chattr.1*
196%{_mandir}/man1/lsattr.1*
197
198%{_mandir}/man5/e2fsck.conf.5*
199%{_mandir}/man5/mke2fs.conf.5*
200
201%{_mandir}/man8/badblocks.8*
202%{_mandir}/man8/debugfs.8*
203%{_mandir}/man8/dumpe2fs.8*
204%{_mandir}/man8/e2fsck.8*
205%{_mandir}/man8/e2undo.8*
206%{_mandir}/man8/filefrag.8*
207%{_mandir}/man8/e2freefrag.8*
208%{_mandir}/man8/fsck.ext2.8*
209%{_mandir}/man8/fsck.ext3.8*
210%{_mandir}/man8/fsck.ext4.8*
211%{_mandir}/man8/fsck.ext4dev.8*
212%{_mandir}/man8/e2image.8*
213%{_mandir}/man8/e2label.8*
214%{_mandir}/man8/e4defrag.8*
215%{_mandir}/man8/logsave.8*
216%{_mandir}/man8/mke2fs.8*
217%{_mandir}/man8/mkfs.ext2.8*
218%{_mandir}/man8/mkfs.ext3.8*
219%{_mandir}/man8/mkfs.ext4.8*
220%{_mandir}/man8/mkfs.ext4dev.8*
221%{_mandir}/man8/mklost+found.8*
222%{_mandir}/man8/resize2fs.8*
223%{_mandir}/man8/tune2fs.8*
224     
225
226%files devel
227%defattr(-,root,root)
228%{_infodir}/libext2fs.info*
229%{_bindir}/compile_et
230%{_bindir}/mk_cmds
231
232%{_libdir}/libcom_err.a
233%{_libdir}/libcom_err.so
234%{_libdir}/libe2p.a
235%{_libdir}/libe2p.so
236%{_libdir}/libext2fs.a
237%{_libdir}/libext2fs.so
238%{_libdir}/libss.a
239%{_libdir}/libss.so
240%{_libdir}/libquota.a
241%{_libdir}/pkgconfig/*.pc
242
243%{_datadir}/et
244%{_datadir}/ss
245%{_includedir}/e2p
246%{_includedir}/et
247%{_includedir}/com_err.h
248%{_includedir}/ext2fs
249%{_includedir}/ss
250%{_includedir}/quota
251%{_mandir}/man1/compile_et.1*
252%{_mandir}/man1/mk_cmds.1*
253%{_mandir}/man3/com_err.3*
254
255
256%if %{build_compat32}
257%files -n compat32-%{name}
258%defattr(-,root,root)
259%{_root_libdir}/libcom_err.so.*
260%{_root_libdir}/libe2p.so.*
261%{_root_libdir}/libext2fs.so.*
262%{_root_libdir}/libss.so.*
263
264%files -n compat32-%{name}-devel
265%defattr(-,root,root)
266%{_libdir}/libcom_err.a
267%{_libdir}/libcom_err.so
268%{_libdir}/libe2p.a
269%{_libdir}/libe2p.so
270%{_libdir}/libext2fs.a
271%{_libdir}/libext2fs.so
272%{_libdir}/libss.a
273%{_libdir}/libss.so
274%{_libdir}/pkgconfig/*.pc
275%endif
276
277
278%changelog
279* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.42.6-1
280- new upstream reelase
281
282* Thu Jan 12 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.42-1
283- new upstram release
284
285* Wed Mar 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.14-1
286- new upstream release
287
288* Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.41.10-2
289- rebuilt with rpm-4.8.1 for pkg-config
290
291* Sun Feb 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.10-1
292- new upstream release
293
294* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.9-1
295- new upstream release
296- disable libuuid/uuidd/libblkid/fsck (replaced by util-linux-ng)
297
298* Thu Jan 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.4-1
299- new upstream release
300
301* Sat Jan 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.3-2
302- add Requires(pre): shadow-utils
303- add Requires(post): chkconfig
304
305* Tue Oct 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.3-1
306- new upstream release
307
308* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.1-1
309- new upstream release
310- drop patch5 (merged in upstream)
311
312* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.41.0-1
313- new upstream release
314- drop patch4 (included in upstream)
315- add e2undo and some ext4 related files in %%files section
316- add patch5 to fix "mount -l" segmentation fault
317
318* Fri Jul 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.10-1
319- new upstream release
320
321* Mon Apr 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.9-1
322- new upstream release
323
324* Fri Apr 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.8-1
325- new upstream release
326- drop unneeded patches
327- update fedora patches
328
329* Sat Dec 22 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.40.2-0vl3
330- removed %%if !%%{build_compat32} case condition
331
332* Mon Dec 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.40.2-0vl2
333- add Patch100 for CVE-2007-5497 (see also <BTS:316>)
334
335* Sun Dec 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.2-0vl1
336- new upstream release
337- import fedora patches
338- drop ext2resize(ext2online), online resize is now supported by resize2fs
339
340* Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 1.38-2vl2
341- rebuilt for x86_64 architecture support
342- added compat32-* packages for x86_64
343
344* Sun Dec 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.38-2vl1
345- new upstream release based on Fedora package
346  * Thu Nov 10 2005 Thomas Woerner <twoerner@redhat.com> 1.38-2.1
347  - fixed file conflicts between 32bit and 64bit packages (#168815)
348  - fixed mklost+found crashes with buffer overflow (#157773)
349    Thanks to Arjan van de Ven for the patch
350  * Thu Sep  8 2005 Thomas Woerner <twoerner@redhat.com> 1.38-1
351  - Close File descriptor for unregognized devices (#159878)
352    Thanks to David Milburn for the patch.
353    Merged from RHEL-4
354  - enable tune2fs to set and clear feature resize_inode (#167816)
355  - removed outdated information from ext2online man page (#164383)
356  * Mon Sep  5 2005 Karel Zak <kzak@redhat.com> - 1.37-5
357  - fix swsuspend partition detection (#165863)
358  - fix revalidate from ext2 to ext3 (#162927)
359  - fix vfat without magic detection (#161873)
360  * Wed Sep  1 2004 Stephen C. Tweedie <sct@redhat.com> 1.35-9.4
361  - Build and package ext2online during the e2fsprogs build
362
363* Fri Jun 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.35-0vl2
364- import Patch7 from fedora package to fix 'check after next mount'
365  for filesystems with maximum mount count -1
366
367* Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.35-0vl1
368- new upstream release
369
370* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.34-0vl1
371- new upstream release
372
373* Sat May 24 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.33-2vl1
374- syncd with rawhide
375
376* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.32-0vl1
377- new upstream release
378
379* Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.29-0vl1
380- new upstream release 1.29
381
382* Tue Mar 12 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.27-0vl1
383- updated to new upstream bugfix release 1.27
384  (the fix associated with Patch10 has been merged)
385- added missing man pages
386
387* Tue Mar 05 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.26-0vl2
388- added Patch10 (upstream fix)
389
390* Thu Feb 14 2002 Toru Sagami <sagami@vinelinux.org> 1.26-0vl1
391- updated to current release 1.26 with minor spec fixes
392
393* Sun Oct 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.25-0vl1
394- updated to newest 1.25 release
395
396* Fri Aug 31 2001 Toru Sagami <sagami@vinelinux.org>
397- 1.24-0vl1: updated to 1.24
398
399* Thu Aug 16 2001 <sagami@vinelinux.org>
400- 1.23-0vl1: updated to 1.23 and added e2image files
401
402* Fri Jul 13 2001 <sagami@vinelinux.org>
403- 1.22-0vl1: updated to 1.22
404
405* Sun Jun 17 2001 <sagami@vinelinux.org>
406- 1.21-0vl1: updated to 1.21
407
408* Sun Jun 10 2001 <sagami@vinelinux.org>
409- 1.20-0vl1: updated to 1.20
410
411* Sat May 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
412- 1.19-4vl2
413- added Japanese summary and description
414- revamp spec file
415
416* Wed May 09 2001 <sagami@vinelinux.org>
417- 1.19-4vl1: in sync with RH 1.19-4
418  * added some documant entries in %doc
419
420* Fri Apr 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
421- add further IDE and SCSI disks to a hardcoded list in fsck #34190
422
423* Tue Feb 27 2001 Florian La Roche <Florian.LaRoche@redhat.de>
424- require the main rpm from the devel rpm
425
426* Thu Feb 22 2001 Helge Deller <hdeller@redhat.de>
427- fix fsck -A bug (#21242)
428
429* Mon Feb 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
430- fix bug with 16 byte long labels #27071
431
432* Mon Sep 11 2000 Jeff Johnson <jbj@redhat.com>
433- build for Red Hat 7.1.
434
435* Tue Aug  8 2000 Jeff Johnson <jbj@redhat.com>
436- merge LABEL patch.
437- update to 1.19.
438
439* Tue Jul 25 2000 Erik Troan <ewt@redhat.com>
440- fixed LABEL handling
441
442* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
443- rebuild to cope with glibc locale binary incompatibility
444
445* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
446- automatic rebuild
447
448* Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
449- added resize2fs from the WIP snapshot
450
451* Thu Jun 15 2000 Matt Wilson <msw@redhat.com>
452- patched to build against linux 2.4 headers
453
454* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
455- FHS packaging.
456
457* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
458- fix for ia64
459
460* Sat Feb  5 2000 Bill Nottingham <notting@redhat.com>
461- add install-info scripts
462
463* Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
464- Fix bug #8585 (Y2K problems in debugfs)
465
466* Wed Feb 02 2000 Jakub Jelinek <jakub@redhat.com>
467- allow multiline errors in et, so that other programs
468  can use compile_et (from Kerberos)
469
470* Thu Jan 13 2000 Jeff Johnson <jbj@redhat.com>
471- build 1.18 for 6.2.
472
473* Tue Oct 26 1999 Bill Nottingham <notting@redhat.com>
474- update to 1.17
475
476* Mon Oct 25 1999 Bill Nottingham <notting@redhat.com>
477- update to 1.16
478
479* Thu Oct 21 1999 Bill Nottingham <notting@redhat.com>
480- add patch to fix SIGUSR1 kills.
481
482* Mon Oct 04 1999 Cristian Gafton <gafton@redhat.com>
483- rebuild against new glibc in the sparc tree
484
485* Thu Sep 23 1999 Jakub Jelinek <jakub@redhat.com>
486- update mke2fs man page so that it reflects changes in mke2fs
487  netweem 1.14 and 1.15
488
489* Thu Aug  5 1999 Bill Nottingham <notting@redhat.com>
490- fix lsattr on alpha
491
492* Thu Jul 29 1999 Jeff Johnson <jbj@redhat.com>
493- update to 1.15.
494
495* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
496- auto rebuild in the new build environment (release 4)
497
498* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
499- fix fsck segfault
500
501* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
502- update to 1.14
503- use %configure to generate config.sub on arm
504
505* Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
506- fix /usr/bin/compile_et and doco for com_err.h (#673)
507
508* Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
509- build with prefix=/usr
510- add arm patch
511
512* Mon Dec 28 1998 Jeff Johnson  <jbj@redhat.com>
513- update to 1.13.
514
515* Fri Aug 28 1998 Jeff Johnson <jbj@redhat.com>
516- recompile statically linked binary for 5.2/sparc
517
518* Mon Jul 13 1998 Jeff Johnson <jbj@redhat.com>
519- upgrade to 1.12.
520
521* Thu May 07 1998 Prospector System <bugs@redhat.com>
522- translations modified for de, fr, tr
523
524* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
525- include <asm/types.h> to match kernel types in utils
526
527* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
528- spec file cleanups
529
530* Wed Oct 01 1997 Erik Troan <ewt@redhat.com>
531- fixed broken llseek() prototype
532
533* Wed Aug 20 1997 Erik Troan <ewt@redhat.com>
534- added patch to prototype llseek
535
536* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
537- built against glibc
Note: See TracBrowser for help on using the repository browser.