source: projects/specs/trunk/e/e2fsprogs/e2fsprogs-vl.spec @ 8829

Revision 8829, 16.8 KB checked in by daisuke, 10 years ago (diff)

e2fsprogs: update to 1.42.11

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _root_sbindir   /sbin
3%define _root_libdir    /%{_lib}
4
5Summary:     Utilities for managing ext2/3/4 filesystem.
6Summary(ja): ext2/3/4 ファイルシステム操作ユーティリティ
7Name:        e2fsprogs
8Version:     1.42.11
9Release:     1%{?_dist_release}
10License:     GPL
11Group:       System Environment/Base
12Url:         http://e2fsprogs.sourceforge.net/
13Source0:     ftp://download.sourceforge.net/pub/sourceforge/%{name}/%{name}-%{version}.tar.xz
14Source1:     ext2_types-wrapper.h
15
16Patch2:      e2fsprogs-1.40.4-sb_feature_check_ignore.patch
17
18BuildRoot:   %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires: gettext, texinfo
21BuildRequires: pkgconfig, device-mapper-devel, gawk
22BuildRequires: libblkid-devel
23BuildRequires: libuuid-devel
24
25Requires(post): /sbin/install-info
26Requires(postun): /sbin/install-info
27Requires(post): chkconfig
28Requires(pre): shadow-utils
29
30%description
31The e2fsprogs package contains a number of utilities for creating,
32checking, modifying, and correcting any inconsistencies in ext2/3/4
33filesystems. E2fsprogs contains e2fsck (used to repair filesystem
34inconsistencies after an unclean shutdown), mke2fs (used to
35initialize a partition to contain an empty ext2/3/4 filesystem),
36debugfs (used to examine the internal structure of a filesystem, to
37manually repair a corrupted filesystem, or to create test cases for
38e2fsck), tune2fs (used to modify filesystem parameters), and most of
39the other core ext2fs filesystem utilities.
40
41You should install the e2fsprogs package if you need to manage the
42performance of an ext2/3/4 filesystem.
43
44%description -l ja
45e2fsprogs パッケージには,ファイルシステムの作成/チェック/変更/修正など,
46ext2/3/4 ファイルシステムに対する様々な操作を行うユーティリティが収めら
47れています.e2fsck(正しくアンマウントされずにシャットダウンされた等して
48破損したファイルシステムの不整合を修正する),mke2fs (パーティションを初
49期化してまっさらの ext2 ファイルシステムを作成する),debugfs(ファイルシ
50ステムの内部構造を直接参照して破損したファイルシステムを手で直したり
51e2fsck のテストケースを作りだしたりするのに使う),tune2fs(ファイルシス
52テムのパラメータを修正するのに使う)等,その他 ext2 ファイルシステム用基
53本ユーティリティが収められています.
54
55ext2/3/4 ファイルシステムのパフォーマンスをきちんと把握しておく為にも
56e2fsprogs パッケージを是非インストールしておきましょう.
57
58
59%package devel
60Summary:     Ext2/3/4 filesystem-specific static libraries and headers.
61Summary(ja): ext2/3/4 ファイルシステム特有のライブラリとヘッダ
62Group:       Development/Libraries
63Requires:    e2fsprogs = %{version}
64Requires(post): install-info
65
66
67%description devel
68E2fsprogs-devel contains the libraries and header files needed to
69develop ext2/3/4 filesystem-specific programs.
70
71%description devel -l ja
72e2fsprogs-devel には ext2/3/4 ファイルシステム固有のプログラムを開発する
73のに必要なライブラリとヘッダファイルが収められています.
74
75
76
77## to build compat32 for x86_64 architecture support
78%package -n compat32-%{name}
79Summary:     Utilities for managing ext2/3/4 filesystem.
80Group:       System Environment/Base
81%description -n compat32-%{name}
82The e2fsprogs package contains a number of utilities for creating,
83checking, modifying, and correcting any inconsistencies in ext2/3/4
84filesystems. E2fsprogs contains e2fsck (used to repair filesystem
85inconsistencies after an unclean shutdown), mke2fs (used to initialize
86a partition to contain an empty ext2 filesystem), debugfs (used to
87examine the internal structure of a filesystem, to manually repair
88a corrupted filesystem, or to create test cases for e2fsck),
89tune2fs (used to modify filesystem parameters), and most of the
90other core ext2fs filesystem utilities.
91
92You should install the e2fsprogs package if you need to manage the
93performance of an ext2/3/4 filesystem.
94
95%package -n compat32-%{name}-devel
96Summary:     Ext2/3/4 filesystem-specific static libraries and headers.
97Group:       Development/Libraries
98Requires:    compat32-%{name} = %{version}
99%description -n compat32-%{name}-devel
100E2fsprogs-devel contains the libraries and header files needed to
101develop second extended (ext2) filesystem-specific programs.
102
103You should install e2fsprogs-devel if you want to develop ext2
104filesystem-specific programs. If you install e2fsprogs-devel, you'll
105also want to install e2fsprogs.
106
107
108%prep
109%setup -q -n e2fsprogs-%{version}
110
111# ignore some flag differences on primary/backup sb feature checks
112# mildly unsafe but 'til I get something better, avoid full fsck
113# after an selinux install...
114%patch2 -p1 -b .featurecheck
115
116%build
117%configure --enable-elf-shlibs --enable-nls --disable-uuidd --disable-fsck \
118           --disable-e2initrd-helper --disable-libblkid --disable-libuuid \
119           --enable-quota
120make %{?_smp_mflags}
121
122
123%install
124rm -rf $RPM_BUILD_ROOT
125export PATH=/sbin:$PATH
126
127make install install-libs DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" \
128        root_sbindir=%{_root_sbindir} root_libdir=%{_root_libdir}
129
130chmod 644 $RPM_BUILD_ROOT%{_libdir}/*.a
131
132%ifarch %{multilib_arches}
133mv -f %{buildroot}%{_includedir}/ext2fs/ext2_types.h \
134      %{buildroot}%{_includedir}/ext2fs/ext2_types-%{_arch}.h
135install -p -m 644 %{SOURCE1} %{buildroot}%{_includedir}/ext2fs/ext2_types.h
136%endif
137
138%find_lang %{name}
139
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144%post -p /sbin/ldconfig
145%postun -p /sbin/ldconfig
146
147%post devel
148/sbin/install-info %{_infodir}/libext2fs.info.gz %{_infodir}/dir || :
149
150%preun devel
151if [ $1 = 0 ]; then
152   /sbin/install-info --delete %{_infodir}/libext2fs.info.gz %{_infodir}/dir || :
153fi
154exit 0
155
156%post -n compat32-%{name} -p /sbin/ldconfig
157%postun -n compat32-%{name} -p /sbin/ldconfig
158
159
160%files -f %{name}.lang
161%defattr(-,root,root)
162%doc README RELEASE-NOTES
163%config(noreplace) %{_sysconfdir}/mke2fs.conf
164%{_root_sbindir}/badblocks
165%{_root_sbindir}/debugfs
166%{_root_sbindir}/dumpe2fs
167%{_root_sbindir}/e2fsck
168%{_root_sbindir}/e2image
169%{_root_sbindir}/e2label
170%{_root_sbindir}/e2undo
171%{_root_sbindir}/fsck.ext2
172%{_root_sbindir}/fsck.ext3
173%{_root_sbindir}/fsck.ext4
174%{_root_sbindir}/fsck.ext4dev
175%{_root_sbindir}/logsave
176%{_root_sbindir}/mke2fs
177%{_root_sbindir}/mkfs.ext2
178%{_root_sbindir}/mkfs.ext3
179%{_root_sbindir}/mkfs.ext4
180%{_root_sbindir}/mkfs.ext4dev
181%{_root_sbindir}/resize2fs
182%{_root_sbindir}/tune2fs
183%{_sbindir}/filefrag
184%{_sbindir}/e2freefrag
185%{_sbindir}/e4defrag
186%{_sbindir}/mklost+found
187
188%{_root_libdir}/libcom_err.so.*
189%{_root_libdir}/libe2p.so.*
190%{_root_libdir}/libext2fs.so.*
191%{_root_libdir}/libss.so.*
192
193%{_bindir}/chattr
194%{_bindir}/lsattr
195
196%{_mandir}/man1/chattr.1*
197%{_mandir}/man1/lsattr.1*
198
199%{_mandir}/man5/e2fsck.conf.5*
200%{_mandir}/man5/mke2fs.conf.5*
201
202%{_mandir}/man8/badblocks.8*
203%{_mandir}/man8/debugfs.8*
204%{_mandir}/man8/dumpe2fs.8*
205%{_mandir}/man8/e2fsck.8*
206%{_mandir}/man8/e2undo.8*
207%{_mandir}/man8/filefrag.8*
208%{_mandir}/man8/e2freefrag.8*
209%{_mandir}/man8/fsck.ext2.8*
210%{_mandir}/man8/fsck.ext3.8*
211%{_mandir}/man8/fsck.ext4.8*
212%{_mandir}/man8/fsck.ext4dev.8*
213%{_mandir}/man8/e2image.8*
214%{_mandir}/man8/e2label.8*
215%{_mandir}/man8/e4defrag.8*
216%{_mandir}/man8/logsave.8*
217%{_mandir}/man8/mke2fs.8*
218%{_mandir}/man8/mkfs.ext2.8*
219%{_mandir}/man8/mkfs.ext3.8*
220%{_mandir}/man8/mkfs.ext4.8*
221%{_mandir}/man8/mkfs.ext4dev.8*
222%{_mandir}/man8/mklost+found.8*
223%{_mandir}/man8/resize2fs.8*
224%{_mandir}/man8/tune2fs.8*
225     
226
227%files devel
228%defattr(-,root,root)
229%{_infodir}/libext2fs.info*
230%{_bindir}/compile_et
231%{_bindir}/mk_cmds
232
233%{_libdir}/libcom_err.a
234%{_libdir}/libcom_err.so
235%{_libdir}/libe2p.a
236%{_libdir}/libe2p.so
237%{_libdir}/libext2fs.a
238%{_libdir}/libext2fs.so
239%{_libdir}/libss.a
240%{_libdir}/libss.so
241%{_libdir}/libquota.a
242%{_libdir}/pkgconfig/*.pc
243
244%{_datadir}/et
245%{_datadir}/ss
246%{_includedir}/e2p
247%{_includedir}/et
248%{_includedir}/com_err.h
249%{_includedir}/ext2fs
250%{_includedir}/ss
251%{_includedir}/quota
252%{_mandir}/man1/compile_et.1*
253%{_mandir}/man1/mk_cmds.1*
254%{_mandir}/man3/com_err.3*
255
256
257%if %{build_compat32}
258%files -n compat32-%{name}
259%defattr(-,root,root)
260%{_root_libdir}/libcom_err.so.*
261%{_root_libdir}/libe2p.so.*
262%{_root_libdir}/libext2fs.so.*
263%{_root_libdir}/libss.so.*
264
265%files -n compat32-%{name}-devel
266%defattr(-,root,root)
267%{_libdir}/libcom_err.a
268%{_libdir}/libcom_err.so
269%{_libdir}/libe2p.a
270%{_libdir}/libe2p.so
271%{_libdir}/libext2fs.a
272%{_libdir}/libext2fs.so
273%{_libdir}/libss.a
274%{_libdir}/libss.so
275%{_libdir}/pkgconfig/*.pc
276%endif
277
278
279%changelog
280* Wed Jul 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.42.11-1
281- new upstream release
282
283* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.42.6-1
284- new upstream reelase
285
286* Thu Jan 12 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.42-1
287- new upstram release
288
289* Wed Mar 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.14-1
290- new upstream release
291
292* Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.41.10-2
293- rebuilt with rpm-4.8.1 for pkg-config
294
295* Sun Feb 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.10-1
296- new upstream release
297
298* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.9-1
299- new upstream release
300- disable libuuid/uuidd/libblkid/fsck (replaced by util-linux-ng)
301
302* Thu Jan 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.4-1
303- new upstream release
304
305* Sat Jan 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.3-2
306- add Requires(pre): shadow-utils
307- add Requires(post): chkconfig
308
309* Tue Oct 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.3-1
310- new upstream release
311
312* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.1-1
313- new upstream release
314- drop patch5 (merged in upstream)
315
316* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.41.0-1
317- new upstream release
318- drop patch4 (included in upstream)
319- add e2undo and some ext4 related files in %%files section
320- add patch5 to fix "mount -l" segmentation fault
321
322* Fri Jul 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.10-1
323- new upstream release
324
325* Mon Apr 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.9-1
326- new upstream release
327
328* Fri Apr 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.8-1
329- new upstream release
330- drop unneeded patches
331- update fedora patches
332
333* Sat Dec 22 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.40.2-0vl3
334- removed %%if !%%{build_compat32} case condition
335
336* Mon Dec 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.40.2-0vl2
337- add Patch100 for CVE-2007-5497 (see also <BTS:316>)
338
339* Sun Dec 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.2-0vl1
340- new upstream release
341- import fedora patches
342- drop ext2resize(ext2online), online resize is now supported by resize2fs
343
344* Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 1.38-2vl2
345- rebuilt for x86_64 architecture support
346- added compat32-* packages for x86_64
347
348* Sun Dec 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.38-2vl1
349- new upstream release based on Fedora package
350  * Thu Nov 10 2005 Thomas Woerner <twoerner@redhat.com> 1.38-2.1
351  - fixed file conflicts between 32bit and 64bit packages (#168815)
352  - fixed mklost+found crashes with buffer overflow (#157773)
353    Thanks to Arjan van de Ven for the patch
354  * Thu Sep  8 2005 Thomas Woerner <twoerner@redhat.com> 1.38-1
355  - Close File descriptor for unregognized devices (#159878)
356    Thanks to David Milburn for the patch.
357    Merged from RHEL-4
358  - enable tune2fs to set and clear feature resize_inode (#167816)
359  - removed outdated information from ext2online man page (#164383)
360  * Mon Sep  5 2005 Karel Zak <kzak@redhat.com> - 1.37-5
361  - fix swsuspend partition detection (#165863)
362  - fix revalidate from ext2 to ext3 (#162927)
363  - fix vfat without magic detection (#161873)
364  * Wed Sep  1 2004 Stephen C. Tweedie <sct@redhat.com> 1.35-9.4
365  - Build and package ext2online during the e2fsprogs build
366
367* Fri Jun 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.35-0vl2
368- import Patch7 from fedora package to fix 'check after next mount'
369  for filesystems with maximum mount count -1
370
371* Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.35-0vl1
372- new upstream release
373
374* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.34-0vl1
375- new upstream release
376
377* Sat May 24 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.33-2vl1
378- syncd with rawhide
379
380* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.32-0vl1
381- new upstream release
382
383* Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.29-0vl1
384- new upstream release 1.29
385
386* Tue Mar 12 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.27-0vl1
387- updated to new upstream bugfix release 1.27
388  (the fix associated with Patch10 has been merged)
389- added missing man pages
390
391* Tue Mar 05 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.26-0vl2
392- added Patch10 (upstream fix)
393
394* Thu Feb 14 2002 Toru Sagami <sagami@vinelinux.org> 1.26-0vl1
395- updated to current release 1.26 with minor spec fixes
396
397* Sun Oct 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.25-0vl1
398- updated to newest 1.25 release
399
400* Fri Aug 31 2001 Toru Sagami <sagami@vinelinux.org>
401- 1.24-0vl1: updated to 1.24
402
403* Thu Aug 16 2001 <sagami@vinelinux.org>
404- 1.23-0vl1: updated to 1.23 and added e2image files
405
406* Fri Jul 13 2001 <sagami@vinelinux.org>
407- 1.22-0vl1: updated to 1.22
408
409* Sun Jun 17 2001 <sagami@vinelinux.org>
410- 1.21-0vl1: updated to 1.21
411
412* Sun Jun 10 2001 <sagami@vinelinux.org>
413- 1.20-0vl1: updated to 1.20
414
415* Sat May 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
416- 1.19-4vl2
417- added Japanese summary and description
418- revamp spec file
419
420* Wed May 09 2001 <sagami@vinelinux.org>
421- 1.19-4vl1: in sync with RH 1.19-4
422  * added some documant entries in %doc
423
424* Fri Apr 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
425- add further IDE and SCSI disks to a hardcoded list in fsck #34190
426
427* Tue Feb 27 2001 Florian La Roche <Florian.LaRoche@redhat.de>
428- require the main rpm from the devel rpm
429
430* Thu Feb 22 2001 Helge Deller <hdeller@redhat.de>
431- fix fsck -A bug (#21242)
432
433* Mon Feb 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
434- fix bug with 16 byte long labels #27071
435
436* Mon Sep 11 2000 Jeff Johnson <jbj@redhat.com>
437- build for Red Hat 7.1.
438
439* Tue Aug  8 2000 Jeff Johnson <jbj@redhat.com>
440- merge LABEL patch.
441- update to 1.19.
442
443* Tue Jul 25 2000 Erik Troan <ewt@redhat.com>
444- fixed LABEL handling
445
446* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
447- rebuild to cope with glibc locale binary incompatibility
448
449* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
450- automatic rebuild
451
452* Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
453- added resize2fs from the WIP snapshot
454
455* Thu Jun 15 2000 Matt Wilson <msw@redhat.com>
456- patched to build against linux 2.4 headers
457
458* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
459- FHS packaging.
460
461* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
462- fix for ia64
463
464* Sat Feb  5 2000 Bill Nottingham <notting@redhat.com>
465- add install-info scripts
466
467* Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
468- Fix bug #8585 (Y2K problems in debugfs)
469
470* Wed Feb 02 2000 Jakub Jelinek <jakub@redhat.com>
471- allow multiline errors in et, so that other programs
472  can use compile_et (from Kerberos)
473
474* Thu Jan 13 2000 Jeff Johnson <jbj@redhat.com>
475- build 1.18 for 6.2.
476
477* Tue Oct 26 1999 Bill Nottingham <notting@redhat.com>
478- update to 1.17
479
480* Mon Oct 25 1999 Bill Nottingham <notting@redhat.com>
481- update to 1.16
482
483* Thu Oct 21 1999 Bill Nottingham <notting@redhat.com>
484- add patch to fix SIGUSR1 kills.
485
486* Mon Oct 04 1999 Cristian Gafton <gafton@redhat.com>
487- rebuild against new glibc in the sparc tree
488
489* Thu Sep 23 1999 Jakub Jelinek <jakub@redhat.com>
490- update mke2fs man page so that it reflects changes in mke2fs
491  netweem 1.14 and 1.15
492
493* Thu Aug  5 1999 Bill Nottingham <notting@redhat.com>
494- fix lsattr on alpha
495
496* Thu Jul 29 1999 Jeff Johnson <jbj@redhat.com>
497- update to 1.15.
498
499* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
500- auto rebuild in the new build environment (release 4)
501
502* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
503- fix fsck segfault
504
505* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
506- update to 1.14
507- use %configure to generate config.sub on arm
508
509* Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
510- fix /usr/bin/compile_et and doco for com_err.h (#673)
511
512* Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
513- build with prefix=/usr
514- add arm patch
515
516* Mon Dec 28 1998 Jeff Johnson  <jbj@redhat.com>
517- update to 1.13.
518
519* Fri Aug 28 1998 Jeff Johnson <jbj@redhat.com>
520- recompile statically linked binary for 5.2/sparc
521
522* Mon Jul 13 1998 Jeff Johnson <jbj@redhat.com>
523- upgrade to 1.12.
524
525* Thu May 07 1998 Prospector System <bugs@redhat.com>
526- translations modified for de, fr, tr
527
528* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
529- include <asm/types.h> to match kernel types in utils
530
531* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
532- spec file cleanups
533
534* Wed Oct 01 1997 Erik Troan <ewt@redhat.com>
535- fixed broken llseek() prototype
536
537* Wed Aug 20 1997 Erik Troan <ewt@redhat.com>
538- added patch to prototype llseek
539
540* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
541- built against glibc
Note: See TracBrowser for help on using the repository browser.